Quantcast

Documentation Center

  • Trial Software
  • Product Updates

Constellation Diagram

Display constellation diagram for input signals

Library

Comm Sinks

Description

The Constellation Diagram block plots constellation diagrams and provides the ability to perform EVM and MER measurements.

Dialog Box

Symbol Display

The symbols that the Constellation Diagram scope displays are always the most recently available symbols from the time buffer. The Symbols to display parameter defines the number of symbols the scope shows. The default setting for this parameter is Input frame length.

When you set the Symbols to display to Input frame length, the block calculates the number of symbols that comprise the frame length according to the following formula:

SymbolsToDisplay = FrameLength/SamplesPerSymbol

To change the number of symbols the scope displays, select View > Configuration Properties to bring up the Configuration Properties dialog box. Then, select <User-defined> from the Symbols to display parameter and enter a value. The value you enter defines the number of symbols the scope displays.

Toolbar

Zoom and Axes Control Buttons

ButtonMenu LocationShortcut KeysDescription

Tools >
Zoom In

N/A

When this tool is active, you can zoom in on the scope window. To do so, click in the center of your area of interest, or click and drag your cursor to draw a rectangular area of interest inside the scope window.

Tools >
Zoom X

N/A

You access the Zoom X button from the menu under the Zoom In icon. When this tool is active, you can zoom in on the x-axis. To do so, click inside the scope window, or click and drag your cursor along the x-axis over your area of interest.

Tools >
Zoom Y

N/A

You access the Zoom Y button from the menu under the Zoom In icon. When this tool is active, you can zoom in on the y-axis. To do so, click inside the scope window, or click and drag your cursor along the y-axis over your area of interest.

Tools >
Pan

N/A

You access the Pan button from the menu under the Zoom In icon. When this tool is active, you can pan on the scope window. To do so, click in the center of your area of interest and drag your cursor to the left, right, up, or down, to move the position of the display.

Tools >
Scale Y-Axes Limits
Ctrl+A

Click this button to scale the axes in the active scope window.

Alternatively, you can enable automatic axes scaling by selecting one of the following options from the Tools menu:

  • Automatically Scale Axes Limits — When you select this option, the scope scales the axes as needed during simulation.

  • Scale Axes Limits after 10 Updates — When you select this option, the scope scales the axes after 10 updates. The scope does not scale the axes again during the simulation.

  • Scale Axes Limits at Stop — When you select this option, the scope scales the axes each time the simulation is stopped.

Tools >
Scale X-Axis Limits
N/A

You access the Scale X-Axis Limits button from the menu under the current Axis Limits icon. Click this button to scale the axes in the X direction in the active scope window.

Alternatively, you can enable automatic axes scaling by selecting one of the following options from the Tools menu:

  • Automatically Scale Axes Limits — When you select this option, the scope scales the axes as needed during simulation.

  • Scale Axes Limits after 10 Updates — When you select this option, the scope scales the axes after 10 updates. The scope does not scale the axes again during the simulation.

  • Scale Axes Limits at Stop — When you select this option, the scope scales the axes each time the simulation is stopped.

Tools >
Scale X and Y Axes Limits
N/A

You access the Scale X and Y Axis Limits button from the menu under the current Axis Limits icon. Click this button to scale the axes in both the X and Y directions in the active scope window.

Alternatively, you can enable automatic axes scaling by selecting one of the following options from the Tools menu:

  • Automatically Scale Axes Limits — When you select this option, the scope scales the axes as needed during simulation.

  • Scale Axes Limits after 10 Updates — When you select this option, the scope scales the axes after 10 updates. The scope does not scale the axes again during the simulation.

  • Scale Axes Limits at Stop — When you select this option, the scope scales the axes each time the simulation is stopped.

Simulation Toolbar

The Simulation Toolbar contains the following buttons.

ButtonMenu LocationShortcut KeysDescription

Simulation >
Simulation Stepping Options

N/A

Open the Simulation Stepping Options dialog box. This button appears only when you have previous stepping disabled.

Simulation >
Step Back

N/A

Advance the model simulation backward by one time step. This button appears only when you have previous stepping enabled and the model simulation is paused.

Simulation >
Run

Ctrl+T, p, Space

Start the model simulation. This button appears only when the model simulation is stopped.

Simulation >
Continue

p, Space

Continue the model simulation. This button appears only when the model simulation is paused.

Simulation >
Pause

p, Space

Pause the model simulation. This button appears only when the model simulation is running.

Simulation >
Step Forward

Right arrow, Page Down

Advance the model simulation forward by one time step. This button starts the model simulation, allows it to run for one time step, and then pauses it again. The scope window then updates with the latest data.

Simulation >
Stop

Ctrl+T, s

Stop the model simulation. This button appears only when the model simulation is running or paused.

Simulation >
Simulink Snapshot

N/A

Take a snapshot of the current scope display. This button temporarily freezes the scope display, while allowing simulation to continue running. To unfreeze the scope display and view the current simulation data, toggle this button to turn off snapshot mode.

View >
Highlight Simulink Block

Ctrl+L

Bring the model window forward, and highlight the scope block whose display you are currently viewing. The scope block that corresponds to the active scope window flashes three times in the model.

You can control whether this toolbar appears in the scope window. From the scope menu, select View > Simulation Toolbar.

To see a full listing of the shortcut keys for these simulation controls, from the scope menu, select Help > Keyboard Command Help.

Measurements Panels

Measurements Panel Buttons

Each of the Measurements panels contains the following buttons that enable you to modify the appearance of the current panel.

ButtonDescription

Move the current panel to the top. When you are displaying more than one panel, this action moves the current panel above all the other panels.

Collapse the current panel. When you first enable a panel, by default, it displays one or more of its panes. Click this button to hide all of its panes to conserve space. After you click this button, it becomes the expand button .

Expand the current panel. This button appears after you click the collapse button to hide the panes in the current panel. Click this button to display the panes in the current panel and show measurements again. After you click this button, it becomes the collapse button again.

Undock the current panel. This button lets you move the current panel into a separate window that can be relocated anywhere on your screen. After you click this button, it becomes the dock button in the new window.

Dock the current panel. This button appears only after you click the undock button. Click this button to put the current panel back into the right side of the Scope window. After you click this button, it becomes the undock button again.

Close the current panel. This button lets you remove the current panel from the right side of the Scope window.

Some panels have their measurements separated by category into a number of panes. Click the pane expand button to show each pane that is hidden in the current panel. Click the pane collapse button to hide each pane that is shown in the current panel.

Settings Pane

The Settings pane enables you to define the measurement interval and normalization method the scope uses when obtaining signal measurements.

  • Measurement interval — Specify the duration of the EVM or MER measurement. For more information see MeasurementInterval.

  • EVM normalization — For the EVM calculations, you may use one of two normalization methods: average constellation power or peak constellation power. The scope performs EVM calculations using the comm.EVM System object™. For more information, see comm.EVM.

Signal Quality Panel

The Signal Quality panel displays Error Vector Measurement (EVM) and Modulation Error Ratio (MER) measurement results.

You can choose to hide or display the Signal Quality panel. In the Scope menu, select Tools > Measurements > Signal Quality.

Signal Quality Pane

The Signal Quality pane displays the calculation results.

  • EVM — An error vector is a vector in the I-Q plane between the ideal constellation point and the actual point at the receiver. EVM is measured in two formats: root mean square (RMS) or normalized Peak. Typically, EVM is reported in decibels. For more information, see comm.EVM.

  • MER — MER is the ratio of the average power of the error vector and the average power of the transmitted signal. The scope indicates the measurement result in decibels. For more information, see comm.MER.

Visuals — Constellation Properties

Main Pane

Samples per symbol

Number of samples used to represent a symbol. This value must be a positive number. When the Measurements tool is on, you must set this property to 1.

Offset (samples)

Number of samples to skip before plotting points. The offset must be a nonnegative integer value less than the value of the samples per symbol.

Symbols to display

The maximum number of symbols that can be displayed. Must be a positive integer value.

Reference constellation

The ideal constellation of the input signal. When the Measurements tool is on, the reference constellation is used to detect the ideal signal input. Therefore, this property cannot be empty when the Measurements tool is on. (When the Measurements tool is not on, this property can be empty.)

Display Pane

Show grid

Select this check box to turn on the grid.

Color fading

When you set select this check box, the points in the display fade as the interval of time after they are first plotted increases. The default value of this property is false. This property is tunable.

Show legend

Select this check box to display a legend for the graph.

Show reference constellation

Select this check box to display the points comprising the reference constellation.

Reference marker

Select the symbol that represents the points on the reference constellation.

Reference color

Select the color of the points on the reference constellation. Refer to the following table for the binary values and their corresponding colors.

ColorBinary Code
Black000
Blue001
Green010
Cyan011
Red100
Magenta101
White111

X-limits (Minimum)

Specify the minimum value of the x-axis.

X-limits (Maximum)

Specify the maximum value of the x-axis.

Y-limits (Minimum)

Specify the minimum value of the y-axis.

Y-limits (Maximum)

Specify the maximum value of the y-axis.

Title

Specify a label that appears above the constellation diagram plot. By default, there is no title.

X-axis label

Specify the text the scope displays along the x-axis

Y-axis label

Specify the text the scope displays along the y-axis

Style Dialog Box

In the Style dialog box, you can customize the style of displays. You are able to change the color of the figure containing the displays, the background and foreground colors of display axes, and properties of lines in a display. From the scope menu, select View > Style to open this dialog box.

Properties

The Style dialog box allows you to modify the following properties of the scope figure:

Figure color

Specify the color that you want to apply to the background of the scope figure. By default, the figure color is gray.

Axes colors

Specify the color that you want to apply to the background of the axes for the active display.

Properties for line

Specify the signal for which you want to modify the visibility, line properties, and marker properties.

Visible

Specify whether the selected signal on the active display should be visible. If you clear this check box, the line disappears.

Line

Specify the line style, line width, and line color for the selected signal on the active display.

Marker

Specify marks for the selected signal on the active display to show at data points. This parameter is similar to the Marker property for the MATLAB® Handle Graphics® plot objects. You can choose any of the marker symbols from the following table.

SpecifierMarker Type
noneNo marker (default)
Circle
Square
Cross
Point
Plus sign
Asterisk
Diamond
Downward-pointing triangle
Upward-pointing triangle
Left-pointing triangle
Right-pointing triangle
Five-pointed star (pentagram)
Six-pointed star (hexagram)

Tools: Plot Navigation Properties

Properties

The Tools—Axes Scaling Properties dialog box appears as follows.

Axes scaling

Specify when the scope should automatically scale the axes. You can select one of the following options:

  • Manual — When you select this option, the scope does not automatically scale the axes. You can manually scale the axes in any of the following ways:

    • Select Tools > Axes Scaling Properties.

    • Press one of the Scale Axis Limits toolbar buttons.

    • When the scope figure is the active window, press Ctrl and A simultaneously.

  • Auto — When you select this option, the scope scales the axes as needed, both during and after simulation. Selecting this option shows the Do not allow Y-axis limits to shrink check box.

  • After N Updates — Selecting this option causes the scope to scale the axes after a specified number of updates. Selecting this option shows the Number of updates edit box.

By default, this property is set to Auto. This property is Tunable.

Do not allow Y-axis limits to shrink

When you select this property, the y-axis is allowed only to grow during axes scaling operations. If you clear this check box, the y-axis or color limits may shrink during axes scaling operations.

This property appears only when you select Auto for the Axis scaling property. When you set the Axes scaling property to Manual or After N Updates, the y-axis or color limits are allowed to shrink. Tunable.

Number of updates

Specify as a positive integer the number of updates after which to scale the axes. This property appears only when you select After N Updates for the Axes scaling property. Tunable.

Scale axes limits at stop

Select this check box to scale the axes when the simulation stops. The y-axis is always scaled. The x-axis limits are only scaled if you also select the Scale X-axis limits check box.

Y-axis Data range (%)

Set the percentage of the y-axis that the scope should use to display the data when scaling the axes. Valid values are between 1 and 100. For example, if you set this property to 100, the Scope scales the y-axis limits such that your data uses the entire y-axis range. If you then set this property to 30, the scope increases the y-axis range such that your data uses only 30% of the y-axis range. Tunable.

Y-axis Align

Specify where the scope should align your data with respect to the y-axis when it scales the axes. You can select Top, Center, or Bottom. Tunable.

Autoscale X-axis limits

Check this box to allow the scope to scale the x-axis limits when it scales the axes. If Axes scaling is set to Auto, checking Scale X-axis limits only scales the data currently within the axes, not the entire signal in the data buffer. Tunable.

X-axis Data range (%)

Set the percentage of the x-axis that the Scope should use to display the data when scaling the axes. Valid values are between 1 and 100. For example, if you set this property to 100, the Scope scales the x-axis limits such that your data uses the entirex-axis range. If you then set this property to 30, the Scope increases the x-axis range such that your data uses only 30% of the x-axis range. Use the x-axis Align property to specify data placement with respect to the x-axis.

This property appears only when you select the Scale X-axis limits check box. Tunable.

X-axis Align

Specify how the Scope should align your data with respect to the x-axis: Left, Center, or Right. This property appears only when you select the Scale X-axis limits check box. Tunable.

Was this topic helpful?