EyeScope

Launch eye diagram scope for eye diagram object H

Syntax

eyescope
eyescope(h)

Description

Eye Diagram Scope is a graphical user interface (GUI) that enables you to visualize and measure the effects that various impairments, such as noise, jitter, and filtering, have on a modulated signal. The scope performs a probability density function (pdf) analysis on the signal to illustrate its trajectory in time, and to calculate such quantities as eye SNR, RMS jitter, rise time, and fall time. The scope also enables you to import and compare measurement results for eye diagrams of multiple signals.

There are two ways to call EyeScope:

  • eyescope calls an empty scope

  • eyescope(h) calls the scope and displays object h

    Note:   You can call EyeScope with an eye diagram object as the input argument. EyeScope uses the inputname function to resolve the caller's work space name for the argument. If the inputname function cannot resolve the caller's work space name, then EyeScope uses a default name. To learn about the cases when EyeScope can not determine the work space name, type help inputname at the MATLAB® command line.

For more information, see Eye Diagram Analysis.

Starting EyeScope

To start EyeScope from the MATLAB command line, type:

eyescope

The following figure shows an EyeScope that does not have an eye diagram object loaded in its memory.

Alternatively, you can start EyeScope so it displays an eye diagram object. To start EyeScope so it displays an eye diagram object, type the following at the MATLAB command line:

eyescope(h)

    Note:   h is a handle to an eye diagram object in the workspace.

The EyeScope Environment

EyeScope Menu Bar

EyeScope Menu Bar

The EyeScope menu bar is comprised of four menus: File, Options, View, and Help.

  • Use the File menu to control the session management functions, import an eye diagram object into EyeScope, and export an eye diagram plot.

  • Use the Options menu to setup the eye diagram scope by selecting which eye diagram settings and measurements EyeScope displays.

  • Use the View menu to toggle between Single eye diagram view or Compare measurement results view, and to add or modify a legend for the eye diagram plot.

  • The Help menu is used to access help pertaining to the eye diagram object and EyeScope.

Eye Diagram Object Plot and Plot Controls

The Eye diagram object plot is the region of the GUI where the eye diagram plot appears.

Eye diagram plot controls are user-configurable settings that specify plot type, color scale, minimum and maximum plot PDF range, and plot time offset for the eye diagram being analyzed. To access the EyeScope plot controls Options > Eye Diagram Plot Controls

    Note:   The value for the Plot time offset parameter can either be entered directly into the text box or set using the slide bar control.

For more information pertaining to the eye diagram properties, refer to the commscope.eyediagram reference page.

Eye Diagram Object Settings Panel

The eye diagram object settings panel displays the eye diagram object settings. The default EyeScope configuration displays the following eye diagram object settings:

  • Sampling frequency

  • Symbol rate

  • Eye level boundaries

  • BER threshold

  • Amplitude threshold

To specify which eye diagram object settings display in EyeScope, refer to Selecting Which Eye Diagram Object Settings To Display. If you select additional eye diagram object settings to display in EyeScope, use the scroll buttons to view all of the settings.

Measurements

The Measurements panel displays the eye diagram measurement settings. The default EyeScope configuration displays the following eye diagram object measurements:

  • Horizontal Eye Opening

  • Random Jitter

  • Deterministic Jitter

  • Total Jitter

  • RMS Jitter

  • Peak to Peak Jitter

  • Vertical Opening

  • Rise Time

  • Fall Time

  • Eye SNR

To select which eye diagram measurements EyeScope displays, refer to Selecting Which Eye Diagram Measurements To Display. If you select additional eye diagram object measurements to display in EyeScope, use the scroll buttons to view all of the settings.

Using EyeScope

Starting EyeScope with an Argument

You can start EyeScope so it is displaying an eye diagram object. To start EyeScope so it is displaying an eye diagram object, type the following at the MATLAB command line:

eyescope(h)

    Note:   h is a handle to an eye diagram object presently in the workspace.

Starting a new Session

Starting a new session purges EyeScope memory, returning EyeScope to an empty plot display. If changes have been made to an open session and you start a new session, you will be prompted to save the open session.

Opening a Session

To open session, choose the file name and location of the session file. The file extensions for a session file is .eds, which stands for eye diagram scope. If changes have been made to a session that is presently open and you try to open up a new session, you will be prompted to save the session that is presently open before the new session can start.

To open a session:

  1. Click File > Open Session.

    The Select File To Open Window appears.

  2. Navigate to the EyeScope session file you want, and click Open.

Saving a Session

The Save Session selection saves the current session, updating the session file. A session file includes the eye diagram object, eyescope options, and plot control selections.

If you attempt to save a session that you have not previously saved, EyeScope will prompt you for a file name and location. Otherwise, the session is saved to the previously selected file.

To save a session, follow these steps:

  1. Click File > Save Session.

  2. Navigate to the folder where you want to save the EyeScope session file and click Save.

Importing an Eye Diagram Object

The Import menu selection imports an eye diagram object from either the workspace or a MAT-file to EyeScope. The imported variable name will be reconstructed to reflect the origin of the eye diagram object, as follows:

  • If an object is imported from the workspace, the variable name will be ws_object name, where object name is the name of the original variable.

  • If the object is imported from a MATLAB file, then the file name (without the path) precedes the object name.

Importing an object creates a copy of the object, using the naming convention previously described. EyeScope displays the object's contents as configured when the object was imported. EyeScope does not track any object changes made in the workspace (or to the MATLAB file) from which the object was imported.

To import an eye diagram object:

  1. Click File > Import Eye Diagram Object

    The Import eye diagram object window appears.

    The contents panel of the of the Import eye diagram object window displays all eye diagram objects available in the source location.

  2. From the Import eye diagram object window, select the source for the object being imported.

    • Select From workspace to import an eye diagram object directly from the workspace.

    • Select From File to choose an eye diagram object file that was previously saved and click Browse to select the file to be loaded.

  3. Click Import.

Printing to a Figure

EyeScope allows you to print an eye diagram plot to a separate MATLAB figure window. From the MATLAB figure window, along with other tasks, you can print, zoom, or edit the plot.

To export an eye diagram figure:

  • Click File > Print to Figure

    The MATLAB figure window, containing the exported image, appears.

Selecting Which Eye Diagram Object Settings To Display

The Eye Diagram Object Settings View allows you to select which object settings display in the eye diagram object settings panel. You make your selections in the Configure eye diagram object settings view window, where a shuttle control allows you to add, remove, or reorder the settings you are displaying.

To add an eye diagram object setting:

  1. Click Options > Eye Diagram Object Settings View

    The Configure eye diagram object settings view window appears.

  2. Locate any items to be added in the list of Available items, and left-click to select.

      Note:   To select multiple items, you can either press and hold the <Shift> key and left-click or press and hold the <Ctrl> key and left-click.

    When you select an item, the Quick help panel displays information about the item. If you select multiple items, Quick help displays information pertaining to the last item you select.

  3. Click Add.

      Note:   Using the Move Up orMove Down buttons, you can change the order in which the eye diagrams settings you select appear.

  4. Click OK .

Selecting Which Eye Diagram Measurements To Display

You can modify the contents of the measurement panel by selecting which eye diagram measurements display in the eye diagram object settings panel. You make your selections in the Configure measurements view window, where a shuttle control allows you to add, remove, or reorder the settings you are including.

Adding An Eye Diagram Measurement Setting

  1. Click Options > Measurements View

    The Configure measurements window appears.

  2. Locate any items to be added in the list of Available items, and left-click to select.

      Note:   To select multiple items, you can either press and hold the <Shift> key and left-click or press and hold the <Ctrl> key and left-click.

    When you select an item, the Quick help panel displays information about the item. If you select multiple items, Quick help displays information pertaining to the last item you select.

  3. Click Add.

      Note:   Using the Move Up or Move Down buttons, you can change the order in which the eye diagrams settings you select appear.

  4. Click OK .

Was this topic helpful?