Documentation Center

  • Trial Software
  • Product Updates

Eye Diagram Analysis

In digital communications, an eye diagram provides a visual indication of how noise might impact system performance.

Use the EyeScope tool to examine the data that an eye diagram object contains. EyeScope shows both the eye diagram plot and measurement results in a unified, graphical environment. You can import, and compare measurement results for, multiple eye diagram objects.

For information about constructing an eye diagram object, running a simulation, collecting data, and analyzing the simulated data, refer to the 'Eye Diagram Measurements''Eye Diagram Measurements' example. The Eye Diagram and Scatter PlotEye Diagram and Scatter Plot example covers eye diagram analysis applied to a communications system.

For a complete list of EyeScope measurements definitions, refer to 'Measurements' in the Communications System Toolbox™ User's Guide.

For instructions on how to perform basic EyeScope tasks, see the EyeScope reference page.

Import Eye Diagrams and Compare Measurement Results

This section provides a step-by-step introduction for using EyeScope to import eye diagram objects, select and change which eye diagram measurements EyeScope displays, compare measurement results, and print a plot object.

MATLAB® software includes a set of data containing nine eye diagram objects, which you can import into EyeScope. While EyeScope can import eye diagram objects from either the workspace or a MAT-file, this introduction covers importing from the workspace. EyeScope reconstructs the variable names it imports to reflect the origin of the eye diagram object.

  1. Type load commeye_EyeMeasureDemoData at the MATLAB command line to load nine eye diagram objects into the MATLAB workspace.

  2. Type eyescope at the MATLAB command line to start the EyeScope tool.

  3. In the EyeScope window, select File > Import Eye Diagram Object.

    The Import eye diagram object dialog box opens.

    In this window, the Workspace contents panel displays all eye diagram objects available in the source location.

  4. Select eyeObj1 and click Import. EyeScope imports the object, displaying an image in the object plot and listing the file name in the Eye diagram objects list.

      Note:   Object names associated with eye diagram objects that you import from the work space begin with the prefix ws.

    Review the image and note the default Eye diagram object settings and Measurements selections. For more information, refer to the EyeScope reference page.

  5. In the EyeScope window, click the Import button.

  6. From the Import eye diagram object window, click to select eyeObj5 then click the Import button.

    • The EyeScope window changes, displaying a new plot and adding ws_eyeObj5 to the Eye diagram objects list. EyeScope displays the same settings and measurements for both eye diagram objects.

    • You can switch between the eyediagram plots EyeScope displays by clicking on an object name in the Eye diagram object list.

    • Next, click ws_eyeObj1 and note the EyeScope plot and measurement values changes.

  7. To change or remove measurements from the EyeScope display:

    • Select Options > Measurements View. The Configure measurement view shuttle control opens.

    • Hold down the <Ctrl> key and click to select Vertical Opening, Rise Time, Fall Time, Eye SNR. Then click Remove.

  8. From the left side of the shuttle control, select Crossing Time and Crossing Amplitude and then click Add. To display EyeScope with these new settings, click OK. EyeScope's Measurement region displays Crossing Time and Crossing Amplitude at the bottom of the Measurements section.

  9. Change the list order so that Crossing Time and Crossing Amplitude appear at the top of the list.

    • Select Options > Measurements View.

    • When the Configure measurement view shuttle control opens, hold down the <Ctrl> key and click to select Crossing Time and Crossing Amplitude.

    • Click the Move Up button until these selections appear at the top of the list. Then, click OK

  10. Select File > Save session as and then type a file name in the pop-up window.

  11. Import ws_eyeObj2, ws_eyeObj3, and ws_eyeObj4. EyeScope now contains eye diagram objects 1, 5, 2, 3, and 4 in the list.

  12. Select ws_eyeObj5, and click the delete button.

  13. Click File > Import Eye Diagram Object, and select ws_eyeObj5.

  14. To compare measurement results for multiple eye diagram objects, click View > Compare Measurement Results View.

    In the data set, random jitter increases from experiment 1 to experiment 5, as you can see in both the table and plot figure.

  15. To include any data from the Measurements selection you chose earlier in this procedure, use the Measurement selector. Go to the Measurement selector and select Total Jitter. The object plot updates to display the additional measurements.

    You can also remove measurements from the plot display. In the Measurements selector, select Random Jitter and Deterministic Jitter. The object plot updates, removing these two measurements.

  16. To print the plot display, select File > Print to Figure. From Figure window, click the print button.

Was this topic helpful?