Documentation

Importing, Exporting, and Deleting Models in the Linear System Analyzer

Importing Models

To import models into the Linear System Analyzer, select File > Import. The Import System Data dialog box opens, as shown below.

Use the Import System Data dialog box to import LTI models into or from the Linear System Analyzer workspace.

To import a model:

  • Click on the desired model in the LTI Browser List. To perform multiple selections:

    • Hold the Control key and click on nonadjacent models.

    • Hold the Shift key while clicking to select multiple adjacent models.

  • Click the OK or Apply Button

Note that the LTI Browser lists only the LTI models in the MATLAB® workspace.

Alternatively, you can directly import a model into the Linear System Analyzer using the linearSystemAnalyzer function, as in

   linearSystemAnalyzer({'step','bode'},modelname)

See the linearSystemAnalyzer reference page for more information.

Exporting Models

Use Export in the File menu to open the Linear System Analyzer Export window, shown below.

The Linear System Analyzer Export window lists all the models with responses currently displayed in your Linear System Analyzer. You can export models back to the MATLAB workspace or to disk.

To export single or multiple models, follow the steps described in the importing models section above. To save your models to disk in a MAT-file, choose Export to Disk.

Deleting Models

To remove models from the Linear System Analyzer workspace, select Edit > Delete Systems. The Linear System Analyzer Delete dialog box opens.

To delete a model:

  • Click on the desired model in the Model list. To perform multiple selections:

    1. Click and drag over several variables in the list.

    2. Hold the Control key and click on individual variables.

    3. Hold the Shift key while clicking, to select a range.

Click the Delete button.

See Also

More About

Was this topic helpful?