Documentation Center

  • Trial Software
  • Product Updates

Using the Graphical Tuning Window Menu Bar

Overview of the Graphical Tuning Window Menu Bar

Several of the tasks you can do in the SISO Design Tool can be done from the menu bar, shown below.

File

Using the File menu, you can:

  • Import and export models

  • Save and reload sessions

  • Set toolbox preferences

  • Print and print to figure

  • Close the Graphical Tuning Window

The following sections describe the File menu options in turn.

Import

Selecting Import opens the same System Data dialog box that clicking System Data on the Architecture pane does. See Model Import.

Export

Selecting Export from the Graphical Tuning window File menu opens the same SISO Tool Export window that selecting Export from the SISO Design Task node File menu does. See Export.

Save Session

Selecting Save Session from the Graphical Tuning window File menu opens the same Save Projects window that selecting Save from the SISO Design Task node File menu does. See Save.

Load Session

To load a saved SISO Design Tool session, select Load Session from the File menu. This opens the Load Session dialog.

Sessions are saved as MAT-files. Select the session you want to load from the list, and click Open. See Save Session for information on saving SISO Design Tool sessions.

Toolbox Preferences

Select Toolbox Preferences from the File menu to open the Control System Toolbox Preferences window.

The Control System Toolbox Preferences Window

For a discussion of this window's features, see "Setting Toolbox Preferences" online in the Control System Toolbox™ documentation.

Print

Use Print to send a picture of the Graphical Tuning window to your printer.

Print to Figure

Print to Figure opens a separate figure window containing the design views in your current Graphical Tuning window.

Close

Use Close to close the Graphical Tuning window.

Edit

Undo and Redo

Selecting Undo and Redo perform the same actions as selecting Undo and Redo from the SISO Design Task Node Edit menu. See Edit Menu Options.

Tuned Parameters

Selecting Tuned Parameters opens the SISO Tool Preferences dialog box on the Options page.

SISO Tool Preferences

Selecting the SISO Tool Preferences option opens the same dialog box that selecting SISO Tool Preferences from the Edit menu on the SISO Design Task Node. See Edit Menu Options.

View

Design Plots Configuration

Select Design Plots Configuration to open the Graphical Tuning pane. See Graphical Tuning.

Closed-Loop Poles

Select Closed-Loop Poles from View to open the Closed-Loop Pole Viewer.

This window displays all the closed-loop pole values of the selected feedback loop and the associated damping and frequency values.

Design History

Select Design History from the View menu to open the Design History window, which displays all the actions you've performed during a design session. You can save the history to an ASCII flat text file by clicking Save to Text File.

Analysis

Common Response Plots

Each of the top group of items in the Analysis menu opens an LTI Viewer that is dynamically linked to your SISO Design Tool. You have the following response plot choices:

  • Response to Step Command — The closed-loop step response of your system

  • Rejection of Step Disturbance — The open-loop step response of your system

  • Closed-Loop Bode — The closed-loop Bode diagram for your system

  • Compensator Bode — The open-loop Bode diagram for your compensator

  • Open-Loop Nyquist — The open-loop Nyquist plot for your system

When you make changes to the design via the Graphical Tuning window, the Compensator Editor pane, or the Automated Tuning pane, the response plots in the LTI Viewer automatically change to reflect the new design's responses.

Other Loop Responses

If you choose Other Loop Responses, the Analysis Plots pane opens. See Analysis Plots.

Tools

Continuous/Discrete Conversions Using the Sample Time Conversion Dialog Box

Converting Continuous-Time Models to Discrete-Time Models.  To convert a continuous-time model to a discrete-time model, perform these steps:

  1. In the SISO Design Tool, select Tools > Continuous/Discrete Conversions to open the Sample Time Conversion window.

  2. Specify a positive number for the sample time in the Sample time (sec) field.

  3. Select a continuous-to-discrete conversion method for each component of your model. The components include the plant (G), the compensator (C), the prefilter (F), or the sensor (H). You can choose from the following conversion methods:

    • Zero-order hold

    • First-order hold

    • Tustin

    • Tustin with prewarping

        Note:   If you choose Tustin with prewarping, you must specify the critical frequency in radians per second.

    • Matched pole/zero

    For more information on each of these conversion methods, see Continuous-Discrete Conversion Methods in the Control System Toolbox documentation.

Converting Discrete-Time Models to Continuous-Time.  To convert a discrete-time model to a continuous-time model, perform these steps:

  1. In the SISO Design Tool, select Tools > Continuous/Discrete Conversions to open the Sample Time Conversion window.

  2. Select a discrete-to-continuous conversion method for each component of your model. The components include the plant (G), the compensator (C), the prefilter (F), or the sensor (H). You can choose from the following conversion methods:

    • Zero-order hold

    • First-order hold

    • Tustin

    • Tustin with prewarping

        Note:   If you choose Tustin with prewarping, you must specify the critical frequency in radians per second.

    • Matched pole/zero

    For more information on each of these conversion methods, see Continuous-Discrete Conversion Methods in the Control System Toolbox documentation.

Changing the Sample Time of a Discrete-Time Model.  To change the sample time of (resample) a discrete system, perform these steps:

  1. In the SISO Design Tool, select Tools > Continuous/Discrete Conversions to open the Sample Time Conversion window.

  2. Click the Discrete time with new sample time option button.

  3. Specify a positive number for the sample time in the Sample time (sec) field.

Draw Simulink Diagram

    Note   You must have a license for Simulink® to use this feature. If you do not have Simulink, this option does not appear under the Tools menu.

Select Draw Simulink Diagram from the Tools menu to draw a block diagram of your system (plant, compensator, prefilter, and sensor). The following diagram shows how the tool would render the DC motor example described in the Control System Toolbox Getting Started Guide.

Automated Tuning

Select Automated Tuning from the Tools menu in the SISO Design Tool to open the Automated Tuning tab of the Control and Estimation Tools Manager. You can use this tab to perform automated tuning of compensators. For more information, see Automated Tuning Design.

Window

The Window menu item lists all of the windows open in the MATLAB® technical computing environment. The first item is always the MATLAB Command Window. After that, the windows you have opened are listed in the order in which you opened them. Select any window from the list to make it the active window.

Help

Help brings you to various places in the Control System Toolbox help system. This figure shows the menu.

Each topics takes you to brief discussions of basic information about the SISO Design Tool and the Control System Toolbox software:

  • SISO Design Tool Help — An overview of the SISO Design Tool

  • Control System Toolbox Help — A roadmap for the Control System Toolbox help

  • What's This? — Activates the "What's This?" cursor, which appears as a question mark. Click in various regions of the SISO Design Tool to see brief descriptions of the tool's features.

  • Importing/Exporting Models — How to import models into the SISO Design Tool and how to export completed designs

  • Tuning Compensators — Basic information about adjusting gains and adding dynamics to your prefilter (F) and compensator (C)

  • Viewing Loop Responses — How to open an LTI Viewer containing loop responses for your system. Many response types are available.

  • Viewing System Data — How to see information about your model

  • Storing/Retrieving Designs — How to store and retrieve designed systems

  • Customizing the SISO Tool — How to open the SISO Tool Preferences editor, which allows you to customize plot displays in the tool

  • Examples — A link to Control System Toolbox featured examples

  • About the Control System Toolbox software — The version number of your Control System Toolbox software

Was this topic helpful?