Documentation Center

  • Trial Software
  • Product Updates

Using the SISO Design Task Node

The SISO Design Task Node

The following figure shows the SISO Design Task node in the Control and Estimation Tools Manager.

SISO Design Task Node on the Control and Estimation Tools Manager

SISO Design Task Node Menu Bar

The SISO Design Task node menu bar contains the following menus:

File Menu Options

Load
Save
Export
Close
  • Load

    To load a saved SISO Design Tool project, select Load from the File menu. This opens the Load Projects window.

    Projects are saved as MAT-files. Select the project you want to load from the list, or click ... to browse for projects you can select from, and click OK.

  • Save

    You can exit the MATLAB® technical computing environment and later restore the SISO Design Tool to the state you left it in by saving the project. Select Save from the File menu. This opens the Save Projects window.

    To save a project, specify a file name and click OK. The current state and configuration of your SISO Design Tool are saved as a MAT-file. To load a saved project, select Load from the File menu (see previous bullet).

  • Export

    Selecting Export from the File menu opens the SISO Tool Export window.

    You can perform the following tasks in this window:

    • Export models to the MATLAB workspace or to a disk. The exported models are:

      • LTI objects if the plant and sensor are LTI models

      • Arrays of LTI objects if the plant or sensor are arrays of LTI models

    • Rename models when exporting

    • Save variations on models, including open and closed loop models, sensitivity transfer functions, and state-space representations

    To export models to the MATLAB workspace, follow these steps:

  1. Select the model you want to export from the Component list by left-clicking the model name. To select more than one model, hold down the Shift key if they are adjacent on the list. If you want to save nonadjacent models, hold down the Ctrl key while selecting the models.

  2. For each model you want to save, specify a name in the model's cell in the Export As list. A default name exists if you do not want to assign a new name.

  3. Click Export to Workspace.

If you want to save your models as a MAT-file, follow steps 1 and 2 and click Export to Disk, which opens this window.

Choose where you want to save the file in the Save in field and specify the name of the MAT-file in the File name field. Click Save to save the file.

  • Close

    Use Close to close the SISO Design Tool. This closes all components of the SISO Design Tool.

Edit Menu Options

Undo
Redo
SISO Tool Preferences
  • Undo

    Use Undo to go back in design steps. Note that the Undo menu changes when the task you have just performed changes. For example, if you change the compensator gain, the Undo menu item now reads Undo Edit Gain.

  • Redo

    Use Redo to go forward in the design steps. You can only use Redo if you have previously used Undo. Like the Undo menu, the Redo menu changes when the task you have just performed changes. For example, if you change the compensator gain, and then select Undo Edit Gain, the Redo menu item becomes Redo Edit Gain.

  • SISO Tool Preferences

    Select SISO Tool Preferences from the Edit menu to open the SISO Tool Preferences dialog box.

    You can use this window to do the following:

    • Change units

    • Add plot grids, change font styles for titles, labels, etc., and change axes foreground colors

    • Change the compensator format

    • Show or hide system poles and zeros in Bode diagrams

    For a discussion of this window's features, see Setting Toolbox Preferences" online in the Control System Toolbox™ documentation.

Help

Selecting About the Control and Estimation Tools Manager in the Help menu opens a window with the version number and a copyright notice for this product.

Buttons Available from Any Pane

Showing the Control Architecture.  Click Show Architecture to open a window that displays the block diagram for your model. For example,

Below the block diagram is a table that shows the default names for each part of the block diagram and the assigned name, if you have one.

Store Design.  Click Store Design to save your design to your SISO Design Task node. Click on Design under the node to see a snapshot summary of your design. Click on the Design History node to show a list of all stored designs.

Was this topic helpful?