Documentation Center

  • Trial Software
  • Product Updates

Financial Time Series Graphical User Interface

Use the Financial Time Series GUI to analyze your time series data and display the results graphically without resorting to the command line. The Financial Time Series GUI lets you visualize the data and the results at the same time.

Using the Financial Time Series GUI discusses how to use this GUI.

Main Window

Start the financial time series GUI with the command

ftsgui

The Financial Time Series GUI window opens.

The title bar acts as an active time series object indicator (indicates the currently active financial time series object). For example, if you load the file disney.mat and want to use the time series data in the file dis, the title bar on the main GUI would read as shown.

The menu bar consists of six menu items: File, Data, Analysis, Graphs, Window, and Help. Under the menu bar is a status box that displays the steps you are doing.

File Menu

The File menu contains the commands for input and output. You can read and save (Load, Save, and Save As) MATLAB® MAT-files, ASCII (text) data files. To load MATLAB MAT-files, the MAT-file must contain a fints object. You can also import (Import) Excel® XLS files. MATLAB software does not support the export of Excel XLS files at this time.

The File menu also contains the printing suite (Page Setup, Print Preview, and Print). Lastly, from this menu you can close the GUI itself (Close FTS GUI) and quit MATLAB (Exit MATLAB).

Data Menu

The Data menu provides a collection of data manipulation functions and data conversion functions.

To use any of the functions here, make sure that the correct financial time series object is displayed in the title bar of the main GUI window.

Analysis Menu

The Analysis menu provides

  • A set of exponentiation and logarithmic functions.

  • Statistical tools (Basic Statistics), which calculate and display the minimum, maximum, average (mean), standard deviation, and variance of the current (active) time series object; these basic statistics numbers are displayed in a dialog window.

  • Data difference (Difference) and periodic average (Periodic Average) calculations. Data difference generates a vector of data that is the difference between the first data point and the second, the second and the third, and so on. The periodic average function calculates the average per defined length period, for example, averages of every five days.

  • Technical analysis functions. See Chart Technical Indicators for a list of the technical analysis functions.

As with the Data menu, to use any of the Analysis menu functions, make sure that the correct financial time series object is displayed in the title bar of the main GUI window.

Graphs Menu

The Graphs menu contains functions that graphically display the current (active) financial time series object. You can also start up the interactive charting function (chartfts) from this menu.

Window Menu

The Window menu lists open windows under the current MATLAB session.

Help Menu

The Help menu provides a standard set of Help menu links.

Was this topic helpful?