Using the Financial Time Series App with GUIs

The Financial Time Series app works with Datafeed Toolbox™ and Database Toolbox™ software to load data. In addition, the Financial Time Series app interoperates with chartfts to display an interactive plot and ftsgui to perform further time series data analysis.

The workflow for using the Financial Time Series app with chartfts is:

  1. After loading data from either Datafeed Toolbox or Database Toolbox software or an internal file, select a variable from the MATLAB Workspace Variables list box.

  2. Click the Plot tab, click Type, and then select Interactive Chart.

  3. Click Plot. The interactive plot is displayed in chartfts. You can then use chartfts menu items for further display options.

    For more information on chartfts, select Help > Graphics Help.

The workflow for using the Financial Time Series app with the Financial Time Series GUI (ftsgui) is:

  1. After loading data from either Datafeed Toolbox or Database Toolbox software or an internal file, select a variable from the MATLAB Workspace Variables list box.

  2. Select Tools > FTSGUI to open the Financial Time Series GUI window.

  3. Select a variable from the MATLAB Workspace Variables list box. Click the Plot tab and then select one of the following from the Type drop-down list: Line Plot, High-Low Plot, or Candlestick Plot.

  4. Click Plot. The plot is displayed in a MATLAB® graphic window. In addition, the Financial Time Series GUI window displays an entry for the plotted fints object. You can then use the menu items in the Financial Time Series GUI window to perform further analysis.

    For more information on ftsgui, select Help > Help on Financial Time Series GUI.

      Note:   If the selected workspace variable that you are plotting is not a fints object, a fints object is created when you click Plot. The new fints object uses the name designated by the MATLAB workspace variable box on the Create tab.

Was this topic helpful?