fuzzyLogicDesigner

Open Fuzzy Logic Designer app

Syntax

fuzzyLogicDesigner
fuzzyLogicDesigner(fis)

Description

fuzzyLogicDesigner opens the Fuzzy Logic Designer app, which allows you to edit the highest level features of the fuzzy inference system, such as the number of input and output variables, the defuzzyfication method, fuzzy implication and fuzzy inference.

fuzzyLogicDesigner(fis) opens a prebuilt fuzzy inference system.

The Fuzzy Logic Designer app is the high-level interface for any fuzzy logic inference system (FIS). This interface provides convenient access to all other editors with an emphasis on maximum flexibility for interaction with the fuzzy system.

Input Arguments

expand all

fis — Name of prebuilt fuzzy interface systemstring

Name of the prebuilt fuzzy interface system, specified as a string. The system must be stored in a .fis file or a workplace variable

The Designer

The Fuzzy Logic Designer shows the inputs, outputs, and a central fuzzy rule processor. Click one of the variable boxes to select a variable to edit. The box is highlighted in red and the Current Variable field displays the default settings of the selected variable. Double-click one of the variables to open the Membership Function Editor. Double-click the fuzzy rule processor to open the Rule Editor. If a variable exists but is not mentioned in the rule base, it is connected to the rule processor block with a dashed line.

Menu Items

The Fuzzy Logic Designer menu bar allows you to open related tools and open and save systems.

  • In the File menu select

    New FIS > Mamdani to open a new Untitled Mamdani-style system with no variables and no rules.

    New FIS > Sugeno to open a new Untitled Sugeno-style system with no variables and no rules.

    Import > From workspace to load a system from a specified FIS structure variable in the MATLAB® workspace.

    Import > From file to load a system from a specified .fis file.

    Export > To workspace. to save the system to a FIS structure variable in the MATLAB workspace.

    Export > To file to save the current system to a .fis file.

    Print to print the GUI display.

    Close to close the GUI.

  • In the Edit menu select

    Undo to undo the most recent change.

    Add variable > Input to add another input to the current system.

    Add variable > Output to add another output to the current system.

    Remove Selected Variable to delete a selected variable.

    Membership functions to open the Membership Function Editor.

    Rules to open the Rule Editor.

  • In the View menu select

    Rules to open the Rule Viewer.

    Surface to open the Surface Viewer.

Inference Method Pop-up Menus

You can also use pop-up menus to change defuzzyfication, implication and inference settings:

  • And method: Choose min, prod, or Custom, to specify a custom operation.

  • Or method: Choose max, probor (probabilistic or), or Custom, for a custom operation.

  • Implication: Choose min, prod, or Custom, for a custom operation. This selection is not available for Sugeno-style fuzzy inference.

  • Aggregation: Choose max, sum, probor, or Custom, for a custom operation. This selection is not available for Sugeno-style fuzzy inference.

  • Defuzzification: For Mamdani-style inference, choose centroid, bisector, mom (middle of maximum), som (smallest of maximum), lom (largest of maximum), or Custom, for a custom operation. For Sugeno-style inference, choose between wtaver (weighted average) or wtsum (weighted sum).

Was this topic helpful?