Documentation Center

  • Trial Software
  • Product Updates

ruleedit

Open Rule Editor

Syntax

ruleedit('a')
ruleedit(a)

Description

The Rule Editor, when invoked using ruleedit('a'), is used to modify the rules of a FIS structure stored in a file, a.fis. It can also be used to inspect the rules being used by a fuzzy inference system.

To use this editor to create rules, you must first define all of the input and output variables you want to use with the FIS editor. You can create the rules using the listbox and check box choices for input and output variables, connections, and weights. Refer to The Rule Editor for more information about how to use ruleedit.

The syntax ruleedit(a) is used when you want to operate on a workspace variable for a FIS structure called a.

Menu Items

On the Rule Editor, there is a menu bar that allows you to open related GUI tools, open and save systems, and so on. The File menu for the Rule Editor is the same as the one found on the FIS Editor. Refer to fuzzy for more information:

  • Use the following Edit menu item:

    Undo to undo the most recent change.

    FIS properties to invoke the FIS Editor.

    Membership functions to invoke the Membership Function Editor.

  • Use the following View menu items:

    Rules to invoke the Rule Viewer.

    Surface to invoke the Surface Viewer.

  • Use the Options menu items:

    Language to select the language: English, Deutsch, and Francais

    Format to select the format:

    Verbose uses the words "if," "then," "AND," "OR," and so on to create actual sentences.

    Symbolic substitutes some symbols for the words used in the verbose mode. For example, "if A AND B then C" becomes "A & B => C."

    Indexed mirrors how the rule is stored in the FIS structure.

See Also

| | | | | |

Was this topic helpful?