Install the NI-SCOPE Support Package

You can use Instrument Control Toolbox™ to communicate with NI-SCOPE oscilloscopes. You can acquire waveform data from the oscilloscope and control it.

This feature is available through the Hardware Support Packages. Using this installation process, you download and install the following file(s) on your host computer:

  • MATLAB Instrument Driver for NI-SCOPE support

  • National Instruments® driver file: NI-SCOPE driver version 3.9.7

    Note:   You can use this support package only on a host computer running a version of 32-bit or 64-bit Windows® that Instrument Control Toolbox supports.

Supported Compiler Requirement

Certain functionality in the NI-SCOPE support package may require a supported compiler on your system. For the current list of supported compilers, see Supported and Compatible Compilers on the MathWorks® website.

Once you have installed a supported C compiler, set up your compiler by running mex -setup, as described in the documentation for mex in the MATLAB® Function Reference.

Installing the Support Package

To install the Instrument Control Toolbox Support Package for NI-SCOPE Oscilloscopes, in MATLAB type:

supportPackageInstaller

to open the Support Package Installer.

You can also open the installer from MATLAB by selecting Home > Environment > Add-Ons > Get Hardware Support Packages.

On the Select support package to install screen, select NI-SCOPE from the list.

For more information about installing support packages, see Supported Hardware.

Was this topic helpful?