Documentation Center

  • Trial Software
  • Product Updates

Using Existing Drivers

Modifying MATLAB Instrument Drivers

If a MATLAB® instrument driver does not exist for your instrument, it may be that a MATLAB instrument driver for an instrument similar to yours does exist. Rather than creating a new MATLAB instrument driver, you may choose to edit an existing MATLAB instrument driver. An existing MATLAB instrument driver can be opened in the MATLAB instrument driver editor with the midedit function.

midedit('drivername')

Deleting an Existing Property, Function, or Group

  1. Select the property, function, or group in the tree.

  2. Select the Edit menu.

  3. Select the Delete menu item.

Renaming an Existing Property, Function, or Group

  1. Select the property, function, or group in the tree.

  2. Select the Edit menu.

  3. Select the Rename menu item.

Other Settings and Tasks

Refer to Creating MATLAB Instrument Drivers for information on

  • Defining summary information

  • Defining initialization and cleanup code

  • Creating a new property

  • Creating a new function

  • Creating a new group

Importing VXIplug&play and IVI Drivers

The MATLAB Instrument Driver Editor can import a VXIplug&play or IVI® driver. You can evaluate or set the driver's functions and properties, and the modified driver can be saved for further use:

  1. Open the MATLAB Instrument Driver Editor with midedit.

  2. Click the File menu, and select Import.

    The Import Driver dialog box appears, showing the installed VXIplug&play and IVI drivers.

  3. Select the desired driver and click Import.

The MATLAB Instrument Driver Editor creates a MATLAB instrument driver based on the properties and/or functions in the original VXIplug&play or IVI driver. The editor displays the new driver's summary information, groups, properties, and functions.

With the MATLAB Instrument Driver Editor, you can

  • Create, delete, modify, or rename properties, functions, or groups

  • Add code around instrument commands for analysis

  • Add create, connect, and disconnect code

  • Save the driver as a separate MATLAB VXIplug&play instrument driver or MATLAB IVI instrument driver

Was this topic helpful?