Documentation Center

  • Trial Software
  • Product Updates

Set the GUIDE GUI Size

Set the size of the GUI by resizing the grid area in the Layout Editor. Click the lower-right corner of the layout area and drag it until the GUI is the desired size. If necessary, make the window larger.

As you drag the corner handle, the readout in the lower right corner shows the current position of the GUI in pixels (regardless of the GUI Units property setting). Existing objects within the GUI resize with the GUI window if their Units are normalized.

    Note   Setting the Units property to characters (nonresizable GUIs) or normalized (resizable GUIs) gives the GUI a more consistent appearance across platforms. See Cross-Platform Compatible Units for more information.

Prevent Existing Objects from Resizing with the GUI Window

Existing objects within the GUI resize with the GUI window if their Units are normalized. To prevent them from resizing with the GUI window:

  1. Set each object's Units property to an absolute value, such as inches or pixels before enlarging the GUI.

    To change the Units property for all the objects in your GUI simultaneously, drag a selection box around all the objects, and then click the Property Inspector button and set the Units.

  2. When you finish enlarging the GUI, set each object's Units property back to normalized.

Set the GUI Position or Size to an Exact Value

  1. In the Layout Editor, open the Property Inspector for the figure by clicking the button (with no components selected).

  2. In the Property Inspector, scroll to the Units property and note whether the current setting is characters or normalized.

  3. Click the down arrow at the far right in the Units row, and select inches.

  4. In the Property Inspector, display the Position property elements by clicking the + sign to the left of Position.

  5. Change the x and y coordinates to the point where you want the lower-left corner of the GUI to appear, and its width and height.

  6. Reset the Units property to its previous setting, as noted in step 2.

Maximize the Layout Area

You can make maximum use of space within the Layout Editor by hiding the GUIDE toolbar and status bar, and showing only tool icons, as follows:

  1. From the View menu, deselect Show Toolbar.

  2. From the View menu, deselect Show Status Bar.

  3. Select File > Preferences, and then clear Show names in component palette

Was this topic helpful?