Documentation

Export Models to Web View Files

Open the Web View Dialog Box

To export a Web view, use the Web View dialog box. The way you access the dialog box differs, depending on whether you are using the Simulink® Editor or the Report Explorer. You can also open the dialog box from the command line.

InterfaceWhat You Do

Simulink Editor

Select File > Export Model to > Web.

Report Explorer

Select Tools > Export Simulink to Web.

Command line

Use the slwebview function without arguments.

Export a Model to a Web View

  1. Open the model to export.

  2. In the Simulink Editor, select File > Export Model to > Web.

  3. In Systems to Export, select the levels of the model to export, in relationship to the system currently displayed or chart currently selected in the Simulink Editor.

  4. For the systems in the levels that you are exporting, in Include Options, select any kinds of systems you want the Web viewer user to be able to navigate below the Subsystem or Model block, to the underlying blocks or models.

    If you select more than one kind of system, the criteria for exporting information for interacting with the contents of the systems are applied downward through the model hierarchy. For example, if you left Referenced Models unchecked when you exported the model, regardless of how you set the Library Links option, in the Web view you cannot interact with a library link block that is inside of a referenced model.

  5. In the Systems to Exclude list of the systems you have selected to export, select any systems that you do not want to export. To select multiple systems, press the Ctrl key and select systems.

  6. To avoid overwriting existing exported Web view packages, select If package exists, increment name to prevent overwriting.

  7. In Package Type, specify whether you want to package the Web view as a zipped file (the default packaging). In Package name, you can specify a name for the zip file or for the folder for the Web view files.

  8. Click Export.

    Note

    If you use the Web View export option in the Report Explorer Properties pane, then click Export model. If you change the visible system or chart while the Report Explorer Web View pane is visible, the pane does not automatically change to show information about the newly visible system. To update the Web View pane, click Refresh.

  9. If you have Simulink Coverage™ installed, you can use the Optional Views tab to select Model Coverage to export the associated kind of information.

    If you have Simulink Requirements™ installed, you can use the Optional Views tab to select Requirements to export the associated kind of information.

See Also

Functions

Related Examples

More About

Was this topic helpful?