Quantcast

Documentation Center

  • Trial Software
  • Product Updates

Interactive Model Exploration

Simulink Report Generator Tools

The Simulink® Report Generator™ provides tools that you can use to obtain information about models, without creating report setup files:

  • Predefined standard reports

  • Web View

  • XML Comparison report

Predefined Standard Reports

From the Simulink Editor, you can access two predefined, standard Simulink Report Generator reports:

  • System Design Description

  • Design Requirements (requires Simulink Verification and Validation™)

The System Design Description report provides summary or detailed information about a system design represented by a model. You can choose report options with the report dialog box, or you can create a customized version using the Report Explorer. For details, see Generate a System Design Description.

You can use the System Design Description report setup file as a starting point for creating a setup file for your own report.

You can also generate an HTML model report for Stateflow® charts.

You must have the Simulink Verification and Validation product installed to use the Design Requirements report. The Design Requirements report includes information about all the requirements associated with the model and its objects. For details, see Customize Requirements Traceability Report for Model in the Simulink Verification and Validation documentation.

Web View

A Web view is an interactive rendition of a model that you can view in a Web browser. You can use Web views to navigate hierarchically to specific subsystems and see properties of blocks and signals.

Web views are useful for presenting models to audiences and for sharing models with colleagues who do not have MathWorks® products installed.

For details, see Export Models to Web View Files.

XML Comparison Report

You can use Simulink Report Generator software to compare XML text renditions of different versions of a Simulink model and to compare the XML renditions to explore differences between versions of the model. You can also compare the XML text renditions of two different models.

For details, see Model Comparison.

Simulink Model Exploration Tools

You can generate a model report, which is an HTML document that describes the structure and content of a model. The model report includes block diagrams of the model and its subsystems and the settings of its block parameters. To generate the report, from the Simulink Editor, select File > Print Details. For more information, see Generate a Model Report.

To interactively focus on specific elements of a model (for example, blocks, signals, and properties) without navigating through the model diagram or chart, using the Model Explorer. To open the Model Explorer, in the Simulink Editor, select View > Model Explorer. For details, see Model Explorer Overview.

To generate a report that lists the suboptimal conditions or settings in a model, with suggestions for better model configuration settings where appropriate, use the Model Advisor. To open the Model Advisor, in the Simulink Editor, select Analysis > Model Advisor. For details, see Consult the Model Advisor

To navigate a model hierarchically, open systems in a model, and determine the blocks contained in a model, you can use the Simulink Model Browser. To open the Model Browser, select View > Model Browser Options > Model Browser. For details, see Model Browser.

Simulink provides several tools for examining the results of a simulation. Simulation data includes signal, time, output, state, and data store logging data. You can set up your model to export simulation data to the MATLAB® workspace during simulation for later retrieval, analysis, and postprocessing. You can use several approaches to explore the simulation data. For example, you can use the Simulation Data Inspector to generate a report with plots of simulation data. For details, see Export Runtime Information in the Simulink documentation.

Was this topic helpful?