Documentation

This is machine translation

Translated by Microsoft
Mouseover text to see original. Click the button below to return to the English verison of the page.

Note: This page has been translated by MathWorks. Please click here
To view all translated materals including this page, select Japan from the country navigator on the bottom of this page.

Model Views

The SimBiology® desktop provides three different views of a model: the Diagram view, Table view, and Equations view. The Diagram view shows a graphical representation of a model. It describes the model using a set of connected blocks. Blocks represent different modeling elements such as quantities and expressions, and the view shows the relationships between model elements graphically. The Table view displays modeling elements and their properties in a tabular form. You can use either view to build a model. The Equations view shows the differential equations and other expressions such as assignment rules of a model. This view does not let you edit the model. If you make a change to the model using the Diagram or Table view, the change is reflected in all views. To open any view, select Open from the Model tab.

Diagram View

The Diagram view shows the structure of a model graphically. It provides information about how model elements, such as species, interact with one another using a block diagram. To supplement the diagram, this view also contains the browser that shows the relationships between quantities and expressions. You can build a model by dragging and dropping blocks from the block library panel to the browser or diagram. The browser and diagram are synchronized, and any update or change is reflected in both. The next figure shows a model open in the Diagram view.

Diagram

The diagram section contains a set of connected blocks that shows the structure of a model and the relationships between model quantities and expressions graphically.

You can add new quantities and expressions by dragging and dropping blocks from the block library panel to the block diagram. To connect two blocks, Ctrl + click (Option + click for a Mac) the first block and drag to the second block. Double-click a block to edit its properties. Right-click a block to see the context menu with more options, such as hiding the block to avoid clutter. Double-click the name of a block to rename.

The desktop uses contextual icons to provide more information about a block. The icons appear above each block. For instance, if a species is being dosed, a dose icon appears above the species block. Hover the mouse over the icon for more information. For details, see contextual icons.

Adding and configuring reactions.  Suppose you want to model the pharmacokinetics of antibacterial drugs in a time-kill curve experiment [1]. Such experiment involve exposing an in vitro bacterial inoculum to a fixed antibiotic dose and monitoring bacterial activity over time. You can model the in vitro drug kinetics using a one-compartment model with linear elimination to account for drug degradation due to compound instability. This is represented by the first reaction Drug_Central -> null. Include a second compartment (Biophase) to incorporate potential pharmacologic delay, which correspond to the second and third reactions: Drug_Central -> Drug_Central + Drug_Biophase, Drug_Biophase -> null.

Drag and drop two compartment blocks onto the diagram. Then drop a species block inside each compartment. To build the first reaction, reaction1, drag and drop a reaction block onto the diagram. Then draw a line (Ctrl+Click or Options+Click on a Mac) from the Drug_Central species to reaction1. Double-click the reaction block and the Block Property Editor opens. In the Quantities Used by Reaction table, enter kdeg in the Name column as the Forward Rate Parameter. This automatically adds a parameter named kdeg, which is used as the forward rate constant for the reaction rate, that is, kdeg*Drug_Central. Similarly, configure the second reaction reaction2. Enter ke as the forward rate parameter for the reaction. To build the third reaction, reaction3, draw a line from Drug_Central to Drug_Biophase. A reaction block is automatically added between two species blocks. The input and output of the Biophase compartment are modeled as first-order kinetic processes. Drug_Central is both a reactant and product in the input process, assuming that the presence of the Biophase compartment does not affect the mass balance. SimBiology indicates such species using a dashed line. The dashed line can be achieved by drawing another line from reaction2 to Drug_Central. You can also update a reaction by dragging a reaction line or arrow (Ctrl+Click or Option+Click in a Mac) to another species.

Defining or updating a quantity value using mathematical equations.  The equations can take the form of initial assignments, assignments during the course of a simulation (repeated assignments), algebraic relationships, or differential equations (rate rules). Each equation is represented by a unique block. For details about rule blocks, see the block library. For more information about rules, see Definitions and Evaluations of Rules.

Suppose, in the above example, you want to set the initial concentration of Drug_Central to a factor of minimal inhibitory concentration (MIC). You can do so by using an assignment rule that initializes the concentration of Drug_Central at simulation time = 0, that is, Drug_Central0 = 0.25*MIC, where MIC is a parameter. The following figure shows the graphical representation of the assignment rule.

Drag and drop the initial assignment rule block from the block library onto the diagram. To define the left-hand-side (LHS) of the equation, draw a line from the rule block to Drug_Central. An arrow appears pointing at Drug_Central. To display the right-hand-side (RHS) of the equation, right-click the rule block and select Show Only Expressions. By default, the RHS is set to 1. Double-click it and enter the equation: Drug_Central = 0.25*MIC. Drag and drop a parameter block and rename it as MIC. A dash–dot line automatically appears connecting MIC to the rule block indicating MIC is referenced by the RHS. You can also change the LHS by dragging the arrow (Ctrl+Click or Option+Click in a Mac) to another quantity.

Incorporating sudden changes in model behavior.  You can model sudden changes in model behavior based on a specified condition. For example, you can reset a parameter value at a certain time point or when a certain concentration threshold is crossed. In SimBiology, you can model such changes using a modeling element called event. An event lets you specify discrete transitions in quantity values that occur when a custom condition becomes true. Such condition is called an event trigger. Once the condition becomes true, one or more event functions are executed. For details, see events.

Suppose you want to set the concentration of Drug_Central at time = 5 to another factor of MIC as well as the parameter value of the elimination rate constant ke. Specifically,

if (time >= 5)
	Drug_Central  = 0.35*MIC;
	ke = p1*Drug_Biophase;
where p1 is another parameter.

The next figure shows the graphical representation of the event.

By default, parameter blocks are hidden from the diagram. To see hidden parameter blocks such as ke, right-click the diagram, and select Show All Hidden Blocks and Lines. Drag and drop an event block onto the diagram. To define the quantities that are being updated by the event, draw a line from the event block to Drug_Central and another line to ke. Two arrows appear pointing at Drug_Central and ke, which are the LHS of event functions. To show the RHS of event functions, right-click the event block and select Show Only Expressions. Double-click the expressions to edit the event functions as shown. To see the dash–dot lines indicating quantities referenced in the RHS of an event function, right-click the event block and select Show Expressions and Lines (Alt+Click). In this example, MIC, p1, and Drug_Biophase are the referenced quantities as indicated by dash–dot lines. You can also change the LHS by dragging the arrow (Ctrl+Click or Option+Click in a Mac) to another species.

Interpreting a model from its diagram.  The next figure shows an example of a block diagram of another model and interpretations from looking at the graphical semantics.

There are three reactions in this model. Species x, y1, and y2 are catalysts, that is, both reactants and products, and z is a product. The amount of species y1 is being modified by an event. Different contextual icons above some blocks indicate:

  • The amount of species z is being increased by a dose.

  • There is an error with an initial assignment rule.

  • The compartment has constant volume.

Making the diagram clearer.  When there are multiple references to the same quantity, multiple lines are connected to the quantity block. This can cause the diagram to look cluttered. To make the diagram clearer, you can split the block, that is, create copies of the same block, so that each reference is connected to a different copy of the block. You can also clone a block to add another use for it. For instance, you can first clone a species block that you know will be referenced in multiple expressions. Then use each clone in each expression as you build the model.

SimBiology lets you clone or split a species block. To do so, first select the block. Then select Split or Clone from the drop-down menu of the Split button on the Block tab. Event blocks can only be split but not cloned. The next figure shows an example where a species (s2) is referenced by a repeated assignment rule and event, and splitting the block creates a copy for each reference. Copied blocks are then marked by a contextual icon to indicate that they have been cloned.

You can also hide blocks to avoid clutter. To hide a block, right-click it, and select Hide Block from the context menu. By default, blocks that represent constant parameters are hidden. Hidden blocks can be shown by selecting Hidden Blocks on the Block tab.

Browser

The browser supplements the diagram by providing a table of model elements that shows the relationships between quantities and expressions. You can edit these elements in the browser or add new quantities or expressions by dragging and dropping blocks from the block library panel onto the browser. If you make a change in the browser, the diagram is automatically updated.

You can view the model elements shown in the browser by quantities or expressions. In the quantities view, the browser shows all quantities of the model. If a quantity is being modified by any expressions and doses, the view also lists them. Alternatively, the expressions view lists all expressions of the model. It also shows quantities that are referenced by each expression. To switch between the two views, select View > By Quantities or View > By Expressions on the Model tab.

View By Quantities.  The quantities view shows a table of quantities and expressions that are modifying them. Use this view to check the values of quantities and if they are being modified by expressions such as events or assignment rules. You can also see the right-hand-side, of each modifying expression. To display quantity units, select Tools > Show Quantity Units on the Model tab. The check box next to each expression indicates whether the expression is active and used during simulation.

You can model biological variability using a modeling element called variant. A variant is a collection of quantities with alternative values. For instance, in the above example, you can have one set of parameter values such as the elimination rate (ke) and degradation rate (kdeg) for each antibacterial drug.

The browser shows a variant column for each variant of a model. For instance, a variant named Vancomycin is shown in the next figure. You can edit each quantity value by double-clicking it. When there are multiple variants, you can display a subset by clicking Select Variants on the Model tab. To add a variant, drag and drop a variant block from the block panel onto the browser.

If there are expressions for which the left-hand-sides are not defined, these expressions are listed under the section named Undefined. For example, in the next figure, the initial assignment rule_2 is modifying a quantity p2 that is not defined yet in the model. You can right-click the undefined quantity and define it as a species, parameter, or compartment.

Before running any analysis task, SimBiology prepares a model for simulation and updates the quantity values according to the variant values, assignment rules, and doses. For details, see Model Simulation. You can check if the quantity values are initialized as you expect by checking the initial conditions of the task. To see the initial conditions, first, select Show Tasks on the Model tab. Then select a task in the task toolbar. For instance, in the following figure, the initial conditions of a simulation task is shown. In this task, a variant called Vancomycin and a dose called dose_1 have been selected to apply to the model during simulation. The concentration of Drug_Central at the beginning of the simulation is 0.25, compared to the model value 0.0. The value is updated because, at simulation time = 0, SimBiology evaluates the initial assignment rule_1 that initializes Drug_Central to 0.25*MIC. Since the variant Vancomycin has been selected, the alternate values stored in it, namely 0.5 and 0.86 for kdeg and ke, are used instead of model values.

Since a dose is applied to species Drug_Biophase at time = 0, the browser displays the total amount of the species, that is, the initial condition value of the species plus the dose amount. For instance, in the next figure, the total amount of species Drug_Biophase after applying the dose is 0.1. Alternatively, you can view the initial value and dose amount separately by selecting Tools > Task Initial Conditions Options > Show the dose amount separate from the initial condition value from the Model tab.

Defining or updating a quantity value using mathematical equations. The equations can take the form of initial assignments, assignments during the course of a simulation (repeated assignments), algebraic relationships, or differential equations (rate rules). For details, see rules. In the following example, the concentration of Drug_Central at time = 0 is defined by an initial assignment equation, that is, Drug_Central0 = 0.25*MIC. The next figure shows how the browser displays the assignment rule in relation to the species Drug_Central.

Drag and drop the initial assignment rule block onto the species Drug_Central. The rule block appears as a separate row below the species. Double-click the RHS of the equation to edit it.

Incorporating sudden changes in model behavior. You can model sudden changes in model behavior based on a specified condition by using a modeling element called event. In the following example, you want to set the concentration of Drug_Central at time = 5 to another factor of MIC as well as the parameter value of the elimination rate constant ke. Specifically,

if (time >= 5)
	Drug_Central  = 0.35*MIC;
	ke = p1*Drug_Biophase;
where p1 is another parameter.

The next figure shows how the browser displays the event.

Drag and drop the event block onto the species Drug_Central. An event appears as a separate row below the species. To add the second event function, right-click the event and select Add EventFcn. Double-click the event trigger or RHS of an event function to edit.

Increasing a species amount using doses. You can model the increase in the amount of a species due to a stimulus such as an oral or intravenous administration of a drug. To model such an increase in a species amount, use the modeling element called dose. In the following example, the concentration of species Drug_Biophase is being increased by a dose.

Drag and drop a dose block onto the target species. A dose appears as a separate row below the species. To edit the dose amount, double-click the table icon. In this example, the concentration of species Drug_Biophase is being increased by a schedule dose dose_1.

View by Expressions.  In the expressions view, you can see all expressions of a model grouped by their types such as reactions, assignment rules, and events. It shows how each expression is defined and the relationship between each expression and quantities. The check box next to each expression indicates whether the expression is active and used during simulation.

You can expand each reaction in the browser to configure its properties, such as reaction rate, kinetic law, quantities referenced by the reactions, and quantity values. You can define your own reaction rate or use a predefined rate that follows some particular reaction kinetics such as mass action.

A built-in kinetic law in SimBiology specifies a rate law that defines the reaction rate. Specifically each law has a predefined reaction rate containing parameters and species that need to be mapped to the corresponding model quantities to determine the final reaction rate. The browser displays the mapping information in parentheses next to a quantity. For instance, if a parameter kf is used as the forward rate parameter in the reaction rate, the browser displays kf(Forward). In case you map incorrectly, you can reset the mapping by right-clicking the quantity and selecting Remove Kinetic Law Mapping.

The kinetic law for a newly added reaction is configured to MassAction by default, and the desktop automatically creates and maps the species and parameters needed by the reaction rate. For other kinetic laws, only parameters are created and mapped. You need to create and map the species manually. To change the default kinetic law and reaction building settings, select Tools > Reaction Building Preferences on the Model tab.

This view also displays the assignment rules grouped according to their types such as initial assignment, repeated assignment, rate rule, and algebraic rule. For each rule, you can see its left-hand-side (LHS) and right-hand-side (RHS). The LHS is the quantity that is being modified by a rule, except for the algebraic rule. The algebraic rule takes the form 0 = Expression, and the rule is specified as the Expression. For details, see Definitions and Evaluations of Rules.

This view also shows events. For each event, its trigger and event functions are grouped together. Each trigger is started with the word if followed by an expression such as if time>=3. You can also configure the LHS and RHS of each event function.

In addition to all the expressions, you can also see doses that are grouped into either schedule doses or repeat doses. For each dose, the corresponding dosed species, that is, dose target, is shown right next to it. You can double-click the dose icon to edit all dose properties or the table icon to edit just the dose schedule.

The following figure shows a model open in the expressions view of the browser.

Adding and configuring reactions. There are three reactions in this example. Suppose the first and second reaction follow the mass action kinetics and the third reaction follows the Michaelis-Menten kinetics. For illustration purposes, the configuration of reaction1 and reaction3 is described below.

The following figure shows the details of reaction1. It follows the mass action kinetics with the reaction rate kdeg*Central.Drug_Central.

To add a reaction, drag and drop a reaction block onto the browser. You can then enter the reaction string by double-clicking the default null -> null string. Since there are species in two compartments, qualify the species name with the compartment name. For example, Central.Drug_Central indicates that the Drug_Central species is inside the Central compartment. By default, the reaction’s kinetic law is configured to MassAction. The parameter kf is automatically created and mapped to the forward rate constant of the reaction rate. If you want to use a different parameter, you can change it by double-clicking kf and entering the name of another parameter such as kdeg. You can then delete the parameter kf which is no longer used in the reaction rate.

The following figure shows the details of reaction3 that is configured to follow Michaelis-Menten enzyme kinetics with the reaction rate Vm*S/(Km+S).

Drag and drop a reaction block onto the browser. By default, it uses the mass action kinetic law. The parameter kf is automatically created and mapped to the forward rate constant. To specify the reaction to follow Michaelis-Menten kinetics, double-click the row labeled MassAction and select Henri-Michaelis-Menten. SimBiology automatically updates the reaction rate to Vm*S/(Km+S). The parameters vm and km are also automatically added and mapped to Vm and Km, which are the parameters referenced in the reaction rate. However, the S species referenced in the reaction rate is not mapped yet as indicated by a dotted species block. Double-click the (S) row to enter a model species that corresponds to the species S. The reaction rate is then automatically updated using the selected species. To avoid confusion, you may delete the parameter kf, which is no longer used in the reaction rate.

Adding and configuring assignment rules. In this example, there are two initial assignment rules. The first initial assignment rule_1 initializes the concentration of species Drug_Central. The second initial assignment rule_2 initializes an undefined quantity p2.

The next figure shows how the expressions view displays such assignment rules.

Drag and drop the initial assignment rule block onto the browser. Define the LHS of the rule by double-clicking the string null and entering the name of a quantity that the rule is modifying. Double-click the RHS of the equation to edit it. If the LHS of the rule is referring to a quantity that is not yet defined in the model, such as p2 in this example, right-click the undefined quantity and select Define Quantities to define it as a species, parameter, or compartment.

Adding and configuring events. In this example, there is one event event_1 with two event functions changing the concentration of species Drug_Central and parameter ke respectively. Specifically,

if (time >= 5)
	Drug_Central  = 0.35*MIC;
	ke = p1*Drug_Biophase;
where p1 is a parameter.

The next figure shows how the expressions view displays the event.

Drag and drop the event block onto the browser. Double-click the default trigger if time>=1 to edit it. The default event function, null = 0.0, is listed below the trigger. Double-click its LHS and RHS to edit. To add more event functions, right-click the event and select Add EventFcn.

Adding and configuring doses. You can increase the amount or concentration of a species using a dose during simulation. In this example, the concentration of species Drug_Biophase is being increased by a schedule dose dose_1. The next figure shows how the expressions view displays the dose.

Drag and drop a dose block onto the browser. Define the dosed species by double-clicking the LHS of the table icon. Double-click the dose icon to edit all dose properties or the table icon to edit just the dose schedule.

Block Library Panel

The block library panel contains blocks from one or more block libraries. SimBiology provides a default block library which contains blocks that represent all modeling elements that you can use to build models. You can also create a library of custom blocks with different block appearance settings. For instance, you can customize a receptor protein to have a different block shape or color than other species whenever you use it in the diagram. For details on the SimBiology libraries, see Libraries.

You can drag and drop most blocks from the panel to both the browser and diagram, and there are some blocks that can be dropped only in the browser, not in the diagram. Some blocks do not appear as blocks in the diagram but as contextual icons. For instance, a dose block appears as a contextual icon above a species block that is being dosed. The following table summarizes the behaviors of different built-in block types.

Block NameBlock GraphicsDrag and Drop onto the BrowserDrag and Drop onto the DiagramBlock appears asDescription
SpeciesYesYesBlockQuantity that participates in expressions, such as reactions and represents an amount or concentration.
CompartmentYesYesBlockPhysically bounded region that contains species in a model. All species in a model must belong to a compartment. A compartment can also belong to another compartment. For instance, a compartment that represents a cell can contain other cellular components such as mitochondria and nucleus as separate compartments within the cell compartment.
ParameterYesYesBlock

Quantity that is referenced by expressions. For instance, you can use it to define a rate constant of a reaction.

By default, if you drop a parameter block onto the browser or diagram, it is available to all expressions including reactions. This type of parameter is called a model-scoped parameter and listed under the Model Scoped Parameters section in the quantities view of the browser.

Another type is called a reaction-scoped parameter, where the parameter is only available to one particular reaction. These parameters are listed under the Reaction Scoped Parameters section. To add a reaction-scoped parameter, switch to the expressions view of the browser and then drop a parameter block onto a particular reaction.

To switch between the two types, right-click a parameter block and select Change Scope.

ReactionYes (only in the expressions view of the browser)Yes BlockProcess such as a transformation, transport, or the binding and unbinding of reactants and products.
Initial assignmentYesYesBlockExpression to assign the initial value of a quantity. For example, an initial assignment rule s4 = 0.75 means that the amount of species s4 is initialized to 0.75 at simulation time = 0.
Repeated assignmentYesYesBlockExpression to assign a quantity value repeatedly during simulation. For example, a repeated assignment rule x = y1 + y2 means that the amount of species x is repeatedly assigned the total amount of species y1 and y2 throughout the simulation.
Rate ruleYesYesBlockDifferential equation to specify the time derivative of a model quantity. For example, a differential equation x = k * (y + z) specifies that the time derivative of species x (dx/dt) is evaluated continuously during the simulation according to the equation.
Algebraic ruleYesYesBlockExpression to specify a mathematical constraint (for example, a nonlinear equation) on one or more quantities that must hold during simulation. For example, if you have an equation such as x = log(x+time), write the corresponding algebraic rule as log(x+time)-x.

Tip

Use algebraic rules only for nonlinear equations that cannot be solved analytically to get closed-form solutions. For details, see Algebraic Rules.

EventYesYesBlockDiscrete transition in a quantity value. This discrete transition occurs when a specified condition becomes true.
Repeat doseYesNoContextual icon above a species block that is being dosedModeling element that increases the value of a species by a certain amount at predefined time intervals. To add a dose to a species, drag and drop the dose block onto the species in the quantities view of the browser. Double-click the dose icon to edit the dose value.
Schedule doseYesNoContextual icon above a species block that is being dosedModeling element that increases the value of a species by certain amount at specific time points. To add a dose to a species, drag and drop the dose block onto the species in the quantities view of the browser. Double-click the dose icon to edit the dose value.
VariantYes (only in the quantities view of the browser)NoColumn in the BrowserModeling element that is a collection of quantities with alternate values from the original model values.
Text NoYesBlockText block to annotate the model in the diagram.

Table View

This view presents a model in a tabular format, and there are many tables that organize the model information differently. For instance, the Table Overview gives an overview of the entire model by showing the complete list of model quantities, expressions, and some of their properties. There are also tables dedicated to each type of quantity or expression, doses, and variants, and these individual tables provide more information specific for each type.

You can open different tables from the Open drop-down list to edit and add elements to each table. For instance, you can enter a reaction string such as y2 -> z in the Table Overview or Reactions table.

The context menu, which you can open using a right-click, provides options to customize the table and open other modeling tools. For instance, to check which expressions are referencing a quantity, right-click the quantity and select Show Usages from the context menu.

Equations View

This view describes a model in the form of mathematical equations. It shows a system of ordinary differential equations (ODEs) that represent a model. Specifically, the ODEs are derived from model reactions and define what quantities are being integrated during model simulation. For details about the simulation process and how SimBiology constructs ODEs, see Model Simulation.

You can use this view to help debug a model. For instance, you can check the initial conditions of ODEs to see if the quantity values are initialized as you expect. You can also see how SimBiology corrects the dimensions of ODEs by dividing the right-hand-sides of equations with compartment volumes. The volume-correction information can help debug unexpected simulation results, especially when you have a multi-compartment model with different compartment volumes. You can also compare the ODEs to the ones from a publication to reproduce the reported results.

The initial conditions of ODEs are used as starting points to simulate the dynamics of a model. The initial conditions are the quantity values at simulation time = 0. The Value at Time Zero column of the view shows these values. You can check this column to see if the quantity values are initialized as you expect based on initial assignment and repeated assignment rules, and debug the rules as necessary. For details about how SimBiology evaluates the assignment rules, see Model Simulation.

The next figure shows a model open in the equations view, which has the Equations and Initial Conditions sections. The Equations section contains the expressions and ODEs that SimBiology evaluates during model simulation. The Initial Conditions section contains the quantity values at simulation time = 0. Since initial assignments are evaluated just once at time = 0, they are only accessible in the Initial Conditions section via a contextual icon. Repeated assignments are evaluated both at time = 0 and during simulation. Hence they are shown in the Equations section and also indicated by contextual icons.

In this model, the concentration of drug in the central compartment Drug_Central is initialized to 0.25*MIC, resulting in the amount of 0.25 as shown in the Value at Time Zero column. To see the initial assignment equation, click the contextual icon next to Drug_Central. In addition, a repeated assignment equation sets the value of parameter kdeg to p1*1.5, resulting in the value of 0.75. You can see the equation listed under the Repeated Assignments section. The desktop also shows a contextual icon next to the parameter kdeg to indicate the application of the assignment rule.

To perform an analysis on a model such as simulation or sensitivity calculation, you need to run a task. You can specify which doses and variants to use for the analysis in the task configuration. When you select a task, the desktop applies the doses and variants specified in the task, hence updating the corresponding quantity values in the Value at Time Zero column. The dose is also added to the Equations section. The next figure shows the equations view of the same model with a task selected. In this example, the task is a simulation task that uses a dose dose_1 to increase the concentration of drug in the Biophase compartment Drug_Biophase at simulation time = 0.

The grayed-out numbers in the Model Value column indicates the quantity values that have been changed due to the task configuration. The model value and the value at time zero are considered different if the relative tolerance between the values is greater than 10-12, that is, |x-y| > 1e-12*min(|x|,|y|) where x is the model value and y is the value at time zero.

The Fluxes section of the equations view contains reaction fluxes for all reactions in the order they appear in the model. Reaction fluxes are equivalent to reaction rates except that the dimensions of fluxes are always amount/time. Hence, if the dimension of a reaction rate is concentration/time, the expression for the reaction flux is equal to the reaction rate multiplied by a compartment volume. SimBiology uses the name of a compartment to represent its volume in reaction fluxes and ordinary differential equations (ODEs). For details, see Deriving ODEs from Reactions. The next figure illustrates an example where reaction1 is volume-corrected.

While preparing a model for simulation and other analyses, SimBiology performs dimensional analysis to make sure the dimensions of the left-hand-side (LHS) and right-hand-side (RHS) of each ODE are consistent. The LHS of each ODE is the time-derivative of the amount or concentration of a species, and the RHS is defined using reaction fluxes. If you specify no units, the default dimension for a species is concentration, and the default dimension for a flux is amount/time. For such cases, SimBiology divides the RHS by a compartment volume to make the dimensions of LHS and RHS consistent. For details, see Deriving ODEs from Reactions. You can see all the ODEs in the ODEs section of the view as shown in the next figure. In this example, SimBiology uses the default dimensions for species and fluxes. Hence each RHS of ODE is divided by the corresponding compartment volume Central or Biophase for volume-correction. By default, the flux names are used in ODEs. To use the expressions explicitly instead of using the flux names, select Tools > Embed fluxes on the Model tab. The following figure shows ODEs after fluxes have been embedded.

References

[1] Nielsen, E. I., Viberg, A., Lowdin, E., Cars, O., Karlsson, M.O., and Sandstrom, M. (2007) Semimechanistic pharmacokinetic/pharmacodynamic model for assessment of activity of antibacterial agents from time-kill curve experiments. Antimicrobial Agents and Chemotherapy. 51:128-136.

Related Topics

Was this topic helpful?