Create a New Project to Manage Existing Files

If you have files that you want to organize into a project, with or without source control, use the following steps for a new project.

To create a new project to manage your files:

  • From MATLAB®, on the Home tab, in the File section, select New > Simulink Project > Blank Project.

  • From the Model Editor, select File > New > Simulink Project.

  • From the Simulink® Project, on the Simulink Project tab, click New.

The Create Simulink Project dialog box appears.

  1. Specify the project name and location. The default project folder is a subfolder inside your current folder.

  2. If you want, click Add to use the Select a Template dialog box to add one or more templates to apply to the project. See Create a New Project Using Templates. Note: avoid adding templates if you are creating a project in a folder that already contains files, unless you know that the template files are compatible. You see a warning if a template will overwrite files.

    • Try the Project Environment template if you are creating a project in a new folder and intend to add files later. The Project Environment template can create a new project with a preconfigured structure, and utilities to configure the path and environment with startup and shutdown shortcuts. For example, the path utilities help set up your search path to ensure dependency analysis can detect project files. You can modify any of these files, folders, and settings later.

    • Try the Code Generation Example template to set up a project with settings for production code generation of a plant and controller. This template requires Simulink Coder™ and Embedded Coder®.

    • Create your own templates. See Using Templates to Create Standard Project Settings.

  3. If your project folder is already under a supported source control, click Show More Options, then click Detect to check the project folder for source control integration options. See below for details.

  4. Click Create to create the project.

    The Simulink Project displays the empty Project Files View for the specified project root. Your project does not yet contain any files. You need to select files to add. For next steps, see Add Files to the Project.

If you have existing source control in your project folder, you might need the following options when creating projects. Click Show More Options to expand them.

  • Click Detect to check the project folder for source control integration options. If your selected folder is under source control that the project can recognize, the Source control integration field reports the detected source control. For example, you might want to use this option to use a specific version of SVN. See Set Up SVN Source Control.

  • Change project definition files.

    Use multiple project files is the default and is better for avoiding merging issues on shared projects.

    Use a single project file is likely to cause merge issues when multiple users submit changes in the same project to a source control tool. See Project Definition Files.

Related Examples

More About

Was this topic helpful?