Organize Checks and Folders Using the Model Advisor Configuration Editor

Overview of the Model Advisor Configuration Editor

When you start the Model Advisor Configuration Editor, two windows open; the Model Advisor Configuration Editor and the Model Advisor Check Browser. The Configuration Editor window consists of two panes: the Model Advisor Configuration Editor hierarchy and the Workflow. The Model Advisor Configuration Editor hierarchy lists the checks and folders in the current configuration. The Workflow on the right shows the common workflow you use to create a custom configuration.

Model Advisor Configuration Editor

When you select a folder or check in the Model Advisor Configuration Editor hierarchy, the Workflow pane changes to display information about the check or folder. You can change the display name of the check or folder in this pane.

The Model Advisor Check Browser window includes a read-only list of available checks. If you delete a check in the Model Advisor Configuration Editor, you can retrieve a copy of it from the Model Advisor Check Browser.

    Tip   If you use a process callback function in a sl_customization file to hide checks and folders, the Model Advisor Configuration Editor and Model Advisor Check Browser do not display the hidden checks and folders. For a complete list of checks and folders, remove process callback functions and update the Simulink® environment (see Update the Environment to Include Your sl_customization File).

Model Advisor Check Browser

Using the Model Advisor Configuration Editor, you can perform the following actions.

To...Select...
Create new configurationsFile > New
Find checks and folders in the Model Advisor Check BrowserView > Check Browser
Add checks and folders to the configurationEdit > Copy
Edit > Paste
Edit > New folder
The check or folder and drag and drop
Remove checks and folders from the configurationEdit > Delete
Edit > Cut
Reorder checks and foldersEdit > Move up
Edit > Move down
The check or folder and drag and drop
Rename checks and folders

    Note:   MathWorks® folder display names are restricted. When you rename a folder, you cannot use the restricted display names.

The check or folder and edit Display Name in right pane.
Allow or gray out the check box control for checks and foldersEdit > Enable
Edit > Disable
Save the configuration as a MAT file for use and distributionFile > Save
File > Save As
Set the configuration so it opens by default in the Model AdvisorFile > Set Current Configuration as Default
Restore the MathWorks default configurationFile > Restore Default Configuration
Load and edit saved configurationsFile > Open

Start the Model Advisor Configuration Editor

    Note:  

    • Before starting the Model Advisor Configuration Editor, verify that the current folder is writable. If the folder is not writable, you see an error message when you start the Model Advisor Configuration Editor.

    • The Model Advisor Configuration Editor uses the Simulink project (slprj) folder (for details about storing reports and other relevant information, see Model Reference Simulation Targets) in the current folder. If this folder does not exist in the current folder, the Model Advisor Configuration Editor creates it.

  1. To include custom checks in the new Model Advisor configuration, update the Simulink environment to include your sl_customization.m file. For more information, see Update the Environment to Include Your sl_customization File.

  2. Start the Model Advisor Configuration Editor.

    To start the Model Advisor Configuration Editor... Do this:
    ProgrammaticallyAt the MATLAB® command line, enter Simulink.ModelAdvisor.openConfigUI. For more information, see the Simulink.ModelAdvisor function reference page.
    From the Model Advisor
    1. Start the Model Advisor.

    2. Select Settings > Open Configuration Editor.

    The Model Advisor Configuration Editor and Model Advisor Check Browser windows open.

  3. Optionally, to edit an existing configuration in the Model Advisor Configuration Editor window:

    1. Select File > Open.

    2. In the Open dialog box, navigate to the configuration file that you want to edit.

    3. Click Open.

Organize Checks and Folders Using the Model Advisor Configuration Editor

The following tutorial steps you through creating a custom configuration.

  1. Open the Model Advisor Configuration Editor at the MATLAB command line by entering Simulink.ModelAdvisor.openConfigUI . For more options, see Start the Model Advisor Configuration Editor.

  2. In the Model Advisor Configuration Editor, in the left pane, delete the By Product and By Task folders, to start with a blank configuration.

  3. Select the root node which is labeled Model Advisor Configuration Editor.

  4. In the toolbar, click the New Folder button to create a folder.

  5. In the left pane, select the new folder.

  6. In the right pane, edit Display Name to rename the folder. For the purposes of this tutorial, rename the folder to Review Optimizations.

  7. In the Model Advisor Check Browser window, in the Find field, enter optimization to find Simulink > Check optimization settings.

  8. Drag and drop Check optimization settings into Review Optimizations.

  9. In the Model Advisor Check Browser window, find Simulink Verification and Validation > Modeling Standards > DO-178C/DO-331Checks > Check safety-related optimization settings.

  10. Drag and drop Check safety-related optimization settings into Review Optimizations.

  11. In the Model Advisor Configuration Editor window, expand Review Optimizations.

  12. Rename Check optimization settings to Check Simulink optimization settings.

  13. Select File > Save As to save the configuration.

  14. Name the configuration optimization_configuration.mat.

  15. Close the Model Advisor Configuration Editor window.

    Tip   To move a check to the first position in a folder:

    1. Drag the check to the second position.

    2. Right-click the check and select Move up.

Was this topic helpful?