Quantcast

Documentation Center

  • Trial Software
  • Product Updates

Using the Vehicle CAN Bus Monitor

View Messages on a Channel

  1. Open the Vehicle CAN Bus Monitor and select the device and channel connected to your CAN bus by selecting Configure > Channel.

  2. The Vehicle CAN Bus Monitor defaults to the bus speed set in the device driver. You can also configure a new bus speed. See Configuring the Channel Bus Speed

  3. Click Start, or select Run > Start.

  4. To pause the display, click Pause or select Run > Pause.

  5. To stop the display, click Stop or select Run > Stop.

Configure the Channel Bus Speed

Configure the bus speed when your network speed differs from the default value of the channel. You require initialization access for the channel to configure the bus speed.

To configure a new bus speed:

  1. Select Configure > Bus Speed.

  2. Type the desired value in the Specify bus speed dialog box.

  3. Click OK.

The value you set takes effect once you start the CAN channel. If an error occurs when applying the new bus speed, the value reverts to the default value specified in the hardware.

Filter CAN Messages in Vehicle CAN Bus Monitor

Filter CAN messages to allow or block messages displayed in the Vehicle CAN Bus Monitor.

To set up filters:

  1. Select Configure > Message Filters.

  2. To set filters on standard message IDs, select:

    1. Allow All to set the hardware filter to allow all messages with standard IDs.

    2. Block All to set the hardware filter to block all messages with standard IDs.

    3. Allow Only to set up custom filters. Type the standard IDs of the message you want to filter. You can type a range or single IDs. The default is 0:2047.

  3. To set filters on extended message IDs, select:

    1. Allow All to set the hardware filter to allow all messages extended IDs.

    2. Block All to set the hardware filter to block all messages extended IDs.

    3. Allow Only to set up custom filters. Type the extended IDs of the message you want to filter. You can type a range or single IDs. The default is 0:536870911.

        Note:   If you are using a custom filter, change the default range to the desired range. The default range allows all messages and you should select Allow All to allow all incoming messages with extended IDs.

  4. Click OK.

Attach a Database

Attach a database to the Vehicle CAN Bus Monitor to see signal information of the displayed messages.

  1. Select Run > Stop to stop the message display in the Vehicle CAN Bus Monitor.

  2. Select Configure > Database.

  3. Select the database to attach and start the message display again.

    When the tool displays the messages, it shows the message name in the Message table.

  4. Click the plus (+) sign to see the details of the message.

The tool displays the signal name as defined in the attached database and the signal's physical value.

Change the Message Count

You can change the maximum number of messages displayed to a value from 100 through 5000.

  1. Select View > Maximum Message Count.

  2. In the Specify maximum message count dialog box, type the number of messages you want displayed at one time.

  3. Click OK.

Change the Number Format

By default the message data is displayed in hexadecimal format. To change the display to decimal format, select View > Number Format > Decimal.

View Unique Messages

To view the most recent instance of each unique message received on the channel, select View > Show Unique Messages. In this view, you do not see messages scroll up, but each message refreshes its data and timestamp with each new instance. You can also click .

Use this feature to get a snapshot of message IDs that the selected channel receives. Use this information to analyze specific messages.

When you select Show Unique Messages, the tool continues to receive message actively. This simplified view allows you to focus on specific messages and analyze them.

To save messages when Show Unique Messages is selected, click Pause and then click Save. You cannot save just the unique message list. This operation saves the complete message log in the window.

Save the Message Log File

You can save a log file of the messages currently displayed while the tool is running. You need not stop or pause the display to save a log file.

To save a log file of the messages currently displayed in the window, select File > Save Messages or click .

The tool saves the messages in a MATLAB file in your current working folder by default. You can change the location by browsing to a different folder in the Save dialog box.

Each time you save the message log to a file, the Vehicle CAN Bus Monitor saves them as VNT CAN Log.mat with sequential numbering by default. You can change the name by typing a new name in Save dialog box.

Was this topic helpful?