Documentation

Monitor Signals Using Simulink Real-Time Explorer

This procedure uses the model xpcosc as an example. You must have already completed the following setup:

  1. Built and downloaded the real-time application to the target computer using Simulink® (  on the toolbar).

  2. Run Simulink Real-Time™ Explorer (Tools > Simulink Real-Time).

  3. Connected to the target computer in the Targets pane (  on the toolbar).

  4. Set property Stop time to inf in the Applications pane (  on the toolbar).

To monitor a signal:

  1. In Simulink Real-Time Explorer, expand the Model Hierarchy node under the real-time application node.

  2. To view the signals in the real-time application, select the model node. On the toolbar, click the View Signals button  . The Signals workspace opens.

  3. To view the value of a signal, in the Signals workspace, select the Monitor check box for the signal. For instance, select the check boxes for Signal Generator and Integrator1. The signal values are shown in the Monitoring Value column.

  4. To start execution, click the real-time application. On the toolbar, click the Start button  .

  5. To stop execution, click the real-time application. On the toolbar, click the Stop button  .

    The Application Parameters and Signals workspaces look like this figure.

To make both workspaces visible at the same time, drag one workspace tab down until the   icon appears in the middle of the dialog box. Continue to drag until the cursor reaches the required quadrant, and then release the mouse button.

To save your Simulink Real-Time Explorer layout, click File > Save Layout. In a later session, you can click File > Restore Layout to restore your layout.

Related Examples

More About

Was this topic helpful?