Discover MakerZone

MATLAB and Simulink resources for Arduino, LEGO, and Raspberry Pi

Learn more

Discover what MATLAB® can do for your career.

Opportunities for recent engineering grads.

Apply Today

SVM

Asked by C N N on 18 Jan 2012

Basically, i am using SVM for classificiation for images. I used Local Binary pattern for feature extraction. The problem i face is when i apply SVM the pred is always postive. It is not able to detect negative data.Although it shows me the accuracy value, but the pred label is always 1. It is a not able to detect negative data

clear all;
 clc;
 load('C:\Users\HP\Documents\MATLAB\TrainLabel'); 
load('C:\Users\HP\Documents\MATLAB\TrainVec'); 
cvFolds = crossvalind('Kfold', TrainLabel, 10);  
 cp = classperf(TrainLabel);   
for i = 1:10            
    testIdx = (cvFolds == i);               
    trainIdx = ~testIdx;         
    Model = svmtrain(TrainVec(trainIdx,:), TrainLabel(trainIdx), ...                    'Autoscale',true, 'Showplot',false, 'Method','QP', ...                    'BoxConstraint',2e-1, 'Kernel_Function','rbf', 'RBF_Sigma',1);  
  pred = svmclassify(Model, TrainVec(testIdx,:),'Showplot',false);          
 cp = classperf(cp, pred, testIdx);
end  
cp.CorrectRate  
cp.CountingMatrix 

The values for pred is [1;1;1;1;1;1] but my correctrate is 0.53(53%) and the TrainLabel is <267x1 double> and TrainVec is <267x1495 double>.

Any reason why this is so ? Need some help on it.

1 Comment

M@lik Ali on 28 Aug 2012

Hi CNN, I am also facing the problem of SVM. Can you upload here the TrainLabel and TrainVec Thanks in Advance.

C N N

Products

No products are associated with this question.

1 Answer

Answer by dantuluri suryasree on 9 Mar 2012

hello , i am also working on the project my project is 2dpca and svm i have completed my pca for feature extraction but could not find any way to complete my svm for classification can u give me an idea of how do i proceed doing svm with feature vector

0 Comments

dantuluri suryasree

Contact us