Discover MakerZone

MATLAB and Simulink resources for Arduino, LEGO, and Raspberry Pi

Learn more

Discover what MATLAB® can do for your career.

Opportunities for recent engineering grads.

Apply Today

To resolve issues starting MATLAB on Mac OS X 10.10 (Yosemite) visit: http://www.mathworks.com/matlabcentral/answers/159016

ADAMS 2012 and Matlab 2012 Co-Simulation error

Asked by pouya jamali on 16 Jun 2012
Latest activity Commented on by jone on 9 Apr 2014

Dear all I want to Co-simulate an Adams model provided by MD_ADAMS 2012 x64 with Matlab Simulink r2012a but there is a problem. that is: when I run the Simulink block diagram that contains adams plant I see the following error message>> Error in S-function 'testmecanum/adams_sub/ADAMS Plant/S-Function': S-Function 'adams_plant' does not exist. Any body know how can I overcome this problem?

All the best

0 Comments

pouya jamali

Products

No products are associated with this question.

1 Answer

Answer by pouya jamali on 16 Jun 2012
Accepted answer

I found it. Here is the solution:

One file is missing from The MD_ADAMS 2012 x64 installation process. you must download it from MSC.Software official website and install it in the recommended path. take a look at this article : http://simcompanion.mscsoftware.com/infocenter/index?page=content&id=KI8008249&actp=search&searchid=1339844767117

2 Comments

pouya jamali on 16 Jun 2012

Maybe you should register in www.mscsoftware.com first and also log in to watch this hyper link.

jone on 9 Apr 2014

Hi pouya jamali I have same problem but with adams 2013.2 Student edition and matlab 2012a on windows 7 x64 when I tried to follow same step in the link you posted I didn't find win64 directory in path "C:\MSC.Software\Adams_Student_Edition\2013_2\controls" there is win32 directory so can you help me please

thank you very much

pouya jamali

Contact us