MATLAB Answers

Jonas Carlson

Calling curl from within Matlab

Asked by Jonas Carlson
on 28 Sep 2012
Latest activity Answered by amjad majid
on 21 Apr 2015

I have a number of datafiles to be processed. They should be sent to a server, processed, with the results being further processed in Matlab.

I am using curl to communicate with the server using: reply = evalc('!curl https://... -H ... -d ...') and I get the result: curl: (1) Protocol https not supported or disabled in libcurl

I am using Matlab R2012a running under Linux (Fedora 17). When I try the exact same command in a terminal window, it works just fine. Also, this exact program worked before I upgraded Matlab from a previous version (2010).

As I need to use the -H and -d switches of curl I (think) I cannot use "urlread".

What is the difference between using curl in a terminal and invoking it via "!" or "system" from Matlab?

/Jonas Carlson


on 4 Jan 2013

I've got the exact same problem on the exact same OS. I haven't fixed it yet but I can see there is a in /usr/local/MATLAB/R2012a/bin/glnxa64/ directory which is in LD_LIBRARY_PATH before the libcurl in /usr/lib64. This could have something to do with it.

I have the same problem. Has anyone found a fix? Thanks.



No products are associated with this question.

4 Answers

Answer by Christopher
on 5 Jan 2013

Can't you just use a system call?

[A,cURL_out] = system('curl')

  1 Comment

That would do the same thing as evalc('!curl...')

Answer by Pär Halje
on 5 Sep 2013


Apparently the version of libcurl that is bundled with Matlab does not support https. I found a somewhat cumbersome solution here:

This solution is written for Mac so you need to get your libcurl library from somewhere else than MacPort...

Or maybe libcurl is updated in a newer matlab version?



Answer by M. A. Hopcroft on 17 Sep 2013

I had the same issue with Linux (Ubuntu) and R2012a, and solved it by changing the libcurl link in the MATLAB application libraries to point to the system libcurl.

The MATLAB application directory looks like this after installation:

/usr/local/MATLAB/R2012a/bin/glnxa64$ ll libcur*
  lrwxrwxrwx 1 root root     16 2012-06-18 18:12 ->*
  -r-xr-xr-x 1 root root 320452 2011-12-29 00:33*

The link in the system library directory is pointing to, which was built with https support:

/usr/lib$ ll libcurl*
lrwxrwxrwx 1 root root     19 2013-07-12 14:22 ->
lrwxrwxrwx 1 root root     23 2013-07-12 14:22 ->
-rw-r--r-- 1 root root 274368 2013-06-27 12:32
lrwxrwxrwx 1 root root     12 2013-07-12 14:22 ->
lrwxrwxrwx 1 root root     16 2013-07-12 14:22 ->
-rw-r--r-- 1 root root 295360 2013-06-27 12:32

So I changed the softlink:

/usr/local/MATLAB/R2012a/bin/glnxa64$ sudo ln -s /usr/lib/

This fixed the problem for me and has not caused any unintended consequences in MATLAB (so far).

>> system('curl -V')
curl 7.19.7 (x86_64-pc-linux-gnu) libcurl/7.19.7 OpenSSL/0.9.8k zlib/ libidn/1.15
Protocols: tftp ftp telnet dict ldap ldaps http file https ftps 
Features: GSS-Negotiate IDN IPv6 Largefile NTLM SSL libz 


Answer by amjad majid
on 21 Apr 2015

The way I solved this is as follows:

1- go to /Applications/ 2- rename libcurl.dylib to libcurl-OLD.dylib 3- rename libcurl.4.dylib to libcurl.4-OLD.dylib 5- make a symbolic link form to the libcurl from the operating system sudo ln -s /usr/lib/libcurl.4.dylib libcurl.4.dylib sudo ln -s /usr/lib/libcurl.dylib libcurl.dylib

Hopefully that would help


Join the 15-year community celebration.

Play games and win prizes!

Learn more
Discover MakerZone

MATLAB and Simulink resources for Arduino, LEGO, and Raspberry Pi

Learn more

Discover what MATLAB® can do for your career.

Opportunities for recent engineering grads.

Apply Today

MATLAB Academy

New to MATLAB?

Learn MATLAB today!