Discover MakerZone

MATLAB and Simulink resources for Arduino, LEGO, and Raspberry Pi

Learn more

Discover what MATLAB® can do for your career.

Opportunities for recent engineering grads.

Apply Today

Not fully recognizing webcam model

Asked by Sam on 16 Nov 2012

Hello all,

I have three Logitech C600 webcams attached and integrated within a program in MATLAB. Two out of the three are properly identified in MATLAB as 'DeviceName: 'Logitech Webcam 600', however one is identified only as 'USB Video Device'. This reduces the resolutions I can choose and it seems like the unrecognised webcam has a slower frame rate.

I have had a look and haven't found anything. Any help in getting MATLAB to recognise the webcam would be appreciated!

3 Comments

Walter Roberson on 16 Nov 2012

Is it always the same one that is unidentified? If you move them around in USB ports, does the problem move or does it stay with the slot? If you unplug one of the ones that is recognized and try again, does the unrecognized one become recognized?

Sam on 16 Nov 2012

Hello,

It is always one particular webcam and it doesn't depend on which USB port it is connected to. Just plugging in the one webcam by itself results in: 'DeviceName: 'USB Video Device''

The other two always remain recognised no matter which USB port they are connected to.

Walter Roberson on 16 Nov 2012

Possibly different firmware ?

Sam

Products

No products are associated with this question.

1 Answer

Answer by Image Analyst on 16 Nov 2012
Accepted answer

Is this Windows? Can you go into Device Manager and update the driver for the USB device to use the proper Logitech driver instead of the generic one? It's actually probably not a MATLAB issue.

1 Comment

Sam on 17 Nov 2012

Thanks, I'm such an idiot!

Image Analyst

Contact us