Discover MakerZone

MATLAB and Simulink resources for Arduino, LEGO, and Raspberry Pi

Learn more

Discover what MATLAB® can do for your career.

Opportunities for recent engineering grads.

Apply Today

To resolve issues starting MATLAB on Mac OS X 10.10 (Yosemite) visit: http://www.mathworks.com/matlabcentral/answers/159016

how to solve this at my command window: 'make' is not recognized as an internal or external command, operable program or batch file....

Asked by Nurul Mohd on 16 Jan 2013

Hi guys, I've got this problem too but it can't be solved. I use Matlab 2006b. when I tried to connect with external hardware through ADC/DAC, the error is

'make' is not recognized as an internal or external command, operable program or batch file. ###Real-time Workshop build procedure for model: ' ' aborted due to an error.

I've run the mex -setup, [1] Lcc C version 2.4.1 in C:\MATLAB~2\2006b\sys\lcc [2] Microsoft Visual C/C++ version 6.0 in C:\Program Files|Microsoft Visual Studio

and I choose [2]. But it still didn't work for me.

I still using this old Matlab version because my supervisor want me to do so because this version we have custom toolbox made by his former student.

Please, I really stuck with this for 2 days.

Thanks in advanced!

Nurul

4 Comments

Nurul Mohd on 18 Jan 2013

'make'..what do u mean comes with AFAIK?Do you mean that nmake AFAIK file is missing that's why it caused this error? But I already did the mex -setup and choose [2] as a compiler. Do you have any idea what should i do to troubleshoot this prblem?Thanks a lot..

Kaustubha Govind on 1 Feb 2013

AFAIK=as far as I know.

Did "mex -setup" locate the compiler automatically, or did you say "n" to the first question that it asks?

Image Analyst on 1 Feb 2013

(She wouldn't have been able to choose [2] if she had said no). Nurul, what exactly does it say when you tell it 2? You say it doesn't work, but WHAT doesn't work? The mex-setup, or trying to run the m-file, or trying to compile the m-file?

Have you tried the toolbox in your newer version and verified that it definitely doesn't work? Like it uses obsolete functions that are no longer included?

Nurul Mohd

Products

0 Answers

Contact us