File Exchange

image thumbnail

Simulink Support Package for LEGO MINDSTORMS EV3 Hardware

version 1.3.1 (15.1 KB) by

Run models on LEGO MINDSTORMS EV3.

275 Downloads

Updated

Simulink® Support Package for LEGO® MINDSTORMS® EV3 Hardware enables you to create and run Simulink models on LEGO MINDSTORMS EV3 hardware. The support package includes a library of Simulink blocks for configuring and accessing LEGO MINDSTORMS EV3 sensors, actuators, and communication interfaces. It also enables you to interactively monitor and tune algorithms developed in Simulink as they run on the LEGO MINDSTORMS EV3.

This support package is functional for R2014a and beyond.

Comments and Ratings (11)

Mohith Prabhu

@ Wendell Capili
Simulink Support Package for LEGO Mindstorms EV3 is supported on Mac starting from R2016a release.
Details can be found here : https://www.mathworks.com/hardware-support/system-requirements.html

Is there no version for macOS? I am installing but this is what I am getting:

Simulink Support Package for LEGO MINDSTORMS EV3 Hardware cannot be installed on this system.
It requires:

Base Product: Simulink
Host Platforms: Win32,Win64,Linux64

Marco Biroli

I take back what I previously said about the 2016a version. The 2017a is much more well rounded and solved nearly all the problems I had. It's great to see all the effort that went in this add-on in just a year ! Keep it up !

Marco Biroli

There is no way as of 2016a to read distance from an infrared sensor, furthermore it could note manage to retreive data while the program runs in external mode, but maybe i'm just not good with this yet

I always get the Message, when i try to install the package:

There was a problem installing the support package. To resolve this issue, contact Technical Support

I have MATLAB R2016b.

What is the Problem here?

Pradeep KS

Hi, I was trying to install the support file for my MATLAB, I own the 2014a release, but everytime I try I always get this error message:

"MATLAB Support Package for LEGO MINDSTORMS EV3 Hardware is not available for this release of MATLAB."

So, what I need to do? It is because I don't have the data acquisition toolbox?

I was trying to install the support file for MATLAB ( I already have the support package for Simulink). Here's the link:

http://www.mathworks.se/hardware-support/lego-mindstorms-ev3-matlab.html

However, I got this error:
The file you are trying to view is not in a published state.

How can I get this support package ? And do I need it if I already have the Simulink support package ?

John

John (view profile)

Is there a way to get this to work on Mac platform as I get an error

Brian McKay

Brian McKay (view profile)

@J S: Sorry, but the Simulink Support Package for Lego MINDSTORMS EV3 Hardware is only available for release R2014a onwards; there is no support package for R2013b and older releases.

J S

J S (view profile)

how should i install it in 2013b version?
(my school haven't got the latest vertion yet)

Updates

New thumbnail

Fix typos

minor text/spacing in description

typos and image

MATLAB Release
MATLAB 8.3 (R2014a)
Tags Add Tags

Download apps, toolboxes, and other File Exchange content using Add-On Explorer in MATLAB.

» Watch video