Rank: 129124 based on 0 downloads (last 30 days) and 0 file submitted
photo

mario

E-mail

Personal Profile:

Hi I´m using Matlab R2010a, target arduino UNO, software arduino-0022, but i have a problem when I use my board in SIMULINK,
I follow steps in README Arduino Target for Use With Simulink Software, Version 1.0 (R2010a) 01-July-2010
>> arduino.Prefs.setComPort(comPorts{1});
??? Cell contents reference from a non-cell array object.

but i don´t know why this problem
I try to use arduino.Prefs.setComPort('COM1')
but demo_arduino_blink.mdl doesn´t work

Download failed. Check your serial connection and and run the command arduino.Prefs.getMcu to check you have specified the correct MCU.

### If your target board has TX and RX LED you should see them flashing ...
avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

What can I do?
Thankyou
Mario Camacho
Theacher Catolica University Colombia

Professional Interests:

 

Watch this Author's files

 

Comments and Ratings by mario
Updated File Comments Rating
19 May 2011 Arduino IO package: Slides and Examples Slides for the webinar: "Learning Basic Mechatronics Concepts Using the Arduino Board and MATLAB". Author: Giampiero Campa

Hi I´m using Matlab R2010a, target arduino UNO, software arduino-0022, but i have a problem when I use my board in SIMULINK,
I follow steps in README

Arduino Target for Use With Simulink Software, Version 1.0 (R2010a) 01-July-2010
>> cd c:\ARDUINO_TARGET
>> addpath(fullfile(pwd,'arduino'),fullfile(pwd,'blocks'),fullfile(pwd,'demos'))
>> savepath
>> sl_refresh_customizations
>> arduino.Prefs.setArduinoPath('c:\Program Files\ArduinoPRGM\arduino-0022')
>> arduino.Prefs.setMcu('atmega328p')
>> comPorts=arduino.Prefs.searchForComPort;
>> arduino.Prefs.setComPort(comPorts{1});
??? Cell contents reference from a non-cell array object.

but i don´t know why this problem
I try to use arduino.Prefs.setComPort('COM1')
but demo_arduino_blink.mdl doesn´t work

Download failed. Check your serial connection and and run the command arduino.Prefs.getMcu to check you have specified the correct MCU.

The call to arduino_make_rtw_hook, during the after_make hook generated the following error:
Download failed. Check your serial connection and and run the command arduino.Prefs.getMcu to check you have specified the correct MCU.
The build process will terminate as a result.

### If your target board has TX and RX LED you should see them flashing ...
avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

What can I do?
Thankyou
Mario Camacho

Contact us