Path: news.mathworks.com!not-for-mail
From: "Matthias " <matthew.goddard@bcf.uni-freiburg.de>
Newsgroups: comp.soft-sys.matlab
Subject: Re: Keyboard stops working (Linux)
Date: Fri, 3 Sep 2010 09:42:06 +0000 (UTC)
Organization: Universit&#228;t Freiburg
Lines: 22
Message-ID: <i5qfte$k7t$1@fred.mathworks.com>
References: <i50ahq$8bd$1@fred.mathworks.com> <i50i88$1be$1@fred.mathworks.com> <i50jik$s6c$1@fred.mathworks.com> <i50k1g$skr$1@fred.mathworks.com> <i52fvq$9r5$1@fred.mathworks.com> <i52tij$hkg$1@fred.mathworks.com> <i5380c$92o$1@fred.mathworks.com> <i55hso$bl5$1@fred.mathworks.com> <i55ms4$874$1@fred.mathworks.com> <i5l59s$8j1$1@fred.mathworks.com> <i5pgnv$8mr$1@fred.mathworks.com>
Reply-To: "Matthias " <matthew.goddard@bcf.uni-freiburg.de>
NNTP-Posting-Host: webapp-02-blr.mathworks.com
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 8bit
X-Trace: fred.mathworks.com 1283506926 20733 172.30.248.37 (3 Sep 2010 09:42:06 GMT)
X-Complaints-To: news@mathworks.com
NNTP-Posting-Date: Fri, 3 Sep 2010 09:42:06 +0000 (UTC)
X-Newsreader: MATLAB Central Newsreader 1879395
Xref: news.mathworks.com comp.soft-sys.matlab:667376

"Jackson Tan" <tornado.zone84@gmail.com> wrote in message <i5pgnv$8mr$1@fred.mathworks.com>...
> Just to throw in a comment that I'm facing the same problem as well. I'm using R2010a on Ubuntu 10.04. Happened numerous times.
> 
> MatLab stops taking in keyboard inputs even though it is obviously working with other applications. MatLab is not busy either, since mouse buttons work. I'm not certain what triggers it, but I think it is probably windows/desktop switching (i.e. outside MatLab).
> 
> Puzzling, and irritating (especially when re-running the script will take several minutes and stretch my computer).
> 
> Jackson

Hey, 

I contacted support and they pointed out the following known issue with linux and java (Matlab uses Java for the GUI), which interestingly specifically also related to IBus: 
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6506617 

After disabling IBus, Matlab ran problem free all day yesterday. 

I also updated java to: 
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01, mixed mode)

I will test over the next week whether the java update, with and without IBus running, resolves the issue.