Path: news.mathworks.com!newsfeed-00.mathworks.com!newsfeed2.dallas1.level3.net!news.level3.com!postnews.google.com!news1.google.com!npeer01.iad.highwinds-media.com!news.highwinds-media.com!feed-me.highwinds-media.com!post01.iad.highwinds-media.com!newsfe22.iad.POSTED!33b9410e!not-for-mail
From: Doug Schwarz <see@sig.for.address.edu>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.18) Gecko/20110616 Lightning/1.0b2 Thunderbird/3.1.11
MIME-Version: 1.0
Newsgroups: comp.soft-sys.matlab
Subject: Re: ls problem with matlab 2009a in ubuntu
References: <iubk50$g2i$1@newscl01ah.mathworks.com> <see-F425FC.07370628062011@news.frontiernet.net>
In-Reply-To: <see-F425FC.07370628062011@news.frontiernet.net>
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 7bit
Lines: 38
Message-ID: <ZBkOp.4305$_b7.1102@newsfe22.iad>
X-Complaints-To: abuse-news@frontiernet.net
NNTP-Posting-Date: Tue, 28 Jun 2011 13:24:09 UTC
Organization: Frontier
Date: Tue, 28 Jun 2011 09:24:08 -0400
Xref: news.mathworks.com comp.soft-sys.matlab:734014

On 6/28/2011 7:37 AM, Doug Schwarz wrote:
> In article<iubk50$g2i$1@newscl01ah.mathworks.com>,
>   "David Zhang"<solarbikedz@gmail.com>  wrote:
>
>>  I've installed matlab 2009a on my ubuntu 10.04 box.  Everything works great,
>>  except with the annoying problem where if I type the command "ls" to show the
>>  current directory, the results contains strange characters in addition to the
>>  file names.  For example, in my home folder:
>>  >>  ls
>>  bin  Desktop  Documents  
>>  [01;34mDownloads  finance  Music  
>>  [01;34mPictures  Public  Templates  
>>  [01;34mVideos
>>  
>>  Repeating the same thing by explicitly invoking the unix command "!ls" gives
>>  the same problem, which suggests there is some sort of communication problem
>>  between matlab and unix.  Running the same matlab in terminal and I don't
>>  have this issue.
>>
>>  Some might say "why don't you just navigate using directory window?"  Well, I
>>  could.  However being with Linux for so long, moving through directories
>>  using command line is much faster and more comfortable for me.  Although this
>>  is not a serious problem, it is annoying enough that it stains an otherwise
>>  beautiful installation of matlab on ubuntu.
>
> Those are ANSI escape sequences.<escape>[0m turns all attributes off,
> <escape>[01;34m makes the text bold with a blue background.  You must
> have ls configured to use color by default, perhaps with the environment
> variable CLICOLOR.  See the man page for ls for more info.

On Ubuntu, it looks like the appropriate environment variable is 
LS_COLORS.  See also the man page for dircolors.


-- 
Doug Schwarz
dmschwarz&ieee,org
Make obvious changes to get real email address.