Path: news.mathworks.com!not-for-mail
From: "Gianluca " <seansecrets@hotmail.com>
Newsgroups: comp.soft-sys.matlab
Subject: Breakpoint strange behaviour
Date: Fri, 12 Jul 2013 19:58:20 +0000 (UTC)
Organization: The MathWorks, Inc.
Lines: 10
Message-ID: <krpn4s$a6f$1@newscl01ah.mathworks.com>
Reply-To: "Gianluca " <seansecrets@hotmail.com>
NNTP-Posting-Host: www-06-blr.mathworks.com
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 8bit
X-Trace: newscl01ah.mathworks.com 1373659100 10447 172.30.248.38 (12 Jul 2013 19:58:20 GMT)
X-Complaints-To: news@mathworks.com
NNTP-Posting-Date: Fri, 12 Jul 2013 19:58:20 +0000 (UTC)
X-Newsreader: MATLAB Central Newsreader 3843093
Xref: news.mathworks.com comp.soft-sys.matlab:799257

Hi,

I am doing some debugging to a code that I made, but something strange happens when I use conditional breakpoints. In particular, I am integrating some equations with ODE45. The equations are written in a function, while ODE45 is called on a separate script. Basically, all I want to do is to stop the integration at a certain time t, in order to check the values of some variables. So I put a conditional breakpoint inside the function. The breakpoint only works in two cases (t==1 and t==2) and the integration is effectively stopped at those times. If I put any other value of time the breakpoint is totally ignored and the integration is not stopped. 
Any idea about this problem? I don't know what to do.... 

P.S. I am using Matlab R2011a

Thanks 

Gianluca