Discover MakerZone

MATLAB and Simulink resources for Arduino, LEGO, and Raspberry Pi

Learn more

Discover what MATLAB® can do for your career.

Opportunities for recent engineering grads.

Apply Today

Thread Subject:
3D plot with date on Y axis but an exponential factor 10^5 shows up

Subject: 3D plot with date on Y axis but an exponential factor 10^5 shows up

From: Ben

Date: 16 Sep, 2012 02:39:07

Message: 1 of 3

I surf a 3D figure with axis Y being date. It has 500 dates. After I use

set(gca,'Ylim',[date_axis_start date_axis_end]);
set(gca,'YTick',date_label_pick);
set(gca,'YTickLabel',date_label_str);

there is an exponential 10^5 appear beside the date labels for Y axis. I couldn't get rid of it. When I simply surf the 3D figure, it automatically uses numeric date on Y axis and the exponential appears. But after I used the three commands above, the exponential is still there. Can anyone help me out here? Thanks.

Subject: 3D plot with date on Y axis but an exponential factor 10^5 shows up

From: Bruno Luong

Date: 16 Sep, 2012 07:31:07

Message: 2 of 3

I get this when I run your code:

[ Undefined function or variable 'date_axis_start'. ]
 
Bruno

Subject: 3D plot with date on Y axis but an exponential factor 10^5 shows up

From: Ben

Date: 17 Sep, 2012 13:43:07

Message: 3 of 3

"Bruno Luong" <b.luong@fogale.findmycountry> wrote in message <k33v7r$rpe$1@newscl01ah.mathworks.com>...
> I get this when I run your code:
>
> [ Undefined function or variable 'date_axis_start'. ]
>
> Bruno

The lines above are just for tick labels, I have the date_axis_start and ..._end defined before those lines.

Tags for this Thread

What are tags?

A tag is like a keyword or category label associated with each thread. Tags make it easier for you to find threads of interest.

Anyone can tag a thread. Tags are public and visible to everyone.

Contact us