Skip to Main Content Skip to Search
Accelerating the pace of engineering and science

 

System Requirements - PolySpace Products (Release 2007a)

Choose Your Operating System

Windows

  Operating System Processors Disk Space RAM
32-bit PolySpace Client Products

Windows XP (Service Pack 2)

Windows 2000 (Service Pack 4)

Intel Pentium (Pentium IV and above)

Intel Celeron

Intel Xeon

Intel Core

AMD Athlon

AMD Opteron
2 GB 512 MB

(1024 MB ECC RAM recommended)
32-bit PolySpace Server Products

Windows XP (Service Pack 2)

Windows 2000 (Service Pack 4)

Intel Pentium (Pentium IV and above)

Intel Celeron

Intel Xeon

Intel Core

AMD Athlon

AMD Opteron
2 GB

2 GB

(4 GB ECC RAM recommended)


Required Products and Plug-ins


PolySpace™ Model Link SL (for Simulink®) 4.2 requires:

  • PolySpace™ Client for C/C++ 4.2
  • MATLAB® 6.5.2 (R13 SP2) or 7.4 (R2007a) on Windows
  • Real-Time Workshop® Embedded Coder 3.2.1 (R13 SP2) or 4.6 (R2007a) on Windows

PolySpace™ Model Link TL (for dSPACE® TargetLink®) 4.2 requires:

  • PolySpace™ Client for C/C++ 4.2
  • MATLAB® 6.5.2 (R13 SP2) or 7.3 (R2006b) on Windows
  • dSPACE TargetLink 2.1 or 2.2

PolySpace™ UML Link RH (for Telelogic® Rhapsody®) 4.2 requires:

  • PolySpace™ Client for C/C++ 4.2
  • Telelogic Rhapsody 7.0 - 7.3 on Windows

Graphics

  • 16-, 24-, or 32-bit OpenGL capable graphics adapter
  • DirectX 9.0c (August 2005) or later

License Management

  • Some license types require a license server running Macro vision FLEXNET ™ 10.8, which is included with the installer.
  • TCP/IP is required on all platforms when using a license server.

Contact Us

Call MathWorks: 508-647-7000