Skip to Main Content Skip to Search
Accelerating the pace of engineering and science

 

System Requirements for Polyspace Products - Release 2009b

Choose Your Operating System

Windows


Operating Systems Processors Disk Space RAM
32-bit Polyspace Client and Server Products

Windows XP
(Service Pack 1, 2, or 3)

Windows Vista
(Service Pack 1)

Windows Server 2003
(Service Pack 2)

Windows Server 2008

Intel Pentium (Pentium 4 and above)

Intel Celeron

Intel Xeon

Intel Core

AMD Athlon

AMD Opteron

AMD Sempron

2 GB

Polyspace Client
512 MB
(1024 MB ECC RAM recommended)

Polyspace Server
2 GB
(4 GB ECC RAM recommended)

64-bit Polyspace Client and Server Products

Windows XP
(Service Pack 1, 2, or 3)

Windows Vista
(Service Pack 1)

Windows Server 2003
(Service Pack 2)

Windows Server 2008

Intel Pentium (Pentium 4 and above)

Intel Celeron

Intel Xeon

Intel Core

AMD64

2 GB

Polyspace Client
2 GB
(4 GB ECC RAM recommended)

Polyspace Server
8 GB
(16 GB ECC RAM recommended)


Required Products and Plug-ins


Polyspace Model Link SL (for Simulink) 5.4 requires:

  • Polyspace Client for C/C++ 7.1
  • MATLAB 7.5, 7.6, 7.7, 7.8, or 7.9 on Windows

Polyspace Model Link TL (for dSPACE TargetLink) 5.4 requires:

  • Polyspace Client for C/C++ 7.1
  • MATLAB 7.5, 7.6, 7.7, 7.8, or 7.9 on Windows
  • dSPACE TargetLink 2.1, 2.2, or 3.0

Polyspace UML Link RH (for Telelogic Rhapsody) 5.4 requires:

  • Polyspace Client for C/C++ 7.1
  • Telelogic Rhapsody 7.1, 7.2, or 7.3 on Windows

Graphics

  • 16-, 24-, or 32-bit OpenGL capable graphics adapter
  • DirectX 9.0c (August 2005) or later

License Management

  • Some license types require a license server running FLEXnet 10.8, which is available with the Polyspace installer.
  • TCP/IP is required on all platforms when using a license server.

Contact Us

Call MathWorks: 508-647-7000