Hardware Support

QuickTime Capture Support from Image Acquisition Toolbox

Use video capture devices with MATLAB and Simulink to acquire images and video on Windows PCs.


Image Acquisition Toolbox™ supports UVC compliant webcams using QuickTime. QuickTime 7.6.6 is required on MAC OS X 10.5 (Leopard), and QuickTime 10 (or higher) is required on MAC OS X 10.6 (Snow Leopard). See the Troubleshooting section of the Image Acquisition Toolbox documentation for additional information.

To test your video capture device for compatibility with the toolbox, verify your hardware is functioning properly by running the webcam application that came with MAC OS X (for example, the PhotoBooth or iMovie application). If you can start, run, and close the utility without encountering any errors, the device may work with Image Acquisition Toolbox as long as the camera complies with QuickTime.

UVC-compliant devices, such as webcams, can also be used directly in MATLAB® with the MATLAB Support Package for USB Webcams.

Manufacturers

Many manufacturers provide cameras that are compatible with QuickTime. More detailed information is available for manufacturers linked below.

Allied Vision Microsoft
Basler PixeLINK
Baumer Point Grey
Creative Sony
Hewlett-Packard Toshiba Teli
Logitech  

Please see the Troubleshooting section of the Image Acquisition Toolbox documentation for additional information.

Platform and Release Support

QuickTime is supported on the following operating systems: 

  • MAC OS X

Related Hardware Support Views: MATLAB, Simulink, Allied Vision, Apple, Automotive, Basler, Baumer, Biotech and Pharmaceutical, Computer Vision System Toolbox, Consumer Electronics, Consumer Goods, Creative, Hewlett-Packard, Image Acquisition Toolbox, Image Processing Toolbox, Image Processing and Computer Vision, Industrial Automation and Machinery, Logitech, MATLAB Product Family, MathWorks Supported, Metals, Materials, and Mining, Microsoft, PixeLINK, Point Grey, QuickTime, Semiconductor, Sony, Support Package Installer Enabled, Toshiba Teli

Ready to install?

Before installing the support package, confirm you have the correct setup. View system requirements and installation options.

Get Support Package

Software

Required

Recommended

Support Package

Required

Support Package Installer installs this support package. To start the installer, go to the MATLAB toolstrip and click Add-Ons > Get Hardware Support Packages. For more information, read the documentation.

Get Support Package

Hardware

Required

  • Any QuickTime Compliant Camera

Don't see the hardware you're looking for?