Main Content

Unreal Engine Simulation Environment Requirements and Limitations

Aerospace Blockset™ provides an interface to a simulation environment that is visualized using the Unreal Engine® from Epic Games®. This visualization engine comes installed with the toolbox. When simulating in this environment, keep these requirements and limitations in mind.

Software Requirements

  • Windows® 64-bit platform

  • Visual Studio® 2019

  • Microsoft® DirectX® — If this software is not already installed on your machine and you try to simulate in the environment, the toolbox prompts you to install it. Once you install the software, you must restart the simulation.

In you are customizing scenes, verify that your Unreal Engine project is compatible with the Unreal Engine version supported by your MATLAB® release.

MATLAB Release Unreal Engine Version

R2021b

4.25

Note

Mac and Linux® platforms are not supported for Unreal Engine simulation.

Minimum Hardware Requirements

  • Graphics card (GPU) — Virtual reality-ready with 8 GB of on-board RAM

  • Processor (CPU) — 2.60 GHz

  • Memory (RAM) — 12 GB

Limitations

The Unreal Engine simulation environment blocks do not support:

  • Code generation

  • Model reference

  • Multiple instances of the Simulation 3D Scene Configuration block

  • Multiple Unreal Engine instances in the same MATLAB session

  • Parallel simulations

  • Rapid accelerator mode

  • Multiple instances of the same actor tag. To refer to the same scene actor when you use the 3D block pairs, such as Simulation 3D Actor Transform Get and Simulation 3D Actor Transform Set, specify the same Tag for actor in 3D scene, Actortag parameter.

In addition, when using these blocks in a closed-loop simulation, all Unreal Engine simulation environment blocks must be in the same subsystem.

Related Topics

External Websites