MATLAB®
Desktop Tools and Development Environment

R2019b
How to Contact MathWorks

Latest news: www.mathworks.com

Sales and services: www.mathworks.com/sales_and_services

User community: www.mathworks.com/matlabcentral

Technical support: www.mathworks.com/support/contact_us

Phone: 508-647-7000

The MathWorks, Inc.
1 Apple Hill Drive
Natick, MA 01760-2098

MATLAB® Desktop Tools and Development Environment


The software described in this document is furnished under a license agreement. The software may be used or copied only under the terms of the license agreement. No part of this manual may be photocopied or reproduced in any form without prior written consent from The MathWorks, Inc.

FEDERAL ACQUISITION: This provision applies to all acquisitions of the Program and Documentation by, for, or through the federal government of the United States. By accepting delivery of the Program or Documentation, the government hereby agrees that this software or documentation qualifies as commercial computer software or commercial computer software documentation as such terms are used or defined in FAR 12.212, DFARS Part 227.72, and DFARS 252.227-7014. Accordingly, the terms and conditions of this Agreement and only those rights specified in this Agreement, shall pertain to and govern the use, modification, reproduction, release, performance, display, and disclosure of the Program and Documentation by the federal government (or other entity acquiring for or through the federal government) and shall supersede any conflicting contractual terms or conditions. If this License fails to meet the government’s needs or is inconsistent in any respect with federal procurement law, the government agrees to return the Program and Documentation, unused, to The MathWorks, Inc.

Trademarks

MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other product or brand names may be trademarks or registered trademarks of their respective holders.

Patents

MathWorks products are protected by one or more U.S. patents. Please see www.mathworks.com/patents for more information.
**Revision History**

<table>
<thead>
<tr>
<th>Date</th>
<th>Form</th>
<th>Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>June 2004</td>
<td>First printing</td>
<td>New for MATLAB 7.0 (Release 14). Formerly part of Using MATLAB.</td>
</tr>
<tr>
<td>October 2004</td>
<td>Online only</td>
<td>Revised for Version 7.0.1 (Release 14SP1)</td>
</tr>
<tr>
<td>March 2005</td>
<td>Online only</td>
<td>Revised for Version 7.0.4 (Release 14SP2)</td>
</tr>
<tr>
<td>March 2005</td>
<td>Second printing</td>
<td>Revised for Version 7.0.4 (Release 14SP2)</td>
</tr>
<tr>
<td>June 2005</td>
<td>Third printing</td>
<td>Minor revision for Version 7.0.4 (Release 14SP2)</td>
</tr>
<tr>
<td>September 2005</td>
<td>Online only</td>
<td>Revised for Version 7.1 (Release 14SP3)</td>
</tr>
<tr>
<td>March 2006</td>
<td>Online only</td>
<td>Revised for Version 7.2 (Release 2006a)</td>
</tr>
<tr>
<td>September 2006</td>
<td>Online only</td>
<td>Revised for Version 7.3 (Release 2006b)</td>
</tr>
<tr>
<td>March 2007</td>
<td>Online only</td>
<td>Revised for Version 7.4 (Release 2007a)</td>
</tr>
<tr>
<td>September 2007</td>
<td>Online only</td>
<td>Revised for Version 7.5 (Release 2007b)</td>
</tr>
<tr>
<td>March 2008</td>
<td>Online only</td>
<td>Revised for Version 7.6 (Release 2008a)</td>
</tr>
<tr>
<td>October 2008</td>
<td>Online only</td>
<td>Revised for Version 7.7 (Release 2008b)</td>
</tr>
<tr>
<td>March 2009</td>
<td>Online only</td>
<td>Revised for Version 7.8 (Release 2009a)</td>
</tr>
<tr>
<td>September 2009</td>
<td>Online only</td>
<td>Revised for Version 7.9 (Release 2009b)</td>
</tr>
<tr>
<td>March 2010</td>
<td>Online only</td>
<td>Revised for Version 7.10 (Release 2010a)</td>
</tr>
<tr>
<td>September 2010</td>
<td>Online only</td>
<td>Revised for Version 7.11 (Release 2010b)</td>
</tr>
<tr>
<td>April 2011</td>
<td>Online only</td>
<td>Revised for Version 7.12 (Release 2011a)</td>
</tr>
<tr>
<td>September 2011</td>
<td>Online only</td>
<td>Revised for Version 7.13 (Release 2011b)</td>
</tr>
<tr>
<td>March 2012</td>
<td>Online only</td>
<td>Revised for Version 7.14 (Release 2012a)</td>
</tr>
<tr>
<td>September 2012</td>
<td>Online only</td>
<td>Revised for Version 8.0 (Release 2012b)</td>
</tr>
<tr>
<td>March 2013</td>
<td>Online only</td>
<td>Revised for Version 8.1 (Release 2013a)</td>
</tr>
<tr>
<td>September 2013</td>
<td>Online only</td>
<td>Revised for Version 8.2 (Release 2013b)</td>
</tr>
<tr>
<td>March 2014</td>
<td>Online only</td>
<td>Revised for Version 8.3 (Release 2014a)</td>
</tr>
<tr>
<td>October 2014</td>
<td>Online only</td>
<td>Revised for Version 8.4 (Release 2014b)</td>
</tr>
<tr>
<td>March 2015</td>
<td>Online only</td>
<td>Revised for Version 8.5 (Release 2015a)</td>
</tr>
<tr>
<td>September 2015</td>
<td>Online only</td>
<td>Revised for Version 8.6 (Release 2015b)</td>
</tr>
<tr>
<td>October 2015</td>
<td>Online only</td>
<td>Rereleased for Version 8.5.1 (Release 2015aSP1)</td>
</tr>
<tr>
<td>March 2016</td>
<td>Online only</td>
<td>Revised for Version 9.0 (Release 2016a)</td>
</tr>
<tr>
<td>September 2016</td>
<td>Online only</td>
<td>Revised for Version 9.1 (Release 2016b)</td>
</tr>
<tr>
<td>March 2017</td>
<td>Online only</td>
<td>Revised for Version 9.2 (Release 2017a)</td>
</tr>
<tr>
<td>September 2017</td>
<td>Online only</td>
<td>Revised for Version 9.3 (Release 2017b)</td>
</tr>
<tr>
<td>March 2018</td>
<td>Online only</td>
<td>Revised for Version 9.4 (Release 2018a)</td>
</tr>
<tr>
<td>September 2018</td>
<td>Online only</td>
<td>Revised for Version 9.5 (Release 2018b)</td>
</tr>
<tr>
<td>March 2019</td>
<td>Online only</td>
<td>Revised for Version 9.6 (Release 2019a)</td>
</tr>
<tr>
<td>September 2019</td>
<td>Online only</td>
<td>Revised for Version 9.7 (Release 2019b)</td>
</tr>
</tbody>
</table>
1 Startup and Shutdown

Start MATLAB on Windows Platforms ........................................ 1-2
  Select MATLAB Icon ................................................................... 1-2
  Call matlab from Windows System Command Line .................... 1-3
  Call matlab from MATLAB Command Prompt ......................... 1-3
  Open File Associated with MATLAB ........................................ 1-3
  Select MATLAB Executable from Windows Explorer Tool .......... 1-4

Associate Files with MATLAB on Windows Platforms ................ 1-5

Associate .mat Files with MATLAB ............................................. 1-6

Start MATLAB on Linux Platforms ............................................ 1-8
  Startup Folder ........................................................................ 1-8
  Execute MATLAB Script from Remote ssh Login .................... 1-8

Start MATLAB on macOS Platforms .......................................... 1-10
  Start from Applications Folder ............................................. 1-10
  Start from Terminal Window ............................................... 1-10

Exit MATLAB ........................................................................... 1-12
  Ways to Quit or Exit ............................................................ 1-12
  Confirm Exiting ...................................................................... 1-12
  Run Script When Exiting ...................................................... 1-13

Recovering Data After Abnormal Termination ............................ 1-14

Crash Reporting ....................................................................... 1-15
  Locating Crash Logs ............................................................. 1-15

When MATLAB Terminates Unexpectedly .................................. 1-17
  MathWorks Crash Reporter ..................................................... 1-17
  MathWorks Crash Analyzer .................................................... 1-17
Specifying Java Startup Options .......................... 1-18

MATLAB Startup Folder ........................................ 1-20
  Default Startup Folder .................................. 1-20
  Change Startup Folder .................................. 1-21
  userpath as Initial Working Folder .................. 1-21

Commonly Used Startup Options .............................. 1-23

Specify Startup Options ...................................... 1-25
  Startup Options from Operating System Prompt .... 1-25
  Startup Options in Shortcut on Windows Systems ... 1-25
  Startup Options in MATLAB Startup File ............. 1-26
  Passing Perl Variables on Startup .................... 1-26
  Startup and Calling Java Software from MATLAB ... 1-27

Toolbox Path Caching in MATLAB ............................ 1-28
  About Toolbox Path Caching in MATLAB ............. 1-28
  Using the Cache File Upon Startup ................... 1-28
  Updating the Cache and Cache File ................. 1-28

Startup with Java Access Bridge Software ................. 1-30

Desktop

Change Fonts ..................................................... 2-2
  Change Font Size ....................................... 2-2
  Change Font Name and Style ........................... 2-2
  Advanced Customization ................................ 2-3
  Adding Fonts ........................................... 2-4

Fonts Custom Preferences .................................... 2-6

Change Color Settings ......................................... 2-7
  Change Text and Background Colors in Desktop Tools 2-7
  Change Syntax Highlighting Colors .................. 2-7
  Change Command Window Colors ...................... 2-8
  Change Code Analyzer Colors ......................... 2-9
Access Frequently Used Features ........................................ 2-10

Optimize Desktop Layout ................................................. 2-12
  Desktop Layout .................................................................. 2-12
  Document Layout .......................................................... 2-15

Use Keyboard Shortcuts to Navigate MATLAB .................... 2-17
  MATLAB Online ............................................................. 2-18
  Additional Keyboard Shortcuts ......................................... 2-19

Customize Keyboard Shortcuts ........................................... 2-21
  View Keyboard Shortcuts ................................................ 2-21
  Customize Keyboard Shortcuts for Individual Actions ......... 2-23
  Manage Sets of Keyboard Shortcuts ................................. 2-26

Set Print Options ............................................................. 2-28
  Page Setup Options ....................................................... 2-28
  Layout Options for Page Setup ........................................ 2-28
  Header Options for Page Setup ........................................ 2-29
  Fonts Options for Page Setup ......................................... 2-29

Web Browsers and MATLAB ................................................ 2-31
  About Web Browsers and MATLAB ................................. 2-31
  Display Pages in Web Browsers ....................................... 2-33
  Specify Proxy Server Settings for Connecting to the Internet 2-33
  Specify the System Browser for Linux Platforms ............... 2-34

Manage Your Licenses ....................................................... 2-35

Update an Existing Installation ........................................... 2-37
  Update from Notifications ............................................ 2-37
  Check for Updates ........................................................ 2-37

macOS Platform Conventions ............................................. 2-39
  Mouse Instructions and macOS Platforms ......................... 2-39
  Navigating Within the MATLAB Root Folder on macOS Platforms 2-39
  MATLAB Dock Menu ..................................................... 2-40

Preferences ................................................................. 2-41
  Set Preferences for MATLAB .......................................... 2-41
  Where MATLAB Stores Preferences ............................... 2-41
Preferences MATLAB Uses When Multiple Releases Are Installed ...................................... 2-42
General Preferences .................................................. 2-44
Confirmation Dialog Boxes Preferences .......................... 2-45
Source Control Preferences ........................................ 2-47
Keyboard Shortcuts Preferences .................................... 2-47
Colors Preferences ..................................................... 2-48
Colors Programming Tools Preferences .......................... 2-49
Comparison Preferences ............................................. 2-50
Toolbars Preferences .................................................. 2-51
Web Preferences .......................................................... 2-53

# Entering Commands

Enter Statements in Command Window .......................... 3-2
Find Functions to Use .................................................. 3-4

Format Output .......................................................... 3-7
  Format Line Spacing in Output ................................... 3-7
  Format Floating-Point Numbers ..................................... 3-7
  Wrap Lines of Code to Fit Window Width ........................ 3-8
  Suppress Output .................................................... 3-9
  View Output by Page ................................................ 3-9
  Clear the Command Window ....................................... 3-9

Stop Execution .......................................................... 3-11

Find Text in Command Window or History ...................... 3-12
  Find Text in the Command Window ............................... 3-12
  Find Text in the Command History Window .................... 3-14

Rerun Favorite Commands ............................................ 3-15
  Create and Run Favorite Commands ............................... 3-15
  Organize Favorite Commands ..................................... 3-16

Set Command Window Preferences .................................. 3-18
Set Keyboard Preferences ........................................... 3-21

Check Syntax as You Type ........................................... 3-24
  Syntax Highlighting ................................................ 3-24
  Delimiter Matching ............................................... 3-25
  Code Suggestions and Completions ......................... 3-25
  Function Syntax Hints .......................................... 3-28

Set Command History Preferences ................................. 3-31
  Change the Command History Date Format ................. 3-33

Help and Product Information

4

Ways to Get Function Help ........................................ 4-2

MATLAB Code Examples ........................................... 4-4
  Standalone Examples ............................................. 4-4
  Inline Examples .................................................. 4-5

Search Syntax and Tips ............................................ 4-7

Bookmark and Share Page Locations ............................. 4-10
  Bookmark Favorite Pages ....................................... 4-10
  View Page Locations ............................................ 4-11

Contact Technical Support ......................................... 4-12

Help Preferences .................................................... 4-14

Translated Documentation ......................................... 4-16
  Set Documentation Language .................................. 4-16
  View Installed Documentation ............................... 4-16
  View Documentation on the Web ......................... 4-17

Information About Your Installation ............................. 4-18
Workspace Browser and Variable Editor

Create and Edit Variables ........................................ 5-2
  Create Variables ............................................... 5-2
  View Workspace Contents ..................................... 5-3
  View Variable Contents ........................................ 5-4
  Edit Variable Contents ........................................ 5-5
  Resize or Reshape Variables .................................. 5-10
  Copy, Rename, and Delete Variables ......................... 5-11
  Navigate Variable Contents ................................. 5-12

Display Statistics in the Workspace Browser .................. 5-14
  Improve Workspace Browser Performance During Statistical Calculations ........................................ 5-14
  Include or Exclude NaN Values in Statistical Calculations ........................................ 5-14

Save and Load Workspace Variables ............................. 5-16
  Save Workspace Variables ..................................... 5-16
  Load Workspace Variables ..................................... 5-17
  View Contents of MAT-File .................................... 5-17

Workspace and Variable Preferences ........................... 5-19
  Workspace Preferences ........................................ 5-19
  Variables Preferences ......................................... 5-21

Managing Files in MATLAB

Find Files and Folders ........................................... 6-2
  Simple Search for File and Folder Names ...................... 6-2
  Advanced Search for Files .................................... 6-2

Compare Files and Folders and Merge Files .................... 6-6
  Compare Files and Folders .................................... 6-6
  Compare Folders, Zip Files, and Simulink Manifests ........ 6-8
  Compare and Merge Text ....................................... 6-11
  Compare Files with Autosave Version or Version on Disk 6-15
  Compare and Merge Live Code ................................. 6-15
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compare and Merge MAT-Files</td>
<td>6-19</td>
</tr>
<tr>
<td>Compare Binary Files</td>
<td>6-22</td>
</tr>
<tr>
<td>Comparison Report Tools and Options</td>
<td>6-23</td>
</tr>
<tr>
<td>Source Control</td>
<td>6-24</td>
</tr>
<tr>
<td><strong>Compare XML Files</strong></td>
<td>6-25</td>
</tr>
<tr>
<td>Choose XML Files to Compare</td>
<td>6-26</td>
</tr>
<tr>
<td>Change Comparison Type</td>
<td>6-27</td>
</tr>
<tr>
<td>Navigate the XML Comparison Report</td>
<td>6-27</td>
</tr>
<tr>
<td>Save Comparison Log Files in a Zip File</td>
<td>6-29</td>
</tr>
<tr>
<td>Export Results to the Workspace</td>
<td>6-29</td>
</tr>
<tr>
<td><strong>Manage Files and Folders</strong></td>
<td>6-32</td>
</tr>
<tr>
<td>Manage Files and Folders in MATLAB Online</td>
<td>6-35</td>
</tr>
<tr>
<td><strong>Share Folders in MATLAB</strong></td>
<td>6-36</td>
</tr>
<tr>
<td>Share a Folder</td>
<td>6-36</td>
</tr>
<tr>
<td>Remove Access to Shared Folder</td>
<td>6-36</td>
</tr>
<tr>
<td>Access Folders Share with You</td>
<td>6-37</td>
</tr>
<tr>
<td><strong>Files and Folders that MATLAB Accesses</strong></td>
<td>6-38</td>
</tr>
<tr>
<td>Where Does MATLAB Look for Files?</td>
<td>6-38</td>
</tr>
<tr>
<td>Files and Folders You Should Add to the Search Path</td>
<td>6-38</td>
</tr>
<tr>
<td>When Multiple Files Have the Same Name</td>
<td>6-39</td>
</tr>
<tr>
<td>Locations of MathWorks Products</td>
<td>6-39</td>
</tr>
<tr>
<td><strong>Current Folder Browser Preferences</strong></td>
<td>6-41</td>
</tr>
<tr>
<td><strong>Specify File Names</strong></td>
<td>6-43</td>
</tr>
<tr>
<td>Construct Valid Path and File Names</td>
<td>6-43</td>
</tr>
<tr>
<td>Case Sensitivity of File Names</td>
<td>6-45</td>
</tr>
<tr>
<td><strong>Create and Extract from Zip Archives</strong></td>
<td>6-47</td>
</tr>
<tr>
<td>Create a Zip Archive</td>
<td>6-47</td>
</tr>
<tr>
<td>Add Files to a Zip Archive</td>
<td>6-48</td>
</tr>
<tr>
<td>Extract Files from a Zip Archive</td>
<td>6-48</td>
</tr>
<tr>
<td>Compare Zip Archive to Unzipped Files</td>
<td>6-49</td>
</tr>
<tr>
<td><strong>What Is the MATLAB Search Path?</strong></td>
<td>6-50</td>
</tr>
<tr>
<td>userpath Folder on the Search Path</td>
<td>6-50</td>
</tr>
<tr>
<td>MATLABPATH Environment Variable</td>
<td>6-51</td>
</tr>
<tr>
<td>Determine If Files and Folders Are on the Search Path</td>
<td>6-51</td>
</tr>
<tr>
<td>The Search Path Is Not the System Path</td>
<td>6-52</td>
</tr>
</tbody>
</table>
How MATLAB Stores the Search Path .................................. 6-53

Change Folders on the Search Path ................................. 6-54
  For Current and Future Sessions ............................... 6-54
  For the Current Session Only .................................. 6-56

Use Search Path with Different MATLAB Installations ....... 6-57

Add Folders to the MATLAB Search Path at Startup ........... 6-58
  Use a startup.m File ........................................ 6-58
  Set the MATLABPATH Environment Variable ................. 6-58

Assign userpath as Startup Folder (Macintosh or UNIX) ...... 6-60

Path Unsuccessfully Set at Startup ................................ 6-61

Errors When Updating Folders on Search Path ................. 6-63

Troubleshoot Invalid or Unresponsive Windows Change
Notification Handles ..................................................... 6-64
  Control How MATLAB Detects Changes in Files and Folders
  ........................................................................ 6-64
  Clear Functions from Memory .................................... 6-65
  Configure Change Notification Handle Warnings ............. 6-65

Editor Preferences

Editor/Debugger Preferences ........................................... 7-2
  General Preferences for the Editor/Debugger .................. 7-2
  Editor/Debugger Display Preferences ............................ 7-4
  Editor/Debugger Tab Preferences ................................ 7-5
  Editor/Debugger Language Preferences ......................... 7-6
  Editor/Debugger Code Folding Preferences .................... 7-9
  Editor/Debugger Backup Files Preferences ...................... 7-10
  Editor/Debugger Autoformatting Preferences .................. 7-11
  Editor/Debugger Autocoding Preferences ....................... 7-13

Code Analyzer Preferences ........................................... 7-16
  Code Analyzer Preferences ...................................... 7-16
Add-Ons

Get and Manage Add-Ons .................................................. 8-2
Get Add-Ons .................................................. 8-2
Install Add-Ons from File .................................................. 8-3
Default Add-On Installation Folder ...................................... 8-4
Manage Add-Ons .................................................. 8-5
Update Add-Ons .................................................. 8-5
Run Apps .................................................. 8-6

Internationalization

Locale Settings for MATLAB Process .................................. 9-2
Default Locale Setting .................................................. 9-3
Supported Character Set .................................................. 9-3
Platform-Specific Localized Formats for Current Folder Browser .................................................. 9-3

Limitations to International Character Support ...................... 9-4

Set Locale on Windows Platforms ...................................... 9-5
Locale on Windows 10 Platforms ...................................... 9-5
Locale on Windows 8 Platforms ...................................... 9-5
Locale on Windows 7 Platforms ...................................... 9-6

Set Locale on macOS Platforms ........................................ 9-7

Set Locale on Linux Platforms ......................................... 9-9

Unexpected Behavior on macOS Platforms ......................... 9-10

Characters Incorrectly Displayed on Windows Systems .......... 9-11
datenum Might Not Return Correct Value .......... 9-12
Numbers Display Period for Decimal Point ............. 9-13
File or Folder Names Incorrectly Displayed .......... 9-14
Script Compatibility .................................. 9-15
MATLAB Desktop Language Preference ................. 9-16
X Servers and International Keyboard Layouts .......... 9-17

MATLAB Online

10

Restore Files in MATLAB Online .................. 10-2

Post-Installation Tasks

11

Configure the MATLAB Startup Accelerator .......... 11-2
Change When the MATLAB Startup Accelerator Runs .... 11-2
Startup and Shutdown

- “Start MATLAB on Windows Platforms” on page 1-2
- “Associate Files with MATLAB on Windows Platforms” on page 1-5
- “Associate .mat Files with MATLAB” on page 1-6
- “Start MATLAB on Linux Platforms” on page 1-8
- “Start MATLAB on macOS Platforms” on page 1-10
- “Exit MATLAB” on page 1-12
- “Recovering Data After Abnormal Termination” on page 1-14
- “Crash Reporting” on page 1-15
- “When MATLAB Terminates Unexpectedly” on page 1-17
- “Specifying Java Startup Options” on page 1-18
- “MATLAB Startup Folder” on page 1-20
- “Commonly Used Startup Options” on page 1-23
- “Specify Startup Options” on page 1-25
- “Toolbox Path Caching in MATLAB” on page 1-28
- “Startup with Java Access Bridge Software” on page 1-30
Start MATLAB on Windows Platforms

Choose one of these ways to start MATLAB.

- “Select MATLAB Icon” on page 1-2
- “Call matlab from Windows System Command Line” on page 1-3
- “Call matlab from MATLAB Command Prompt” on page 1-3
- “Open File Associated with MATLAB” on page 1-3
- “Select MATLAB Executable from Windows Explorer Tool” on page 1-4

When you start MATLAB, it automatically adds the userpath folder to the search path. MATLAB also reopens any desktop components that were open when you last shut down.

To customize startup, see “Specify Startup Options” on page 1-25.

The MATLAB startup folder is the folder you are in when you get the MATLAB prompt. To change the default startup folder, see “MATLAB Startup Folder” on page 1-20.

If you have trouble starting MATLAB, then see MATLAB Installation, Activation & Startup Help.

Select MATLAB Icon

On Microsoft Windows platforms, double-click the MATLAB icon. The term Release refers to your MATLAB release number; for example, R2017a.

- Installer shortcut on your Windows desktop — Double-click the MATLAB icon.
- Windows 10 systems — Start > All apps > MATLAB Release
- Windows 8 systems — On the Start screen or the desktop, click MATLAB Release.
- Windows 7 systems — If you chose to have the installer put a shortcut to the MATLAB program on the Windows Start menu, then select Start > MATLAB Release

With this option, the startup folder is the last working folder from the previous MATLAB session or the custom path specified in the Initial working folder preference described in “General Preferences” on page 2-44.

You also can specify a custom startup folder in the MATLAB shortcut icon using the Start in field. However, this technique is the same as setting a custom path in the Initial
working folder preference. If you enter an invalid path in the Start in field, then the startup folder is unpredictable. To set a custom path in the Start in field:

1. Right-click the shortcut icon for MATLAB and select Properties from the context menu. The Properties dialog box for MATLAB opens to the Shortcut pane.
2. In the Start in field, type the full path to a folder on your system, and then click OK.

Call matlab from Windows System Command Line

From the Windows system prompt, type matlab.

The startup folder is the folder in which you run the matlab command. To use the folder specified by the Initial working folder preference, type:

matlab -useStartupFolderPref

Call matlab from MATLAB Command Prompt

If you start another MATLAB session from within MATLAB, then the startup folder is the folder where you call the command:

!matlab

To display the startup folder, type pwd before calling matlab.

Open File Associated with MATLAB

The MATLAB installer sets up associations between certain file types and MathWorks® products. MATLAB starts when you open one of those files. The startup folder is the folder containing the file.

For example, using the Windows Explorer tool, double-click a file with a .m extension. MATLAB starts and opens the file in the MATLAB Editor.

For more information, see “Associate Files with MATLAB on Windows Platforms” on page 1-5.
Select MATLAB Executable from Windows Explorer Tool

When you double-click the `matlab.exe` file from the Windows Explorer, the startup folder is one of the following:

- The last working folder from the previous MATLAB session.
- The custom path specified in the **Initial working folder** preference.

**See Also**

`matlab` (Windows) | `userpath`

**More About**

- “Specify Startup Options” on page 1-25
- “MATLAB Startup Folder” on page 1-20
- “General Preferences” on page 2-44
- “Associate Files with MATLAB on Windows Platforms” on page 1-5
- MATLAB Installation, Activation & Startup Help
Associate Files with MATLAB on Windows Platforms

When you install MATLAB on Windows platforms, the installer sets up associations between certain file types and MathWorks products. When you double-click one of these files in the Windows Explorer (file manager), Windows executes the open action specified by the file association. If Windows starts MATLAB, then it opens the version of MATLAB associated with that file type.

By default, MATLAB associates the latest installed version to MATLAB file types. If you use the Windows file manager or the Control Panel to associate a MATLAB version to a file type, then that version remains associated with the file type even when you install another MATLAB. If, instead, you always want to use the latest MATLAB version, then you must manually reassociate the type with each new installation of MATLAB. If you want to return to the default behavior, then uninstall every MATLAB that is manually associated to any MATLAB file type. Then reinstall the latest MATLAB release.

Sometimes double-clicking a MATLAB file in the Windows file manager opens a new instance of the version of MATLAB that is already open. To work around this issue, uninstall versions of MATLAB, release R2010a or earlier. Then reinstall MATLAB R2010b or later.

Alternatively, change the security setting on the `matlabroot\toolbox\local\pathdef.m` file to allow the Users group to write to the file. For more information, see https://www.mathworks.com/matlabcentral/answers/93468-why-is-a-new-instance-of-matlab-opened-when-i-double-click-on-a-matlab-file-in-windows-explorer-even.

See Also

More About

- “Associate .mat Files with MATLAB” on page 1-6
Associate .mat Files with MATLAB

To associate a .mat extension type with MATLAB R2010b or later, use the Microsoft Windows Default Programs control panel.

1. Open the Windows Control Panel. The Control Panel is typically available from the Windows Start menu, or refer to your Windows documentation.
2. From View by: Category, select Programs.
3. Select Default Programs.
4. Select Set your default programs. The Programs pane shows installed versions of MATLAB, R2010b and later.
5. Select a MATLAB release, then Choose defaults for this program.
6. Check the box next to the .mat entry.
7. Select Save.
8. Close all dialog boxes and menus, and exit the Control Panel.

If you want to use MATLAB R2010a or earlier, then choose the Associate a file type or protocol with a program options from the Default Programs menu instead. Scroll down the list of file types to the .mat entry. Select Change Program... and choose a version of MATLAB from the Recommended Programs list. Do not use the Browse button.

For information about using these options, see your Windows documentation.

Note

By default, MATLAB associates the latest installed version to MATLAB file types. However, once you use the Windows Control Panel or the file manager to associate a MATLAB version to a file type, you must manually reassociate the type with each new installation of MATLAB. If you want to return to the default behavior, then uninstall every MATLAB that is manually associated to any MATLAB file type. Then reinstall the latest MATLAB release.
See Also

More About

- “Associate Files with MATLAB on Windows Platforms” on page 1-5
Start MATLAB on Linux Platforms

To start MATLAB on Linux platforms, type `matlab` at the operating system prompt. If you did not set up symbolic links in the installation procedure, then type `matlabroot/bin/matlab`. `matlabroot` is the name of the folder in which you installed MATLAB. To see the folder, type `matlabroot`.

After starting MATLAB, the desktop opens. Desktop components that were open when you last shut down MATLAB reopen. If the DISPLAY environment variable is not set or is invalid, then the desktop does not display.

MATLAB automatically adds the `userpath` folder to the search path.

To customize startup, see “Specify Startup Options” on page 1-25.

The MATLAB startup folder is the folder you are in when you get the MATLAB prompt. To change the default startup folder, see “MATLAB Startup Folder” on page 1-20.

If you have trouble starting MATLAB, then see MATLAB Installation, Activation & Startup Help.

**Startup Folder**

On Linux platforms, the default startup folder is the folder from which you started MATLAB.

To specify the `userpath` as the startup folder, set the value of the environment variable `MATLAB_USE_USERWORK` to 1 before startup. By default, `userpath` is `userhome/Documents/MATLAB`. To specify a different folder for `userpath`, and for other options, call the MATLAB `userpath` function.

**Execute MATLAB Script from Remote ssh Login**

To execute a MATLAB script `hello.m` via a remote ssh login, in a terminal window type:

```
ssh local.foo.com matlab -nodisplay -nojvm < hello.m
```

The `ssh` command pipes `hello.m` to MATLAB running on the remote host `local.foo.com`. The `-nodisplay` option starts MATLAB without the desktop.
See Also
matlab (Linux) | matlabroot | userpath

More About
- “Specify Startup Options” on page 1-25
- “MATLAB Startup Folder” on page 1-20
- “General Preferences” on page 2-44
- MATLAB Installation, Activation & Startup Help
Start MATLAB on macOS Platforms

Choose one of these ways to start MATLAB.

• “Start from Applications Folder” on page 1-10
• “Start from Terminal Window” on page 1-10

When you start MATLAB, it automatically adds the userpath folder to the search path. MATLAB also reopens any desktop components that were open when you last shut down.

To customize startup, see “Specify Startup Options” on page 1-25.

The MATLAB startup folder is the folder you are in when you get the MATLAB prompt. To change the default startup folder, see “MATLAB Startup Folder” on page 1-20.

If MATLAB fails to start due to a problem with required system components such as Java® software, then diagnostics run automatically. The software advises you of the problem and offers suggestions to correct it. For information about other startup problems, see MATLAB Installation, Activation & Startup Help.

Start from Applications Folder

• Double-click the MATLAB icon in the matlabroot folder. Replace matlabroot with the name of the folder in which you installed MATLAB.

The startup folder is the last working folder from the previous MATLAB session or the custom path specified in the Initial working folder preference described in “General Preferences” on page 2-44.

Start from Terminal Window

• To start from the Terminal window, you need to know the value of matlabroot, the full path to the folder where MATLAB is installed. If you do not know the path, then open MATLAB from the Applications folder, type matlabroot, and note the value. Exit MATLAB.
• Open a Terminal window.
• Navigate to the following location from your terminal window:

    matlabroot/bin
• Start MATLAB.
  ./matlab

The startup folder is the MATLAB installation folder.

See Also
matlab (macOS) | matlabroot | userpath

More About
• “Specify Startup Options” on page 1-25
• “MATLAB Startup Folder” on page 1-20
• “General Preferences” on page 2-44
• MATLAB Installation, Activation & Startup Help
Exit MATLAB

**In this section...**

“Ways to Quit or Exit” on page 1-12
“Confirm Exiting” on page 1-12
“Run Script When Exiting” on page 1-13

**Ways to Quit or Exit**

At any time, do one of the following:

- Click the close button on the MATLAB desktop.
- Click on the left side of the desktop title bar and select Close.
- Type `quit` or `exit` at the command prompt.

MATLAB closes after:

- Prompting you to confirm exiting on page 1-12, if that preference is specified.
- Prompting you to save any unsaved files
- Running a script when exiting on page 1-13, if the `finish.m` script exists in the current folder or on the search path.

**Confirm Exiting**

To set a preference that displays a confirmation dialog box when you exit:

1. On the Home tab, in the Environment section, click Preferences.
2. Select MATLAB > General > Confirmation Dialogs.
3. Select the Confirm before exiting MATLAB check box and click OK.

MATLAB then displays the following dialog box when you exit.
You can also display your own exit confirmation dialog box using a `finish.m` script, as described in the following section.

**Run Script When Exiting**

When MATLAB exits, it runs the script `finish.m`, if the file exists in the current folder or anywhere on the search path. You create the script containing statements such as saving the workspace or displaying a confirmation dialog box. For more information, see `finish`.

There are two sample files in `matlabroot/toolbox/local` that you can use as the basis for your own `finish.m` file:

- `finishsav.m` — Includes a `save` function so the workspace is saved to a MAT-file.
- `finishdlg.m` — Displays a confirmation dialog box that allows you to cancel quitting.

**See Also**

`exit` | `finish` | `quit`

**More About**

- “Confirmation Dialog Boxes Preferences” on page 2-45
- “Recovering Data After Abnormal Termination” on page 1-14
- “Crash Reporting” on page 1-15
- MATLAB Installation, Activation & Startup Help
Recovering Data After Abnormal Termination

If MATLAB terminates unexpectedly, then you might lose information. After you start MATLAB again, you can try the following suggestions to recover some of the information. Some of these suggestions refer to actions you need to take during the session before MATLAB terminates. If you did not take those actions, then consider regularly performing them to help you recover from any future abnormal terminations you might experience.

- Use the Command History or the file on which it is based, `history.m`, to run statements from the previous session. You might be able to recreate data as it was before the termination.
- If you used the `diary` function or `-logfile` startup option for the session in which MATLAB terminated unexpectedly, then you might be able to recover output.
- If you saved the workspace to a MAT-file during the session, then you can recover it by loading the MAT-file.
- If you were editing a file in the Editor when MATLAB terminated unexpectedly, and you had the backup feature enabled, then you should be able to recover changes you made to files you had not saved. To recover, open the backup version `filename.asv` in the Editor. Then save it as `filename.m` to use the last good version of `filename`.
- If you were in a Simulink® session when a segmentation violation occurred, and you have the Simulink Autosave Options preference selected, then the last autosave file for the model reflects the state of the autosave data before the segmentation violation. Because Simulink models might be corrupted by a segmentation violation, a model is not autosaved after a segmentation violation occurs. To recover the file, open the model.

See Also

diary | load | save

Related Examples

- “Save and Load Workspace Variables” on page 5-16
- “Save Files”

More About

- “Commonly Used Startup Options” on page 1-23
Crash Reporting

If MATLAB crashes, then the MathWorks Crash Reporter dialog box prompts you to send the crash report to MathWorks. Doing so helps us improve our products. The crash report contains one or more crash logs containing information on the stack trace and the MATLAB configuration. You can see the entire contents of the crash report by clicking the **Show Report** button in the dialog box. This data, along with information that you provide as reproduction steps, is the only information sent to MathWorks.

Reproduction steps are most helpful if you know what appears to cause the crash, but any information on what you were doing at the time helps our developers better understand the cause.

- If you do know the cause of the crash, then look for information about it in the MathWorks Bug Reports database.
- If the problem is reproducible, then submit a Service Request at https://www.mathworks.com/support/contact_us.html.

Locating Crash Logs

In some situations, The Crash Reporter does not open. For example, the Crash Reporter is unavailable when you start MATLAB with the `-batch` option or run it in deployed mode. If you experience abnormal termination, but do not see the Crash Reporter, then you can email the crash logs to MathWorks instead at https://www.mathworks.com/support/contact_us.html. The crash logs are files with the prefix `matlab_crash_dump`, `java.log`, or `hs_err`. To locate the logs, type one of these commands in the MATLAB Command Window, replacing `prefix` with `matlab_crash_dump`, `java.log`, and `hs_err`.

- On Windows platforms
  ```matlab
dir(fullfile(tempdir,'prefix.*.*'))
  
  Alternatively, open Windows Explorer and navigate to the `%USERPROFILE%\AppData\Local\` folder.
- On Linux and macOS platforms
  ```matlab
dir(fullfile('~','prefix.*'))
  
  Alternatively on macOS, open a Finder window. Press **Command+Shift+G** to open the Go To Folder dialog box and enter ~.
See Also

tempdir

More About
• “When MATLAB Terminates Unexpectedly” on page 1-17
When MATLAB Terminates Unexpectedly

If MATLAB detects an internal error, then MATLAB displays one of two dialog boxes: the “MathWorks Crash Reporter” on page 1-17 or the “MathWorks Crash Analyzer” on page 1-17. In both cases, the internal state of MATLAB is unreliable and not suitable for further use.

MathWorks Crash Reporter

The MathWorks Crash Reporter provides an easy mechanism to send any relevant crash logs to MathWorks Technical Support. If you click Send Report and provide a valid email address, then you should receive an automated message within 5 minutes. If you want help, reply to the automated message and a technical support agent will contact you.

If you do not receive an email, then you can directly contact Technical Support at https://www.mathworks.com/support/contact_us.html.

MathWorks Crash Analyzer

When MATLAB terminates unexpectedly, MATLAB locally analyzes the crash report on your machine to determine a potential cause. If there is a potential solution, MATLAB displays the MathWorks Crash Analyzer dialog box. Click View Solution to open a web page in your browser that points to the relevant MATLAB Answers™ page or MathWorks Bug Reports database. Follow the steps in the solution. To apply a fix, you must restart MATLAB.

After viewing the solution, if you feel that it is not relevant, then click Send Report and enter reproduction steps in the window.

If you apply the fix and still experience a crash, then click Send Report or create a Service Request directly at https://www.mathworks.com/support/contact_us.html.

See Also

More About
- “Crash Reporting” on page 1-15
Specifying Java Startup Options

You can specify custom Java startup options by creating a `java.opts` file, a text file containing one option per line. For example, use the `-Dproperty=value` command to assign a value to a system property.

Put the `java.opts` file in one of the following folders:

- MATLAB startup folder, if starting MATLAB from an operating system prompt. For more information, see “MATLAB Startup Folder” on page 1-20.
- If there is no `java.opts` file in the startup folder, then MATLAB checks the `matlabroot/bin/arch` folder. `matlabroot` is the output of the `matlabroot` function. `arch` is the output of the MATLAB `computer('arch')` function, for example `glnxa64`.

A `java.opts` file in this location applies to all users, but individual users might not have permissions to modify files there.

Do not use a `java.opts` file in the following situations:

- To enable the use of the Java debugger, use the `matlab -jdb` command. For information, see `matlab` (Linux) or `matlab` (macOS).
- To adjust the Java heap size on desktop versions of MATLAB, use “Java Heap Memory Preferences”.
- To modify the static Java class path, create a `javaclasspath.txt` file. For information, see “Static Path”.

To modify the library path, create a `javalibrarypath.txt` file. For information, see “Locate Native Method Libraries”.

- To override built-in options that MATLAB specifies to Java at startup. Options in `java.opts` are appended to the end of the built-in list. Whether these additional options override built-in options is JVM-dependent and can change between Java versions. To see what options MATLAB provides to Java, run this command:

```
java.lang.management.ManagementFactory.getRuntimeMXBean.getInputArguments
```

See Also

`matlab` (Linux) | `matlab` (macOS)
Related Examples
• “Java Heap Memory Preferences”
• “Static Path”
• “Locate Native Method Libraries”

More About
• “MATLAB Startup Folder” on page 1-20
MATLAB Startup Folder

Default Startup Folder

By default, MATLAB sets the startup folder based on the way you start MATLAB. To identify the startup folder, type `pwd` at the command line immediately after starting MATLAB and before typing any other commands. You can change the startup folder using the General Preferences panel. For convenience, make this folder a folder that you frequently use.

**Note** If a `startup.m` file changes the current folder, then this value overrides the initial working folder value. Do not add `cd` statements to `startup.m`. For more information about user-defined options, see `startup`.

Default Folder on Windows Platforms

<table>
<thead>
<tr>
<th>How You Start MATLAB</th>
<th>Startup Folder</th>
</tr>
</thead>
<tbody>
<tr>
<td>Double-click the MATLAB icon on your Windows desktop or in the Start menu</td>
<td>Last working folder from the previous MATLAB session or the custom path specified in the <strong>Initial working folder</strong> preference, described in “General Preferences” on page 2-44</td>
</tr>
<tr>
<td>From a Windows system prompt</td>
<td>Folder in which you run the <code>matlab</code> command (To use the folder specified by the <strong>Initial working folder</strong> preference, use the <code>-useStartupFolderPref</code> startup option.)</td>
</tr>
<tr>
<td>From the MATLAB command prompt</td>
<td>Folder in which you run the <code>!matlab</code> command</td>
</tr>
<tr>
<td>Double-click a file type associated with MATLAB</td>
<td>Folder containing the file</td>
</tr>
<tr>
<td>Double-click the <code>matlab.exe</code> executable file from Windows Explorer Tool</td>
<td>Last working folder from the previous MATLAB session or the custom path specified in the <strong>Initial working folder</strong> preference</td>
</tr>
</tbody>
</table>

For more information, see “Start MATLAB on Windows Platforms” on page 1-2.
### Default Folder on macOS Platforms

<table>
<thead>
<tr>
<th>How You Start MATLAB</th>
<th>Startup Folder</th>
</tr>
</thead>
<tbody>
<tr>
<td>Double-click the MATLAB application</td>
<td>Last working folder from the previous MATLAB session or the custom path specified in the Initial working folder preference described in “General Preferences” on page 2-44</td>
</tr>
<tr>
<td>Start MATLAB from a Terminal window</td>
<td>Folder in which you run the matlab command</td>
</tr>
</tbody>
</table>

For more information, see “Start MATLAB on macOS Platforms” on page 1-10.

### Default Folder on Linux Platforms

On Linux platforms, the default startup folder is the folder from which you started MATLAB.

For more information, see “Start MATLAB on Linux Platforms” on page 1-8.

### Change Startup Folder

Starting in R2014b, you can change the startup folder using the General Preferences panel. On the Home tab, in the Environment section, click Preferences. Select MATLAB > General. Choose an option for the Initial working folder preference.

Alternatively on Windows platforms, specify the initial working folder in the MATLAB shortcut icon. For more information, see “Select MATLAB Icon” on page 1-2.

### userpath as Initial Working Folder

Using userpath as the Initial working folder value offers these benefits.

- You can store the MATLAB files you work with in one folder, such as Documents/MATLAB.
- You can always run your files because MATLAB automatically adds the userpath folder to the top of the search path.
- The first time you run a new version of MATLAB, the software automatically creates the userpath folder if it does not exist.
• When you upgrade to a newer version of MATLAB, the software automatically continues to use the same startup folder and your existing files.

• The default userpath uses the benefits provided by the standard location in the Windows and macOS environments for storing personal files. Files in the Documents/MATLAB folder are available to you when you use other machines. Each user has an individual Documents/MATLAB folder. Other users, even those using your machine, cannot access files in your Documents/MATLAB folder.

See Also
startup

Related Examples
• “Start MATLAB on Windows Platforms” on page 1-2
• “Start MATLAB on macOS Platforms” on page 1-10
• “Start MATLAB on Linux Platforms” on page 1-8

More About
• “General Preferences” on page 2-44
## Commonly Used Startup Options

This table lists commonly used startup options for the `matlab` command. For a complete list of options, refer to the input arguments for `matlab` (Windows), `matlab` (macOS), or `matlab` (Linux).

<table>
<thead>
<tr>
<th>Platform</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>-c licensefile</td>
<td>Set <code>LM_LICENSE_FILE</code> to <code>licensefile</code>. It can have the form <code>port@host</code>.</td>
</tr>
<tr>
<td>All</td>
<td>-h or -help</td>
<td>Display startup options (without starting MATLAB).</td>
</tr>
<tr>
<td>All</td>
<td>-logfile &quot;logfilename&quot;</td>
<td>Automatically write output from MATLAB to the specified log file.</td>
</tr>
<tr>
<td>Windows platforms</td>
<td>-minimize</td>
<td>Start MATLAB with the desktop minimized. Any desktop tools or documents that were undocked when MATLAB was last closed are not minimized at startup.</td>
</tr>
<tr>
<td>macOS and Linux platforms</td>
<td>-nojvm</td>
<td>Start MATLAB without loading the JVM™ software. This minimizes memory usage and improves initial startup speed, but restricts functionality. With nojvm, you cannot use the desktop, figures, or any tools that require Java software.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For example, you cannot set preferences if you start MATLAB with the -nojvm option. However, you can start MATLAB once without the -nojvm option, set the preference, and quit MATLAB. MATLAB remembers that preference when you start it again, even if you use the -nojvm option.</td>
</tr>
<tr>
<td>All</td>
<td>-nosplash</td>
<td>Start MATLAB without displaying its splash screen.</td>
</tr>
<tr>
<td>All</td>
<td>-batch &quot;statement&quot;</td>
<td>Run the specified statement non-interactively.</td>
</tr>
<tr>
<td>All</td>
<td>-r &quot;statement&quot;</td>
<td>Run the specified statement interactively.</td>
</tr>
<tr>
<td>All</td>
<td>-singleCompThread</td>
<td>Limit MATLAB to a single computational thread. By default, Windows uses the multithreading capabilities of the computer on which it is running.</td>
</tr>
</tbody>
</table>

For a complete list of options, refer to the input arguments for `matlab` (Windows), `matlab` (macOS), or `matlab` (Linux).
See Also
matlab (Linux)|matlab (Windows)|matlab (macOS)
Specify Startup Options

<table>
<thead>
<tr>
<th>In this section…</th>
</tr>
</thead>
<tbody>
<tr>
<td>“Startup Options from Operating System Prompt” on page 1-25</td>
</tr>
<tr>
<td>“Startup Options in Shortcut on Windows Systems” on page 1-25</td>
</tr>
<tr>
<td>“Startup Options in MATLAB Startup File“ on page 1-26</td>
</tr>
<tr>
<td>“Passing Perl Variables on Startup” on page 1-26</td>
</tr>
<tr>
<td>“Startup and Calling Java Software from MATLAB“ on page 1-27</td>
</tr>
</tbody>
</table>

**Startup Options from Operating System Prompt**

Startup options instruct MATLAB to perform certain operations when you start the program. Startup options also are called command flags or command-line switches. When you start at the operating system prompt, specify the options as arguments to the `matlab` command. For example, the following starts MATLAB and suppresses the display of the splash screen.

```
matlab -nosplash
```

On Windows platforms, you can precede a startup option with either a hyphen (\-) or a slash (/). For example, `-nosplash` and `/nosplash` are equivalent.

**Startup Options in Shortcut on Windows Systems**

You can add selected startup options to the target path for your shortcut on the Windows platform for MATLAB.

To use startup options for the MATLAB shortcut icon, follow these steps:

1. Right-click the shortcut icon for MATLAB and select **Properties** from the context menu. The Properties dialog box for MATLAB opens to the **Shortcut** pane.

2. In the **Target** field, after the target path for "matlab.exe", add the startup option, and click **OK**.

This example runs the MATLAB `results` script or function after startup, where `results.m` is in the startup folder or on the MATLAB search path. The text in the **Target** field is similar to the following:
"C:\Program Files\MATLAB\R2016b\bin\matlab.exe" -r "results"

Include the statement, but not the option (-r) in double quotation marks.

Use semicolons or commas to separate multiple statements. This example changes the format to short, and then runs the MATLAB code file results:

"... matlab.exe" -r "format('short');results"

Separate multiple options with spaces. This example starts MATLAB without displaying the splash screen, and then runs the MATLAB code file results:

"... matlab.exe" -nosplash -r "results"

**Startup Options in MATLAB Startup File**

The startup.m file is a file you create to specify startup options. Create the startup.m file in a folder on the MATLAB search path. Use startup.m to modify the default search path, predefine variables in your workspace, or define defaults for graphics objects. For example, the following statement adds the user-defined folder /home/myname/mytools to the search path.

```
addpath /home/myname/mytools
```

To change the current folder on startup to mytools, set the **Initial working folder** value, described in “General Preferences” on page 2-44, to:

```
/home/myname/mytools
```

At startup, MATLAB automatically executes the matlabrc.m file and startup.m, if it exists on the MATLAB search path. The file matlabrc.m, which is in the matlabroot/toolbox/local folder, is reserved for use by MathWorks and by system administrators on multiuser systems. To locate the startup.m file, type:

```
which startup
```

If MATLAB finds a startup.m file, then it displays the path to the file.

**Passing Perl Variables on Startup**

You can pass Perl variables to MATLAB on startup by using the -r option of the matlab function. For example, assume a MATLAB function test that takes one input variable:
function test(x)

To pass a Perl variable instead of a constant as the input parameter, follow these steps. This command starts MATLAB and runs test with the input argument 10.

1 Create a Perl script such as

```perl
#!/usr/local/bin/perl
$val = 10;
system('matlab -r "test(' . ${val} . ')"');
```

2 Invoke the Perl script at the prompt using a Perl interpreter.

For more information, see the -r option in `matlab` (Windows), `matlab` (macOS), or `matlab` (Linux).

**Startup and Calling Java Software from MATLAB**

When MATLAB starts, it constructs the class path for Java software using `javaclasspath.txt` and `javalibrarypath.txt` files. For more information, see “Java Class Path” and “Locate Native Method Libraries”.

For information about memory allocation for Java objects, see “Java Heap Memory Preferences”.

**See Also**

- `matlab` (Linux) | `matlab` (Windows) | `matlab` (macOS)

**More About**

- “Commonly Used Startup Options” on page 1-23
- “What Is the MATLAB Search Path?” on page 6-50
Toolbox Path Caching in MATLAB

**In this section...**

| “About Toolbox Path Caching in MATLAB” on page 1-28 |
| “Using the Cache File Upon Startup” on page 1-28 |
| “Updating the Cache and Cache File” on page 1-28 |

**About Toolbox Path Caching in MATLAB**

For performance reasons, MATLAB disables folder change detection for the `matlabroot` folder and caches the folder information across sessions. The disabled folder change detection and caching features are mostly transparent to you. However, if MATLAB does not see the latest versions of your MATLAB code files or if you receive warnings about the path cache, then you might need to update the cache.

**Using the Cache File Upon Startup**

Upon startup, MATLAB gets information from a cache file to build the `matlabroot` folder cache. Because of the cache file, startup is faster, especially if you run MATLAB from a network server or if you have many folders within the `matlabroot` folder. When you end a session, MATLAB updates the cache file.

MATLAB does not use the cache file at startup if you clear the **Enable toolbox path cache** check box in **General Preferences**. Instead, it creates the cache by reading from the operating system folders, which is slower than using the cache file.

**Updating the Cache and Cache File**

**How the Toolbox Path Cache Works**

MATLAB caches (essentially, stores in a known files list) the names and locations of files in the `matlabroot` folder. This folder is for files provided with MathWorks products that should not change except for product installations and updates. Caching those folders provides better performance during a session because MATLAB does not actively monitor those folders.

We strongly recommend that you save any MATLAB code files you create and any files provided by MathWorks that you edit in a folder that is *not* in the `matlabroot` folder.
tree. If you keep your files in the `matlabroot` folder, then they might be overwritten when you install a new version of MATLAB.

**When to Update the Cache**

When you add files to the `matlabroot` folder, the cache and the cache file need to be updated. MATLAB updates the cache and cache file automatically when you install toolboxes or toolbox updates using the installer for MATLAB. MATLAB also updates the cache and cache file automatically when you use MATLAB tools, such as when you save files from the MATLAB Editor to the `matlabroot` folder.

When you add or remove files in the `matlabroot` folder by some other means, MATLAB might not recognize those changes. For example, when you:

- Save new files in the `matlabroot` folder using an external editor
- Use operating system features and commands to add or remove files in the `matlabroot` folder

and then attempt to use one of the new files, MATLAB displays this message:

Undefined function or variable

Update the cache so MATLAB recognizes the changes you made in the `matlabroot` folder.

**Steps to Update the Cache**

To update the cache and the cache file,

1. On the **Home** tab, in the **Environment** section, click **Preferences**. Select **MATLAB > General**.

   The **General Preferences** pane is displayed.

2. Click **Update Toolbox Path Cache** and click **OK**.

**Function Alternative**

To update the cache, use `rehash toolbox`. To update both the cache and the cache file, use `rehash toolboxcache`. For more information, see `rehash`. 
Startup with Java Access Bridge Software

On Windows platforms, MATLAB might crash during startup with screen readers using the Java Access Bridge software. Choose one of these workarounds:

- Disable Java Access Bridge before starting MATLAB, then reenable it after startup. The command to disable Java Access Bridge is:

  \texttt{jabswitch /disable}

- Remove the following file from the MATLAB installation directory. MATLAB displays error messages at startup, but no crash dialog. MATLAB continues to run normally.

  \texttt{sys\java\jre\win64\jre\bin\WindowsAccessBridge-64.dll}

See Also
Desktop

- “Change Fonts” on page 2-2
- “Fonts Custom Preferences” on page 2-6
- “Change Color Settings” on page 2-7
- “Access Frequently Used Features” on page 2-10
- “Optimize Desktop Layout” on page 2-12
- “Use Keyboard Shortcuts to Navigate MATLAB” on page 2-17
- “Customize Keyboard Shortcuts” on page 2-21
- “Set Print Options” on page 2-28
- “Web Browsers and MATLAB” on page 2-31
- “Manage Your Licenses” on page 2-35
- “Update an Existing Installation” on page 2-37
- “macOS Platform Conventions” on page 2-39
- “Preferences” on page 2-41
- “Web Preferences” on page 2-53
### Change Fonts

#### Change Font Size

Changing the font size in MATLAB depends on the tool. This table describes how to change the font size for each tool in MATLAB.

To change the font size for charts, see “Add Title and Axis Labels to Chart”.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Live Editor</td>
<td>Use the Ctrl + Plus (+) and Ctrl + Minus (-) keyboard shortcuts.</td>
</tr>
<tr>
<td>Code tools</td>
<td></td>
</tr>
<tr>
<td>• Editor</td>
<td>On the <strong>Home</strong> tab, in the <strong>Environment</strong> section, click Preferences. Select <strong>MATLAB &gt; Fonts</strong> and in the <strong>Desktop code font</strong> section, select a font size.</td>
</tr>
<tr>
<td>• Command Window</td>
<td></td>
</tr>
<tr>
<td>• Command History</td>
<td></td>
</tr>
<tr>
<td>Text-based tools</td>
<td></td>
</tr>
<tr>
<td>• Current Folder browser</td>
<td>On the <strong>Home</strong> tab, in the <strong>Environment</strong> section, click Preferences. Select <strong>MATLAB &gt; Fonts</strong> and in the <strong>Desktop text font</strong> section, clear the Use system font option. Then, select a font size.</td>
</tr>
<tr>
<td>• Workspace browser</td>
<td></td>
</tr>
<tr>
<td>• Variables editor</td>
<td></td>
</tr>
<tr>
<td>Help Browser</td>
<td>Use the Ctrl + Plus (+) and Ctrl + Minus (-) keyboard shortcuts.</td>
</tr>
<tr>
<td>MATLAB web browser</td>
<td></td>
</tr>
</tbody>
</table>

#### Change Font Name and Style

Changing the font name and style in MATLAB depends on the tool. This table describes how to change the font name and style for each tool in MATLAB.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Live Editor</td>
<td>Changing the font name and style is not supported.</td>
</tr>
<tr>
<td>Tool</td>
<td>Procedure</td>
</tr>
<tr>
<td>--------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Code tools</td>
<td>On the <strong>Home</strong> tab, in the <strong>Environment</strong> section, click Preferences. Select <strong>MATLAB &gt; Fonts</strong> and in the <strong>Desktop code font</strong> section, select a font name and style. By default, the code font is set monospaced to preserve vertical alignment.</td>
</tr>
<tr>
<td>• Editor</td>
<td></td>
</tr>
<tr>
<td>• Command Window</td>
<td></td>
</tr>
<tr>
<td>• Command History</td>
<td></td>
</tr>
<tr>
<td>Text-based tools</td>
<td>On the <strong>Home</strong> tab, in the <strong>Environment</strong> section, click Preferences. Select <strong>MATLAB &gt; Fonts</strong> and in the <strong>Desktop text font</strong> section, clear the <strong>Use system font</strong> option. Then select a font name and style. By default, the text font is set to your system font.</td>
</tr>
<tr>
<td>• Current Folder browser</td>
<td></td>
</tr>
<tr>
<td>• Workspace browser</td>
<td></td>
</tr>
<tr>
<td>• Variables editor</td>
<td></td>
</tr>
<tr>
<td>Help Browser</td>
<td>Changing the font name and style is not supported.</td>
</tr>
<tr>
<td>MATLAB web browser</td>
<td></td>
</tr>
</tbody>
</table>

On UNIX® systems, select **Use antialiasing to smooth desktop fonts** to apply antialiasing and create a smoother desktop appearance. You must restart MATLAB for the preference to take effect. On Microsoft Windows and Macintosh platforms, MATLAB uses system setting for antialiasing.

**Advanced Customization**

You can further customize fonts in MATLAB by changing the font preferences for an individual tool. On the **Home** tab, in the **Environment** section, click Preferences. Select **MATLAB > Fonts > Custom**. Then, select a tool from the list of Desktop tools and specify the **Fonts to use**:

- **Desktop code** — Specify this option to use the desktop code font for this tool.
- **Desktop text** — Specify this option to use the desktop text font for this tool.
- **Custom** — Specify this option to specify a custom font for this tool. Then, specify a font name, style, and size.

For example, to change the Editor font to a custom font, in the list of Desktop tools, select **Editor**. Then, in the **Font to use** section, select **Custom** and specify the desired font name, style, and size.
Some tools, such as the Profiler, use a custom font by default.

**Note** For the Profiler, you can change the font type and size, but not the style (for example, bold or italic).

This table shows the default font preferences for tools in MATLAB. Use this table to restore fonts to their original state.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Font to Use</th>
<th>Default Font</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command History</td>
<td>Desktop code</td>
<td>Monospaced, Plain, 10 point</td>
</tr>
<tr>
<td>Command Window</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Editor (and Shortcuts Editor)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Current Folder browser (and Path browser)</td>
<td>Desktop text</td>
<td>Your system’s current font</td>
</tr>
<tr>
<td>Workspace browser</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Variables editor</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Function Browser</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Profiler</td>
<td>Custom</td>
<td>SansSerif, Plain, 10 point</td>
</tr>
</tbody>
</table>

**Adding Fonts**

MATLAB determines the set the fonts used in font preferences from the fonts installed on your system. MATLAB looks for fonts in these locations:

- The operating system's standard location (see your system administrator for details)
- The `/jre/lib/fonts` folder where Java software is installed on your system

MATLAB only includes compatible fonts in the font preferences.

- For desktop components (such as the Command Window), figure windows, and uicontrols, fonts must be compatible with TrueType and Microsoft OpenType® fonts
- For graphics objects, such as `xlabel`, `ylabel`, `title`, and `text`, fonts must be TrueType and Microsoft OpenType fonts

If you install a font with MATLAB running, restart MATLAB to include the font in the font preferences. A common reason to install additional fonts is to read files created in
different languages. For details on adding fonts to your system, refer to the documentation for your system.

See Also

Related Examples
- “Set Print Options” on page 2-28
- “Add Title and Axis Labels to Chart”
Fonts Custom Preferences

You can override font settings for individual desktop tools, as described in the table that follows. Desktop tools otherwise use the settings that the “Advanced Customization” on page 2-3 specify.

On the Home tab, in the Environment section, click Preferences. Select MATLAB > Fonts > Custom, and then set options as described in this table:

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Desktop tools</td>
<td>Select the desktop tool for which you want to view or customize fonts, such as the Command Window or Editor.</td>
</tr>
<tr>
<td>Font to use</td>
<td>Indicates the font currently being used in the selected desktop tool. Use one of these fonts to change it.</td>
</tr>
<tr>
<td></td>
<td>• Desktop code</td>
</tr>
<tr>
<td></td>
<td>Uses the characteristics of the desktop code font, as described in “Advanced Customization” on page 2-3.</td>
</tr>
<tr>
<td></td>
<td>• Desktop text</td>
</tr>
<tr>
<td></td>
<td>Uses the characteristics of the desktop text font, as described in “Advanced Customization” on page 2-3.</td>
</tr>
<tr>
<td></td>
<td>• Custom</td>
</tr>
<tr>
<td></td>
<td>Uses the type, style, and size you specify in the fields.</td>
</tr>
<tr>
<td></td>
<td>For the Profiler, you can change the font type and size, but changes to the font style (for example, bold or italic) have no effect.</td>
</tr>
</tbody>
</table>
Change Color Settings

<table>
<thead>
<tr>
<th>In this section...</th>
</tr>
</thead>
<tbody>
<tr>
<td>“Change Text and Background Colors in Desktop Tools” on page 2-7</td>
</tr>
<tr>
<td>“Change Syntax Highlighting Colors” on page 2-7</td>
</tr>
<tr>
<td>“Change Command Window Colors” on page 2-8</td>
</tr>
<tr>
<td>“Change Code Analyzer Colors” on page 2-9</td>
</tr>
</tbody>
</table>

Change Text and Background Colors in Desktop Tools

To change the colors that MATLAB uses for text and background in desktop tools, follow these steps:

**Note** The colors you specify also apply to the Import Wizard, but do not apply to the Live Editor, the Help display pane, the web browser, or MATLAB Online™.

1. On the **Home** tab, in the **Environment** section, click 🌐 Preferences. Select **MATLAB > Colors**.

2. Clear **Use system colors**.

   System colors are the text and background colors that your platform (for example, Microsoft Windows) uses for other applications.

3. Select the colors you want to use from the **Text** and **Background** color palettes.

   When you choose a color, the **Syntax Highlighting sample** and **Command Window sample** areas in the dialog box update to show you how it looks.

   **Tip** If you use a gray background color, a selection in an inactive window is not visible.

4. Click **OK**.

Change Syntax Highlighting Colors

In the Command Window, Command History, Editor, Live Editor, and Shortcuts callback area, MATLAB conveys syntax information using different colors. This feature, known as
syntax highlighting, helps you to identify syntax elements, such as if/else statements at
a glance. The Editor also provides syntax highlights colors for other languages.

In the Command Window, only the MATLAB input you type is highlighted. The output from
running MATLAB functions is not highlighted.

To change syntax highlighting colors, follow these steps:

2. From the Language drop-down menu, select the language for which you want to
change syntax highlighting colors.
3. In the Syntax highlighting section, select Enable syntax highlighting.
4. Change the colors.
   • If you set the Language to MATLAB, click the Set syntax colors link, and then
     change the colors under MATLAB syntax highlighting colors.
   • If you did not set the Language to MATLAB, change the colors under Syntax
     highlighting.
5. Click OK.

Change Command Window Colors

To change the colors that MATLAB uses for errors, warnings and hyperlinks in the
Command Window, follow these steps:

2. Select the colors you want to use from the Error text and Warning text, and
   Hyperlinks color palettes.
   
   When you choose a color, the Command Window sample area in the dialog box
   updates to show you how it looks.
3. Click OK.

Command Window color preferences are not available in MATLAB Online.
Change Code Analyzer Colors

Code Analyzer helps you to identify potential problems and refine your MATLAB code. By default, the Editor indicates:

- Code for which there are warnings, by underlining that code with an orange wavy line and placing an orange line in the message bar.
- Code for which there are errors, by underlining that code with a red wavy line and placing a red line in the message bar.
- Code that MATLAB can fix automatically (autofix), by highlighting that code in tan.

To change Code Analyzer colors:

1. On the **Home** tab, in the **Environment** section, click **Preferences**. Select **MATLAB > Colors > Programming Tools**.
2. Under **Code analyzer colors**, select the colors you want for warnings, autofix highlighting, or both.
3. Decide if you want autofix highlights to appear in the Editor.

   - Clear **Autofix highlight** if you do not want autofix highlights to appear in the Editor; select **Autofix highlight** if you do.
4. Click **Apply**.
5. Decide if you want to change the color that the Code Analyzer uses for errors.

   - If you do not, go to step 6.
   - If you do, then:
     a. In the left navigation pane, click **Colors**.
     b. Under **MATLAB syntax highlighting colors**, change the color for **Errors**.

   In addition to changing the color of Code Analyzer indicators for errors, this action also changes the color for errors in the Command Window, Command History window, Editor, and Shortcuts callback area.
6. Click **OK**.

For more information, see “Automatically Check Code in the Editor — Code Analyzer”. Code Analyzer color preferences do not apply in the Live Editor and are not available in MATLAB Online.
Access Frequently Used Features

The quick access toolbar provides access to frequently used operations. This toolbar is always visible, even when you navigate between different MATLAB toolstrip tabs.

You can change the location of the quick access toolbar. On the Home tab, in the Environment section, click Layout, and then select an option for the Quick Access Toolbar. Moving the quick access toolbar is not supported in MATLAB Online.

To add a toolstrip item to the quick access toolbar, right-click the button, and then select Add to Quick Access Toolbar. You also can select from a list of common items by going to the quick access toolbar and clicking the button. To remove an item from the quick access toolbar, right-click the item icon and select Remove from Quick Access Toolbar. To arrange buttons in the quick access toolbar, drag the button icon to the desired location.

To further configure the quick access toolbar, follow these steps:

1. On the quick access toolbar, click the button and select Customize Toolbar. The MATLAB Toolbars Preference panel open.
2. In the Controls list, select or clear the check box for controls that you want to display or remove from the toolbar, respectively.
3. Under Layout, rearrange the controls and separator bars on the selected toolbar, by doing either of the following:
   - Drag the icon for a control or separator bar to another position.
   - Select a Layout icon, and then click one of the Layout buttons below the layout icons.

   For instance, to move the MATLAB desktop Cut icon to the beginning of the toolbar, select the Cut icon, and then click .
4  Click **Apply** or **OK**.

**See Also**

**More About**
- “Use Keyboard Shortcuts to Navigate MATLAB” on page 2-17
- “Customize Keyboard Shortcuts” on page 2-21
Optimize Desktop Layout

In this section...

“Desktop Layout” on page 2-12
“Document Layout” on page 2-15

Desktop Layout

You can close, minimize, and undock desktop tools to optimize the desktop layout. Once you design a layout you like, you can save it for reuse.

This table shows how you can optimize the MATLAB desktop layout on your screen. To optimize the MATLAB Online desktop, see “Desktop Layout in MATLAB Online” on page 2-14.

<table>
<thead>
<tr>
<th>Action</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimize or restore the MATLAB</td>
<td>To minimize, at the lower right corner of the</td>
</tr>
<tr>
<td>toolstrip</td>
<td>toolstrip, click [up] .</td>
</tr>
<tr>
<td></td>
<td>To restore, select one of the tab labels and in the</td>
</tr>
<tr>
<td></td>
<td>lower right corner of the toolstrip, click [down] .</td>
</tr>
<tr>
<td>Open or hide a tool</td>
<td>On the <strong>Home</strong> tab, in the <strong>Environment</strong> section, click <strong>Layout</strong>.</td>
</tr>
<tr>
<td></td>
<td>Then, under <strong>Show</strong>, select, or clear desktop tools you want to show or</td>
</tr>
<tr>
<td></td>
<td>hide.</td>
</tr>
<tr>
<td></td>
<td>You also can use a function to open desktop tools. For example, to</td>
</tr>
<tr>
<td></td>
<td>open the Editor, use <strong>edit</strong>. To open the Profiler, use <strong>profile</strong> with</td>
</tr>
<tr>
<td></td>
<td>the <strong>viewer</strong> option.</td>
</tr>
<tr>
<td>Maximize a tool</td>
<td>Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Double-click the title bar in that tool.</td>
</tr>
<tr>
<td></td>
<td>• On the title bar of a docked tool, click [undock] , and</td>
</tr>
<tr>
<td></td>
<td>then select <strong>Maximize</strong>.</td>
</tr>
<tr>
<td>Action</td>
<td>Procedure</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Minimize a tool</td>
<td>On the title bar of a docked tool, click ☐, and then select <strong>Minimize</strong>. The button for the tool appears along the edge of the MATLAB desktop indicated by the arrow in the <strong>Minimize</strong> icon. Move the button to a different edge of the desktop by dragging it. To use a minimized tool, click the button for the tool to open the tool temporarily on the desktop. When you finish using the tool, click another tool.</td>
</tr>
<tr>
<td>Restore a tool as it appeared before maximizing or minimizing</td>
<td>Do one of the following: • Double-click the title bar of the maximized tool, or the button of the minimized tool. • On the title bar of the tool, click ☐, and then select <strong>Restore</strong>. • Click the Restore button on the title bar in that tool.</td>
</tr>
<tr>
<td>Move a tool</td>
<td>Drag a tool by its title bar to a new location. The status bar indicates where the tool moves if you release the mouse.</td>
</tr>
<tr>
<td>Close a tool</td>
<td>On the title bar of a docked tool, click ☐, and then select <strong>Close</strong>.</td>
</tr>
<tr>
<td>Show or hide title bars</td>
<td>On the <strong>Home</strong> tab, in the <strong>Environment</strong> section, click <strong>Layout</strong>. Then, under <strong>Show</strong>, select, or clear <strong>Panel Titles</strong>.</td>
</tr>
<tr>
<td>Show or hide a toolbar in a figure window</td>
<td>From the <strong>View</strong> menu, select the toolbar of interest.</td>
</tr>
<tr>
<td>Undock tools to move them outside the desktop</td>
<td>Do one of the following: • Drag a tool by its title bar to a new location outside of the MATLAB desktop. • On the title bar of the tool, click ☐, and then select <strong>Undock</strong>.</td>
</tr>
<tr>
<td>Action</td>
<td>Procedure</td>
</tr>
<tr>
<td>--------</td>
<td>-----------</td>
</tr>
<tr>
<td>Move undocked tools back to the desktop</td>
<td>At the upper right of the tool panel, click , and then select <strong>Dock</strong>.</td>
</tr>
<tr>
<td>Manage a desktop arrangement</td>
<td>On the <strong>Home</strong> tab, in the <strong>Environment</strong> section, click <strong>Layout</strong>, and then select an option.</td>
</tr>
<tr>
<td>• Save an arrangement</td>
<td>MATLAB stores the arrangements you save as XML files in the preferences folder on page 2-42 for MATLAB. The layout last used in a session is <strong>MATLABDesktop.xml</strong>. The <strong>MATLABDesktop.xml</strong> file loads when you start MATLAB and is overwritten when you close MATLAB.</td>
</tr>
<tr>
<td>• Use an arrangement</td>
<td></td>
</tr>
<tr>
<td>• Rename or delete a saved arrangement</td>
<td></td>
</tr>
</tbody>
</table>

When you end a session, MATLAB saves the current desktop arrangement. The next time you start MATLAB, the desktop appears as you left it. However, tools such as the Help browser, web browser, and Variables editor do not reopen automatically, even if they were open when you ended the last session. You can use startup options to specify tools that you want to open on startup. For more information, see “Specify Startup Options” on page 1-25. Startup options are not available MATLAB Online.

**Desktop Layout in MATLAB Online**

MATLAB Online provides access to MATLAB from a standard web browser. To change the desktop layout in MATLAB Online go to the **Home** tab, click **Layout**, and then select an option. To move an individual tool, drag the tool by its title bar to a new location. You cannot undock a tool in MATLAB Online.

To minimize a tool, collapse the panel in which the tool resides. For example, if the MATLAB Online desktop is in the default layout with the Current Folder browser in the left side panel, click the button at the bottom left corner of the panel to collapse the panel. To restore the panel, click the button.

If the left or right side panel contains multiple tools, you can minimize an individual tool by clicking the button to the left of the tool's title bar. Multiple tools in the bottom panel display as tabs and cannot be minimized.
Document Layout

When you open MATLAB documents, they open in the associated tool, such as the Editor or Variables editor. The Editor and Variables editor appear in the position they occupied when last used. Entries for undocked documents appear on the Windows task bar, or the equivalent for your platform. Click the task bar entry for a document to make that document active.

This table shows how to optimize the layout of documents within a tool.

<table>
<thead>
<tr>
<th>Action</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the tabs position</td>
<td>On the View tab, in the Document Tabs section, click Tabs Position ▼, and then select an option. In MATLAB Online, on the title bar of the tool, click ☐, select Tab Position, and then select an option.</td>
</tr>
<tr>
<td>Reorder documents</td>
<td>Drag a document tab to a different position. To alphabetize names of documents, in the Document Tabs section of the View tab, select Alphabetize.</td>
</tr>
<tr>
<td>Arrange or tile documents</td>
<td>In the Editor and Variables editor, select the View tab. In the Tiles section, click a tile option. In a Figure panel, Help browser, or web browser, select a tile option, ☐, ☐, ☐, or ☐, on the right side of the toolbar. In MATLAB Online, on the title bar of the tool, click ☐, select Tile All, and then select a tile option.</td>
</tr>
<tr>
<td>Move a tiled document</td>
<td>Drag the document tab to another tile. If you drag it to a tile that already contains a document, the document you are dragging covers up the other document.</td>
</tr>
<tr>
<td>Action</td>
<td>Procedure</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Undock a document</td>
<td>Right-click the document tab and then select <strong>Undock</strong>.</td>
</tr>
<tr>
<td>Close and save the document currently displaying</td>
<td>Click <strong>x</strong>.</td>
</tr>
<tr>
<td>Close a document in the Editor without saving</td>
<td>Click <strong>Ctrl +x</strong>.</td>
</tr>
</tbody>
</table>
Use Keyboard Shortcuts to Navigate MATLAB

Using keyboard shortcuts to navigate MATLAB can increase productivity and is useful in situations where using a mouse is not an option.

This table describes the actions and related keyboard shortcuts useful for navigating MATLAB without a mouse. On macOS systems, use the **Command** key instead of Ctrl.

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the next visible panel.</td>
<td>Ctrl+Tab</td>
</tr>
<tr>
<td>Move to the previous visible panel.</td>
<td>Ctrl+Shift+Tab</td>
</tr>
<tr>
<td>Move to the next tabbed panel.</td>
<td>Ctrl+Page Down</td>
</tr>
<tr>
<td>Move to the previous tabbed panel.</td>
<td>Ctrl+Page Up</td>
</tr>
<tr>
<td>Make an open tool the active tool.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Command Window: Ctrl+0</td>
</tr>
<tr>
<td></td>
<td>• Command History: Ctrl+1</td>
</tr>
<tr>
<td></td>
<td>• Current Folder: Ctrl+2</td>
</tr>
<tr>
<td></td>
<td>• Workspace: Ctrl+3</td>
</tr>
<tr>
<td></td>
<td>• Profiler: Ctrl+4</td>
</tr>
<tr>
<td></td>
<td>• Figure Palette: Ctrl+6</td>
</tr>
<tr>
<td></td>
<td>• Plot Browser: Ctrl+7</td>
</tr>
<tr>
<td></td>
<td>• Property Editor: Ctrl+8</td>
</tr>
<tr>
<td></td>
<td>• Editor: Ctrl+Shift+0</td>
</tr>
<tr>
<td></td>
<td>• Figures: Ctrl+Shift+1</td>
</tr>
<tr>
<td></td>
<td>• Web browser: Ctrl+Shift+2</td>
</tr>
<tr>
<td></td>
<td>• Variables Editor: Ctrl+Shift+3</td>
</tr>
<tr>
<td></td>
<td>• Comparison Tool: Ctrl+Shift+4</td>
</tr>
<tr>
<td></td>
<td>• Help browser: Ctrl+Shift+5</td>
</tr>
<tr>
<td>Show access keys for the toolstrip.</td>
<td>Alt</td>
</tr>
</tbody>
</table>
Open a toolstrip tab and show access keys for the toolstrip.

**Keyboard Shortcut**: Alt+<character>

For example, pressing **Alt** followed by **H** accesses the **Home** tab and displays access keys for the features available on that tab.

You cannot customize most of these shortcuts. For information about customizable keyboard shortcuts and how to view and modify them, see “Customize Keyboard Shortcuts” on page 2-21.

### MATLAB Online

MATLAB Online provides access to MATLAB from a standard web browser. Because MATLAB Online runs in a browser, navigation using the keyboard is slightly different.

This table describes the actions and related keyboard shortcuts useful for navigating MATLAB Online without a mouse.

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move forward through the toolstrip and other tools.</td>
<td><strong>Ctrl+F6</strong></td>
</tr>
<tr>
<td></td>
<td>On macOS systems, use <strong>Cmd+F6</strong> instead.</td>
</tr>
<tr>
<td>Move backward through the toolstrip and other tools.</td>
<td><strong>Ctrl+Shift+F6</strong></td>
</tr>
<tr>
<td></td>
<td>On macOS systems, use <strong>Cmd+Shift+F6</strong> instead.</td>
</tr>
<tr>
<td>Move into a tool.</td>
<td><strong>Tab</strong></td>
</tr>
<tr>
<td>Move between controls within a tool.</td>
<td><strong>Up/Down Arrow, Left/Right Arrow</strong></td>
</tr>
<tr>
<td>Close controls within a tool, for example, documents in the Editor and Live Editor.</td>
<td><strong>Delete</strong></td>
</tr>
<tr>
<td>Open context menu on Windows and UNIX systems.</td>
<td><strong>Shift+F10</strong></td>
</tr>
<tr>
<td>Show access keys for the toolstrip.</td>
<td><strong>Alt</strong></td>
</tr>
</tbody>
</table>
### Use Keyboard Shortcuts to Navigate MATLAB

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open a toolstrip tab and show access keys for the toolstrip.</td>
<td>Alt+&lt;character&gt;</td>
</tr>
<tr>
<td>For example, pressing Alt followed by H accesses the Home tab and displays access keys for the features available on that tab.</td>
<td></td>
</tr>
<tr>
<td>Display a compact list of keyboard shortcuts.</td>
<td>Ctrl+/&gt;</td>
</tr>
</tbody>
</table>

Customizing shortcuts is not supported in MATLAB Online.

### Additional Keyboard Shortcuts

In addition to navigation, keyboard shortcuts are useful for accessing other frequently used actions in MATLAB.

This table describes several of these actions and their related keyboard shortcuts. For additional keyboard shortcuts, see the documentation for a specific tool or feature.

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cancel the current action.</td>
<td>Esc (escape)</td>
</tr>
<tr>
<td>For example, if you click the name of the Edit menu, the whole menu appears. Pressing Esc hides the menu again.</td>
<td></td>
</tr>
<tr>
<td>In the Function Browser, pressing Esc up to three times has the following effects:</td>
<td></td>
</tr>
<tr>
<td>1  Dismiss the search history.</td>
<td></td>
</tr>
<tr>
<td>2  Clear the search field.</td>
<td></td>
</tr>
<tr>
<td>3  Close the Function Browser.</td>
<td></td>
</tr>
<tr>
<td>Interrupt MATLAB execution.</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>On Windows and UNIX systems, you also can use Ctrl+Break. On Mac systems, you also can use Cmd+. (period).</td>
<td></td>
</tr>
</tbody>
</table>
You cannot customize these shortcuts. For information about customizable keyboard shortcuts and how to view and modify them, see “Customize Keyboard Shortcuts” on page 2-21.

See Also

More About

• “Customize Keyboard Shortcuts” on page 2-21
• “Rerun Favorite Commands” on page 3-15
• “Access Frequently Used Features” on page 2-10
Customize Keyboard Shortcuts

Keyboard shortcuts are useful for accessing desktop features quickly. To optimize your experience, you can customize the current set of keyboard shortcuts in MATLAB.

There are several ways you can modify the current set of keyboard shortcuts. You can:

• Create new keyboard shortcuts or modify existing ones.
• Choose among available sets of keyboard shortcuts.
• Create customized sets of keyboard shortcuts or use existing customized sets.

To view or modify the current set of keyboard shortcuts, use the Keyboard Shortcuts Preferences panel. To open the Keyboard Shortcuts Preferences panel, go to the Home tab, and in the Environment section, click Preferences. Then, select MATLAB > Keyboard > Shortcuts.

View Keyboard Shortcuts

For actions performed with a menu item, keyboard shortcuts appear in the menu itself. (This is true whether the menu item is in the toolstrip or in a context menu.) If a menu item does not display a keyboard shortcut, then a keyboard shortcut for the action does not exist.

For actions that are not performed with a menu item, to find keyboard shortcuts, open the Keyboard Shortcuts Preferences panel. Then, in the search box, enter the name of the tool or action for which you want to see the keyboard shortcuts. For example, type Editor clear to find the keyboard shortcut for clearing selected text in the Editor.
To view the shortcuts for an action, select the action name. For example, select **Clear Selection.** MATLAB displays the keyboard shortcuts for the selected action. For example, the keyboard shortcut for the **Clear Selection** action in the Editor is the **Escape** key.

### Create a List of All Keyboard Shortcuts in a Set

You can create a list of all the keyboard shortcuts in the current set by copying them to the clipboard and pasting them in a text file or spreadsheet application, such as Microsoft Excel®. For the best formatting, use a spreadsheet application. To copy all the keyboard shortcuts, open the Keyboard Shortcuts Preferences panel. Click the Actions button and from the drop-down menu, choose **Copy to Clipboard.** Paste the data into the desired application.
Customize Keyboard Shortcuts for Individual Actions

Customizing a keyboard shortcut is useful if you frequently perform an action and the action does not have a keyboard shortcut defined, or if the defined keyboard shortcut is hard to use or conflicts with a different shortcut. For an overview on customizing keyboard shortcuts, watch the Customizable Keyboard Shortcuts video. You must have an internet connection to watch the video.

To customize a keyboard shortcut:

1. Open the Keyboard Shortcuts Preferences panel and, in the search box, type an existing keyboard shortcut or the name of an action, tool, or menu.

   For example, you can type Ctrl+R (shortcut), Delete (action), Command Window (tool), or File (menu).

   You can enter most keyboard shortcuts by either pressing keystrokes or typing the key names. If using keystrokes for a keyboard shortcut does not work, try typing the key names instead. For example, if pressing the Ctrl key and then R does not work, try typing the text Ctrl+R.

   MATLAB displays the list of matching actions for which you can customize or define a keyboard shortcut. If you specify the name of a tool, MATLAB displays actions associated with the tool or menu, as well as any action names that contain the specified text.

2. Select the name of the action for which you want to define or modify a keyboard shortcut.

3. Click the Add button.

   An editable text box opens in the Shortcut column.
4 Specify the keystrokes you want to use for the keyboard shortcut.

A *keystroke* can be a single key or the combination of a modifier (Alt, Shift, or Ctrl) and another key. Specify a keystroke by performing it, not by typing the names of the keys character by character. For example, press the Ctrl key and the Y key. Do not type C-t-r-l-Y.

Alternatively, you can choose a shortcut from the drop-down menu.

To specify multiple keystrokes for one action, or to limit the number of keystrokes for an action, click the down arrow next to the key icon in the Shortcuts box. Then, select either Limit to 1 keystroke, Limit to 2 keystrokes, or Limit to 3 keystrokes. For example, to specify Ctrl+Y, Shift+Z, F9 as the three keystrokes for an action, select Limit to 3 keystrokes and then type the keystrokes.

5 In the Tools with shortcut column, click the down arrow and select which tools you want to assign the keyboard shortcut to.

6 Evaluate and resolve any conflicts, indicated by the and icons. The icon indicates that two different actions within the same tool have the same shortcut. The icon indicates that two different actions in two different tools have the same shortcut.

There is no requirement to resolve keyboard shortcut conflicts. However, if the same shortcut specifies two different actions, the shortcuts can be confusing to use. Resolving all conflicts indicated by the error icon is recommended, although in some situations, resolving a conflict might be unnecessary. For example, resolving the conflict might be unnecessary if the conflict is temporary or the two actions are associated with different modes of the same tool. Resolving conflicts indicated by the informational icon is recommended if you use both tools frequently and you perform both actions frequently.

To resolve a conflict, change or delete shortcuts such that there is a one-to-one correspondence between shortcuts and frequently used actions.

7 Click OK or Apply.
New or modified keyboard shortcuts become available immediately. Changed shortcuts that correspond to menu items immediately appear in the menu.

To delete a keyboard shortcut for a selected action, select the keyboard shortcut that you want to delete and click the Delete button.

**Restore Default Keyboard Shortcut Sets**

If you modify keyboard shortcuts, and then decide you do not want to keep the changes, you can restore the default shortcuts. To restore the default state of a keyboard shortcut, click the Actions button and select **Undo Modifications to Default Set (modified)**, where **Set Name** is the name of the modified default set.

**Note** Undoing modifications reverts all keyboard shortcuts changes that you made to the set. You cannot undo modifications on a shortcut-by-shortcut basis.

**Restrictions When Customizing Keyboard Shortcuts**

There are some actions and tools for which you cannot change the keyboard shortcuts. Actions for which the keyboard shortcut cannot be customized do not appear when you search for them in the MATLAB Keyboard Shortcuts Preferences panel. Examples of these actions include canceling the current action (**Esc**), interrupting MATLAB execution (**Ctrl+C**), and some of the navigational actions described in “Use Keyboard Shortcuts to Navigate MATLAB” on page 2-17.

In addition, you cannot change the keyboard shortcuts associated with these tools or portions of tools:

- **Figure windows** — For example, you cannot modify the keyboard shortcut, **Ctrl+S**, for saving a MATLAB .fig file.
- **Toolboxes** — For example, you cannot modify keyboard shortcuts in the SimBiology® desktop.
- **Incremental search** — You can modify the keyboard shortcuts for initiating a forward or backward incremental search. However, you cannot change the keyboard shortcuts that you use within incremental search mode, such as **Ctrl+Shift+S** to search forward.
- **Dialog boxes** — For example, you cannot create a keyboard shortcut for the **OK** button.
Manage Sets of Keyboard Shortcuts

Select Set of Keyboard Shortcuts

By default, MATLAB uses the keyboard shortcut settings for your current platform. To select a different set of keyboard shortcuts, open the Keyboard Shortcuts Preferences panel and, in Active settings, select from the available options. To use a keyboard shortcut settings file that is on your system but not in the Active settings list, select Browse... to find and select the desired file.

This table lists the keyboard shortcut settings files installed with MATLAB.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Keyboard Shortcut Settings Files Installed with MATLAB</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td>• Windows Default Set (Default)</td>
</tr>
<tr>
<td></td>
<td>• Emacs Default Set</td>
</tr>
<tr>
<td>UNIX</td>
<td>• Emacs Default Set (Default)</td>
</tr>
<tr>
<td></td>
<td>• Windows Default Set</td>
</tr>
<tr>
<td>Macintosh</td>
<td>• Macintosh Default Set (Default)</td>
</tr>
</tbody>
</table>

You also can download keyboard shortcut settings files from File Exchange. For example, to restore the MATLAB default keyboard shortcuts that were in place for MATLAB Version 7.9 (R2009a) and earlier releases, go to File Exchange and search for MATLAB Desktop R2009a Default Keyboard Shortcut sets. Download and extract the set and then select it as the active settings file. A valid keyboard shortcut settings file appears with a keyboard key icon 🔄.

Compare Sets of Keyboard Shortcuts

To compare the current set of keyboard shortcuts to another set:

1. Open the Keyboard Shortcuts Preferences panel and click the Actions button 🔄.
2. From the drop-down menu, choose the set of keyboard shortcuts to which you want to compare the current set.
3. The Comparison Tool opens and displays the two keyboard shortcut sets side-by-side. For more information about how to read the results, see “Compare and Merge Text” on page 6-11.
Save Set of Keyboard Shortcuts to File

Saving a set of keyboard shortcuts to a settings file is useful if you want to:

- Save the changes you make to a default keyboard shortcut set to a new set.
- Use a set of customized keyboard shortcuts on another system running MATLAB.
- Overwrite a previously saved set of keyboard shortcuts.
- Share a set of keyboard shortcuts with others, for example, on File Exchange.

To save a keyboard shortcut settings file, open the Keyboard Shortcuts Preferences panel. Then, click the Actions button and select Save As. MATLAB saves the file as an .xml file in the folder that you specify.

You cannot overwrite the default settings files that install with MATLAB. MATLAB saves modifications that you make to a default set using the name of the default set appended with the text (modified), for instance, Windows default (modified).

Delete Set of Keyboard Shortcuts

To delete a previously saved set of keyboard shortcuts, open the Keyboard Shortcuts Preferences panel and in Active settings, select the set of keyboard shortcuts that you want to delete. Click the Actions button and select Delete filename, where filename is the name of a keyboard shortcut set you want to delete. You cannot delete default keyboard shortcut sets, such as Windows Default Set.

See Also

More About

- “Use Keyboard Shortcuts to Navigate MATLAB” on page 2-17
- “Rerun Favorite Commands” on page 3-15
- “Access Frequently Used Features” on page 2-10
Set Print Options

<table>
<thead>
<tr>
<th>In this section...</th>
</tr>
</thead>
<tbody>
<tr>
<td>“Page Setup Options” on page 2-28</td>
</tr>
<tr>
<td>“Layout Options for Page Setup” on page 2-28</td>
</tr>
<tr>
<td>“Header Options for Page Setup” on page 2-29</td>
</tr>
<tr>
<td>“Fonts Options for Page Setup” on page 2-29</td>
</tr>
</tbody>
</table>

**Page Setup Options**

MATLAB provides special page setup options for printing from the Command Window and Editor. Page setup is not supported in the Live Editor.

To specify page setup options for printing from the Command Window, right-click in the Command Window, and then select **Page Setup**.

To specify page setup options for printing from the Editor, first select the **Editor** tab. Then, in the **File** section, click **Print ▾** and select **Page Setup**.

The Page Setup dialog box opens for that tool.

Then, perform these steps:

1. Click the **Layout**, **Header**, or **Fonts** tab in the dialog box and set those options for that tool, as detailed in subsequent sections. On Mac platforms, you must first select **MATLAB** in the **Settings** menu in order to see these tabs.
2. Click **OK**.
3. After specifying the options, select **Print** in the tool you want to print from, for example, the Command Window.

   The contents from the tool print, using the options you specified in Page Setup.

**Layout Options for Page Setup**

You can specify the following layout options. A preview area shows you the effects of your selections.

- **Print header** — Print the header specified in the **Header** pane.
• **Print line numbers** — Print line numbers.
• **Wrap lines** — Wrap any lines that are longer than the printed page width.
• **Syntax highlighting** — For keywords and comments that are highlighted in the Command Window, specify how they are to appear in print. Options are black and white text (that is, no highlighting), colored text (for use with a color printer), or styled text. For styled text, keywords appear in bold, comments appear in italics, and all other text appears in the normal style. Only keywords and comments you input in the Command Window are highlighted; output is not highlighted.

**Header Options for Page Setup**

If you want to print a header, select the **Layout** tab and then select **Print header**. Next, select the **Header** tab and specify how the elements of the header are to appear. A preview area shows you the effects of your selections:

• **Page number** — Format for the page number, for example, `# of n`
• **Border** — Border style for the header, for example, `Shaded box`
• **Layout** — Layout style for the header. For example, `Standard one line` includes the date, time, and page number all on one line

**Fonts Options for Page Setup**

Specify the font to use for the printed contents:

1. From **Choose font**, select the element, either **Body** or **Header**, where **Body** text is everything except the **Header**.
2. Select the font to use for the element.

   For example, if you access this dialog box while using the Command Window, you can select **Use Command Window font** for **Body** text. The printed text matches the Command Window font.
3. Repeat for the other element.

   If you did not select **Print header** on the **Layout** pane, you do not need to specify the **Header** font.

As an example, for **Header** text, select **Use custom font** and then specify the font characteristics — type, style, and size. After you specify a custom font, the **Sample** area shows how the font will look.
Tip  You can change the font that a desktop tool uses. On the **Home** tab, in the **Environment** section, click **Preferences > Fonts > Custom**.
Web Browsers and MATLAB

In this section...

“About Web Browsers and MATLAB” on page 2-31
“Display Pages in Web Browsers” on page 2-33
“Specify Proxy Server Settings for Connecting to the Internet” on page 2-33
“Specify the System Browser for Linux Platforms” on page 2-34

About Web Browsers and MATLAB

From MATLAB, Web sites and documents can display in any of the following browsers:

• MATLAB Web browser
• Help browser
• Your system Web browser, such as Mozilla® Firefox®

MATLAB uses the different browsers to display different types of information:

• Web sites display in your system browser.
• Documentation displays in the Help browser.
• Other HTML files display in the MATLAB Web browser. For example, after publishing a MATLAB program file to HTML, the HTML file displays in the MATLAB Web browser:
MATLAB Web and Help Browsers

The MATLAB Web and Help browsers may not support all the features that a particular Web site or HTML page uses. For example, the MATLAB Web browser does not display .bmp (bitmap) image files. Instead use .gif or .jpeg formats for image files in HTML pages.
System Browser

The system browser that MATLAB uses depends on your platform:

- On Microsoft Windows and Apple Macintosh platforms, MATLAB uses the default browser for your operating system.
- On UNIX platforms, MATLAB uses the Mozilla Firefox browser. You can specify a different system browser for MATLAB using Web preferences on page 2-34.

Display Pages in Web Browsers

To display an HTML document in the MATLAB Web browser, double-click the document name in the Current Folder browser.

To display a Web page or any file type in the MATLAB Web browser:

1. Open the browser using the web command.
2. Type a URL or full path to a filename in the Location field.

Specify Proxy Server Settings for Connecting to the Internet

If your network uses a firewall or another method of protection that restricts Internet access, provide information about your proxy server to MATLAB. Be aware that:

- MATLAB supports non-authenticated, basic, digest, and NTLM proxy authentication types.
- If a proxy with basic authentication is specified, MATLAB only supports HTTP connections. HTTPS connections are not supported.
- You cannot specify the proxy server settings using a script.
- There is no automated way to provide the proxy server settings your system browser uses to MATLAB.

To specify the proxy server settings:

2. Select the Use a proxy server to connect to the Internet check box.
3. Specify values for Proxy host and Proxy port.
Examples of acceptable formats for the host are: 172.16.10.8 and ourproxy. For the port, enter an integer only, such as 22. If you do not know the values for your proxy server, ask your system or network administrator for the information.

If your proxy server requires a user name and password, select the **Use a proxy with authentication** check box. Then enter your proxy user name and password.

**Note** MATLAB stores the password without encryption in your matlab.prf file.

4 Ensure that your settings work by clicking the **Test connection** button.

MATLAB attempts to connect to https://www.mathworks.com:

- If MATLAB can access the Internet, **Success!** appears next to the button.
- If MATLAB cannot access the Internet, **Failed!** appears next to the button. Correct the values you entered and try again. If you still cannot connect, try using the values you used when you authenticated your MATLAB license.

5 Click **OK** to accept the changes.

6 Restart MATLAB to enable the changes.

**Specify the System Browser for Linux Platforms**

To specify the system browser:

1 On the **Home** tab, in the **Environment** section, click **Preferences**. Select **MATLAB > Web**.

2 Under **System Web browser**, in the **Command** field, specify the system command to open the browser, for example, **opera**, which opens the Opera Web browser.

3 Add options for opening your system browser in the **Options** field. For example, **geometry 1064x860** specifies the size of the window for Opera.

4 Click **OK**.

**Note** The Mac platform does not have a **System Web browser** preference.
Manage Your Licenses

You can use the MATLAB licensing features to perform license management activities, such as activating licenses, deactivating licenses, or updating licenses. You also can visit the License Center at the MathWorks website to perform other license-related activities.

To access the licensing feature:

1. On the Home tab, in the Resources section, click Help > Licensing.
2. Select a Licensing option. The following table describes the Licensing options. Depending on your license type, your system might not include all these options.

Note Some options require an internet connection. If your internet connection requires a proxy server, use MATLAB web preferences to specify the server host and port. See “Specify Proxy Server Settings for Connecting to the Internet” on page 2-33 for more information.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update Current Licenses</td>
<td>Displays a list of all your MathWorks licenses on this computer, with their status. When you select a license and click <strong>Update Selected License</strong>, MATLAB contacts MathWorks to retrieve the most current version of the License File for the license. The update process overwrites the current License File on your system. You need to restart MATLAB.</td>
</tr>
<tr>
<td>Activate Software</td>
<td>Starts the activation application, which walks you through the activation process. Answer the questions on each dialog box, select the license you want to activate, and click <strong>Activate</strong>.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Deactivate Software</td>
<td>Displays a list of all your MathWorks licenses on this computer, with their status. When you select a license and click <strong>Deactivate</strong>, MATLAB deactivates all releases on this computer associated with the license, and updates the licensing information at the MathWorks website. You will not be able to use MathWorks software with that license on this computer. If you are not connected to the Internet, MATLAB deactivates the licenses on your computer but cannot update the corresponding license information stored at the MathWorks website. In this scenario, MATLAB returns a deactivation string. To complete deactivation, save a copy of this string, go to a computer with an internet connection, and visit the License Center at the MathWorks website. There you can sign in to your MathWorks Account and enter the deactivation string.</td>
</tr>
<tr>
<td>Manage Licenses</td>
<td>Starts a web browser, opening the My Licenses page associated with your MathWorks Account. You can use this page, called the License Center, to perform many licensing activities.</td>
</tr>
</tbody>
</table>

**See Also**

**More About**

- “Introduction to Installation and Licensing” (Installation, Licensing, and Activation)
Update an Existing Installation

You can download and install a more recent version for the release of MATLAB that you currently have installed. For example, if you have R2019a installed, you might be able to download a more recent version of R2019a.

When you install a MATLAB update, you get not only the most recent update for your version but all prior updates for your version as well.

Update from Notifications

If a more recent version is available, a notification displays in MATLAB when you start the program.

To install the MATLAB update, click the notification icon and select Install Update. If you click the notification but then decide to update at a later time, the notification icon is no longer red, but you can still install the update.

Check for Updates

You also can check for updates manually.

1. Make sure that you have an active internet connection.
2. On the Home tab, click Help > Check for Updates. The Add-On Manager opens with the Updates tab selected.
3. If there is an update available for your version of MATLAB, click the Update button to the right of the update name to install it. If there is no update available for your version or if you have already installed the latest update, MATLAB displays that information.
See Also

More About

• “Update MathWorks License and Software” (Installation, Licensing, and Activation)
• “Upgrade MATLAB Release” (Installation, Licensing, and Activation)
macOS Platform Conventions

In this section...

- “Mouse Instructions and macOS Platforms” on page 2-39
- “Navigating Within the MATLAB Root Folder on macOS Platforms” on page 2-39
- “MATLAB Dock Menu” on page 2-40

Mouse Instructions and macOS Platforms

The documentation typically presents conventions for Microsoft Windows platforms. Therefore, some conventions and operations differ on the macOS platform from those that appear in the rest of the documentation. The intended action for the macOS platform is typically obvious. Mouse operations follow macOS conventions.

Make the following replacements to adjust documented mouse instructions for Macintosh platforms if you are using a one-button mouse:

- Replace right-click with Ctrl+click
- Replace middle-click with Command+click

Navigating Within the MATLAB Root Folder on macOS Platforms

On macOS platforms, MATLAB is installed as an application bundle. The root folder, the string returned by the `matlabroot` command, has a .app extension.

To view the contents of the MATLAB root folder in the Mac Finder, right-click the MATLAB application bundle, and then select **Show Package Contents** from the context menu.

To view the content of the MATLAB root folder from within MATLAB:

1. On the **Home** tab, in the **File** section, click 📦
2. In the File Browser dialog box, press **Command+Shift+G** to open the Go To Folder dialog box.
3. Enter the full path to a folder within the MATLAB application package, for example, `/Applications/MATLAB_R2019a.app/bin`. 
4 Press Go.

To open a file with a MATLAB command, such as `edit`, specify the full path of the MATLAB root folder. For example:

```matlab
eedit(fullfile(matlabroot,'/toolbox/matlab/demos/lotka.m'))
```

**MATLAB Dock Menu**

Starting in MATLAB R2012a, the MATLAB Dock menu lists open windows and documents associated with the running MATLAB. Choosing an open document from the Dock menu brings the selected document's window to the foreground. In addition, the MATLAB Dock menu includes the item **Open Additional Instance of MATLAB.** This option starts another instance of MATLAB. You can select **Options > Keep in Dock**, but only for the first MATLAB instance. Use **Open Additional Instance of MATLAB** to start additional instances rather than trying to keep multiple MATLAB icons in the Dock.
Preferences

Set Preferences for MATLAB

MATLAB provides various options called preferences for customizing MATLAB. To access and set preferences:

1. On the Home tab, in the Environment section, click Preferences.
2. From the left pane of the Preferences dialog box, select a tool, product, or an entry revealed when you click an arrow preceding a tool or product name.
3. Change settings in the right pane of the Preferences dialog box.
4. Click Apply or OK.

Preferences take effect immediately. They remain persistent across sessions of MATLAB.

Most preferences are not available in MATLAB Online.

Function Alternative

You can open the Preferences dialog box using the preferences function.

You also can access and set some MATLAB options programmatically using settings. For more information, see “Access and Modify Settings”.

Where MATLAB Stores Preferences

MATLAB and other MathWorks products store their preferences in the preferences folder. To see the full path for the preferences folder type prefdir in the MATLAB Command Window. The name of the preferences folder matches the name of the release. For instance, for MATLAB R2016b, the name of the preferences folder is R2016b.

On macOS and iOS, the folder might be in a hidden folder. If so, to access the hidden folder:

1. In the Apple macOS Finder tool, select Go > Go to Folder.
2. In the resulting dialog box, type the path returned by prefdir, and then press Enter.
You must have write access to the preferences folder. Otherwise, MATLAB generates an error in the Command Window when you try to change preferences. MATLAB also can generate an error if the preferences folder is hidden.

**Temporary Preferences Folder**

In some situations, if MATLAB is unable to create or use the preferences folder when starting up, it creates a temporary preferences folder. If a preferences folder exists for a previous release, MATLAB copies the preference files from that release to the temporary preferences folder. Otherwise, MATLAB creates the default preference files for the current release. MATLAB continues to use the temporary preferences folder until the issue is resolved.

If you make changes to preferences while MATLAB is using the temporary preferences folder, the preferences persist across sessions. Once the issue preventing MATLAB to access the preferences folder is resolved though, MATLAB copies the preference files from the previous release or creates the default preference files for the current release. Any changes made to the preferences while using the temporary preference folder are lost.

Each version of MATLAB can have a temporary preferences folder. MATLAB does not migrate preferences from the temporary preferences folder across releases.

**Effects of Installation and Deinstallation on the Preferences Folder**

Installing MATLAB has no effect on the preferences folder. That is, MATLAB creates, checks, copies, and writes to the preferences folder when you start up MATLAB, not when you install it. When you uninstall MATLAB, there is an option in the uninstaller to remove the preferences folder. However, this option is not selected by default.

**Preferences MATLAB Uses When Multiple Releases Are Installed**

The files in the preferences folder that MATLAB uses depends on the version of MATLAB you are starting up. How and if MATLAB migrates (reuses) preferences files from one version of MATLAB to the next also depends on the version.

**Process for Creating and Migrating Preferences Folder and Files**

When you start up, MATLAB looks for a preferences folder name that matches the release starting up, and then it does one of the following:
• If MATLAB finds a preferences folder name matching the release starting up, then it uses that folder and the files within it. This is usually the case after the first time you start MATLAB for a given release.

If a preference folder exists but is empty, then MATLAB recreates the default preference files for the release starting up.

• If MATLAB does not find a preferences folder name matching the release starting up, then it creates one. Next, MATLAB checks to see if a preference folder exists for any of the three releases of MATLAB that immediately precede the one you are starting.

• If none of the preference folders from the previous three releases exist, then MATLAB creates the default preference files for the release starting up.

  For example, if you start up R2016a and neither R2015b, R2015a, or R2014b are installed, then MATLAB creates the default files for the R2016a release. This is true even if a preference folder exists for the R2014a release or earlier.

• If one or more of the preference folders for the previous three releases exist, then MATLAB migrates the files from the preferences folder corresponding to the latest previous release to the preferences folder for the release starting up.

  For example, if you start up R2016a and a preference folder exists for both the R2015b and R2014b releases, then MATLAB migrates the files from the R2015b preferences folder to the R2016a preferences folder.

**Control Preferences Files MATLAB Uses**

This table describes how to control which versions of preferences files MATLAB uses.

<table>
<thead>
<tr>
<th>To Use:</th>
<th>Do This:</th>
</tr>
</thead>
</table>
| Default preference files for a given release of MATLAB | • If a preference folder for the given release exists, make sure that the folder is empty before starting up.  
• If a preference folder for the given release does not exist and one or more of the preference folders for the previous three releases do exist, create an empty preferences folder for the given release. |
To Use:

All the preference files from a release of MATLAB up to three releases preceding the release you plan to start up or sign into.

Do This:

Ensure that the preferences folder exists for that previous release. Delete the entire preferences folder for each release after the release you want to migrate from, including the folder for the release of MATLAB you plan to start up or sign into.

The release-specific default for just a particular file in the preferences folder

Delete just that file from the preferences folder for the release of MATLAB you plan to start up or sign into.

One file to consider keeping is history.m. For more information, see “Set Command History Preferences” on page 3-31.

General Preferences

You can set preferences for the initial working folder, deleting files, and toolbox path caching.

On the Home tab, in the Environment section, click Preferences. Select MATLAB > General. Then, adjust preference options as described in this table.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial working folder</td>
<td>Select the last working folder from your previous MATLAB session, or specify the full path to a folder on your system. For more information, see “MATLAB Startup Folder” on page 1-20. If you create a startup.m file, cd commands in that file override the preference option.</td>
</tr>
<tr>
<td>Preference</td>
<td>Usage</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Deleting files</td>
<td>Select an option to specify what MATLAB does with files you delete using the delete function.</td>
</tr>
<tr>
<td></td>
<td>Selecting <strong>Delete permanently</strong> makes the delete function run faster.</td>
</tr>
<tr>
<td></td>
<td>On Linux systems, if you select <strong>Move to a temporary folder</strong>, MATLAB moves files to a subfolder with the prefix <code>MATLAB_Files_</code> in the system temporary folder, as returned by the <code>tempdir</code> function.</td>
</tr>
<tr>
<td>Toolbox path caching</td>
<td>Select <strong>Enable toolbox path caching</strong> to have MATLAB cache <code>matlabroot</code> folder information across sessions for quicker startup performance.</td>
</tr>
<tr>
<td></td>
<td>Click <strong>Update Toolbox Path Cache</strong> to add files to the <code>matlabroot</code> folder. (Use after you use tools not provided with MATLAB to create MATLAB files.)</td>
</tr>
<tr>
<td></td>
<td>For details, see “Toolbox Path Caching in MATLAB” on page 1-28.</td>
</tr>
<tr>
<td>Desktop language</td>
<td>Select the language in which the MATLAB desktop appears. Supported languages include Japanese, Korean, and Chinese. This option affects the text in dialog boxes, button names, menu items, and error and warning messages.</td>
</tr>
</tbody>
</table>

**Confirmation Dialog Boxes Preferences**

You can specify whether MATLAB displays specific confirmation dialog boxes.

On the **Home** tab, in the **Environment** section, click **Preferences**. Select **MATLAB > General > Confirmation Dialogs**. Then, adjust preference options as described in the table below.

This table summarizes the core MATLAB confirmation dialog boxes. There might be additional confirmation dialog boxes for other products you install, and some options are not available in MATLAB Online.
<table>
<thead>
<tr>
<th>Option</th>
<th>Confirmation Dialog Box Appears</th>
</tr>
</thead>
<tbody>
<tr>
<td>Warn before deleting Command History items</td>
<td>When you delete entries from the Command History window.</td>
</tr>
<tr>
<td></td>
<td>For details, see <strong>Command History Window</strong>.</td>
</tr>
<tr>
<td>Warn before clearing the Command Window</td>
<td>When, on the <strong>Home</strong> tab, in the <strong>Code</strong> section, you click <strong>Clear Commands</strong>. Does not appear when you use the <code>clc</code> function.</td>
</tr>
<tr>
<td>Confirm when overwriting variables in MAT-files</td>
<td>When you save variables by dragging them from the Workspace browser onto a MAT-file in the Current Folder browser.</td>
</tr>
<tr>
<td>Confirm when overwriting workspace variables via drag-and-drop</td>
<td>When you load variables by dragging them from the Details Panel of the Current Folder browser to the Workspace browser or Command Window.</td>
</tr>
<tr>
<td>Prompt when editing files that do not exist</td>
<td>When you type <code>edit filename</code> and <code>filename</code> does not exist in the current folder or on the search path.</td>
</tr>
<tr>
<td>Prompt to exit debug mode when saving file</td>
<td>When you try to save a modified file while in debug mode.</td>
</tr>
<tr>
<td></td>
<td>For details, see “End Debugging Session”.</td>
</tr>
<tr>
<td>Prompt to save on activate</td>
<td>When you have unsaved changes to a figure and program file and you activate the UI by clicking the <strong>Run</strong> button, for example.</td>
</tr>
<tr>
<td></td>
<td>For details, see “GUIDE Preferences”.</td>
</tr>
<tr>
<td>Prompt to save on export</td>
<td>When you have unsaved changes to a figure and program file and you select <strong>File &gt; Export</strong>.</td>
</tr>
<tr>
<td></td>
<td>For details, see “GUIDE Preferences”.</td>
</tr>
<tr>
<td>Confirm changing default callback implementation</td>
<td>When you have modified a callback signature in GUIDE.</td>
</tr>
<tr>
<td></td>
<td>For details, see “GUIDE Preferences”.</td>
</tr>
<tr>
<td>Confirm before exiting MATLAB</td>
<td>When you quit MATLAB.</td>
</tr>
<tr>
<td>Confirm when deleting variables</td>
<td>When you delete variables from the workspace using menu items. Does not appear with the <code>clear</code> function.</td>
</tr>
<tr>
<td></td>
<td>For details, see “Save and Load Workspace Variables” on page 5-16.</td>
</tr>
</tbody>
</table>
Source Control Preferences

You can select which previously installed and configured source control system to use with MATLAB.

On the Home tab, in the Environment section, click Preferences. Select MATLAB > General > Source Control. Then, select an option from the list.

For more information, see “Select or Disable Source Control System”.

Keyboard Shortcuts Preferences

You can set keyboard shortcuts for actions you perform using MathWorks software. You can specify or import sets of predefined keyboard shortcuts, set individual shortcuts on an action-by-action basis, or use a combination of both approaches.

On the Home tab, in the Environment section, click Preferences. Select MATLAB > Keyboard > Shortcuts. Then, adjust preference options as described in this table.

For more information on customizing keyboard shortcuts, see “Customize Keyboard Shortcuts for Individual Actions” on page 2-23.

If you use source control integration through the MATLAB Current Folder Browser, MATLAB might crash when you view or commit changes.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active settings</td>
<td>Select or import a set of predefined keyboard shortcuts.</td>
</tr>
<tr>
<td>Preference</td>
<td>Usage</td>
</tr>
<tr>
<td>---------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>[Image]</td>
<td>Select any one of these options:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Save As</strong> — Save current set of keyboard shortcuts to a file.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Copy to clipboard</strong> — Copy current set of keyboard shortcuts to clipboard, so you can import into Microsoft Excel, for example.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Compare</strong> — Compare the current set of keyboard shortcuts to another set.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Undo Modifications</strong> — Undo changes to a default keyboard shortcut set.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Delete</strong> — Delete a set of keyboard shortcuts you previously saved or added.</td>
</tr>
<tr>
<td><strong>Search by action name or shortcut</strong></td>
<td>Search the list of displayed actions.</td>
</tr>
<tr>
<td><strong>Shortcuts for &lt;action-name&gt;</strong></td>
<td>View the keyboard shortcut assigned to a selected action.</td>
</tr>
<tr>
<td>[+ -]</td>
<td>Add or delete a keyboard shortcut to a selected action.</td>
</tr>
<tr>
<td><strong>All possible conflicts</strong></td>
<td>Display conflicts when two or more different actions have the same shortcut.</td>
</tr>
<tr>
<td>[Image]</td>
<td>Remove the keyboard shortcut from the selection in the All possible conflicts list.</td>
</tr>
</tbody>
</table>

**Colors Preferences**

You can specify the text and background color for desktop tools, as well as colors for highlighting syntax elements of MATLAB code.

On the **Home** tab, in the **Environment** section, click ☐ **Preferences**. Select **MATLAB > Colors**. Then, set options as described in the table below.
Preference | Usage
--- | ---
**Desktop tool colors** | Specify that desktop tools use the same text and background colors that your platform uses for other applications by selecting **Use system colors**.

Customize colors by clearing **Use system colors**, and then choose **Text** and **Background** colors from the drop-down menus.

These colors do not apply to the Help display pane, nor to the web browser.

For details, see “Change Text and Background Colors in Desktop Tools” on page 2-7.

**MATLAB syntax highlighting colors** | Set colors to help you quickly identify elements of MATLAB syntax in the Editor, Command Window, Command History window, and the MATLAB shortcuts callback area.

For details, see “Change Syntax Highlighting Colors” on page 2-7.

**MATLAB Command Window colors** | Set colors to help you quickly identify errors, warnings, and hyperlinks in the Command Window.

### Colors Programming Tools Preferences

You can specify options used for editing and debugging code, including code analysis colors, variable and function colors, and cell display options.

On the **Home** tab, in the **Environment** section, click **Preferences**. Select **MATLAB > Colors > Programming Tools**. Then, set options as described in the table below.
### Preference  
**Code analyzer colors**

- **Warnings**—Specifies the color Code Analyzer uses to identify code in the Editor for which there are warning messages.
- **Autofix highlight**—Specifies the color Code Analyzer uses to identify code in the Editor for which there is an automatic fix.

For details, see “Automatically Check Code in the Editor — Code Analyzer”.

### Preference  
**Variable and function colors**

- **Automatically highlight**—Specifies the color the Editor uses to highlight all occurrences of a specific variable or function. For details, see “Find and Replace Functions or Variables in the Current File”.
- **Variables with shared scope**—Specifies the color of variables with shared scope. The text is colored, not shaded. For details, see “Check Variable Scope in Editor”

### Preference  
**Section display options**

- **Highlight sections**—Specifies the color the Editor uses to shade code sections.

- **Show lines between sections**—Specifies that code section divisions appear with a gray line between each section in the Editor. These lines do not appear in the published or printed file. See also “Code Sections”.

### Comparison Preferences

#### Colors

You can change and save your diff color preferences for the Comparison tool. You can apply your color preferences to all comparison types.

On the **Home** tab, in the **Environment** section, click ☰ **Preferences**. Select **MATLAB > Comparison**. Then, set options as described in the table below.
### Preference: Colors

Set colors to help you quickly identify differences, modifications, and merges in comparison reports. Choose colors from the drop-down menus. View the colors in the **Sample** pane. To use your modified settings in comparisons, click **Apply**. Refresh any open comparison reports to use the new colors.

### Preference: Active Settings

To save your modified color preferences for use in future MATLAB sessions, click **Save As**. Enter a name for your color settings profile and click **OK**.

After saving settings, you can select them in the **Active Settings** list.

For details, see “Comparison Report Tools and Options” on page 6-23.

---

**External Source Control Integration**

Use the check box to control external source control interactions: **Allow external source control tools to use open MATLAB sessions for diffs and merges**. After you configure your source control tool to use MATLAB Comparison tool, the Comparison tool prompts you to set this preference. For details, see “Customize External Source Control to Use MATLAB for Diff and Merge” (Simulink).

---

**Toolbars Preferences**

You can customize some toolbars in the MATLAB application.

On the **Home** tab, in the **Environment** section, click **Preferences**. Select **MATLAB > Toolbars**. Then, set options as described in the table below.

For step-by-step instructions on setting these preferences, see “Access Frequently Used Features” on page 2-10.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Toolbar</strong></td>
<td>Select the toolbar you want to customize.</td>
</tr>
<tr>
<td>Preference</td>
<td>Usage</td>
</tr>
<tr>
<td>------------</td>
<td>-------</td>
</tr>
<tr>
<td><strong>Layout</strong></td>
<td>Rearrange controls in the toolbar by dragging and dropping them to a new location in the <strong>Layout</strong>.</td>
</tr>
<tr>
<td><strong>Controls</strong></td>
<td>Select which buttons appear on the selected toolbar.</td>
</tr>
</tbody>
</table>

**See Also**
prefdir

**More About**
- “Access and Modify Settings”
Web Preferences

Web preferences enable you to specify internet connection information to MATLAB.

Limitations

- MATLAB supports nonauthenticated, basic, digest, and NTLM proxy authentication types.
- You cannot specify proxy server settings using a script.
- There is no automated way to provide MATLAB with the proxy server settings that your system browser uses.

You can set Web preferences on the Home tab, in the Environment section. Click Preferences. Select MATLAB > Web, and then adjust preference options as described in this table.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a proxy server to connect to the Internet</td>
<td>Provide information that MATLAB needs to access the Internet when your network uses a firewall or another method of protection that restricts internet access.</td>
</tr>
<tr>
<td>Proxy host</td>
<td>Specify a value for the Proxy host. For example, 172.16.10.8 or ourproxy. If you do not know the values for your proxy server, ask your system or network administrator for the information.</td>
</tr>
<tr>
<td>Proxy port</td>
<td>Specify an integer value for the Proxy port. For example, 22. If you do not know the values for your proxy server, ask your system or network administrator for the information.</td>
</tr>
<tr>
<td>Use a proxy with authentication</td>
<td>Specifies that your proxy server requires a user name and password.</td>
</tr>
<tr>
<td>Proxy username</td>
<td>Specify the proxy server user name.</td>
</tr>
<tr>
<td>Proxy password</td>
<td>Specify the proxy server password.</td>
</tr>
</tbody>
</table>

**Note** MATLAB stores the password without encryption in your matlab.prf file.
<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test connection</td>
<td>Ensure that your settings work. If MATLAB cannot access the Internet, <strong>Failed!</strong> appears next to the button. Correct the values you entered and try again. If you still cannot connect, try using the values you used when you authenticated your MATLAB license.</td>
</tr>
<tr>
<td>System Web browser</td>
<td>Select <strong>Use system web browser when opening links to external sites (recommended)</strong> to open external sites in your system browser. Clear the option to use the MATLAB browser instead. Using the system browser is recommended when opening external sites.</td>
</tr>
<tr>
<td></td>
<td>UNIX platforms only, excluding Macintosh:</td>
</tr>
<tr>
<td></td>
<td>Specify the system <strong>Command</strong> to open the browser. For example, <strong>opera</strong>, opens the Opera Web browser.</td>
</tr>
<tr>
<td></td>
<td>Specifies the <strong>Options</strong> for the system browser. For example, <strong>geometry 1064x860</strong> specifies the size of the window for Opera.</td>
</tr>
</tbody>
</table>
Entering Commands

- “Enter Statements in Command Window” on page 3-2
- “Find Functions to Use” on page 3-4
- “Format Output” on page 3-7
- “Stop Execution” on page 3-11
- “Find Text in Command Window or History” on page 3-12
- “Rerun Favorite Commands” on page 3-15
- “Set Command Window Preferences” on page 3-18
- “Set Keyboard Preferences” on page 3-21
- “Check Syntax as You Type” on page 3-24
- “Set Command History Preferences” on page 3-31
Enter Statements in Command Window

As you work in MATLAB, you can enter individual statements in the Command Window. For example, create a variable named \( a \) by typing this statement at the command line:

\[ a = 1 \]

MATLAB immediately adds variable \( a \) to the workspace and displays the result in the Command Window.

\[ a = 1 \]

When you do not specify an output variable, MATLAB uses the variable \( \text{ans} \), short for \textit{answer}, to store the results of your calculation.

\[ \sin(a) \]

\[ \text{ans} = 0.8415 \]

The value of \( \text{ans} \) changes with every command that returns an output value that is not assigned to a variable.

If you end a statement with a semicolon, MATLAB performs the computation, but suppresses the display of output in the Command Window.

\[ b = 2; \]

To enter multiple statements on multiple lines before running any of the statements, use \textbf{Shift+Enter} between statements. This action is unnecessary when you enter a paired keyword statement on multiple lines, such as \textit{for} and \textit{end}.

You also can enter more than one statement on the same line by separating statements. To distinguish between commands, end each one with a comma or semicolon. Commands that end with a comma display their results, while commands that end with a semicolon do not. For example, enter the following three statements at the command line:

\[ A = \text{magic}(5), \ B = \text{ones}(5) * 4.7; \ C = A./B \]

\[ A = \begin{bmatrix} 17 & 24 & 1 & 8 & 15 \end{bmatrix} \]
MATLAB displays only the values of A and C in the Command Window.

To recall previous lines in the Command Window, press the up- and down-arrow keys, ↑ and ↓. Press the arrow keys either at an empty command line or after you type the first few characters of a command. For example, to recall the command \( b = 2 \), type \( b \), and then press the up-arrow key.

To clear a command from the Command Window without executing it, press the Escape (Esc) key.

You can evaluate any statement already in the Command Window. Select the statement, right-click, and then select Evaluate Selection.

In the Command Window, you also can execute only a portion of the code currently at the command prompt. To evaluate a portion of the entered code, select the code, and then press Enter.

For example, select a portion of the following code:

```matlab
>> disp('hello'), disp('world')
```

hello
Find Functions to Use

This example shows how to find the name and description of a MathWorks function from the Command Window or Editor using the Function browser. The Function browser is not supported in the Live Editor.

1. Click the Browse for functions button, \( \mathcal{F} \). In the Command Window, this button is to the left of the prompt. In the Editor, the button is on the Editor tab, in the Edit section. The Function browser opens.

   ![Function browser image]

   **Tip** The Function browser closes when you move the pointer outside of it. To keep the browser open, drag it by the top edge to a different location.

2. Optionally, select a subset of products to display in the list. Click the product area at the bottom of the browser (where the text **All installed products** appears by default), and then set the **Selected Products** preference and click **OK**. This preference also applies to the Help browser.

3. Find functions by browsing the list or by typing a search term. For example, search for the term *fourier*. 
In the search results, a parenthetical term after a function name indicates either that the function is in a product folder other than MATLAB, or that there are multiple functions with the same name. For example, \texttt{fft (comm)} corresponds to the \texttt{fft} function in the Communications Toolbox™ folder.

4 Select a function that you would like to use or learn more about, as follows.

- Insert the function name into the current window by double-clicking the name. Alternatively, drag and drop the function name into any tool or application.
- View syntax information for the function by single-clicking its name. A brief description for each of the syntax options displays in a yellow pop-up window.
You can change the font that the Function browser uses by setting preferences. On the Home tab, in the Environment section, select Preferences > Fonts. By default, the Function browser uses the desktop text font and the pop-up window uses the Profiler font.
Format Output

MATLAB displays output in both the Command Window and the Live Editor. You can format the output display using several provided options.

Format Line Spacing in Output

By default, MATLAB displays blanks lines in command window output.

You can select one of two numeric display options in MATLAB.

- **loose** — Keeps the display of blank lines (default).
  
  ```matlab
  >> x = [4/3 1.2345e-6]
  x =
  1.3333    0.0000
  ```

- **compact** — Suppresses the display of blank lines.
  
  ```matlab
  >> x = [4/3 1.2345e-6]
  x =
    1.3333    0.0000
  ```

To format the output display, do one of the following:

- On the **Home** tab, in the **Environment** section, click **Preferences**. Select **MATLAB > Command Window**, and then choose a **Numeric display** option.
- Use the `format` function at the command line, for example:

  ```matlab
  format loose
  format compact
  ```

**Note** Line spacing display options do not apply in the Live Editor.

Format Floating-Point Numbers

You can change the way numbers display in both the Command Window and the Live Editor. By default, MATLAB uses the short format (5-digit scaled, fixed-point values).
For example, suppose that you enter \( x = \begin{bmatrix} 4/3 & 1.2345e^{-6} \end{bmatrix} \) in the Command Window. The MATLAB output display depends on the format you selected. This table shows some of the available numeric display formats, and their corresponding output.

<table>
<thead>
<tr>
<th>Numeric Display Format</th>
<th>Example Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>short (default)</td>
<td>( x = 1.3333 \ 0.0000 )</td>
</tr>
<tr>
<td>short e</td>
<td>( x = 1.3333e+00 \ 1.2345e^{-06} )</td>
</tr>
<tr>
<td>long</td>
<td>( x = 1.333333333333333 \ 0.000001234500000 )</td>
</tr>
<tr>
<td>+</td>
<td>( x = ++ )</td>
</tr>
</tbody>
</table>

**Note** The text display format affects only how numbers are shown, not how MATLAB computes, or saves them.

To format the way numbers display, do one of the following:

- On the **Home** tab, in the **Environment** section, click 🎨 **Preferences**. Select MATLAB > Command Window, and then choose a **Numeric format** option.
- Use the `format` function, for example:

  ```matlab
  format short
  format short e
  format long
  ```

  See the `format` reference page for a list and description of all supported numeric formats.

## Wrap Lines of Code to Fit Window Width

A line of code or its output can exceed the width of the Command Window, requiring you to use the horizontal scroll bar to view the entire line. To break a single line of input or output into multiple lines to fit within the current width of the Command Window:

1. On the **Home** tab, in the **Environment** section, click 🎨 **Preferences**. Select MATLAB > Command Window.
2. Select **Wrap Lines**.
Click **OK**.

**Note** Line wrapping options do not apply in the Live Editor.

### Suppress Output

To suppress code output, add a semicolon (;) to the end of a command. This is useful when code generates large matrices.

Running the following code creates `A`, but does not show the resulting matrix in the Command Window or the Live Editor:

```matlab
A = magic(100);
```

### View Output by Page

Output in the Command Window might exceed the visible portion of the window. You can view the output, one screen at a time:

1. In the Command Window, type `more on` to enable paged output.
2. Type the command that generates large output.
3. View the output:
   - Advance to the next line by pressing `Enter`.
   - Advance to the next page by pressing `Space Bar`.
   - Stop displaying the output by pressing `q`.

To disable paged output, type `more off`.

**Note** Paged output options do not apply in the Live Editor.

### Clear the Command Window

If the Command Window seems cluttered, you can clear all the text (without clearing the workspace) by doing one of the following:
• On the **Home** tab, in the **Code** section, select **Clear Commands > Command Window** to clear the Command Window scroll buffer.

• Use the `clc` function to clear the Command Window scroll buffer.

• Use the `home` function to clear your current view of the Command Window, without clearing the scroll buffer.

**See Also**

`clc` | `format` | `home` | `more`
Stop Execution

To stop execution of a MATLAB command, press Ctrl+C or Ctrl+Break.

On Apple Macintosh platforms, you also can use Command+. (the Command key and the period key).

Ctrl+C does not always stop execution for files that run a long time, or that call built-ins or MEX-files that run a long time. If you experience this problem, include a drawnow, pause, or getframe function in your file, for example, within a large loop. Also, Ctrl+C might be less responsive if you start MATLAB with the -nodesktop option.

**Note** For certain operations, stopping the program might generate errors in the Command Window.

To programmatically stop execution of a function or script before reaching the end, use the return function. MATLAB returns control to the Command Window or the invoking function.

**See Also**
drawnow | getframe | pause | return
Find Text in Command Window or History

<table>
<thead>
<tr>
<th>In this section...</th>
</tr>
</thead>
<tbody>
<tr>
<td>“Find Text in the Command Window” on page 3-12</td>
</tr>
<tr>
<td>“Find Text in the Command History Window” on page 3-14</td>
</tr>
</tbody>
</table>

Find Text in the Command Window

You can search text currently in the Command Window. This includes text that is visible on the screen, and text that is in the scroll buffer.

- “Search Using Find Dialog Box” on page 3-12
- “Search Using Keyboard Shortcuts” on page 3-13

Search Using Find Dialog Box

To search for specified text in the Command Window, on the Command Window title bar, click , and then select Find. The Find dialog box opens. The search begins at the current cursor position. MATLAB finds the text you specified and highlights it.

MATLAB beeps when a search for Find Next reaches the end of the Command Window, or when a search for Find Previous reaches the top of the Command Window. If you have Wrap around selected, MATLAB continues searching after beeping.

To search for the specified text in other MATLAB desktop tools, change the selection in the Look in field.

You can increase the amount of information available in the Command Window so that more text is available for searching. Doing so requires more memory. On the Home tab, in the Environment section, click Preferences. Select MATLAB > Command Window, and then increase the setting for Number of lines in the command window scroll buffer.

Clearing the command window (for example, with the clc function), empties the scroll buffer. The cleared text is no longer available for searching. To clear your display in the Command Window without clearing the buffer, use the home function.
**Search Using Keyboard Shortcuts**

You can also perform an incremental search in the Command Window using keyboard shortcuts.

1. Begin an incremental search by using one of the defined keyboard shortcuts.

<table>
<thead>
<tr>
<th>Action</th>
<th>Windows Default Shortcut</th>
<th>Macintosh or Emacs Default Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initiate a forward incremental search.</td>
<td>Ctrl+Shift+S</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Initiate a backward incremental search.</td>
<td>Ctrl+Shift+R</td>
<td>Ctrl+R</td>
</tr>
</tbody>
</table>

An incremental search field appears in the bottom right corner of the MATLAB Desktop window. For a forward search, the text **F Inc Search** appears. The F indicates a forward search.

2. Begin typing your search term.

When you enter lowercase letters in the incremental search field, MATLAB looks for both lowercase and uppercase instances of the letters. For example, if you enter b, MATLAB looks for b and B. However, if you enter uppercase letters, MATLAB only looks for instances that match the case you entered.

3. Perform incremental search actions using these keyboard shortcuts:

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Complete a partially highlighted set of characters.</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Find the next occurrence of a set of characters.</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Remove characters from the incremental search field, back to the last successful search</td>
<td>Ctrl+G</td>
</tr>
</tbody>
</table>

If you search for a set of characters that does not appear in the Command Window text, **Failing** appears in the incremental search field.

4. End incremental searching by pressing **Esc** (escape), **Enter**, or any other key that is not a character or number.
The incremental search field disappears. The cursor remains at the position where the text was last found, with the search text highlighted.

**Find Text in the Command History Window**

You can search for text in the Command History Window. You can search for text either at the beginning of a command, or anywhere within a command.

1. In the Command History window, type in the Search field. To display the Search field if is not visible, click , and then select **Find**.

2. Begin typing your search term.

   The Command History window searches backward and selects the previous entry that contains the sequence of letters you typed.

3. Select from the different search options using the buttons to the right of the search field. Options include (match case), (match anywhere within command), and (match at beginning of command).

4. Find the previous or next occurrence of the entry with the up and down arrow keys, respectively.

5. Press **Esc** to clear the search.
Rerun Favorite Commands

Create and Run Favorite Commands

MATLAB favorite commands (previously called command shortcuts) are an easy way to run a group of MATLAB language statements that you use regularly. For example, you can use a favorite command to set up your environment when you start working, or to set the same properties for figures you create.

To create a favorite command:

1. On the **Home** tab, in the **Code** section, click **Favorites** and then click **New Favorite**. The Favorite Command Editor dialog box opens.

2. In the **Label** field, enter a name for the favorite command. For this example, enter **Setup Workspace**.

3. In the **Code** field, type the statements you want the favorite command to run. You also can drag and drop statements from the Command Window, the Command History Window, or a file. MATLAB automatically removes any command prompts (>>) from the **Code** field when you save the favorite command.

   For example, enter these statements:

   ```matlab
   format compact
clear
workspace
filebrowser
clc
   ```

4. In the **Category** field, type the name of a new category or select an existing category from the drop-down list. If you leave this field blank, the favorite command appears in the default **Favorite Commands** category.

5. In the **Icon** field, select an icon.

6. To add the favorite command to the quick access toolbar, select both the **Add to quick access toolbar** and **Show label on quick access toolbar** options.

7. To run the statements in the **Code** section and ensure they perform the desired actions, click **Test**.

8. When you are done configuring the favorite command, click **Save**.

To run a favorite command, on the **Home** tab, click **Favorites** and then click the icon for the desired favorite command. All the statements in the **Code** field of the Favorite
Command Editor execute as if you ran those statements from the Command Window, although they do not appear in the Command History window.

To edit a favorite command, click the icon to the right of the favorite command. To delete a favorite command, click the icon to the right of the favorite command. You also can right-click the favorite command and select Edit Favorite or Delete Favorite.

**Organize Favorite Commands**

You can organize your favorite commands by storing them in different categories.

To create a new category:

1. On the **Home** tab, in the **Code** section, click **Favorites** and then click **New Category**. The Favorite Category Editor dialog box opens.
2. In the **Label** field, enter a name for the category. For this example, enter **My Favorite Favorites**.
3. In the **Icon** field, select an icon.
4. To add the category to the quick access toolbar, select both the **Add to quick access toolbar** and **Show label on quick access toolbar** options.
5. Click **Save**.

To move a category up or down in the list of categories, or to move a favorite command within a category, drag the category or favorite command to the desired location. You also can use the and buttons to the right of the category.

To change whether a single category or favorite command appears in the quick access bar, click the and icons to the right of the category or favorite command. To add all favorite commands to the quick access bar, on the **Home** tab, right-click **Favorites** and select **Add to quick access toolbar**.

To further configure which favorite commands and categories appear in the quick access bar, on the **Home** tab, in the **Code** section, click **Favorites** and then click **Quick Access**. Adding and configuring favorite commands and categories in the quick access bar is not supported in MATLAB Online.
See Also

More About

- “Customize Keyboard Shortcuts” on page 2-21
- “Set Command History Preferences” on page 3-31
Set Command Window Preferences

You can customize the visual display of the Command Window and command output within it.

On the Home tab, in the Environment section, click Preferences. Select MATLAB > Command Window, and then adjust preference options as described in the table below.

Some Command Window preferences are not available in MATLAB Online.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Text display</strong></td>
<td>Select a <strong>Numeric format</strong> option to specify the output format of numeric values in the Command Window. For details, see “Format Floating-Point Numbers” on page 3-7. Select a <strong>Numeric display</strong> option to specify whether blank lines appear in Command Window output. To suppress blank lines, select compact. To display blank lines, select loose.</td>
</tr>
<tr>
<td><strong>Datetime format</strong></td>
<td>Select a <strong>Locale</strong> option to specify the default input locale of the Datetime object. You also can enter a custom locale. For more information, including a list of common values, see datetime. Select a <strong>Default date and time format</strong> option to specify the default format of the Datetime object. You also can enter a custom format. For more information, see the Format property for datetime arrays. Select a <strong>Default date-only format</strong> option to specify the default date format of the Datetime object. You also can enter a custom format. For more information, see the Format property for datetime arrays.</td>
</tr>
<tr>
<td><strong>Display</strong></td>
<td>Select <strong>Wrap lines</strong> to make each line of input or output in the Command Window break into multiple lines to fit within the current width of the Command Window. For details, see “Wrap Lines of Code to Fit Window Width” on page 3-8.</td>
</tr>
<tr>
<td>Preference</td>
<td>Usage</td>
</tr>
<tr>
<td>------------</td>
<td>-------</td>
</tr>
<tr>
<td><strong>Set matrix display width to eighty columns</strong></td>
<td>Select <strong>Set matrix display width to eighty columns</strong> to limit the width of matrix output.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>If you also select <strong>Wrap lines</strong>, and the width of the Command Window is fewer than 80 characters, each row of 80 characters of matrix output wraps to fit within the width of the Command Window.</td>
</tr>
<tr>
<td><strong>Show getting started message bar</strong></td>
<td>Select <strong>Show getting started message bar</strong> to display the Command Window message bar that provides links to introductory information.</td>
</tr>
<tr>
<td><strong>Show function browser button</strong></td>
<td>Select <strong>Show function browser button</strong> to display the Function Browser button $\mathcal{F}$ to the left of the prompt in the Command Window. You can use the Function Browser to search for MATLAB functions.</td>
</tr>
<tr>
<td><strong>Suggest corrections for mistyped functions and variables</strong></td>
<td>Select <strong>Suggest corrections for mistyped functions and variables</strong> to display suggestions in the Command Window. If you enter an undefined function, variable name, or MATLAB operator, MATLAB displays:</td>
</tr>
<tr>
<td></td>
<td>Did you mean:</td>
</tr>
<tr>
<td></td>
<td>followed by a suggested command at the command line. You can press <strong>Enter</strong> to execute that command, or <strong>Esc</strong> to delete the suggestion.</td>
</tr>
<tr>
<td><strong>Number of lines in command window scroll buffer</strong></td>
<td><strong>Number of lines in command window scroll buffer</strong> specifies the maximum number of lines displayed in the Command Window. A larger scroll buffer provides a larger base for search features, but requires more memory. By default, the scroll buffer is set to 5,000 lines.</td>
</tr>
<tr>
<td></td>
<td>The scroll buffer size does not impact the number of lines you can recall. By default, you can use the up arrow key ↑ to recall all lines shown in the Command History window, regardless of how many lines you can see in the Command Window.</td>
</tr>
<tr>
<td>Preference</td>
<td>Usage</td>
</tr>
<tr>
<td>-------------</td>
<td>-----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Tab key</td>
<td>Tab size specifies the number of spaces assigned to the tab key.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This setting does not apply if you have enabled tab completion for the Command Window or Editor. To enable or disabled tab completion, on the Home tab, select Preferences &gt; Keyboard.</td>
</tr>
</tbody>
</table>

**See Also**

**More About**
- “Change Fonts” on page 2-2
Set Keyboard Preferences

Keyboard preferences enable you to set suggestion and completion options and delimiter matching options in the Command Window, Editor, and Live Editor.

**Note** Some keyboard preferences do not apply in the Live Editor.

To set Keyboard Preferences, on the **Home** tab, in the **Environment** section, click Preferences. Select **MATLAB > Keyboard**, and then adjust preference options as described in this table.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suggestions and completions</td>
<td>Select <strong>Tab key narrows completions</strong> to have MATLAB continue to reduce the list of possible names for completions as you type each additional character and press the <strong>Tab</strong> key. This option is not supported in the Live Editor.</td>
</tr>
<tr>
<td></td>
<td>For details, see “Code Suggestions and Completions” on page 3-25.</td>
</tr>
<tr>
<td></td>
<td>In the <strong>Command Window</strong> or <strong>Editor</strong> sections, select <strong>Enable tab completion</strong> to have MATLAB suggest and complete names when you type the first few characters of the name and press the <strong>Tab</strong> key in the Command Window and/or Editor.</td>
</tr>
<tr>
<td>Preference</td>
<td>Usage</td>
</tr>
<tr>
<td>------------</td>
<td>-------</td>
</tr>
<tr>
<td><strong>Preference</strong></td>
<td><strong>Usage</strong></td>
</tr>
<tr>
<td>In the <strong>Command Window</strong> or <strong>Editor</strong> sections, select <strong>Enable function hints</strong> to have MATLAB display function hints in the Command Window and/or Editor. When enabled, if you type a function name with an opening parenthesis, and then pause, a tooltip opens showing the basic syntax for the function. For example:</td>
<td></td>
</tr>
<tr>
<td><img src="image_url" alt="Image" /></td>
<td>For details, see “Function Syntax Hints” on page 3-28.</td>
</tr>
<tr>
<td>In the <strong>Live Editor</strong> section, select <strong>Show automatically</strong> to have MATLAB suggest and complete names automatically when you type the first few characters of the name. Select <strong>Show on tab</strong> to have MATLAB suggest and complete names only after you press the <strong>Tab</strong> key.</td>
<td></td>
</tr>
<tr>
<td>Preference</td>
<td>Usage</td>
</tr>
<tr>
<td>--------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Delimiter Matching | Specify when and if MATLAB alerts you to matched and mismatched delimiters. Delimiters include parentheses, brackets, braces, and, in the Editor only, paired keywords.  
If you select **Match while typing**, MATLAB alerts you to matched and mismatched delimiters as you type.  
If you select **Match on arrow key**, MATLAB alerts you to matched and mismatched delimiters when you move the cursor over a delimiter using an arrow key.  
For details, see “Delimiter Matching” on page 3-25.  
Select one of these **Show match with** options to specify how MATLAB indicates matching delimiters:  
  - **Balance** — The corresponding delimiter highlights briefly (default).  
  - **Underline** — Both delimiters in the pair display underlines briefly.  
  - **Highlight** — Both delimiters in the pair highlight briefly.  
Select one of these **Show mismatch with** options to specify how MATLAB indicates mismatched delimiters  
  - **Beep** — MATLAB beeps.  
  - **Strikethrough** — The delimiter you type appears crossed out briefly (default).  
  - **None** — There is no alert. |
Check Syntax as You Type

Syntax Highlighting

To help you identify MATLAB elements, some entries appear in different colors in the Command Window and the Editor. This is known as *syntax highlighting*. By default:

- Keywords are blue.
- Character vectors are purple.
- Untermated character vectors are maroon.
- Comments are green.

% check to see if A is greater than B
if A > B
 'greater'
 elseif A < B
 'less'
 end

Except for errors, output in the Command Window does *not* appear with syntax highlighting.

MATLAB software copies the selection to the Clipboard in RTF format, which many Microsoft Windows and Macintosh applications support. When you paste or drag a selection from the Editor to another application, such as Microsoft Word, the pasted text maintains the syntax highlighting colors and font characteristics from the Editor.

You can change syntax highlighting preferences. On the **Home** tab, in the **Environment** section, click **Preferences**. Select **MATLAB > Editor/Debugger > Languages**. Changing syntax highlighting preferences is not supported in MATLAB Online. In the Live Editor, changing syntax highlighting color preferences is supported, but disabling syntax highlighting is not supported.
**Delimiter Matching**

MATLAB indicates matched and mismatched delimiters, such as parentheses, brackets, and braces, to help you avoid syntax errors. MATLAB also indicates paired language keywords, such as for, if, while, else, and end statements.

By default, MATLAB indicates matched and mismatched delimiters and paired language keywords as follows:

- Type a closing delimiter—MATLAB briefly highlights or underlines the corresponding opening delimiter.
- Type more closing delimiters than opening delimiters—MATLAB puts a strikethrough or underline on the unmatched delimiter.
- Use the arrow keys to move the cursor over one delimiter—MATLAB briefly underlines both delimiters in a pair. If no corresponding delimiter exists, MATLAB puts a strikethrough on the unmatched delimiter.

If a matching delimiter exists, but it is not visible on the screen, a pop-up window appears and shows the line containing the matching delimiter. Click in the pop-up window to go to that line.

```matlab
>> a = ['first', ...
    'third', ...
    'fourth', ...
    'fifth', ...
    'sixth']
```

You can change what the delimiter matching indicators are, and when or if they appear. On the **Home** tab, in the **Environment** section, click ☰ **Preferences**. Select **MATLAB > Keyboard**. Changing delimiter matching indicator preferences is not supported in the Live Editor or in MATLAB Online.

**Code Suggestions and Completions**

When you write code, MATLAB automatically suggests and completes the names of functions, models, MATLAB objects, files, folders, variables, structures, graphics properties, parameters, and options. You can use automatic suggestions and completions to write commands faster and avoid typographical errors.
The Live Editor automatically displays possible matches as you type. To insert a match in your script, use the arrow keys to select the name you want, and then press the Tab key. Press the Esc key to clear the list of possible completions without selecting anything. To complete names in the Command Window or Editor, type the first few characters of the name you want to complete, and then press the Tab key. Use the arrow keys to select the name you want, and then press the Tab key again. In MATLAB Online, the Editor behaves the same as the Live Editor.

Automatic suggestions and completions are especially useful when completing the names and values of graphics properties. For example, `plot(x,y,'LineStyle','-')`.

You can also use the suggestions to complete parameter names and options for certain functions. For example, `format('shortEng')`. 
When entering a statement that includes a function, MATLAB might suggest multiple syntaxes for the function. To view the additional syntaxes, click the arrow to the right of the syntax. You also can use the Ctrl + Down Arrow keyboard shortcut to show and hide the additional syntaxes. On macOS systems, use the Command key instead of Ctrl.

Similarly, if MATLAB suggests multiple arguments, click the arrow to the right of the argument description to view the additional arguments. You also can use the Ctrl + Alt + Right Arrow and Ctrl + Alt + Left Arrow keyboard shortcuts.

MATLAB displays suggestions based on its current state. This includes:

- Variables that are defined in the current workspace
- Files and folders that are on the search path or in the current folder
Variables, functions, class properties, and class methods that are defined in the active
document and available at the current location of the cursor

MATLAB does not complete field names of structure arrays defined only within the active
file.

**Tip** To use the Tab key to add multiple spaces within a statement, first add a space, and
then press Tab. Otherwise, when tab completion is enabled, MATLAB attempts to
complete a name.

To have MATLAB suggest and complete names only after you press the Tab key in the
Live Editor, on the Home tab, in the Environment section, click Preferences. Then,
select MATLAB > Keyboard and in the Suggestions and completions > Live Editor
section, select Show on tab.

To disable suggestions and completions in the Command Window and Editor, in the
Suggestions and completions section, clear Enable tab completion for the desired
tool.

Changing suggestions and completions preferences is not supported MATLAB Online.

**Function Syntax Hints**

As you enter a function in the Command Window, Live Editor, or Editor, syntax hints open
in a pop-up window to display allowable input arguments for the function.

Function syntax hints appear for both MATLAB installed functions and functions you
create. The syntax hints for MATLAB functions come from the documentation. The syntax
hints for functions you create come from the function definition statement (first
executable line) in the MATLAB program file. That file must be on the search path or in
the current folder. For more information about adding help to the functions you create,
see “Add Help for Your Program”.

To use function syntax hints, type a function name with an opening parenthesis. A pop-up
window opens showing the basic syntax for the function. In the Live Editor (and Editor in
MATLAB Online), you can use the drop-down arrow ▼ to the right of the syntax to display
all available syntaxes.
You can type an input for any argument that appears in blue. Enter your own input names, and not the argument names shown in the window. The displayed syntax options change based on the argument you just entered.

In the Live Editor (and Editor in MATLAB Online), MATLAB displays descriptions for each argument. Optional arguments are indicated by the \textbf{(optional)} keyword next to the argument description.

Some function names are overloaded. That is, there are different functions with the same name that support different types of input. Overloaded functions require that you pass an object as the first input. When you specify the object name, the syntax hints update to reflect the correct version of the function, as shown. The Live Editor might not display all overloads.
Function syntax hints are suggestions only. For detailed information about a function, see the function reference page in the documentation. To open the documentation for the function, click the button to the left of the function syntax hint.

To disable function syntax hints in the Command Window and Editor, on the Home tab, in the Environment section, click Preferences. Then, select MATLAB > Keyboard and in the Suggestions and completions section, clear Enable function hints for the desired tool. Disabling function syntax hints is not supported in MATLAB Online.
Set Command History Preferences

You can exclude statements from the command history and specify how many commands to save to the command history file, History.xml. MATLAB uses the command history file for both the Command History window and statement recall in the Command Window.

**Note** When you exclude statements from the command history file, you cannot recall them in the Command Window, nor can you view them in the Command History window.

You can also change the way you search for previously executed statements in the command history. Select from different search text matching options and change the way results are displayed in the Command History window.

To set Command History preferences, on the **Home** tab, in the **Environment** section, click **Preferences**. Select **MATLAB > Command History**, and then adjust the preference options as described in this table:

<table>
<thead>
<tr>
<th>Option</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Save</strong></td>
<td>Select <strong>Save exit/quit commands</strong> to save exit and quit commands in the command history.</td>
</tr>
<tr>
<td></td>
<td>Select <strong>Save consecutive duplicate commands</strong> to save consecutive executions of the same statement in the command history.</td>
</tr>
<tr>
<td></td>
<td>• With this option selected, if you run <code>magic(5)</code> two times in a row, the entries for <code>magic(5)</code> appear on separate lines in the command history.</td>
</tr>
<tr>
<td></td>
<td>• With this option cleared, the command history retains only one entry for <code>magic(5)</code> and displays a tally of consecutive executions to the left.</td>
</tr>
</tbody>
</table>
### Option

<table>
<thead>
<tr>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select <strong>Don't save history file</strong> to prevent saving the command history across sessions. This option is useful when multiple users share the same machine. For example, the option prevents each user from viewing statements others have run. Any entries predating the current session remain unless you first delete entries from the Command History window. <strong>Save last n commands</strong> specifies the number of commands to save.</td>
</tr>
</tbody>
</table>

### Match

<table>
<thead>
<tr>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select <strong>Match anywhere</strong> to retrieve statements that contain the search text in any location. Select <strong>Match beginning</strong> to retrieve statements that begin with the search text. This option is selected by default. Select <strong>Match case</strong> to retrieve statements that match the case of the search text. Select <strong>Filter matches</strong> to display only statements that match the search text. Clear <strong>Filter matches</strong> to display all previously executed statements and highlight the statements that match the search text.</td>
</tr>
</tbody>
</table>

### Show

<table>
<thead>
<tr>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select <strong>Show match toolbar</strong> to display a search toolbar at the top of the Command History window. Search for previously executed statements using the search field and change <strong>Match</strong> preferences using the provided buttons. Select <strong>Show match locations</strong> to display yellow markers to the right of the scroll bar in the Command History window that indicate the location of matches throughout the command history. Select <strong>Show execution time</strong> to display an approximate execution time to the right of each statement. Times display for any statements that takes longer than 0.1 seconds to execute.</td>
</tr>
<tr>
<td>Option</td>
</tr>
<tr>
<td>------------------------</td>
</tr>
<tr>
<td>Favorite Commands</td>
</tr>
</tbody>
</table>

**Change the Command History Date Format**

MATLAB uses your operating system's short date format to display dates in the Command History window. To change the date format, for instance from MM/DD/YYYY to DD/MM/YYYY:

1. Change the short date format for your operating system as described in its documentation.
2. Restart MATLAB.

**Note** Clearing the command history deletes all entries from the Command History window. You can no longer recall those entries in the Command Window.

**See Also**
Command History Window
Help and Product Information

- “Ways to Get Function Help” on page 4-2
- “MATLAB Code Examples” on page 4-4
- “Search Syntax and Tips” on page 4-7
- “Bookmark and Share Page Locations” on page 4-10
- “Contact Technical Support” on page 4-12
- “Help Preferences” on page 4-14
- “Translated Documentation” on page 4-16
- “Information About Your Installation” on page 4-18
Ways to Get Function Help

Each MATLAB function has supporting documentation that includes examples and describes the function inputs, outputs, and calling syntax. This table describes ways to access that documentation.

<table>
<thead>
<tr>
<th>Type of Help</th>
<th>How to Access</th>
<th>Example or Icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference page in Help browser</td>
<td>Use the <code>doc</code> command. — or — Select a function name in the Editor, Command Window, or Help browser; right-click; and then select <strong>Help on Selection</strong>.</td>
<td><code>doc mean</code></td>
</tr>
<tr>
<td>Function syntax hints in Command Window</td>
<td>After you type an open parenthesis for function inputs, pause or press <code>Ctrl + F1</code>.</td>
<td><code>mean()</code></td>
</tr>
<tr>
<td>Abbreviated help text in Command Window</td>
<td>Use the <code>help</code> command.</td>
<td><code>help mean</code></td>
</tr>
<tr>
<td>Function browser in Command Window</td>
<td>Click the function icon to the left of the command prompt.</td>
<td><code>f_x</code></td>
</tr>
<tr>
<td>Complete documentation in Help browser</td>
<td>Click the Help button on the quick access toolbar or on the <strong>Home</strong> tab. — or — Enter search terms in the <strong>Search Documentation</strong> box.</td>
<td>![Help button icon]</td>
</tr>
</tbody>
</table>

See Also

doc
More About

• “MATLAB Code Examples” on page 4-4
MATLAB Code Examples

Standalone Examples

A standalone example is a readable version of a MATLAB script or live script that shows how to accomplish a particular task. MATLAB and all MATLAB toolboxes include examples as part of the installed documentation. (Before release R2012b, these examples were called demos.)

To access examples, click Examples at the top of a documentation page. The Help browser displays the examples for the current product category.

MATLAB includes examples that demonstrate various functionalities. For instance, to view examples demonstrating plotting in MATLAB, navigate to the MATLAB > Graphics > 2-D and 3-D Plots category and click Examples at the top of the page.
Each example combines comments, code, and output in a formatted document. If you are viewing the documentation in MATLAB, you can open the corresponding script or live script by clicking **Open Script** or **Open Live Script**.

If you are viewing the documentation on the web, you can open live script examples using the Live Editor in a web browser. To open the example, click the **Try this Example** button to the right of the example and select **Try it in your browser**.

Once it is open, run the example by clicking **Run**. To run the example one section at a time and view the incremental results, select the first section and then step through the script by clicking **Run and Advance**.

Additional examples, created by members of the MATLAB community, are available at the File Exchange.

**Inline Examples**

The product documentation also includes inline code excerpts, such as examples on function pages like `cos` or `plot`. You can run inline code from the Help browser by selecting the code, right-clicking, and then selecting **Evaluate Selection**, as shown. Evaluating a selection from the Help browser is not available in MATLAB Online.
See Also
demo | echodemo

Related Examples
• “Code Sections”

External Websites
• File Exchange
Search Syntax and Tips

Find keywords in the documentation by entering text in the Search box on the desktop or in the Help browser.

When you view pages linked from the search results, search terms appear with highlights. To clear the highlights, press the Esc key.

The search engine ignores common, insignificant words such as a, an, the, and of, unless they are part of an exact phrase in quotation marks. It also ignores capitalization, punctuation, and special characters such as +. To find a symbol or special character:

- Search for the word instead of the symbol or character, such as plus instead of +.
- View the documentation on “MATLAB Operators and Special Characters”.
- Search the PDF documentation, available from the documentation home page.

Searches can include the following operators:

```
" "  Exact phrase
Example: "plot tools" finds pages that contain plot tools, in that sequence, with no words between them.

*    Wildcard
Requires at least two nonwildcard characters, and cannot appear at the start of a keyword or in an exact phrase.

Example: plot* finds plot, plot3, and plotting.

OR    Boolean OR
Example: plot OR graph finds pages with either plot or graph.

NOT   Boolean NOT
Example: "plot tools" NOT "time series" finds pages with plot tools but excludes pages with time series.
```
AND  Boolean AND

Implied when no operator is present between keywords.

Example: plot AND tools is equivalent to "plot" "tools".

The Help browser search evaluates NOT operators first, OR operators second, and AND operators last. For example,

"plotting tool" OR "plot tools" NOT "time series" AND workspace

finds pages that contain either plotting tool or plot tools and contain workspace, but do not contain time series.

You can filter search results using facets that appear on the left side of the page. For example, view MATLAB topics by selecting MATLAB and Help Topics.

The search engine searches the following text in the documentation:

• Documentation — Text and code shown in the Help browser
• User interface examples — Help comments in the program file
• Videos — Title
Bookmark and Share Page Locations

<table>
<thead>
<tr>
<th>In this section...</th>
</tr>
</thead>
<tbody>
<tr>
<td>“Bookmark Favorite Pages” on page 4-10</td>
</tr>
<tr>
<td>“View Page Locations” on page 4-11</td>
</tr>
</tbody>
</table>

**Bookmark Favorite Pages**

In MATLAB, bookmarks are called favorites. Add, find, and organize favorites by clicking the Favorites button in the Help browser, ★.

When you add a favorite, do not change the Callback. MATLAB requires special values to create a shortcut that opens the page in the Help browser. In addition, if you want the bookmark to appear in your list of favorites, keep the Category set to Help Browser Favorites, as shown.

![Favorites Editor](image)

**Note** You cannot migrate favorites that you save in one MATLAB release to a new release.
View Page Locations

To identify the location of a page in the Help browser to share with someone else, right-click within the page, and then select Get Page Address.

The Help Page Location dialog box provides two ways to access the page:

- A web command to run from the command line that opens the page from the installed documentation. This command is subject to change between releases, so it is not always accurate for someone running a different version of MATLAB.
- A URL for the page corresponding to your product version at the MathWorks website. This documentation is available to anyone, even if they do not have MathWorks products. However, to access archived documentation from previous releases, as well as translated documentation, you must sign in with a MathWorks Account.

Note If you are running a prerelease version, the URL is invalid because the documentation does not yet exist on the website.
Contact Technical Support

This example shows how to contact MathWorks Technical Support to report a bug or request help. This procedure requires internet access.

1. On the **Home** tab, in the **Resources** section, click **Request Support**.

2. When requested, sign in using your MathWorks Account email address and password. If you do not have a MathWorks Account, create one.

3. Provide information to help technical support reproduce your issue, such as a description of the steps you followed or a code excerpt. Optionally, you can attach up to five files to your request, where each file is no larger than 5 MB.
Specify the product that is related to the issue.
Submit the request.

**See Also**

**External Websites**
- MathWorks Support Page
Help Preferences

To set Help preferences:

2. Adjust the preference options as described in the table.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Documentation Location</strong></td>
<td>Specify whether to view the documentation provided with your installed products or the documentation on the web at <a href="https://www.mathworks.com/help">https://www.mathworks.com/help</a>. Viewing the web documentation requires an internet connection and a MathWorks Account. If your preference is set to view web documentation, but your internet connection becomes unavailable, MATLAB changes the preference to view the installed documentation. You can reset the preference after your connection is restored. Changes to this preference apply only to new Help browser tabs.</td>
</tr>
<tr>
<td><strong>Selected Products</strong></td>
<td>Select the products to include for viewing and searching documentation in the Help browser or Function browser. If your Documentation Location is set to view documentation on the web, then you can select Show products that are not installed to select and access documentation for all MathWorks products. When the Help browser is already open, changes to this preference apply only to new Help browser tabs.</td>
</tr>
<tr>
<td>Preference</td>
<td>Usage</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Quick Help Display</strong></td>
<td>Specify whether help links display content in the Help browser or in a small window. This preference applies to reference pages or</td>
</tr>
<tr>
<td></td>
<td>program help that you access using:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Help on Selection</strong> in context menus or <strong>F1</strong></td>
</tr>
<tr>
<td></td>
<td>• Function hints or the Function Browser</td>
</tr>
<tr>
<td></td>
<td>• Links in error messages</td>
</tr>
<tr>
<td></td>
<td>Links to reference pages from the Current Folder browser always open in the Help browser.</td>
</tr>
<tr>
<td><strong>Language</strong> (selected non-English systems only)</td>
<td>Specify whether you want documentation in the Help browser and context-sensitive help to appear in English. Installed non-English documentation is not always current.</td>
</tr>
<tr>
<td></td>
<td>This option is only available if your <strong>Documentation Location</strong> is set to view documentation on the web, and for selected non-English systems only.</td>
</tr>
</tbody>
</table>

To adjust the font size in the Help browser or MATLAB web browser, use the **Ctrl + Plus** and **Ctrl + Minus** keyboard shortcuts.

**See Also**

**More About**
- “Translated Documentation” on page 4-16
Translated Documentation

Many MathWorks products have translated documentation in Japanese. In addition, some features of MATLAB have translated documentation in Korean, simplified Chinese, and Spanish. Usually, if a product provides translated documentation, the new version of the product installs the translated documentation from the previous version and the English documentation for the current version.

For information about documentation in other languages, contact your MathWorks sales and service office.

Set Documentation Language

By default, if your system language is set to Japanese, Korean, Chinese, or Spanish, MATLAB opens the web documentation in that language.

If the documentation does not display in the language you want, check the preference settings using these steps:

1. Go to the Home tab and, in the Environment section, click Preferences.
2. Select MATLAB > Help.
3. Make sure the Language is set to Japanese, Korean, Chinese, or Spanish.

The Language preference is only available when your system language is set to Japanese, Korean, Chinese, or Spanish. The preference changes the language only in the Help browser and context-sensitive help. If the documentation for a product is not translated, the Help browser displays the English documentation.

To view the English documentation, set the Language preference to English.

View Installed Documentation

To view the installed version of the documentation, follow these steps:

1. Go to the Home tab and in the Environment section, click Preferences.
2. Select MATLAB > Help.
3. Set the Documentation Location to Installed locally.
4. Select the desired Language.
Spanish documentation is only available on the web, and is not installed with MATLAB.

**View Documentation on the Web**

To view the documentation directly on the web in a different language:

2. Click the button with the globe icon at the bottom-left corner of the web page, and select a country based on the language in which you want to view the documentation.

**See Also**

**Related Examples**

- “Set Locale on Windows Platforms” on page 9-5
- “Set Locale on Linux Platforms” on page 9-9
- “Set Locale on macOS Platforms” on page 9-7
**Information About Your Installation**

MATLAB software can tell you what products are installed, their versions, and other information about your license and platform. This information is important to have in the event you contact technical support on page 4-12.

<table>
<thead>
<tr>
<th>Type of Information You Want</th>
<th>To Get the Information</th>
</tr>
</thead>
</table>
| Version and license for Installed product | From the product, select **Help > About Product Name**. Or use functions:  
  • **license** — for the license number  
  • **ver** — for version numbers for MATLAB and libraries  
  • **version** — for version numbers for MathWorks products |
| MATLAB platform | In MATLAB, select **Help > About MATLAB**. The About MATLAB dialog box shows 32-bit or 64-bit. |
| arch value used to locate library files for the mex function and standalone applications | In MATLAB, select **Help > About MATLAB**. The About MATLAB dialog box shows the arch value, for example win64. Or use the **computer** function. |
| Passcodes and licenses | From any desktop tool, select **Help > Licensing > Manage Licenses**. |
Workspace Browser and Variable Editor

- “Create and Edit Variables” on page 5-2
- “Display Statistics in the Workspace Browser” on page 5-14
- “Save and Load Workspace Variables” on page 5-16
- “Workspace and Variable Preferences” on page 5-19
Create and Edit Variables

Create Variables

The MATLAB workspace consists of the variables you create and store in memory during a MATLAB session. You can create new variables in the workspace by running MATLAB code or using existing variables.

To create a new variable, enter the variable name in the Command Window, followed by an equal sign (=) and the value you want to assign to the variable. For example, if you run these statements, MATLAB adds the three variables x, A, and I to the workspace:

```
x = 5.71;
A = [1 2 3; 4 5 6; 7 8 9];
I = besseli(x,A);
```

![Workspace Browser and Variable Editor](image)

You do not have to declare variables before assigning values to them.

If you do not end the assignment statement with a semicolon (;), MATLAB displays the result in the Command Window. For example,

```
x = 5.71
```

```
x =
   5.7100
```

If you do not explicitly assign the output of a statement to a variable, MATLAB generally assigns the result to the reserved word ans. The value of ans changes with every statement that returns an output value that is not assigned to a variable. For example,

```
sin(1)
```
To view and edit variables, use the Workspace browser and Variables Editor. (Some editing options are not available in MATLAB Online.)

**View Workspace Contents**

To view a list of variables in your workspace, use the Workspace browser.

To open the Workspace browser if it is not currently visible, do either of the following:
- On the **Home** tab, in the **Environment** section, click **Layout**. Then, under **Show**, select **Workspace**.
- Type `workspace` in the Command Window.

By default, the Workspace browser displays the base workspace. You also can view function workspaces if MATLAB is in debug mode. For more information, see “Base and Function Workspaces”.

To display additional columns such as size and range, on the Workspace browser title bar, click ![Column Selection](image), and then click **Choose Columns**. In MATLAB Online, select which columns to display by right-clicking the Workspace browser title bar and selecting or clearing the desired column names.

You also can use the `who` command in the Command Window to view a list of variables. To list information about size and class, use the `whos` command. For example, if you have the variables `x`, `A`, and `I` in your workspace, you can run the `who` and `whos` commands to view your workspace contents:

```matlab
who
```
Your variables are:

A  I  x

whos

<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Bytes</th>
<th>Class</th>
<th>Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>3x3</td>
<td>72</td>
<td>double</td>
<td></td>
</tr>
<tr>
<td>I</td>
<td>3x3</td>
<td>72</td>
<td>double</td>
<td></td>
</tr>
<tr>
<td>x</td>
<td>1x1</td>
<td>8</td>
<td>double</td>
<td></td>
</tr>
</tbody>
</table>

View Variable Contents

You can view the contents of a variable in several ways:

- **Command Window** — Type the variable name at the command prompt. For example:

  ```
  x
  x =
  5.7100
  ```

- **Variables editor** — In the Workspace browser, double-click a variable name. The Variables editor opens for that variable.
Some variables open a viewer or other tool appropriate for the type of value they have, such as timeseries. For details, see the documentation for that data or object type.

A or icon next to a variable property in the Variables editor indicates that the property is protected or private.

To change how the Variables editor displays variables, go to the View tab, and in the Format section, select a number display format. The display format does not affect how values are displayed in the Command Window or Workspace browser, or how the variables are saved.

Note The maximum number of elements in a variable that you can open in the Variables editor depends on your operating system and the amount of physical memory installed on your system.

**Edit Variable Contents**

You can edit the contents of scalar (1-by-1) variables in the Workspace browser. To edit the contents, click the variable value to select it and then enter a new value.
To edit other variables, open them in the Variables editor. For example, suppose that you create a cell array, C, by running these commands in the Command Window:

\[
A = \text{magic}(4);
C = \{A A A\};
\]

In the Workspace browser, double-click the variable name C to open it in the Variables editor.

To edit an element of a variable, double-click the element. The element opens in a new document within the Variables editor. For example, if you double-click element \(C\{1,1\}\) in the Variables editor, the contents of that cell open in a new tab. You can edit the value of a variable element by clicking the element and typing a new value. Press \textbf{Enter} or click another element to save the change.
To return to the parent cell array or structure of an element, go to the View tab and click the Go Up button.

Changes you make in the Variables editor are automatically saved in the workspace. Changes you make to variables via the Command Window or other operations automatically update the information for those variables in the Workspace browser and Variables editor.

**Note**

- You cannot edit elements or subsets of multidimensional arrays in the Variables editor.
- You cannot edit tall arrays in the Variables editor.
- When editing strings in the Workspace browser or as part of a structure in the Variables editor, you must use double quotes to surround the string value.

**Edit Table and Structure Array Variables**

Tables (including timetables) and structure arrays support additional editing actions.
<table>
<thead>
<tr>
<th>Action</th>
<th>Procedure</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modify column or</td>
<td>Double-click the name and enter the new text.</td>
<td><img src="image" alt="Example of modifying column or row name" /></td>
</tr>
<tr>
<td>row name</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reorder variables</td>
<td>Hover over the left side of a variable until a four-headed arrow appears. Then, click and drag the column to a new location.</td>
<td><img src="image" alt="Example of reordering variables" /></td>
</tr>
<tr>
<td>Action</td>
<td>Procedure</td>
<td>Example</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Modify units and description of variables</td>
<td>Click the arrow that appears to the right of a variable name. Then, enter new text in the <strong>Units</strong> and <strong>Description</strong> fields.</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td>Sort variable data</td>
<td>Click the arrow that appears to the right of a variable name and select <strong>Ascending</strong> or <strong>Descending</strong>.</td>
<td><img src="image" alt="Example" /></td>
</tr>
</tbody>
</table>

**Note** The contents of a table are only visible and modifiable when the number of variables is fewer than 5000. When the number of variables equals or exceeds 5000, you can only view the table properties.
Changes made to certain variable types in the Variables editor also appear in the Command Window. For example, suppose you have a table T that contains three columns, A, B, and C. If you delete column A in the Variables editor, the line \( T(:, 'A') = [] \); displays in the Command Window. To suppress code display in the Command Window, on the View tab, clear the Show MATLAB Code check box.

### Resize or Reshape Variables

To modify the size, shape, and order of variable elements in the Variable editor, use one of these procedures.

<table>
<thead>
<tr>
<th>Action</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete row, column, or variable elements</td>
<td>Right-click the desired row header, column header, or selected elements and select Delete Row or Delete Column.</td>
</tr>
<tr>
<td>Insert new row or column</td>
<td>Right-click the desired row header, column header, or element and select Insert Row Above, Insert Row Below, Insert Column to the Left, or Insert Column to the Right. You can also add rows or columns simply by entering a value in an empty row or column. For example, to add a row and column to the array in ( C{1,1} ), enter a value in element (5,5).</td>
</tr>
<tr>
<td>Cut variable elements</td>
<td>Right-click the desired row header, column header, or selected elements and select Cut. The cut values move to the clipboard and are replaced by the default value for empty elements. For more information, see “Empty Elements” on page 5-10.</td>
</tr>
<tr>
<td>Copy variable elements</td>
<td>Right-click the desired row header, column header, or selected elements and select Copy.</td>
</tr>
<tr>
<td>Paste variable elements</td>
<td>Right-click the row header, column header, or element where you want the insertion to begin and select Paste.</td>
</tr>
<tr>
<td>Paste cells from Microsoft Excel spreadsheet</td>
<td>Right-click the element where you want the insertion to begin, and then select Paste Excel Data.</td>
</tr>
</tbody>
</table>

### Empty Elements

Empty elements in variables are assigned default values. Default assignments are:
• 0 for numeric arrays
• [] for cell arrays and structure arrays
• <undefined> for categorical variables

## Copy, Rename, and Delete Variables

You can copy and paste, duplicate, rename, and delete variables within the Workspace browser.

<table>
<thead>
<tr>
<th>Action</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy variable to and from clipboard</td>
<td>Select the variables, right-click, and then select <strong>Copy</strong>. Then, you can paste the names, for example, into the Command Window or an external application. Multiple variables are comma-separated.</td>
</tr>
<tr>
<td>Duplicate variable</td>
<td>Select the variables, right-click, and then select <strong>Duplicate</strong>. MATLAB creates a copy of the selected variables.</td>
</tr>
<tr>
<td>Rename a workspace variable</td>
<td>Right-click the variable name, and then select <strong>Rename</strong>. Type the new variable name and press <strong>Enter</strong>.</td>
</tr>
<tr>
<td>Delete all variables in workspace</td>
<td>On the <strong>Home</strong> tab, in the <strong>Variable</strong> section, click <strong>Clear Workspace</strong>. You also can use the clear function in the Command Window.</td>
</tr>
<tr>
<td>Delete selected variables from workspace</td>
<td>Select the variables in the Workspace browser, right-click, and then select <strong>Delete</strong>. You can also use the clear function in the Command Window. For example, to clear variables A and B, use the command clear A B.</td>
</tr>
<tr>
<td></td>
<td>To preserve specified variables, but delete others, use the clearvars function with the -except option. For example, to clear all variables except variable A, use the command clearvars -except A.</td>
</tr>
</tbody>
</table>
To create a new workspace variable from an existing variable, in the Variables editor, select an element, data range, row, or column in an array, and then in the Variable tab, select **New from Selection**.

You can change the character that delimits decimals in the data when you cut and paste values from the Variables editor into text files or other applications. You might do this, for instance, if you provide data to a locale that uses a character other than the period (.). To change the delimiter character, specify a **Decimal separator for exporting numeric data via system clipboard** in the “Variables Preferences” on page 5-21.

**Navigate Variable Contents**

When editing variables in the Variables editor, some variables can contain large amounts of data, making it difficult to navigate between elements. Use these keyboard shortcuts to move easily between variable elements in the Variables editor. You cannot modify these keyboard shortcuts.

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Commit changes to element and move to next element.</td>
<td>Enter</td>
</tr>
<tr>
<td>“Variables Preferences” on page 5-21 enable you to specify what the next element is. The default is to move down.</td>
<td></td>
</tr>
<tr>
<td>Move right.</td>
<td>Tab</td>
</tr>
<tr>
<td>Within a selection, <strong>Tab</strong> also moves from the last column in one row to the first column in the next row.</td>
<td></td>
</tr>
<tr>
<td>Move in opposite direction of <strong>Enter</strong> or <strong>Tab</strong>.</td>
<td>Shift+Enter or Shift+Tab</td>
</tr>
<tr>
<td>Move up ( m ) rows, where ( m ) is the number of visible rows.</td>
<td>Page Up</td>
</tr>
<tr>
<td>Move down ( m ) rows, where ( m ) is the number of visible rows.</td>
<td>Page Down</td>
</tr>
<tr>
<td>Move to column 1.</td>
<td>Home</td>
</tr>
<tr>
<td>Move to row 1, column 1.</td>
<td>Ctrl+Home</td>
</tr>
<tr>
<td>Edit current element, positioning cursor at the end of the element.</td>
<td>F2 (Ctrl+U on Apple Macintosh platforms)</td>
</tr>
</tbody>
</table>
More About

- "Variable Names"
- "Display Statistics in the Workspace Browser" on page 5-14
- "Workspace and Variable Preferences" on page 5-19
- "Save and Load Workspace Variables" on page 5-16
Display Statistics in the Workspace Browser

For each variable or object, the Workspace browser can display statistics such as the Min, Max, and Mean, when relevant. MATLAB performs these calculations using the min, max, and mean functions, and updates the results automatically.

To display statistics, on the Workspace browser title bar, click , and then select Choose Columns. Select the statistics you want MATLAB to calculate.

Improve Workspace Browser Performance During Statistical Calculations

If you show statistical columns in the Workspace browser, and you work with very large arrays, you might experience performance issues when the data changes as MATLAB updates the statistical results. To improve performance, consider one or both of the following:

• Show only the statistics of interest to you.

  On the Workspace browser title bar, click , and then select Choose Columns. Clear the statistics you do not want MATLAB to calculate.

• Exclude large arrays from statistical calculations.

  On the Home tab, in the Environment section, click Preferences. Select MATLAB > Workspace, and then use the arrow buttons under Statistical calculations to change the maximum array size for which the Workspace browser performs statistical calculations. Any variable exceeding the maximum array size reports <Too many elements> in Workspace browser statistics columns instead of statistical results.

Include or Exclude NaN Values in Statistical Calculations

If your data includes NaNs (Not-a-Number values), you can specify that the Workspace browser statistical calculations consider or ignore the NaNs. On the Home tab, in the Environment section, click Preferences. Select MATLAB > Workspace, and then select one of the following:

• Use NaNs when calculating statistics
If a variable includes a NaN, and you select this option, the values for Min, Max, Var, and several other statistics appear as NaN. However, Mode and several other statistics show a numeric result.

• **Ignore NaNs whenever possible**

If a variable includes a NaN, and you select this option, numeric results appear for most statistics including Min, Max, and Mode. However, Var still appears as NaN.

**See Also**

**More About**

• “Infinity and NaN”
• “Workspace and Variable Preferences” on page 5-19
Save and Load Workspace Variables

The workspace is not maintained across sessions of MATLAB. When you quit MATLAB, the workspace clears. However, you can save any or all the variables in the current workspace to a MAT-file (.mat). You can then reuse the workspace variables later during the current MATLAB session or during another session by loading the saved MAT-file.

Save Workspace Variables

There are several ways to save workspace variables interactively:

- To save all workspace variables to a MAT-file, on the Home tab, in the Variable section, click Save Workspace.
- To save a subset of your workspace variables to a MAT-file, select the variables in the Workspace browser, right-click, and then select Save As. You also can drag the selected variables from the Workspace browser to the Current Folder browser.
- To save variables to a MATLAB script, click the Save Workspace button or select the Save As option, and in the Save As window, set the Save as type option to MATLAB Script. Variables that cannot be saved to a script are saved to a MAT-file with the same name as that of the script.

You also can save workspace variables programmatically using the save function. For example, to save all current workspace variables to the file june10.mat, use the command

```matlab
save('june10')
```

To save only variables A and B to the file june10.mat, use the command

```matlab
save('june10','A','B')
```

To store fields of a scalar structure as individual variables, use the save function with the -struct option. This can be useful if you previously loaded variables from a MAT-File into a structure using the syntax `S = load(filename)` and want to keep the original variable structure when saving to a new MAT-File.

To save part of a variable, use the matfile function. This can be useful if you are working with very large data sets that are otherwise too large to fit in memory. For more information, see “Save and Load Parts of Variables in MAT-Files”.

5-16
In MATLAB Online, variables persist between sessions. Saving allows you to clear the workspace and load variables at a later time. To save variables, use the `save` or `matfile` functions.

### Load Workspace Variables

To load saved variables from a MAT-file into your workspace, double-click the MAT-file in the Current Folder browser.

To load a subset of variables from a MAT-file on the Home tab, in the Variable section, click Import Data. Select the MAT-file you want to load and click Open. You also can drag the desired variables from the Current Folder browser Details panel of the selected MAT-file to the Workspace browser.

To load variables saved to a MATLAB script into the workspace, simply run the script.

You also can load saved variables programmatically, use the `load` function. For example, load all variables from the file `durer.mat`

```matlab
load('durer')
```

To load variables `X` and `map` from the file `durer.mat`

```matlab
load('durer','X','map')
```

To load part of a variable, use the `matfile` function. This is useful if you are working with very large data sets that are otherwise too large to fit in memory. For more information, see “Save and Load Parts of Variables in MAT-Files”.

---

**Caution** When you load data into the MATLAB workspace, the new variables you create overwrite any existing variables in the workspace that have the same name. To avoid overwriting existing variables, use the `load` function to load the variables into a structure. For example, \( S = \text{load('durer')} \) loads all the variables from the file `durer.mat` into the structure `S`.

### View Contents of MAT-File

To see the variables in a MAT-file before loading the file into your workspace, click the file name in the Current Folder browser. Information about the variables appears in the Details pane.
Alternatively, use the command `whos -file filename`. This function returns the name, dimensions, size, and class of all variables in the specified MAT-file. For example, you can view the contents of the example file `durer.mat`.

```
whos -file durer.mat
```

<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Bytes</th>
<th>Class</th>
<th>Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>648x509</td>
<td>2638656</td>
<td>double</td>
<td></td>
</tr>
<tr>
<td>caption</td>
<td>2x28</td>
<td>112</td>
<td>char</td>
<td></td>
</tr>
<tr>
<td>map</td>
<td>128x3</td>
<td>3072</td>
<td>double</td>
<td></td>
</tr>
</tbody>
</table>

The byte counts represent the number of bytes that the data occupies in memory when loaded into the MATLAB workspace. Because of compression, data encoding, and metadata, the space occupied in the file by a variable may be different from the in-memory size. MATLAB compresses data in Version 7 or higher MAT-files. For more information, see “MAT-File Versions”.

**See Also**

`load` | `save`

**More About**

- “MAT-File Versions”
- “Save and Load Parts of Variables in MAT-Files”
Workspace and Variable Preferences

Workspace Preferences

Workspace preferences enable you to configure options for saving workspace variables to MATLAB scripts. They also enable you to restrict the size of arrays on which MATLAB performs calculations, and to specify if you want those calculations to include or ignore NaNs.

To open Workspace preferences, on the Home tab, in the Environment section, click Preferences. Select MATLAB > Workspace. Workspace preferences are not available in MATLAB Online.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Threshold for saving variables to MATLAB script</strong></td>
<td>Specify <strong>Maximum array size</strong> to limit the number of elements of arrays saved to a MATLAB script.</td>
</tr>
<tr>
<td></td>
<td>Specify <strong>Maximum struct/object nesting levels</strong> to limit the nesting level of structures, arrays, or objects saved to a MATLAB script.</td>
</tr>
<tr>
<td>Preference</td>
<td>Usage</td>
</tr>
<tr>
<td>------------</td>
<td>-------</td>
</tr>
<tr>
<td><strong>Multidimensional array formatting</strong></td>
<td>Specify how multidimensional arrays are formatted when saved to a MATLAB script. To create a compact script, select <strong>Row vector with reshape (compactness and efficiency)</strong>. To retain array representation, select <strong>As 2-D pages (readability)</strong>. Specify the dimensions of a 2-D slice as positive integers less than or equal to the dimensions of the n-D array. The second integer must be greater than the first.</td>
</tr>
<tr>
<td><strong>File formatting</strong></td>
<td>Set the character width at which text in the MATLAB script is wrapped by specifying <strong>Maximum characters per line</strong>.</td>
</tr>
<tr>
<td><strong>n element and smaller arrays show statistics</strong></td>
<td>Limit the size of arrays for which the Workspace browser displays statistics to improve performance when MATLAB updates the statistical results in the Workspace browser. For more information, see “Improve Workspace Browser Performance During Statistical Calculations” on page 5-14.</td>
</tr>
<tr>
<td><strong>Handling NaN values in calculations</strong></td>
<td>Specify whether NaN values are included or excluded from calculations for the statistics displayed in the Workspace browser. You can select to either <strong>Use NaNs when calculating statistics</strong> or <strong>Ignore NaNs when calculating statistics</strong>.</td>
</tr>
</tbody>
</table>
### Preference

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>MATLAB array size limit</td>
<td>By default, MATLAB can use up to 100% of the size of RAM (not including virtual memory) of your computer to allocate memory for each MATLAB array. To change this limit to a smaller percentage, select the <strong>Limit the maximum array size to a percentage of RAM</strong> check box. Then move the slider to adjust the percentage of RAM. To allow MATLAB to use both RAM and virtual memory when creating an array, clear the <strong>Limit the maximum array size to a percentage of RAM</strong> check box. If MATLAB attempts to allocate memory that exceeds the resources available on the computer, your system might become nonresponsive. This limit applies to the size of each array, not the total size of all MATLAB arrays.</td>
</tr>
</tbody>
</table>

**Variables Preferences**

When working in the Variables editor, Variables preferences enable you to specify array formatting, cursor movement, and the decimal separator for exporting data using the system clipboard.

To open Variables preferences, on the **Home** tab, in the **Environment** section, click **Preferences**. Select **MATLAB > Variables**.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format</td>
<td>Select an option from the <strong>Default array format</strong> to specify the default array output format of numeric values displayed in the Variables editor. This format preference affects only how numbers display, not how MATLAB computes or saves them. For information on formatting options, see the reference page for the <strong>format</strong> function.</td>
</tr>
</tbody>
</table>
Preference | Usage
--- | ---
Editing | Specify where the cursor moves to after you type an element and press Enter.

To keep the cursor in the element where you typed, clear the **Move selection after Enter** check box.

To move the cursor to another element, select the **Move selection after Enter** check box. In the **Direction** field, specify how you want the cursor to move.

International number handling | In the **Decimal separator for exporting numeric data via system clipboard** field, specify the decimal separator for numbers you cut or copy from the Variables editor and then paste into text files or other applications.

This preference has no effect on numeric data copied from and pasted into MATLAB. Within MATLAB, decimal separators are always periods.

Most Variables preferences are not available in MATLAB Online. To show generated code in the Command Window when performing operations in the MATLAB Online Variables Editor, select **Show MATLAB code for operations**.

### See Also

### More About
- “Create and Edit Variables” on page 5-2
Managing Files in MATLAB

- “Find Files and Folders” on page 6-2
- “Compare Files and Folders and Merge Files” on page 6-6
- “Compare XML Files” on page 6-25
- “Manage Files and Folders” on page 6-32
- “Share Folders in MATLAB” on page 6-36
- “Files and Folders that MATLAB Accesses” on page 6-38
- “Current Folder Browser Preferences” on page 6-41
- “Specify File Names” on page 6-43
- “Create and Extract from Zip Archives” on page 6-47
- “What Is the MATLAB Search Path?” on page 6-50
- “Change Folders on the Search Path” on page 6-54
- “Use Search Path with Different MATLAB Installations” on page 6-57
- “Add Folders to the MATLAB Search Path at Startup” on page 6-58
- “Assign userpath as Startup Folder (Macintosh or UNIX)” on page 6-60
- “Path Unsuccessfully Set at Startup” on page 6-61
- “Errors When Updating Folders on Search Path” on page 6-63
- “Troubleshoot Invalid or Unresponsive Windows Change Notification Handles” on page 6-64
Find Files and Folders

<table>
<thead>
<tr>
<th>In this section...</th>
</tr>
</thead>
<tbody>
<tr>
<td>“Simple Search for File and Folder Names” on page 6-2</td>
</tr>
<tr>
<td>“Advanced Search for Files” on page 6-2</td>
</tr>
</tbody>
</table>

Simple Search for File and Folder Names

If you know the name of the file you want to find, begin typing the first characters of the name in the Current Folder browser. As you type, the Current Folder browser searches downward from the top of the window, looking through all expanded folders.

Alternatively, to find a series of characters anywhere in the name of a file:

1. Click the search button in the current folder toolbar. The address bar becomes a search field.
2. Type a portion of a file name. The asterisk character (*) is a wildcard. For example, to show only file names that begin with coll and have a .m extension, type coll*.m.
3. Press Enter.

MATLAB displays all files within the current folder (including its subfolders) that match that file name. If you typed the full path to a folder, that folder becomes the current folder.

4. Clear the results and show all items in the current folder by pressing the Esc key.

Tip: To open the Current Folder browser if it is not open, do the following: on the Home tab, in the Environment section, click Layout. Then, under Show, select Current Folder. Show and hide columns, or sort and group columns by clicking , and then selecting an option.

Advanced Search for Files

To conduct an advanced search for files, you can use the Find Files tool. Use the Find Files tool to:

- Search for specific text in file names and within files
- Include or exclude specified file types from your search
- Search in specified folders
- Exclude large files from your search

To open the Find Files tool, on the Home tab, in the File section, click Find Files. Enter your search criteria in the dialog box that opens.

Use the Look in menu to specify the folders you want to search. Select Entire MATLAB Path to search all folders on the MATLAB search path. Alternatively, you can browse for a folder by selecting Browse... or you can enter the full path for one or more folders. Separate each path with a semicolon (;).

Click Find to begin the search. Search results appear in the right pane of the dialog box, with a summary at the bottom. For text searches, results include the line number and line of code. To see file locations, select Show full path names.

Open one or more files by right-clicking the files and selecting one of the Open options.
Include or Exclude File Types

You can search for files with only a specified extension, by selecting an option in the Include only file type(s) menu. For example, select *.m, *.mlx to limit the search to MATLAB program files.

To exclude some file types from the search:

1. In the Include only file type(s) menu, select All files (*).
2. Under More options, select the Skip file type(s) box and click Edit. The Edit Skipped File Extensions dialog box opens.
3. Select the State check box for the file types to exclude from your search.
4. Click OK to accept your changes.

You can remove any file extension from the list by selecting the extension to highlight it. Then, click Remove.

Search Within File

Under More options, you can choose to search file contents for a partial word. From the Search type menu, select Contains text. To find an exact full-word match, select Matches whole word.

Searching within large files can be time consuming. To speed up your search, specify a file size in the Skip files over field. The Find Files tool ignores files larger than the size you specify.

Troubleshooting

If the Find Files tool does not find the file you want, try the following:

- When searching for file names, use the asterisk character (*) as a wildcard character to expand your search. For example, to show file names that begin with coll and have a .m extension, type coll*.m.
- Select the Include Subfolders check box if the file might be in a subfolder.
- If you select the Skip file type(s) check box, ensure that you do not exclude relevant file types from your search. Click Edit and review the Edit Skipped File Extensions dialog box. Ensure that relevant file types do not have the State check box selected.
See Also

dir | exist | what | which

More About

- “Find Functions to Use” on page 3-4
- “What Is the MATLAB Search Path?” on page 6-50
Compare Files and Folders and Merge Files

Compare Files and Folders

You can use the Comparison tool to display the differences between selected pairs of files or folders. For some file types, you also can merge changes from one file to the other.

The comparison process involves three steps:

1. Select the files or folders to compare.
2. Choose a comparison type.
3. Explore the comparison report.

Select the Files or Folders to Compare

You can select files and folders to compare using any of these methods:

- **Current Folder browser** — Select a file or folder, right-click, and select **Compare Against**. Browse to select a second item to compare, or drag and drop a file or folder from your file browser.

You also can select two files or subfolders, right-click, and select **Compare Selected Files/Folders**.

- **Editor or Live Editor** — Go to the **Editor** or **Live Editor** tab, and in the **File** section, click **Compare**. The Comparison tool autopopulates the first file for comparison with the current open file. Browse to select a second item to compare, or drag and drop a file or folder from your file browser.

- **MATLAB desktop** — Go to the **Home** tab, and in the **File** section, click **Compare**. Browse to select items to compare, or drag and drop the files or folders from your file browser.

- **Command Window** — Use the **visdiff** function. For example, to compare the two files `lengthofline.m` and `lengthofline2.m` using the **visdiff** function and the default text comparison, type `visdiff('lengthofline.m', 'lengthofline2.m')`. MATLAB opens the Comparison tool and displays the resulting comparison report.

In addition to selecting two files and folder, you also can compare a file with a past version of itself. To compare a file with the autosave version or the saved version on disk, click **Compare** and select **Compare with Version on Disk** or **Save and Compare**.
with Autosave. For more information, see “Compare Files with Autosave Version or Version on Disk” on page 6-15. These options are not available for live scripts or functions.

Choose a Comparison Type

The Comparison tool compares selected items using the default comparison type defined for the items. For some item types, you can select a different comparison type from the default. For example, you can choose from a text, binary, file list, or XML comparison. To change the comparison type, select the files or folders to compare and then select from the options in the Comparison type menu. The Comparison tool only displays the valid options for the selected item types.

You cannot change the comparison type for an existing comparison report. To change the comparison type, start a new comparison.

If you specify two files or folders to compare using either the Current Folder browser or the visdiff function, then the Comparison tool automatically performs the default comparison type. For example, from the Current Folder browser, if you select two MAT-files to compare, you get the default comparison type showing information about the variables. To change the comparison type to binary, create a new comparison using the Comparison tool.

Explore the Comparison Report

You can explore the comparison report in different ways depending on the items being compared:
• **Folders, zip files, and Simulink manifests** — Compare any combination of folders, zip files, or Simulink manifests to determine which file and folder names are unique to each list. You also can identify whether files and folders with the same name have the same content. For more information, see “Compare Folders, Zip Files, and Simulink Manifests” on page 6-8.

• **Text** — Compare and merge lines in two text files (some other applications refer to this as a file diff operation). For more information, see “Compare and Merge Text” on page 6-11.

• **Live Code** — Compare and merge code and text lines in two live code files. For more information, see “Compare and Merge Live Code” on page 6-15.

• **MAT-files** — Compare and merge variables in two MAT-files. For more information, see “Compare and Merge MAT-Files” on page 6-19.

• **Binary files** — Determine whether the contents of two binary files match. For more information, see “Compare Binary Files” on page 6-22.

• **XML files** — Compare XML files with a text comparison or a hierarchical XML comparison. For more information, see “Compare XML Files” on page 6-25.

• **Simulink models** — If you have Simulink, compare and merge Simulink models. For information, see “Model Comparison” (Simulink).

### Compare Folders, Zip Files, and Simulink Manifests

You can perform file list comparisons for any combinations of folders, zip files, and Simulink Manifests. For example, you can compare the contents of a folder to the contents of a zip file.

Create a folder comparison report to:

• Identify common files.
• Determine whether files or folders with identical names have identical content. If such files or folders exist, you can open a detailed comparison report for the items directly from the report.

### Select Files or Folders to Compare

To select items to compare, see “Select the Files or Folders to Compare” on page 6-6. When selecting items to compare, include subfolder content in the comparison report by selecting **Include subfolders**.
Explore Differences

When you perform any file list comparison, a new window opens and displays the contents of the specified lists side by side. This image shows an example comparison report for a two folder comparison.

The Comparison tool highlights files and subfolders that do not match as described in this table.

<table>
<thead>
<tr>
<th>Difference Summary</th>
<th>Highlight Color</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents changed</td>
<td>Purple</td>
<td>The contents of the files or folders differ. Click the compare link to investigate.</td>
</tr>
</tbody>
</table>
### Difference Summary

<table>
<thead>
<tr>
<th>Added</th>
<th>Blue</th>
<th>The file or folder only exists in the right list.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Removed</td>
<td>Yellow</td>
<td>The file or folder only exists in the left list.</td>
</tr>
<tr>
<td>Identical</td>
<td>None</td>
<td>The files or folders are identical.</td>
</tr>
</tbody>
</table>

You further can explore the results using several methods:

- To sort the results by name, type, size, or last modified timestamp, click the corresponding column header. For example, click the Type column header to sort by folder and file type.
- To open a detailed comparison report for items with differing content, click the compare link next to the item.
- To open a file in the Editor, click the open link next to a file name. If the file is present in both folders, you can click links to open the left or right version of the file.
- If subfolders are very large and contain many files, analysis continues in the background. The tool displays the number of items still to be compared at the top of the report. You can click Skip Current to skip the current item or Cancel All to stop further analysis.

For information about how to further configure the comparison report, see “Comparison Report Tools and Options” on page 6-23.

### Filter the Report

To save time when reviewing differences, especially when comparing many subfolders, you can filter the report. To create a filter, go to the View tab, click the Filter button, and then select Add/Remove Filter. You can specify filters to ignore certain files and folders, such as backup files or files created by a revision control system.

For example, to ignore all files and folders in a folder named CVS, type CVS/. To ignore all files in a folder named CVS, but not ignore subfolders, type CVS/*.
To edit existing filters, double click the filter.

**Compare and Merge Text**

You can compare and merge lines in two text files using the Comparison tool.

**Select Files or Folders to Compare**

To select the files to compare, see “Select the Files or Folders to Compare” on page 6-6. By default, XML files are compared using a text comparison. To compare XML files with a hierarchical comparison instead, see “Compare XML Files” on page 6-25.

When you perform a text comparison, a new window opens and displays the two files side by side. Symbols in between the two displayed files indicate how you can adjust the files to make them match. For example, run this code to view a text comparison of the example files lengthofline.m and lengthofline2.m.

```matlab
file1 = fullfile(matlabroot,'help','techdoc','matlab_env','examples','lengthofline.m')
file2 = fullfile(matlabroot,'help','techdoc','matlab_env','examples','lengthofline2.m')
visdiff(file1,file2)
```

The Comparison tool displays the resulting report.
Explore Differences

The Comparison tool highlights the lines that have changed as described in this table.

<table>
<thead>
<tr>
<th>Highlight Color</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Purple</td>
<td>The content of the lines differs between the two files. The Comparison tool displays an $\times$ between the two lines.</td>
</tr>
<tr>
<td>Dark Purple</td>
<td>Highlighted characters are different between the two lines.</td>
</tr>
<tr>
<td>Blue</td>
<td>Line exists only in right file. The Comparison tool displays a $&gt;$ between the two lines.</td>
</tr>
<tr>
<td>Yellow</td>
<td>Line exists only in left file. The Comparison tool displays a $&lt;$ between the two lines.</td>
</tr>
</tbody>
</table>

The Comparison tool attempts to match lines and detects text that is added, deleted, or changed. It does not do a simple line-by-line comparison. For example, in the text
comparison of `lengthofline.m` and `lengthofline2.m`, the tool determines that `lengthofline2.m` has a line of code that does not exist in `lengthofline.m` and highlights it (line 23) in blue. Also, notice that the tool takes the additional line into account and determines that the line containing the `end` statement in each file matches, even though the `end` statement does not occur on the same line number.

If the files you are comparing are extremely long, the tool could run out of memory while attempting to perform the file comparison. If it does, it displays this message:

```
Maximum file length exceeded.
Defaulting to line-by-line comparison.
```

When this occurs, the Comparison tool switches to a line-by-line comparison. In a line-by-line comparison, the tool highlights the lines containing the `end` statement because in performing this operation, it finds that the last line in one file does not match the last line in the other file.

You further can explore and configure the results using several methods:

- **View a summary of differences** — To view a summary of differences between two text files, including the number of matching lines and the number of unmatched lines in each file, scroll to the bottom of the comparison report.

- **Ignore whitespace differences** — To help distinguish between functional changes and changes to indentation, you can hide whitespace differences. To hide differences that only involve white-space characters, go to the **View** tab, click the **Filter** button, and select **Ignore White Space**.

- **Show differences only** — To specify whether to show only differences or the entire files, go to the **View** tab, click the **Filter** button, and select or clear **Show Differences Only**. Showing differences only is especially useful in large text comparison reports. When you are showing differences only and some lines are hidden, the report displays a message indicating the number of lines hidden. For example, if 10 lines are hidden, the report displays `10 unmodified lines hidden`.

- **Change the display width** — To increase or decrease the line lengths of the text files in the comparison display, go to the **View** tab, and in the **Display** section, change the **Column Width**. Resize the window if necessary.

- **Save HTML Report** — To save a copy of the comparison report as an HTML file, go to the **Comparison** tab, and in the **Comparison** section, click **Save As > HTML**.
Step Through Differences

If a text file is lengthy, use the ← and → buttons to step through the results one difference at a time. Once the last difference has been reached, clicking the → button loops back to the first difference in the files. Similarly, if the first difference is selected and the ← button is clicked, the Comparison tool loops to the last difference in the files.

Merge Differences

When comparing text files you can merge changes from one file to the other. Merging changes can be useful when resolving conflicts between different versions of files.

Tip You can only merge from left to right. If you want to merge into the left file, use Swap Sides before you start merging. Swap Sides revert any merges already made and creates a new comparison report for the original files.

To merge a difference from the left file to the right file, select the difference in the report and on the Comparison tab, click the Merge button. The Comparison tool highlights merged lines in gray and displays a green merge arrow.

The merged file name at the top of the report indicates that the file contains unsaved changes (filename.m*).

To revert the last merge operation, on the Comparison tab, click Undo. Click Redo to reapply a merge. To revert all merges and start again, click Refresh.

To save your changes, click Save Merged File. To save to a different name, select Save Merged File > Save Merged File As.

To view the files in the Editor, click a line number link in the report.

Tip Save your merge changes from the comparison report before making any changes in the Editor; otherwise the comparison report can become incorrect. The report does not update to reflect changes you make in the Editor.
Compare Files with Autosave Version or Version on Disk

You can choose to compare a file open in the Editor with an autosaved or saved version of the file.

To compare the latest version of a file with the Editor's backup copy, first open the file in the Editor. Then, go to the Editor tab, click Compare, and select **Save and Compare with Autosave**. If your file is modified, the Editor saves the file before comparing. For more information, see “Backing Up Files”.

To compare an open file that has unsaved changes to the saved version, go to the Editor tab, click Compare, and select **Compare with Version on Disk**.

Compare and Merge Live Code

Create Live Code Comparison Report

You can compare and merge lines in two live code files using the Comparison tool. To select the files to compare, see “Select the Files or Folders to Compare” on page 6-6.

When you perform a live code comparison, a new window opens and displays the two files side by side. For example, suppose you have two files *averageweight.mlx* and *averageweight2.mlx* with several differences. When you compare the two files, the Comparison tool displays the resulting report.
Explore Differences

The Comparison tool displays the total number of differences in the bottom right corner of the comparison report, and highlights the lines that do not match as described in this table.

<table>
<thead>
<tr>
<th>Highlight Color</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Purple</td>
<td>The content of the lines differs between the two files.</td>
</tr>
<tr>
<td>Dark Purple</td>
<td>Highlighted characters are different between the two files.</td>
</tr>
<tr>
<td>Highlight Color</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Blue</td>
<td>Line exists only in right file (insertion in right file). The corresponding line in the left file is highlighted using a gray striped pattern.</td>
</tr>
<tr>
<td>Yellow</td>
<td>Line exists only in left file (deletion in right file). The corresponding line in the right file is highlighted using a gray striped pattern.</td>
</tr>
</tbody>
</table>

When comparing live code files, the Comparison tool detects differences in code, text, and text formatting. The Comparison tool ignores output, even if the file contains saved output. If the tool detects a difference within an equation, image, or control, the entire item is highlighted.

The Comparison tool attempts to match lines and detects code and text that is added, deleted, or changed. It does not do a simple line-by-line comparison. For example, in the live code comparison of `averageweight.mlx` and `averageweight2.mlx`, the tool determines that `averageweight.mlx` has two lines of code that do not exist in `averageweight2.mlx` and highlights them (line 5 and line 7) in yellow. Also, notice that the tool takes the additional lines into account and determines that the line containing the `disp` statement in each file matches, even though the `disp` statement does not occur on the same line number.

If a live code file is lengthy, use the **Next** and **Previous** buttons to step through the results one difference at a time.

**Merge Differences**

When comparing live code files, you can merge changes from one file to the other. Merging changes can be useful when resolving conflicts between different versions of files. You only can merge from left to right. If you want to merge into the left file, click the **Swap Sides** button before you start merging. Clicking the **Swap Sides** button reverts any merges already made and creates a new comparison report for the original files.

To begin merging, on the **Comparison** tab, click the **Merge Mode** button. Then, to replace content from the right pane with content from the left pane, click the **button**
located next to the line you want to merge. You also can select a difference and in the **Merge** tab, click the **Replace Content** button.

The right pane contains the merged result. An asterisk next to the merged file name in the right pane (*filename_modified.mlx*) indicates that the file contains unsaved changes.

To undo a replacement, click the **button between the modified lines or on the Comparison tab. To revert all merges and start again, click the **button. You also can click the **button to update the comparison report after making changes to and saving the files in the Live Editor. Refreshing discards all merged changes.
To save your changes and return to the comparison report, click the **Save Result** button. To return to the comparison report without saving changes, click the **Return to Comparison** button.

**Compare and Merge MAT-Files**

**Create MAT-File Comparison Report**

You can use the Comparison tool to compare two MAT-files. Compare two MAT-files to:

- Determine which variables are common to each file and which are unique.
- Identify differences between individual variables. For example, you can determine which fields of a structure are different, or which elements of an array differ.

To select items to compare, see “Select the Files or Folders to Compare” on page 6-6.

When you perform a MAT-file comparison, a new window opens and displays the two files side by side. For example, supposed you have two MAT-files, data1.mat and data2.mat. When you compare the two files, the Comparison tool displays the resulting report.
### Explore Differences

The Comparison tool report highlights changes in variables as described in this table.

<table>
<thead>
<tr>
<th>Variables in data1.mat</th>
<th>Variables in data2.mat</th>
<th>Difference Summary</th>
<th>Merge (no undo)</th>
</tr>
</thead>
<tbody>
<tr>
<td>a 1x2 cell (not in this file)</td>
<td>b 1x5 char Added</td>
<td></td>
<td></td>
</tr>
<tr>
<td>b 6x1 uint32</td>
<td>p 6x1 uint32 Equivalent</td>
<td></td>
<td></td>
</tr>
<tr>
<td>q 6x1 uint32</td>
<td>q 6x1 uint32 Equivalent</td>
<td></td>
<td></td>
</tr>
<tr>
<td>x 1x1 double</td>
<td>x 1x1 double Equivalent</td>
<td></td>
<td></td>
</tr>
<tr>
<td>y 1x2 double</td>
<td>y 1x3 double Modified(compare)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>z 2x2x2 double</td>
<td>z 2x2x2 int32 Class changed(compare)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Load C:\Work\comparisons\data1.mat
Load C:\Work\comparisons\data2.mat
<table>
<thead>
<tr>
<th>Difference Summary</th>
<th>Highlighting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modified</td>
<td>Purple</td>
<td>Values of the variable differ between the two files. Click the compare link to investigate. For more information, see “Compare Variables” on page 6-21.</td>
</tr>
<tr>
<td>Added</td>
<td>Blue</td>
<td>The variable only exists in the right file.</td>
</tr>
<tr>
<td>Removed</td>
<td>Yellow</td>
<td>The variable only exists in the left file.</td>
</tr>
<tr>
<td>Equivalent</td>
<td>None</td>
<td>The variables in both files are equivalent. The tool ignores differences in NaN patterns, field ordering in structs, and the difference between negative zero or positive zero.</td>
</tr>
<tr>
<td>Class changed</td>
<td>Purple (only in Class columns)</td>
<td>The variable data class changed. Click the compare link to investigate.</td>
</tr>
</tbody>
</table>

The report displays a message if the variables in both files are equivalent but the files are not identical. Possible causes of the differences between the files include file formats, file timestamps, the order in which the variables are stored, or variables that contain ignored differences.

You can further explore the results in the report using several methods:

- **Sort results** — To sort the results by name, size, class, or difference summary, click the corresponding column header. For example, click the Class column header to sort by class type.
- **Load variable** — To load the contents of a variable into the Variable Editor, click the name of that variable.
- **Load MAT-file** — To load one of the MAT-files into the workspace, click the corresponding Load link at the bottom of the report.
- **Save HTML report** — To save a copy of the report as an HTML file, go to the Comparison tab and click Save As > HTML.

For information about how to further configure the comparison report, see “Comparison Report Tools and Options” on page 6-23.

**Compare Variables**

The variable comparison report displays differences in individual array elements or fields of a structure. To investigate individual differences, double-click a highlighted row.
Merge Differences

When comparing MAT-files, you can merge changes from one file to the other. There are no undo capabilities when merging MAT-files, so merge with caution.

To copy modified variables from one file to the other, on the Comparison tab, in the Merge section, click the Merge button.

Compare Binary Files

Create Binary Comparison Report

You can compare two binary files such as DLL files or MEX-files using the Comparison tool. To select the files to compare, see “Select the Files or Folders to Compare” on page 6-6.

You also can perform a binary comparison on any two selected files, instead of the default comparison. To compare any two files using a binary comparison, set the Comparison type to Binary comparison. For more information, see “Compare Binary Files” on page 6-22.
When you perform a binary comparison, a new window opens and indicates whether the two files are identical or different. If the files are different, click the Show Details link to view the binary files and the byte offset of the first difference.

**Comparison Report Tools and Options**

You can further explore and configure a comparison report using the available tools and options.

- **Exchange the Left and Right Sides of the Report** — To switch the left side file or folder with the right side file or folder, go to the Comparison tab and click the Swap Sides button.

- **Refresh the Report to Show Updated File** — After making changes to and saving the files in the Editor, to update the results in the Comparison tool, go to the Comparison tab and click the Refresh button.

- **Find Text** — To find a phrase in the current display, go to the Comparison tab and click the Find button. For more information, see “Find Text in Command Window or History” on page 3-12.

- **Change Color Preferences** — To change and save the color preferences for the Comparison tool:

  1. On the MATLAB Home tab, click Preferences and select MATLAB > Comparison.
  2. Select the desired colors for differences, modified lines, modified contents, and merged lines. If you change a color preference, Active Settings displays Default (modified).
  3. Click Apply and refresh the comparison report to see the updated colors reflected in the report.
  4. To save the modified color preferences for use in future MATLAB sessions, click Save As. Enter a name for your color settings profile and click OK.

     After saving a color settings profile, you can select the profile in the Active Settings list.

  5. To restore the default settings, click Reset and then click Apply. Refresh the comparison report.

Color preferences apply to all comparison types.
**Source Control**

You can customize external source control tools to use the MATLAB Comparison tool for comparing and merging files and folders. For more information, see “Customize External Source Control to Use MATLAB for Diff and Merge”.

**See Also**

visdiff

**Related Examples**

- “Model Comparison” (Simulink)
Compare XML Files

You can use the Comparison tool to compare a pair of XML text files. The tool processes the results into a report that you can use to explore the file differences. You can compare XML files with a text comparison or a hierarchical XML comparison.

You can access the XML comparison tool from the Current Folder browser, the Comparison Tool, or programmatically using the `visdiff` function.

The XML comparison compares the files using the “Chawathe” algorithm, as described in this paper:


XML comparison reports display in the Comparison Tool. For more information about the Comparison Tool, see “Compare Files and Folders and Merge Files” on page 6-6.

The XML comparison report shows a hierarchical view of the portions of the two XML files that differ. The report does not show sections of the files that are identical.

If the files are identical, you see a message reporting there are no differences.

**Note** It might not be possible for the analysis to detect matches between previously corresponding sections of files that have diverged too much.
Change detection in the Chawathe analysis is based on a scoring algorithm. Items match if their Chawathe score is above a threshold. The implementation of Chawathe's algorithm uses a comparison pattern that defines the thresholds.

**Choose XML Files to Compare**

**From the Current Folder Browser**

To compare two files from the Current Folder browser:

- For two files in the same folder, select the files, right-click and select **Compare Selected Files/Folders**.
- To compare files in different folders:
  1. Select a file, right-click, and select **Compare Against**
  2. Select the second file to compare in the Select Files or Folders for Comparison dialog box.
  3. Select the **Comparison type XML text comparison**.
  4. Click **Compare**.

The XML comparison tool performs a Chawathe analysis on the files and displays a report in the Comparison Tool. The file you right-click to open the XML comparison tool displays on the right side of the report.

For more information about comparisons of other file types with the Comparison Tool, such as text, MAT, or binary, see “Compare Files and Folders and Merge Files” on page 6-6.

**Compare from the Comparison Tool**

To compare files using the Comparison Tool, from the MATLAB toolstrip, in the **File** section, select the **Compare** button. In the dialog box, select files to compare.

If the files you select to compare are XML files and you select an **XML text comparison**, the XML comparison tool performs a Chawathe analysis of the XML files, and generates a report.

**Compare from the Command Line**

To compare XML files from the command line, enter
visdiff(filename1, filename2, 'xml')

where filename1 and filename2 are XML files.

**Change Comparison Type**

If you specify two XML files to compare using either the Current Folder Browser or the `visdiff` function, then the Comparison Tool performs the default comparison type for the selected files. You can compare XML files with a text comparison or a hierarchical XML comparison.

To change comparison type, either create a new comparison from the Comparison Tool, or use the **Compare Against** option from the Current Folder browser. You can change comparison type in the Select Files or Folders for Comparison dialog box. Select XML text comparison before clicking **Compare**.

**Navigate the XML Comparison Report**

The XML comparison report shows changes only. The report is a hierarchical view of the differences between two XML text files, and is not a hierarchical view of the original XML data.

To *step through differences*, use the **Comparison** tab on the toolstrip. To move to the next or previous group of differences, on the **Comparison** tab, in the **Navigate** section, click the arrow buttons to go to the previous or next difference.

You can also click to select items in the hierarchical trees.

- Selected items appear highlighted in a box.
- If the selected item is part of a matched pair, it is highlighted in a box in both left and right trees.

Report item highlighting indicates the nature of each difference as follows:
<table>
<thead>
<tr>
<th>Type of Report Item</th>
<th>Highlighting</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modified</td>
<td>Pink</td>
<td>Modified items are matched pairs that differ between the two files. When you select a modified item, it is highlighted in a box in both trees. Changed parameters for the selected pair are displayed underneath. If the text is too long to display, select <strong>Compare</strong> to open a new comparison of the parameters.</td>
</tr>
<tr>
<td>Unmatched</td>
<td>Green</td>
<td>When you select an unmatched item, it is highlighted in a box in one tree only.</td>
</tr>
<tr>
<td>Container</td>
<td>None</td>
<td>Rows with no highlighting indicate a container item that contains other modified or unmatched items.</td>
</tr>
</tbody>
</table>

Use the **Comparison** tab for the following functions:

- **Refresh** — Run Chawathe analysis again to refresh the comparison report.
- **Swap Sides** — Swap sides and rerun comparison. Runs the Chawathe analysis again.
- **Save As > HTML** — Opens the Save dialog box, where you can choose to save a printable version of the XML comparison report. The report is a noninteractive HTML document of the differences detected by the Chawathe algorithm for printing or archiving a record of the comparison.
- **Save As > Workspace Variable** — Export XML comparison results to workspace.
- In the **Navigate** section, click the arrow buttons (or press Up or Down keys) to go to the previous difference or go to the next difference.
- **Compare Selected Parameter** — Open a new report for the currently selected pair of parameters. Use this when the report cannot display all the details in the Parameters pane, e.g., long character vectors or a script.

Use the **View** tab controls on the toolstrip for the following functions:

- **Expand All** — Expands every item in the tree.

  **Tip** Right-click to expand or collapse the hierarchy within the selected tree node.

- **Collapse All** — Collapses all items in the tree to the most compact view possible.

  **Note** It may not be possible for the analysis to detect matches between previously corresponding sections of files that have diverged too much.
Save Comparison Log Files in a Zip File

Temporary XML comparison files accumulate in `tempdir/MatlabComparisons/XMLComparisons/TempDirs/`. These temporary files are deleted when you close the related comparison report.

You can zip the temporary files (such as log files) created during XML comparisons, for sharing or archiving. While the comparison report is open, enter:

```
xmlcomp.zipTempFiles('c:\work\myexportfolder')
```

The destination folder must exist. The output reports the zip file name:

```
Created the zipfile "c:\work\myexportfolder\20080915T065514w.zip"
```

To view the log file for the last comparison in the MATLAB Editor, enter:

```
xmlcomp.showLogFile
```

Export Results to the Workspace

To export the XML comparison results to the MATLAB base workspace,

1. On the Comparison tab, in the Comparison section, select Save As > Workspace variable.

   The Input Variable Name dialog box appears.

2. Specify a name for the export object in the dialog box and click OK. This action exports the results of the XML comparison to an `xmlcomp.Edits` object in the workspace.

   The `xmlcomp.Edits` object contains information about the XML comparison including file names, filters applied, and hierarchical nodes that differ between the two XML files.

To create an `xmlcomp.Edits` object at the command line without opening the Comparison Tool, enter:

```
Edits = xmlcomp.compare(a.xml,b.xml)
```
<table>
<thead>
<tr>
<th><strong>Property of xmlcomp.Edits</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Filters</td>
<td>Array of filter structure arrays. Each structure has two fields, Name and Value.</td>
</tr>
<tr>
<td>LeftFileName</td>
<td>File name of left file exported to XML.</td>
</tr>
<tr>
<td>LeftRoot</td>
<td>xmlcomp.Node object that references the root of the left tree.</td>
</tr>
<tr>
<td>RightFileName</td>
<td>File name of right file exported to XML.</td>
</tr>
<tr>
<td>RightRoot</td>
<td>xmlcomp.Node object that references the root of the right tree.</td>
</tr>
<tr>
<td>TimeSaved</td>
<td>Time when results exported to the workspace.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Property of xmlcomp.Node</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Children</td>
<td>Array of xmlcomp.Node references to child nodes, if any.</td>
</tr>
<tr>
<td>Edited</td>
<td>Boolean — If Edited = true then the node is either inserted (green) or part of a modified matched pair (pink).</td>
</tr>
<tr>
<td>Name</td>
<td>Name of node.</td>
</tr>
<tr>
<td>Parameters</td>
<td>Array of parameter structure arrays. Each structure has two fields, Name and Value.</td>
</tr>
<tr>
<td>Parent</td>
<td>xmlcomp.Node reference to parent node, if any.</td>
</tr>
<tr>
<td>Partner</td>
<td>If matched, Partner is an xmlcomp.Node reference to the matched partner node in the other tree. Otherwise empty[].</td>
</tr>
</tbody>
</table>
See Also

Related Examples
  • “Compare Files and Folders and Merge Files” on page 6-6
Manage Files and Folders

This table shows how to create, open, move, and rename files and folders on local and network drives. If you have MATLAB Drive Connector installed on your system, you also can access files and folders in MATLAB Drive from MATLAB.

<table>
<thead>
<tr>
<th>Action</th>
<th>Tools Workflow</th>
<th>Function Alternative</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a new folder</td>
<td>In the Current Folder browser, right-click in white space, and then select New &gt; Folder. MATLAB creates and selects a folder named New Folder in the current folder.</td>
<td>Use the mkdir function. For example, create a subfolder named newdir in a parent folder named parentFolder: mkdir('parentFolder','newdir');</td>
</tr>
<tr>
<td>Move a file or folder</td>
<td>In the Current Folder browser, click and drag the item. You cannot move a folder while it is on the search path.</td>
<td>Use the movefile function. For example, move the file named myfile.m in the current folder to the folder, d:/work: movefile('myfile.m','d:/work');</td>
</tr>
<tr>
<td>Rename a file or folder</td>
<td>In the Current Folder browser, right-click the item and select Rename. File names must start with a letter, and can contain letters, digits, or underscores.</td>
<td>Use the movefile function. For example, in the current folder, rename myfile.m to oldfile.m: movefile('myfile.m','oldfile.m');</td>
</tr>
<tr>
<td>Action</td>
<td>Tools Workflow</td>
<td>Function Alternative</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>-------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Open a file in MATLAB</td>
<td>On the <strong>Home</strong> tab, in the <strong>File</strong> section, click <strong>Open</strong> 📋, and then select a file to open.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>You also can double-click the file in the Current Folder browser.</td>
<td>Use the open function. The file opens in MATLAB or in an external application, depending on the file extension.</td>
</tr>
<tr>
<td></td>
<td>To open a file in the Editor as a text file, even if the file type is associated with another application or tool right-click the file in the Current Folder browser and select <strong>Open as Text</strong>.</td>
<td></td>
</tr>
<tr>
<td>Open a file in another program</td>
<td>In the Current Folder browser, right-click the file and select <strong>Open Outside MATLAB</strong>. The file opens in the application or tool that the operating system associates with the file type.</td>
<td></td>
</tr>
<tr>
<td>Preview file contents without opening the file</td>
<td>In the Current Folder browser, right-click the file and select <strong>Show Details</strong>. The Details Panel expands.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Not supported for live scripts and functions.</td>
<td>none</td>
</tr>
<tr>
<td>Action</td>
<td>Tools Workflow</td>
<td>Function Alternative</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Delete a file or folder</td>
<td>In the Current Folder browser, select the file or folder and press <strong>Delete</strong>.</td>
<td>To delete a file, use the <code>delete</code> function. For example, delete a file named <code>myfile.m</code> in the current folder: <code>delete('myfile.m');</code></td>
</tr>
<tr>
<td></td>
<td>By default, MATLAB deletes or recycles files and folders according to your operating system preferences. To permanently remove the selection when the system preference is set to recycle, press <strong>Shift+Delete</strong>.</td>
<td>By default, files are permanently removed. To move deleted files to a temporary folder instead, use the <code>recycle</code> function or set the <strong>Deleting files</strong> preference.</td>
</tr>
<tr>
<td></td>
<td>On Linux systems, you can request that MATLAB move deleted files to a temporary folder by setting the <strong>Deleting files</strong> preference. Access this preference on the <strong>Home</strong> tab, in the <strong>Environment</strong> section, by clicking <code>Preferences</code>. Select <strong>MATLAB &gt; General</strong>.</td>
<td>To delete a folder, use the <code>rmdir</code> function.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> You cannot recover folders deleted using <code>rmdir</code>.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Action</th>
<th>Tools Workflow</th>
<th>Function Alternative</th>
</tr>
</thead>
<tbody>
<tr>
<td>View MATLAB Drive recent activity</td>
<td>In the Current Folder browser, right-click any MATLAB Drive file or folder and select <strong>MATLAB Drive &gt; View Recent Activity</strong>....</td>
<td>none</td>
</tr>
</tbody>
</table>

| Open MATLAB Drive online | In the Current Folder browser, right-click any MATLAB Drive file or folder and select **MATLAB Drive > Go to MATLAB Drive Online**.... | none |

To open the Current Folder browser if it is not visible, go to the **Home** tab, and in the **Environment** section, click **Layout**. Then, under **Show**, select **Current Folder**. Double-clicking a subfolder displays its contents, and makes that folder the current folder.

To add a quick access button to the toolbar, right-click the toolbar and select **Customize**.... MATLAB opens the MATLAB Toolbar Preferences panel. In the **Controls** section, select from the available options and click **OK**. For example, if you have MATLAB **6-34**
Drive Connector installed, you can add a MATLAB Drive quick access button. To do so, in the MATLAB Toolbar Preferences panel, select the **Go to MATLAB Drive** option and click **OK**. MATLAB adds the button to the toolbar.

**Manage Files and Folders in MATLAB Online**

MATLAB Online provides access to MATLAB from a standard web browser. In MATLAB Online, you only have access to the files and folders in your MATLAB Drive, and some file actions are not available, such as previewing file contents in the Details panel. A special purpose folder named **Published** stores the paths to your published program files and results. This folder is publicly available to others on the web.

To transfer a file from MATLAB Online to the local system, select the file and on the **Home** tab, select **Download**.

**See Also**
delete | edit | mkdir | movefile | open | recycle | rmdir

**More About**
- “Share Folders in MATLAB” on page 6-36
- “Save and Load Workspace Variables” on page 5-16
- “Run Functions in the Editor”
- “Errors When Updating Folders on Search Path” on page 6-63
Share Folders in MATLAB

Starting in R2019b, if you want other people to be able to view or edit your files, you can share the folder in MATLAB and control the file permissions. You can share a folder by inviting individual members to have access to the folder or by sharing a link to the folder.

To share a folder from MATLAB, MATLAB Drive Connector must be running and the folder you choose to share must be in your MATLAB Drive. If you are working in MATLAB Online, you do not need MATLAB Drive Connector to share folders since sharing is always enabled.

For more information about sharing with MATLAB Drive, including limitations, see the MATLAB Drive documentation.

Share a Folder

To share a folder by invitation, in the Current Folder browser, right-click the folder and select Share > Manage Members. You can select to share with view-only or can-edit permission for each person individually. To enter several addresses at one time, use a semi-colon or comma separator. You can only do this if they all have the same access level.

People you invite to a shared folder in this way will receive an email invitation. They must accept the invitation to have access to the shared folder. When inviting individual participants, you can make changes to each member’s access at any time after the initial invite.

To share a folder with a view-only link, in the Current Folder browser, right-click the folder and select Share > Manage Link. Click Copy Link to copy the link to the clipboard.

In MATLAB Online, to share a folder that you have not shared before by invitation, right-click the folder and select Share > Invite Members. To share a folder by link, right-click the folder and select Share > Create Link.

Remove Access to Shared Folder

You can rescind invitations to a shared folder when you no longer want the content to be shared. To rescind an invitation, right-click the shared folder and select Share > Manage Members. Click the X next to each member name to delete shared access.
access of invited members does not change access for people who joined using a shared link.

To remove access to a shared folder from a view-only link, right-click the folder and select **Share > Manage Link**. Then, click **Delete Link**.

People who joined using the link will no longer have access to the shared folder, and anyone who then clicks the link gets an error. Deleting the link does not cause any change in access by members who received personal invitations.

**Access Folders Share with You**

When you are personally invited to a shared folder, you will receive an email invitation. After you accept the invitation, you can view the shared folder in the Current Folder browser.

When you are provided with a link to a shared folder, click the link and an invitation shows up in MATLAB Drive online. When you accept the invitation, the shared folder appears in the Current Folder browser.

**See Also**

**More About**

- “Manage Files and Folders” on page 6-32
- “Restore Files in MATLAB Online” on page 10-2
Files and Folders that MATLAB Accesses

In this section...

“Where Does MATLAB Look for Files?” on page 6-38
“Files and Folders You Should Add to the Search Path” on page 6-38
“When Multiple Files Have the Same Name” on page 6-39
“Locations of MathWorks Products” on page 6-39

Where Does MATLAB Look for Files?

When you do not specify a path to a file, MATLAB looks for the file in the current folder or on the search path. Functions in the current folder take precedence over functions with the same file name that reside anywhere on the search path. To identify the current folder, type `pwd` in the Command Window.

To make files accessible to MATLAB, do one of the following:

- Change the current folder to the folder that contains the files. Use the `cd` function or browse to a different folder in the current folder toolbar:

![Directory Browser](image)

- Add the folder that contains the files to the search path. Changes you make to the search path apply to the current MATLAB session. To reuse the modified search path in future MATLAB sessions, save your changes.

- Store individual files in the `userpath` MATLAB folder, which is on the search path. To determine the location of this folder, run the `userpath` function.

Files and Folders You Should Add to the Search Path

The MATLAB search path should include:

- Folders containing files that you run.
- Folders containing files that are called by files you run.
- Subfolders containing files that you run. Making a folder accessible does not make its subfolders accessible.
For files in @ (class) and + (package) folders, make the parent folder accessible. For details, see “Folders Containing Class Definitions”.

If files call other files that are in multiple folders, determine the location of all the called files by creating a Dependency Report. See “Dependencies Within a Folder”

**When Multiple Files Have the Same Name**

Name conflicts arise when MATLAB has access to multiple files with the same name, and when a file has the same name as a variable in the base workspace or a built-in function for a MathWorks product.

When there are name conflicts, MATLAB follows these precedence rules:

- “Function Precedence Order”
- “Class Precedence and MATLAB Path”

The file that MATLAB does not use is called a shadowed file. In some cases, MATLAB warns you that a shadowed file exists.

**Locations of MathWorks Products**

Files and folders for products provided by MathWorks are in `matlabroot/toolbox`. The files and folders under `matlabroot` are important to your installation. In particular:

- Do not store your personal files and folders in `matlabroot/toolbox`.
- Do not change files, folders, and subfolders in `matlabroot/toolbox`. The exception is the `pathdef.m` file, which you can update and save in its default location, `matlabroot/toolbox/local`.

To see a list of all toolbox folder names supplied with MathWorks products, run:

```
dir(fullfile(matlabroot,'toolbox'))
```

**See Also**

`cd` | `pwd` | `userpath`
More About

- “What Is the MATLAB Search Path?” on page 6-50
- “MATLAB Startup Folder” on page 1-20
- “Toolbox Path Caching in MATLAB” on page 1-28
Current Folder Browser Preferences

You can specify the number of files that display in the Current Folder browser, and customize their appearance.

On the Home tab, in the Environment section, click Preferences. Then, select MATLAB > Current Folder.

Some Current Folder Browser preferences are not available in MATLAB Online.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>History</strong></td>
<td>Specify the number of recently used folders maintained in the Current Folder toolbar drop-down list.</td>
</tr>
</tbody>
</table>
| **Refresh** | Specify how frequently the Current Folder browser updates to reflect changes to files made from programs and tools other than MATLAB.  
When you access files on a network, frequent refreshing of the Current Folder browser can slow performance in MATLAB. If this seems to be a problem, try increasing the value for Number of seconds between auto-refresh. Alternatively, clear the Auto-refresh view from file system selection to disable automatic refresh.  
To manually refresh the view at any time, right-click in the Current Folder browser and select Refresh. |
<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
</table>
| Path indication     | Control the appearance of folders and files that are inaccessible to MATLAB, and whether to display tooltips describing their status. MATLAB cannot access files if they are not on the search path or, in some cases, if they are in a private folder.  
Select the **Indicate inaccessible files** check box to dim the display of files and folders inaccessible to MATLAB. Move the **Text and icon transparency** slider to adjust the level of dimming.  
Select the **Show tooltip explaining why files are inaccessible** check box to display a tooltip that provides information on why a dimmed file is inaccessible, when you hover over it.  
If you do not select the **Indicate inaccessible files** check box, then the Current Folder browser displays all files and folders as undimmed and provides no tooltips. |
| Toolbar             | Access the toolbar preferences to adjust the toolbar layout and controls for Desktop tools, including the Current Folder browser.                                                                               |
| Initial working folder | Access the General preferences to specify the current folder in MATLAB when it starts.                                                                                                                        |
| Hidden Files        | Specify whether the Current Folder browser displays files and folders that the operating system hides from system file browsers and file-listing commands.  
This preference does not apply to Microsoft Windows platforms. On Windows platforms, the Current Folder browser follows the Windows preference for showing hidden files. To set or change the Windows preference, access the Folder Options, and then select an option for viewing **Hidden files and folders**. |

To change how dates display in the Current Folder browser, change the short date format for your operating system. Then, refresh the date display: Right-click in the Current Folder browser and select **Refresh**. MATLAB uses your operating system's short date format to display dates in both the Current Folder browser and the Command History.
Specify File Names

In this section...

“Construct Valid Path and File Names” on page 6-43
“Case Sensitivity of File Names” on page 6-45

Construct Valid Path and File Names

Specify Path Names

A path name specifies file locations, for example, C:\work\my_data (on Microsoft Windows platforms) or /usr/work/my_data (on Linux or Mac platforms). If you do not specify a path name when accessing a file, MATLAB first searches in the current folder. To indicate a file in a particular location, specify a path name.

Path name specifications differ, depending on the platform on which you are running MATLAB. Use the `fullfile` function to construct path names in statements that work on any platform. This function is particularly useful when you provide code to someone using it on a platform other than your own.

`fullfile` inserts platform-specific file separators where necessary. The file separator character is the symbol that distinguishes one folder level from another in a path name. A forward slash (/) is a valid separator on any platform. A backward slash (\) is valid only on Microsoft Windows platforms. In the full path to a folder, the final slash is optional. Type `filesep` in the Command Window to determine the correct file separator character to use on your platform.

To identify the platform on which MATLAB is currently running, use the `ismac`, `ispc`, and `isunix` functions.

Characters Within File and Folder Names

File names must start with a letter, and can contain letters, digits, or underscores.

Avoid using accent characters such as umlauts or circumflexes in path names. MATLAB might not recognize the path. In addition, attempts to save a file to such a path might result in unpredictable behavior.

If a path or file name contains spaces, enclose the input in single quotes. For example:
load 'filename with space.mat'

or

load('filename with space.mat')

**Absolute and Relative Path Names**

MATLAB always accepts absolute path names (also called full path names), such as \Documents/My_Files or /users/myuserid/Homework/myfile.m. An absolute path name can start with any of the following:

- UNC path '\'.
- Drive letter, on Microsoft Windows platforms, such as C:.
- '/' character on Linux platforms.

Some MATLAB functions also support relative path names. Unless otherwise noted, the path name is relative to the current folder. For example:

- myfile.m refers to the myfile.m file in the current folder.
- myfolder refers to the myfolder folder in the current folder.
- ../myfolder/myfile.m refers to the myfile.m file in the myfolder folder, where myfolder is at same level as the current folder. Each repetition of ../ at the beginning of the path moves up an additional folder level.

**Tip** If multiple documents are open and docked in the Editor, you can copy the absolute path of any of these documents to the clipboard. This practice is useful if you need to specify the absolute path in another MATLAB tool or an external application. Right-click the document tab, and then select **Copy Full Path to Clipboard**.

**Partial Path Names in MATLAB**

A partial path name is the last portion of a full path name for a location on the MATLAB search path. Some functions accept partial path names.

Examples of partial path names are: matfun/trace, private/cancel, and demos/clown.mat.

Use a partial path name to:
• Specify a location independent of where MATLAB is installed.
• Locate a function in a specific toolbox when multiple toolboxes contain functions with that name. For example, to open the file for the `set` function in the Database Toolbox™ product, type:

```
open database/set
```

• Locate method files. For example, to check if a `plot` method exists for the time series object, type:

```
exist timeseries/plot
```

Specifying the at sign character (@) in method folder names is optional.

• Locate private and method files, which sometimes are hidden.

Be sure to specify enough of the path name to make the partial path name unique.

### Maximum Length of Path Names in MATLAB

The maximum length allowed for a path name depends on your platform.

For example, on Microsoft Windows platforms:

• The maximum length is known as `MAX_PATH`.
• You cannot use an absolute path name that exceeds 260 characters.
• For a relative path name, you might need to use fewer than 260 characters. When the Windows operating system processes a relative path name, it can produce a longer absolute path name, possibly exceeding the maximum length.

If you get unexpected results when working with long path names, use absolute instead of relative path names. Alternatively, use shorter names for folders and files.

### Case Sensitivity of File Names

In general, it is best to specify path and case precisely when specifying a file name.

#### Case Sensitivity When Calling Functions

You call function files by specifying the file name without the file extension. MATLAB returns an error if it cannot find a case-sensitive match on the search path. By default, MATLAB suggests a function with the correct case.
When multiple files have the same name, MATLAB follows precedence rules to determine which to call. For more information, see “Function Precedence Order”.

**Case Sensitivity When Loading and Saving Files**

**Linux platforms** — File names are case sensitive.

- When loading or reading from a file, specify the file name using the correct case.
- When saving or writing to a file, MATLAB saves the file in the case you specify. Two files with the same name, but different cases can exist in the same folder.

**Windows platforms** — File names are case insensitive. The Windows operating system considers two files with the same name to be the same file, regardless of case. Therefore, you cannot have two file names that differ only by case in the same folder.

- When loading or reading from a file, MATLAB accesses the file with the specified name that is higher on the search path, regardless of case. For example, if you attempt to load MYFILE and myfile.mat is higher on the search path than MYFILE.MAT, then MATLAB loads myfile.mat without warning that there is a case mismatch.
- When saving or writing to a file, if you specify a file name that already exists in the folder, MATLAB accesses the existing file without warning. For example, if you save data to a file named myfile using the save function, and MYFILE.mat already exists in the folder, the data replaces the contents of MYFILE.mat. However, the file name remains MYFILE.mat.

**See Also**

filesep | fullfile | ismac | ispc | isunix | which

**More About**

- “What Is the MATLAB Search Path?” on page 6-50
Create and Extract from Zip Archives

**Create a Zip Archive**

Create archives using zip files to back up files, conserve file storage space, or to share collections of files with others. You can either create an empty archive, or select files and folders to create an initial archive. In either case, you can add more files later.

Create zip archives interactively using the Current Folder browser:

- To create an empty zip file, right-click white space, and then select **New > Zip File**.
- To create a populated zip file from selected files and folders, select the folders and files you want to archive, right-click, and then select **Create Zip File**.

MATLAB creates an archive with a default name of `Untitled\(n\).zip`, where \(n\) is an integer.

Type over the default file name to specify a descriptive name, for example `listmaster_export.zip`, as shown here.
You also can create zip archives programmatically using the `zip` function. For example, to zip all files with a `.m` and `.mat` extension in the current folder to a zip file archive named `backup.zip`, call:

```matlab
zip('backup', '*.m', '*.mat');
```

### Add Files to a Zip Archive

To add files and folders to a zip file archive in the Current Folder browser, do one of the following:

- Select, and then drag the file that you want to add onto the archive.
- Copy the file that you want to add to the archive. Then, select the archive to which you want to add the file and paste the file into the archive.

### Extract Files from a Zip Archive

To extract a single file from within a zip file archive in the Current Folder browser:

1. Expand the zip file archive to view the archive contents, by clicking the associated + (expand) button. By default, files within a zip file archive appear dimmed to indicate that they are not on the MATLAB path.
2. Drag the file into a folder in the Current Folder browser.

MATLAB extracts the file and saves it to the folder where you dragged or pasted it.
To extract all the contents of a zip file, double-click the zip file in the Current Folder browser. MATLAB creates a folder with the same name as the zip file, and extracts the entire contents of the zip file into this folder.

To extract the contents of a zip file programmatically, use the `unzip` function. `unzip` also allows you to specify a target folder. For example, to unzip the file, `examples.zip`, to a folder named `myfolder`, call:

```matlab
unzip('examples.zip','myfolder')
```

**Note** Archives created outside of MATLAB can be encrypted or password-protected. You cannot add files to, or extract files from, protected archives from within MATLAB.

### Compare Zip Archive to Unzipped Files

To determine differences between archived and unarchived files, use the Comparison Tool from within the Current Folder browser as you would for any other files and folders.

- Right-click a zip archive, and then from the context menu select **Compare Against** and specify the folder to which you want to compare the contents of the zip archive.
- Expand a zip archive, right-click a file within it, and then from the context menu select **Compare Against**. Specify the file to which you want to compare the archived file.

### See Also

`unzip` | `zip`

### More About

- “Compare Files and Folders and Merge Files” on page 6-6
What Is the MATLAB Search Path?

The MATLAB search path is a subset of all the folders in the file system. MATLAB uses the search path to locate files used with MathWorks products efficiently.

The order of folders on the search path is important. When files with the same name appear in multiple folders on the search path, MATLAB uses the one found in the folder nearest to the top of the search path.

By default, the search path includes

- The MATLAB userpath folder, which is added to the search path at startup, and is the default location for storing user files
- The folders defined as part of the MATLABPATH environment variable
- The folders provided with MATLAB and other MathWorks products, which are under matlabroot/toolbox, where matlabroot is the folder displayed when you run matlabroot in the Command Window

Class, package, private, and resources folders are special folders that cannot be specified explicitly as part of the search path. A special folder is added to the search path implicitly when its parent folder is specified as part of the path. To access the files and folders within a special folder, you must add its parent folder to the path.

You can explicitly add folders to the search path for the files you run. For more information about adding files to the search path, see “Change Folders on the Search Path” on page 6-54.

In MATLAB Online, all folders are automatically on the path.

userpath Folder on the Search Path

The userpath folder is first on the search path. By default, MATLAB adds the userpath folder to the search path at startup. This folder is a convenient place for storing files that you use with MATLAB.

The default userpath folder is platform-specific.

- Windows platforms — %USERPROFILE%/Documents/MATLAB.
- Mac platforms — $home/Documents/MATLAB.
• Linux platforms — $home/Documents/MATLAB if $home/Documents exists.
• MATLAB Online — /users/youruserid.

Alternatively, to determine or change the current userpath folder, call userpath.

By default, the userpath folder is also the startup folder when you start MATLAB by double-clicking either the MATLAB shortcut on Windows systems or the MATLAB application on Mac systems.

**MATLABPATH Environment Variable**

The MATLABPATH environment variable can contain a list of additional folders to be added to the MATLAB search path at startup. These folders are placed after the userpath folder, but ahead of the folders supplied by MathWorks. By default, the MATLABPATH environment variable is not set. For more information on how to set the MATLABPATH environment variable, see “Set the MATLABPATH Environment Variable” on page 6-58.

**Determine If Files and Folders Are on the Search Path**

There are several ways to determine if files and folders are on the search path. You can either check whether an individual file or folder is on the search path, or you can view the entire search path.

**Check Whether File or Folder on Search Path**

To determine whether a file is on the search path, run which filename. If the file is on the search path, MATLAB returns the full path to the file.

To determine whether a file or folder is on the search path, use the Current Folder browser. Files and folders not on the path are dimmed. To ensure that the Current Folder browser is set to indicate whether a file or folder in on the search path, right-click any file or folder, and select the **Indicate Files Not on Path** option.

Hover the pointer over any dimmed file or folder in the Current Folder browser to find out why it is dimmed. A tooltip opens with an explanation. Frequently, the tooltip indicates that the file or folder is not on the MATLAB path. If a tooltip does not appear, it may be disabled. To enable it, go the Home tab and in the Environment section, click 🙂 Preferences. Then, select MATLAB > Current Folder. Select **Show tooltip explaining why files are inaccessible** to display the tooltip.
View Entire Search Path

Run the `path` command to view all the folders on the MATLAB search path.

Alternatively, use the Set Path dialog box to view the entire MATLAB search path. On the Home tab, in the Environment section, click Set Path. The Set Path dialog box opens, listing all folders on the search path. For more information on using the Set Path dialog box, see “Change Folders on the Search Path” on page 6-54.

The Search Path Is Not the System Path

The search path is not the same as the system path. Furthermore, there is no explicit relationship between the MATLAB search path and the system path. However, both paths help in locating files, as follows:
MATLAB uses the search path to locate MATLAB files efficiently.
The operating system uses a system path to locate operating system files efficiently.

**How MATLAB Stores the Search Path**

MATLAB saves search path information in the `pathdef.m` file. This file contains a series of full path names, one for each folder on the search path.

By default, `pathdef.m` is in `matlabroot/toolbox/local`.

When you change the search path, MATLAB uses it in the current session, but does not update `pathdef.m`. To use the modified search path in the current and future sessions, save the changes using `savepath` or the **Save** button in the Set Path dialog box. This updates `pathdef.m`.

In MATLAB Online, all changes to the search path are automatically saved.

**See Also**

`userpath`

**More About**

- “Add Folders to the MATLAB Search Path at Startup” on page 6-58
- “Change Folders on the Search Path” on page 6-54
Change Folders on the Search Path

<table>
<thead>
<tr>
<th>In this section...</th>
</tr>
</thead>
<tbody>
<tr>
<td>“For Current and Future Sessions” on page 6-54</td>
</tr>
<tr>
<td>“For the Current Session Only” on page 6-56</td>
</tr>
</tbody>
</table>

For Current and Future Sessions

You can interactively add and remove folders, and change the order of folders on the search path, for the current MATLAB session and for future MATLAB sessions. When files with the same name appear in multiple folders on the search path, MATLAB uses the one found in the folder nearest to the top of the search path.

2  Use the Set Path dialog box to modify the search path.
3  Apply or cancel the search path changes:
   • To use the newly modified search path only in the current session, click **Close**.
   • To reuse the newly modified search path in the current session and future sessions, click **Save**, and then **Close**.
   • To undo your changes, click **Revert**, and then **Close**.
   • To restore the default search path, click **Default**, and then **Close**. The default search path contains only folders provided by MathWorks.

**Note** The MATLAB (userpath) folder automatically moves to the top of the search path the next time you start MATLAB. For more information about the userpath folder, see “userpath Folder on the Search Path” on page 6-50
For the Current Session Only

There are three ways to change the folders on the search path for the current MATLAB session only:

• Use the Set Path dialog box to make changes to the search path, and do not save the changes.

  2. After making the changes, click Close.

• Use the Current Folder browser to add or remove folders from the search path.

  1. From the Current Folder browser, select, and then right-click the folder or folders to add or remove.
  2. From the context menu, select Add to Path or Remove from Path, and then select an option:
     • Selected Folders
     • Selected Folders and Subfolders
     • In the Editor, you also can add or remove the folder that contains an Editor document from the search path. Right-click the document tab, and then select an option to Add or Remove the folder from the Search Path.

See Also

addpath | rmpath | savepath
Use Search Path with Different MATLAB Installations

The default search path changes for each MATLAB version because the default folders that come with the products change. Different MATLAB versions cannot use the same pathdef.m file.

To use your files with a new MATLAB version or with multiple versions, do one of the following:

- For each version, add the folders containing your files to the search path. Save the search path (that is, save the pathdef.m file) where that version of MATLAB can access it.
- Include addpath statements in the startup.m file. Use the same startup.m file with the multiple versions of MATLAB.

Including addpath statements in the startup.m file also allows you to use your files with MATLAB on different platforms.

See Also
addpath

More About
- “Startup Options in MATLAB Startup File” on page 1-26
Add Folders to the MATLAB Search Path at Startup

There are two ways to add folders to the MATLAB search path at startup. You can either use a `startup.m` file or you can set the `MATLABPATH` environment variable.

**Use a startup.m File**

The `startup.m` file is for specifying startup options. You can add folders to the search path by including `addpath` statements in a `startup.m` file. For example, to add the specified folder, `/home/username/mytools` to the search path at startup, include this statement in a `startup.m` file:

```
addpath /home/username/mytools
```

For more information on creating a `startup.m` file with `addpath` statements, see “Startup Options in MATLAB Startup File” on page 1-26.

**Set the MATLABPATH Environment Variable**

You can also add folders to the search path at startup by setting the `MATLABPATH` environment variable.

**Windows**

To set the `MATLABPATH` environment variable in Windows, from the Windows Control Panel, go to System and select Advanced system settings. Click the Environment Variables... button. Click New... or Edit... to create or edit the `MATLABPATH` environment variable. In the dialog box that appears, set the variable name to `MATLABPATH` and the variable value to a semicolon-separated list of folders you want to add to the search path. For example, to add two folders, `c:\matlab_files\myfolder1` and `c:\matlab_files\myfolder2`, to the `MATLABPATH` environment variable, enter `c:\matlab_files\myfolder1;c:\matlab_files\myfolder2` as the variable value. Click OK to set the variable and exit the dialog box. Restart MATLAB for the new settings to take effect.

To set the environment variable from a command window, run the command `set MATLABPATH=folders`, where `folders` is a semicolon-separated list of folders. For example, suppose that you want to add two folders, `c:\matlab_files\myfolder1` and `c:\matlab_files\myfolder2`, to the `MATLABPATH` environment variable. Run the command
set MATLABPATH=c:\matlab Files\myfolder1;c:\matlab Files\myfolder2

Once the environment variable is set, you must start MATLAB from the same command window for the settings to take effect. The environment variable persists only as long as the command window is open.

**UNIX and Mac**

To set the MATLABPATH environment variable in UNIX and Mac, in a terminal, run the command `export MATLABPATH=folders`, where `folders` is a colon-separated list of folders.

For example, suppose that you want to add two folders, `/home/j/Documents/MATLAB/mine` and `/home/j/Documents/MATLAB/research`, to the MATLABPATH environment variable on a UNIX platform. Run the command

```
export MATLABPATH=/home/j/Documents/MATLAB/mine:/home/j/Documents/MATLAB/research
```

Once the environment variable is set, you must start MATLAB from the same shell for the settings to take effect. The environment variable persists only as long as the shell remains open.

**Note** If you are using a C shell (csh or tcsh), the command for setting the MATLABPATH environment variable is `setenv MATLABPATH folders`.

To add the folders for all future MATLAB sessions, set the MATLABPATH environment variable as part of your shell configuration script.

**See Also**

**More About**
- “What Is the MATLAB Search Path?” on page 6-50
- “Change Folders on the Search Path” on page 6-54
Assign userpath as Startup Folder (Macintosh or UNIX)

This example shows how to assign the `userpath` folder as the startup folder on a Macintosh platform. The procedure is similar for UNIX platforms. Assume that `userpath` is set to the default value on a Macintosh platform where `smith` is the home folder.

Using a bash shell, set the `MATLAB_USE_USERWORK` environment variable so that `userpath` will be used as the startup folder.

```bash
export MATLAB_USE_USERWORK=1
```

From that shell, start MATLAB. Next, verify the current folder in MATLAB.

```bash
pwd
/Users/smith/Documents/MATLAB
```

Confirm that this is the same as the folder defined for `userpath`.

```bash
userpath
/Users/smith/Documents/MATLAB;
```

Confirm that the `userpath` is at the top of the search path.

```bash
path
/Users/smith/Documents/MATLAB
/Users/smith/Applications/MATLAB/R2009a/toolbox/matlab/general
/Users/smith/Applications/MATLAB/R2009a/toolbox/matlab/ops
...
Path Unsuccessfully Set at Startup

When there is a problem with the search path, you cannot use MATLAB successfully.

Search path problems occur when:

- You save the search path on a Windows platform, and then try to use the same `pathdef.m` file on a Linux platform.
- The `pathdef.m` file becomes corrupt, invalid, renamed, or deleted.
- MATLAB cannot locate the `pathdef.m` file.

When MATLAB starts, if there is a problem with the search path, a message such as the following appears:

Warning: MATLAB did not appear to successfully set the search path...

For problems with the search path, try these recovery steps. Proceed from one step to the next only as necessary.

1. Ensure MATLAB is using the `pathdef.m` file you expect:
   a. Run `which pathdef`
   b. If you want MATLAB to use the `pathdef.m` file at another location, make corrections. For example, delete the incorrect `pathdef.m` file and ensure the correct `pathdef.m` file is in a location that MATLAB can access.

2. Look for and correct problems with the `pathdef.m` and `startup.m` files:
   a. Open `pathdef.m` and `startup.m` in a text editor. Depending on the problem, you might not be able to open the `pathdef.m` file.
   b. Look for obvious problems, such as invalid characters or path names.
   c. Make corrections and save the files.
   d. Restart MATLAB to ensure that the problem does not recur.

3. Try to correct the problem using the Set Path dialog box:
   a. Restore the default search path and save it. See “Change Folders on the Search Path” on page 6-54. Depending on the problem, you might not be able to open the dialog box.
   b. Restart MATLAB to ensure that the problem does not recur.
4 Restore the default search path using functions:
   a Run `restoredefaultpath`, which sets the search path to the default and stores it in `matlabroot/toolbox/local`.
   b If `restoredefaultpath` seems to correct the problem, run `savepath`.
   c Restart MATLAB to ensure that the problem does not recur.

Depending on the problem, a message such as the following could appear:
The path may be bad. Please save your work (if desired), and quit.

5 Correct the search path problems encountered during startup:
   a Run
      ```matlab
      restoredefaultpath; matlabrc
      ```
      Wait a few minutes until it completes.
   b If there is a `pathdef.m` file in the startup folder, it caused the problem. Either remove the bad `pathdef.m` file or replace it with a good `pathdef.m` file. For example, run:
      ```matlab
      savepath('path_to_your_startup_folder/pathdef.m')
      ```
      See “MATLAB Startup Folder” on page 1-20.
   c Restart MATLAB to ensure that the problem does not recur.

After correcting problems with the search path, make any changes to run your files. For example, add the `userpath` folder or other folders to the search path.
Errors When Updating Folders on Search Path

You can encounter errors or unexpected behavior when you try to delete, rename, or move folders that:

• Are on the search path
• Contain subfolders that are on the search path

The behavior varies by platform because it depends on the behavior of similar features in the operating system.

If your task fails and the error message indicates it is because the folder is on the search path, then do the following:

1. Remove the folder from the search path.
2. Delete, rename, or move the folder.
3. Add the folder to the search path.
Troubleshoot Invalid or Unresponsive Windows Change Notification Handles

MATLAB uses a Windows operating system feature called change notification handles to detect when files in an associated folder are modified. Under certain circumstances, Windows fails to provide MATLAB with a valid or responsive Change Notification Handle. The three most common causes for invalid or unresponsive change notification handles are:

- Windows has exhausted its supply of notification handles.
- The specified folder resides on a file system that does not support change notification. (Syntax TAS file server, SAMBA file server, and many NFS file servers are known to have this limitation.)
- Network or file server latency delays the arrival of the change notification so that changes are not detected on a timely basis.

When MATLAB is unable to obtain a valid or responsive Change Notification Handle, it cannot automatically detect changes to files and folders. For example, new functions added to an affected folder might not be visible, and changed functions in memory might not be reloaded.

Control How MATLAB Detects Changes in Files and Folders

If MATLAB is unable to detect changes to your files and folders due to invalid or unresponsive change notification handles, you can control how MATLAB detects changes in folders.

If your file system updates folder timestamps when files are added to folders, you can set your system remote path policy to detect changes by testing the timestamps of folders. To do so, include these commands in a startup.m file. For more information on creating a startup.m file, see “Startup Options in MATLAB Startup File” on page 1-26.

```matlab
system_dependent('RemotePathPolicy', 'TimecheckDir');
rehash path;
```

You might notice a performance degradation due to the time required to check the timestamps.
If your file system does not update folder timestamps (such as an NT file system), you can set your system remote path policy to detect changes by rereading the affected folders at frequent intervals. To do so, include these commands in a startup.m file.

```matlab
system_dependent('RemotePathPolicy', 'Reload');
rehash path;
```

You might notice a significant performance degradation due to the time required to reread the folders.

To determine how MATLAB detects changes in folders, use this command:

```matlab
system_dependent('RemotePathPolicy', 'Status');
```

In some cases, detecting new files or changed files in folders affected by the invalid or unresponsive change notification handles is not necessary. If detecting changes is not necessary, to provide maximum performance, you can disable your system remote path policy. To do so, include these commands in a startup.m file.

```matlab
system_dependent('RemotePathPolicy', 'None');
rehash path;
```

**Clear Functions from Memory**

Sometimes, changing your system remote path policy is not effective in preventing problems related to remote file system caching or network latency. If MATLAB is still unable to detect the changes that you have made to a function, you can clear the old copy of the function from memory using the `clear` function. MATLAB reads the updated function the next time it is called.

**Configure Change Notification Handle Warnings**

To analyze which folders are affected by invalid or unresponsive Windows change notification handles, you can configure the number of warning messages issued by Windows. To do so, include one of these commands in a startup.m file. For more information on creating a startup.m file, see “Startup Options in MATLAB Startup File” on page 1-26.

- Show warning messages for all invalid or unresponsive change notification handles.

  ```matlab
  system_dependent('DirChangeHandleWarn', 'Always');
  ```
• Only show the first warning message about invalid or unresponsive change notification handles.

    system_dependent('DirChangeHandleWarn', 'Once');

• Never show warning messages about invalid or unresponsive change notification handles.

    system_dependent('DirChangeHandleWarn', 'Never');

To determine when Windows warns about invalid or unresponsive change notification handles, use this command.

    system_dependent('DirChangeHandleWarn', 'Status');

**See Also**

addpath | rehash

**More About**

• “What Is the MATLAB Search Path?” on page 6-50
• “Startup Options in MATLAB Startup File” on page 1-26
Editor Preferences

- “Editor/Debugger Preferences” on page 7-2
- “Code Analyzer Preferences” on page 7-16
Editor/Debugger Preferences

In this section...

| “General Preferences for the Editor/Debugger” on page 7-2 |
| “Editor/Debugger Display Preferences” on page 7-4 |
| “Editor/Debugger Tab Preferences” on page 7-5 |
| “Editor/Debugger Language Preferences” on page 7-6 |
| “Editor/Debugger Code Folding Preferences” on page 7-9 |
| “Editor/Debugger Backup Files Preferences” on page 7-10 |
| “Editor/Debugger Autoformatting Preferences” on page 7-11 |
| “Editor/Debugger Autocoding Preferences” on page 7-13 |

You can customize the visual display and functionality of the Editor, Live Editor, and Debugger using Editor/Debugger preferences.

**General Preferences for the Editor/Debugger**

You can specify which editor MATLAB uses, as well as how the MATLAB Editor and Live Editor behaves under various circumstances.

On the **Home** tab, in the **Environment** section, click **Preferences**. Select **Editor/Debugger**, and then adjust preference options as described in the table below.

Some general preferences are not available in MATLAB Online.
<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editor</td>
<td>Select which editor you want the MATLAB desktop to use when you edit a file:</td>
</tr>
<tr>
<td></td>
<td>• MATLAB Editor</td>
</tr>
<tr>
<td></td>
<td>• Text editor</td>
</tr>
<tr>
<td></td>
<td>If you select <strong>Text editor</strong>, specify the full path for the editor application you want to use, such as Emacs or vi. For example, <code>c:/Applications/Emacs.exe</code>.</td>
</tr>
<tr>
<td></td>
<td>This preference only applies to plain text files such as files with a <code>.m</code> or <code>.txt</code> extension.</td>
</tr>
<tr>
<td>Most recently used file list</td>
<td>In the <strong>Number of entries</strong> field, type the number of files that you want to appear in the list of recently used files at the bottom of the <strong>File</strong> menu.</td>
</tr>
<tr>
<td>Opening files in editor</td>
<td>Select <strong>On restart reopen files from previous MATLAB sessions</strong> if you want the Editor and the files it contained during your last MATLAB session to reopen when you restart MATLAB.</td>
</tr>
<tr>
<td></td>
<td>Select <strong>Automatically open files when MATLAB reaches a breakpoint</strong> to open a running program file when MATLAB encounters a breakpoint in that file.</td>
</tr>
<tr>
<td>Automatic file changes</td>
<td>Select <strong>Save changes upon clicking away from a file</strong> if you want the Editor to automatically save changes to a file in the Editor when you click away from the Editor. For the changes to be automatically saved upon clicking away from the Editor, you must have already saved the file at least once.</td>
</tr>
</tbody>
</table>
## Preference

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Preference</strong></td>
<td><strong>Usage</strong></td>
</tr>
<tr>
<td>Select <strong>Reload unedited files</strong></td>
<td>Select <strong>Reload unedited files</strong> if you want the Editor to automatically reload the version of a file that you opened and edited outside of MATLAB when the file currently open in the Editor has no unsaved changes.</td>
</tr>
<tr>
<td>that have been externally modified</td>
<td>Select <strong>Add line termination at end of file</strong> to have MATLAB add a new empty line (sometimes referred to as a &quot;&lt;CR&gt;&quot;) to the end of a file automatically if the last line in the file is not empty. This preference only applies to plain text files such as files with a .m or .txt extension.</td>
</tr>
<tr>
<td><strong>Debugging in the Live Editor</strong></td>
<td>Select <strong>Only show Step in button for user-defined functions</strong> to have the Live Editor only step into user-defined functions and scripts. To have the Live Editor step into MathWorks functions as well, clear the option.</td>
</tr>
</tbody>
</table>

### Editor/Debugger Display Preferences

You can change the appearance of the Editor and Live Editor.

On the **Home** tab, in the **Environment** section, click 🕵️‍♂️ **Preferences**. Select **Editor/Debugger > Display**, and then adjust preference options as described in the table below.

Some display preferences do not apply in the Live Editor and are not available in MATLAB Online.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General display option</strong></td>
<td>Select <strong>Highlight Current Line</strong> and select a color to highlight the row with the cursor (also called the caret). This preference does not apply in the Live Editor.</td>
</tr>
</tbody>
</table>
### Preference | Usage
--- | ---
Show line numbers | Select **Show line numbers** to display line numbers along the left edge of the Editor window.
Enable data tips in edit mode | Select **Enable data tips in edit mode** to display data tips when you are editing a MATLAB code file. (Data tips are always enabled in debug mode.)

For details, see “View Variable Value”.

This preference does not apply in the Live Editor.

Display the Open as a Live Script banner | Select **Display the Open as a Live Script banner** if you want the Open as a Live Script banner to appear at the top of documents in the Editor.

Right-hand text limit | Select **Show line** to display a vertical line with the specified **Width** and **Color** at the specified column (**Placement**) in the Editor.

For details, see “Right-Side Text Limit Indicator”.

This preference does not apply in the Live Editor.

---

### Editor/Debugger Tab Preferences

You can specify the size of tabs and indents and details about how tabs behave in the Editor.

On the **Home** tab, in the **Environment** section, click 📏 Preferences. Select **Editor/Debugger > Tab**, and then adjust preference options as described in the table below.

Tab preferences do not apply in the Live Editor and are not available in MATLAB Online.
### Option

<table>
<thead>
<tr>
<th>Tab size</th>
<th>Specify the amount of space inserted when you press the Tab key. When you change the Tab size, it changes the tab size for existing lines in that file, unless you also select Tab key inserts spaces.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Indent size</td>
<td>Specify the indent size for smart indenting. Smart indenting is one of the “Editor/Debugger Language Preferences” on page 7-6.</td>
</tr>
<tr>
<td>Tab key inserts spaces</td>
<td>Select to insert a series of spaces when you press the Tab key. Otherwise, a tab acts as one space whose length is equal to the Tab size.</td>
</tr>
<tr>
<td>Emacs-style Tab key smart indenting</td>
<td>Specifies an indenting style similar to the style that the Emacs editor uses. Lines indent according to smart indenting preferences when you position the cursor in a line or select a group of lines, and then press the Tab key. Smart indenting is one of the “Editor/Debugger Language Preferences” on page 7-6. If you select this preference, you cannot insert tabs within a line.</td>
</tr>
</tbody>
</table>

---

**Editor/Debugger Language Preferences**

You can specify how various languages appear in the Editor and Live Editor. MATLAB applies language preferences based on the file extension of the file that is open.

On the **Home** tab, in the **Environment** section, click 🎨 **Preferences**. Select **Editor/Debugger > Language**, and then adjust preference options as described in the table below.

Not all preferences are available for all languages. In addition, some language preferences do not apply in the Live Editor and are not available in MATLAB Online.
<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Language</td>
<td>Select the language for which you want to set preferences.</td>
</tr>
<tr>
<td>Syntax highlighting</td>
<td>Select <strong>Enable syntax highlighting</strong> to have the Editor use different colors for different language constructs. Then, adjust the colors you want to use for each language element. Disabling syntax highlighting is not supported in the Live Editor. Access color options for the MATLAB language by clicking <strong>Set syntax colors</strong>. For all other languages, color options appear under <strong>Enable syntax highlighting</strong>. For details, see “Syntax Highlighting” on page 3-24.</td>
</tr>
<tr>
<td>Variable and function renaming</td>
<td>Select <strong>Enable automatic variable and function renaming</strong> to have MATLAB prompt you to rename all instances of a function or variable in a file when you rename a function or variable. For details on when MATLAB prompts you, see “Automatically Rename All Functions or Variables in a File”.</td>
</tr>
<tr>
<td><strong>MATLAB Language only</strong></td>
<td></td>
</tr>
<tr>
<td>Preference</td>
<td>Usage</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Comment formatting</strong></td>
<td>In the <strong>Maximum column width</strong> field, enter the maximum number of characters you want to allow in a line of comments, and then select where you want counting to begin.</td>
</tr>
<tr>
<td>MATLAB Language only</td>
<td>Consider selecting:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Start from beginning of line</strong> when the absolute width of the comments is important. For example, set 75 columns from the start of the line to match the width that fits on a printed page when you use the default font for the Editor.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Start from beginning of comment</strong> when comments are indented, and you want each block of comments to have a consistent indent and width.</td>
</tr>
<tr>
<td></td>
<td>Select <strong>Wrap comments automatically while typing</strong> to automatically wrap comments at the <strong>Maximum column width</strong> value when you type comments in an Editor document.</td>
</tr>
<tr>
<td></td>
<td>If you clear this option, you can still wrap comments manually, as described in “Add Comments to Programs”.</td>
</tr>
<tr>
<td><strong>Indenting</strong></td>
<td>Select <strong>Apply smart indenting while typing</strong> to automatically:</td>
</tr>
<tr>
<td></td>
<td>• Indent the body of loops within the start and end of the loop statement.</td>
</tr>
<tr>
<td></td>
<td>• Align subsequent lines with lines you indent using tabs or spaces.</td>
</tr>
<tr>
<td></td>
<td>• Indent functions as specified with the <strong>Function indenting format</strong> option.</td>
</tr>
<tr>
<td></td>
<td>This is called <strong>smart indenting</strong>. You also can manually apply smart indenting after you type the code.</td>
</tr>
<tr>
<td></td>
<td>For more information, see “Indenting Code”.</td>
</tr>
</tbody>
</table>
Preference | Usage
--- | ---
Select an option from **Function Indenting Format** (MATLAB Language only) to specify how functions indent in the Editor, as follows:
- **Classic** — The Editor aligns the function code with the function declaration.
- **Indent nested functions** — The Editor indents the function code within a nested function.
- **Indent all functions** — The Editor indents the function code for both main and nested functions.

For more information and examples of each indenting format, see “Indenting Code”.

| File extensions | Add one or more file extensions to associate with the **Language**. The preferences you set for that language apply to all files with the listed extensions. |

---

**Editor/Debugger Code Folding Preferences**

Code folding enables you to expand and collapse blocks of MATLAB code that you want to hide when you are not currently working on them.

On the **Home** tab, in the **Environment** section, click **Preferences**. Select **Editor/Debugger > Code Folding**, and then adjust preference options as described in the table below.

For examples and detailed information about code folding, see “Code Folding — Expand and Collapse Code Constructs”.

Code folding preferences do not apply in the Live Editor.

| Option | Usage |
--- | ---|
**Enable Code Folding** | Specifies whether you want code folding enabled for the programming constructs that have their corresponding **Enable** check box selected. |
<table>
<thead>
<tr>
<th>Option</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable</td>
<td>Specifies whether you want code folding enabled for the corresponding Programming Construct. If you select this option for any construct, but clear the Enable Code Folding option, the construct will not have code folding enabled.</td>
</tr>
<tr>
<td>Fold Initially</td>
<td>Specifies whether the corresponding Programming Construct displays collapsed (folded) the first time that you open a MATLAB file.</td>
</tr>
</tbody>
</table>

**Editor/Debugger Backup Files Preferences**

You can specify if, when, and how you want MATLAB to automatically back up files that are open in the Editor:

On the Home tab, in the Environment section, click Preferences. Select Editor/Debugger > Backup Files, and then adjust preference options as described in the table below.

Backup files preferences do not apply in the Live Editor and are not available in MATLAB Online.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatically create backup files while working in the MATLAB Editor</td>
<td>Select to have MATLAB automatically save a copy of the files you are currently editing.</td>
</tr>
<tr>
<td>Save options</td>
<td>Save the backup every: n minutes specifies how often you want MATLAB to save a copy of the file you are editing.</td>
</tr>
<tr>
<td>Preference</td>
<td>Usage</td>
</tr>
<tr>
<td>------------</td>
<td>-------</td>
</tr>
<tr>
<td><strong>Save untitled files</strong></td>
<td>saves a copy of new, untitled, files to Untitled.asv.</td>
</tr>
<tr>
<td></td>
<td>When there is more than one untitled file, each additional file is saved to Untitledn.asv (where n is an integer value).</td>
</tr>
</tbody>
</table>
| | For details, see “Backing Up Files”.

| Close options | **Automatically delete backup files when the Editor closes** directs MATLAB to delete the backup file when you close the source file in the Editor. |

<table>
<thead>
<tr>
<th>File name</th>
<th>Select the naming convention you want MATLAB to use for autosave files. For example:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• If you specify <strong>Replace extension with:</strong> asv, the backup file for filename.m is filename.asv</td>
</tr>
<tr>
<td></td>
<td>• If you specify <strong>Append file name with:</strong> <del>, the backup file for filename.m is filename.m</del></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Location</th>
<th><strong>Source file directories</strong> specifies that you want backup files stored in the same folder as the files being edited.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Single directory</strong> specifies that you want autosave files stored in a single folder. Specify the full path to that folder and be sure you have write permissions for it.</td>
</tr>
</tbody>
</table>

**Editor/Debugger Autoformatting Preferences**

You can quickly format live scripts and functions using autoformatting markup in the Live Editor. You can enable and disable autoformatting as a whole, or as individual options.

On the **Home** tab, in the **Environment** section, click 🌐 **Preferences**. Select **Editor/Debugger > Autoformatting**, and then adjust preference options as described in this table.
Autoformatting preferences do not apply in the Editor.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Enable autoformatting in Live Editor</strong></td>
<td>Select to enable autoformatting options in the Live Editor. Once enabled, options can then be enabled or disabled individually.</td>
</tr>
<tr>
<td><strong>Text format</strong></td>
<td>Select <em>italic</em>, <em>bold</em> to enable bold and italic formatting using underscores (_).</td>
</tr>
<tr>
<td></td>
<td>Select <code>monospace</code>, <code>monospace</code> to enable monospace autoformatting.</td>
</tr>
<tr>
<td><strong>Section break</strong></td>
<td>Select %%%, *** or --- for section break to enable inserting section breaks by entering %%%, *** or --- and then Enter.</td>
</tr>
<tr>
<td></td>
<td>Select %%% text for section break and heading to enable inserting section breaks with heading 1 style headings by entering %%%%text and then Enter.</td>
</tr>
<tr>
<td><strong>Insert Options</strong></td>
<td>Select $LaTeX$ for LaTeX equation to enable converting LaTeX expressions into equations using the format $LaTeX$.</td>
</tr>
<tr>
<td></td>
<td>Select URL for hyperlink to enable converting internet paths automatically to hyperlinks.</td>
</tr>
<tr>
<td></td>
<td>Select &lt;URL&gt; for hyperlink to enable converting internet paths to hyperlinks using the format &lt;URL&amp;gt.;</td>
</tr>
<tr>
<td></td>
<td>Select <a href="URL">Label</a> for labeled hyperlink to enable converting internet paths to labeled hyperlinks using the format <a href="URL">Label</a>.</td>
</tr>
<tr>
<td></td>
<td>Select (TM), (SM), (R), and (C) for trademark, service mark, and copyright symbols to enable inserting trademark and copyright symbols (™, ©, and ®) using the format (TM), (SM), (R), and (C).</td>
</tr>
</tbody>
</table>
For more information about autoformatting in the Live Editor, see “Autoformatting”.

**Editor/Debugger Autocoding Preferences**

When you enter code in the Live Editor or in App Designer, MATLAB autocompletes block endings, parentheses, and quotes. MATLAB also autocompletes comments, character vectors, and strings when split across two lines. You can enable and disable autocoding as a whole, or as individual options.

On the **Home** tab, in the **Environment** section, click **Preferences**. Select **Editor/ Debugger > Autocoding**, and then adjust preference options as described in this table.

Autocoding preferences do not apply in the Editor.
<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Autocomplete quotes</strong></td>
<td>Select <strong>Square brackets</strong> <code>[ ]</code> to enable autocompletion of square brackets. Select <strong>Single quotes</strong> <code>' '</code> to enable autocompletion of single quotes. Select <strong>Double quotes</strong> <code>&quot; &quot;</code> to enable autocompletion of double quotes.</td>
</tr>
</tbody>
</table>
| **Autocomplete when splitting** | Select **Comments** `%` to enable autocompletion of comments when split across two lines. For example, pressing **Enter** with your cursor after the period in the comment

```
% This is my first comment. This is my second comment.
```

splits the comments into two lines.

```
% This is my first comment.
% This is my second comment.
```

Select **Character vectors** `' '` to enable autocompletion of character vectors when split across two lines. For example, pressing **Enter** with your cursor after the word **Random** in the character vector

```
title('Mean of Random Uniform Data')
```

splits the character vector into two character vectors across two lines.

```
title(['Mean of Random' ... ' Uniform Data'])
```
<table>
<thead>
<tr>
<th>Preference</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Preference</strong></td>
<td><strong>Usage</strong></td>
</tr>
<tr>
<td><strong>Preference</strong></td>
<td><strong>Usage</strong></td>
</tr>
<tr>
<td>Preference</td>
<td>Usage</td>
</tr>
</tbody>
</table>
| Select *Strings (" ")* to enable autocompletion of strings when split across two lines. For example, pressing **Enter** with your cursor after the word *long* in the string 

exist("exceptionally_long_file_name.txt") | splits the string into two strings on two lines. 

exist("exceptionally_long" + ... 
"_file_name.txt") |
| Select **Parentheses ()** to enable autocompletion of parentheses when split across two lines. For example, pressing **Enter** with your cursor after the number 10 and the comma in the command 

plot(x,y,'--gs','LineWidth',2,'MarkerSize',10,'MarkerEdgeColor','b') | splits the command into two lines. 

plot(x,y,'--gs','LineWidth',2,'MarkerSize',10, ... 
'MarkerEdgeColor','b') |
| **Autocomplete block endings** | **Select Control flow statements (if, for, etc.) to enable autocompletion of control flow statements. To autocomplete a statement, enter the statement and press **Enter**. For a list of control flow statements, see “Loops and Conditional Statements”.** |
| **Autocomplete block endings** | **Select Function and class definitions to enable autocompletion of functions and class definitions. To autocomplete a definition, enter either function or class and press **Enter**.** |
Code Analyzer Preferences

You can change how Code Analyzer messages appear in the Editor. With a few exceptions, these preferences apply to messages in the Editor, the MATLAB Function Block Editor (if your products use that tool), and the Code Analyzer Report.

On the Home tab, in the Environment section, click Preferences. Select Code Analyzer, and then adjust preference options as described in the table below.

<table>
<thead>
<tr>
<th>Option</th>
<th>Usage</th>
</tr>
</thead>
</table>
| **Enabled Integrated Warning and Error Messages** | Specify whether you want to display Code Analyzer message indicators, such as the underlining of code and the message indicator bar, for documents open in the Editor.  
For more information, see “Automatically Check Code in the Editor — Code Analyzer”. |
| **Underlining**                             | Specify the type of coding issues that you want to have underlined.  
Regardless of the underlining menu option you choose, the Editor marks errors and warnings in the message indicator bar. |
| **Autofix**                                 | Provides a link to a preference panel that enables you to adjust the color highlighting errors and warnings that MATLAB can autofix.  
You trigger autofix by clicking the Fix button in a Code Analyzer message. |
<table>
<thead>
<tr>
<th>Option</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Active Settings</strong></td>
<td>Select the set of message settings to use. Click the down arrow to select or browse to a previously saved settings file.</td>
</tr>
<tr>
<td><strong>Actions button</strong></td>
<td>Click to open a menu that enables you to select:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Save as</strong> — Saves the current Code Analyzer message settings to a file.</td>
</tr>
<tr>
<td></td>
<td>The default location for settings is the MATLAB preferences folder (the folder returned when you run <code>prefdir</code>).</td>
</tr>
<tr>
<td></td>
<td>• <strong>Restore Defaults</strong> — Restores default Code Analyzer message settings.</td>
</tr>
<tr>
<td><strong>Search field</strong></td>
<td>Searches the list of Code Analyzer messages that display below the search field. For details, see “Searching Messages in the Code Analyzer Preferences Dialog Box” on page 7-17.</td>
</tr>
<tr>
<td><strong>Code Analyzer message settings</strong></td>
<td>Select or clear messages to enable or suppress their appearance in your Editor documents.</td>
</tr>
<tr>
<td></td>
<td>To suppress a message on a line-by-line or file-by-file basis, see “Adjust Code Analyzer Message Indicators and Messages”.</td>
</tr>
</tbody>
</table>

**Searching Messages in the Code Analyzer Preferences Dialog Box**

You can search the list of Code Analyzer messages in the Preferences dialog box to display only those messages that are currently of interest to you. Use any combination of the methods that the following table presents.

**Note** If you do not have the MATLAB Compiler™ installed, the Code Analyzer preferences pane does not display the MATLAB Compiler (deployment) messages category.
<table>
<thead>
<tr>
<th>To See a List of Messages ...</th>
<th>Perform this action...</th>
<th>Example Scenario</th>
</tr>
</thead>
<tbody>
<tr>
<td>Containing specified text in the:</td>
<td>Type the text in the search field.</td>
<td>You recall seeing a message containing some text that you want to review, but you cannot remember the exact message text. For example, type <code>com</code> in the search field to display those messages that contain that text in the short message, extended message, or message ID.</td>
</tr>
<tr>
<td>• Short message</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Extended message</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Message category</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Message ID</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Corresponding to a given message ID</td>
<td>Type <code>msgid:</code> followed by the message ID in the search field.</td>
<td>You are reviewing the code that someone else wrote and you want to see the message that corresponds to a suppressed one using the <code>%#ok&lt;AGROW&gt;</code> directive. Type <code>msgid:agrow</code> in the search field. Messages IDs containing AGROW display as links. Click each link for more information about the message. Not all Code Analyzer messages have additional information. These messages do not appear as links.</td>
</tr>
<tr>
<td>That you can set using Code Analyzer preferences</td>
<td>Click the down arrow to the right of the search field, and then click <strong>Show All</strong>.</td>
<td>You want to see the complete list of messages after you have searched the messages for some text or a given search menu option.</td>
</tr>
<tr>
<td>To See a List of Messages ...</td>
<td>Perform this action...</td>
<td>Example Scenario</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>------------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Different from the default setting (of enabled or disabled)</td>
<td>Click the down arrow to the right of the search field, and then click <strong>Show Messages Modified from Default</strong>. A gray dot precedes a message with a setting different from the default. For example: <img src="image" alt="DATENUM(NOW)" /></td>
<td>A coworker gave you a settings file and you want to review each message that the coworker changed from its default setting.</td>
</tr>
<tr>
<td>In a given category</td>
<td>Click the down arrow to the right of the search field, click <strong>Show Messages in Category</strong>, and then click the category you want.</td>
<td>You want to review messages that describe coding practices that make it difficult for others to use your code. Click the down arrow to the right of the search field, select <strong>Show Messages in Category</strong>, and then select <strong>Aesthetics and Readability</strong>. Click the messages that appear as links for more information. Not all messages appear as links.</td>
</tr>
<tr>
<td>That are warnings</td>
<td>Click the down arrow to the right of the search field, and then select <strong>Show All Warnings</strong>. An exclamation point in a yellow triangle indicates a warning message.</td>
<td>You recall previous warnings that your code generated, but you cannot remember enough details to use the search field to find it. You want to skim all the warning messages to find a particular one of interest.</td>
</tr>
</tbody>
</table>
To See a List of Messages ...

<table>
<thead>
<tr>
<th>Perform this action...</th>
<th>Example Scenario</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Are errors</strong></td>
<td>You want to find a message elicited by a script you worked on previously. All you can recall is that it was an error and it involved <code>parfor</code>.</td>
</tr>
<tr>
<td>Click the down arrow to the right of the search field, and then select <strong>Show All Errors</strong>. By default, an X in a red dot indicates an error message, 🔄.</td>
<td>Click the down arrow to the right of the search field, and then select <strong>Show All Errors</strong>. Then, type a space and <code>parfor</code> in the search field.</td>
</tr>
<tr>
<td><strong>Are disabled</strong></td>
<td>You want to see the messages that are disabled by default or you have previously disabled.</td>
</tr>
<tr>
<td>Click the down arrow to the right of the search field, and then select <strong>Show Disabled Messages</strong>.</td>
<td>The Code Analyzer preference pane displays only error messages that contain the word <code>parfor</code>.</td>
</tr>
</tbody>
</table>

**Example of Searching Messages**

To display Code Analyzer error messages that contain the word `variable` and are disabled:

1. Click the down arrow in the search field, and then select **Show All Errors**.

   The search field contains `severity:error`.

2. At the end of the text `severity:error`, press the **Space** key, and then type `variable`.

3. Click the down arrow in the search field and select **Show Disabled Messages**.

   The search field now contains `severity:error variable enabled:false`. Only the messages that fulfill those requirements appear in the Preferences pane.

   To restore the list of all messages, click the clear search button `×`. 
Get and Manage Add-Ons

Add-ons encompass a wide variety of resources, including products, apps, support packages, and toolboxes. They extend the capabilities of MATLAB with functionality for additional tasks and applications.

**Get Add-Ons**

To find and install add-ons, go to the **Home** tab and, in the **Environment** section, click the **Add-Ons** icon. The Add-On Explorer opens and displays the list of available add-ons.
To find add-ons, use the search bar, or browse through the available categories on the left side of the Add-On Explorer window. Select an add-on from the list to view additional information about it, such as what files it includes and what documentation is available.

To install an add-on, select it from the list. Then, select from the available install actions. After you install an add-on, MATLAB manages the MATLAB path for you. This lets you start using it without adjusting your desktop environment.

For some add-ons, you also can download the files from the Add-on Explorer without installing them. This is useful if you want to install the add-on on a system without an internet connection. To download the add-on without installing, select **Install > Download Only**.

**Install Add-Ons from File**

You can install some add-ons manually using an installation file. This is useful in several situations:

- The add-on is not available for installation through the Add-On Explorer, for example, if you create a custom add-on yourself or receive one from someone else.
• You downloaded the add-on from the Add-On Explorer without installing it.
• You downloaded the add-on from the File Exchange at MATLAB Central™.

Valid add-on installation files include .mltbx files (for toolboxes), .mlappinstall files (for apps), and .mlpkginstall files (for hardware support packages). To install an add-on from one of these files, in the MATLAB Current Folder browser, double-click the file. An installer opens to guide you through the installation process.

**Note** Make sure to double-click the installation file in the MATLAB Current Folder browser. Double-clicking to install the add-on from the system file browser is not supported on all operating systems.

You also can install some add-ons programmatically. For more information, see `matlab.addons.install`.

**Default Add-On Installation Folder**

The install location of an add-on depends on its type. MATLAB installs MathWorks products in the `matlabroot` folder and hardware support packages and some additional packages in a custom location specified by the package. For more information about a specific support package install location, see the documentation for the package.

MATLAB installs all other add-ons in a default installation folder specific to the platform.

• Windows— `C:\Users\username\AppData\Roaming\MathWorks\MATLAB_Add-Ons`
• Linux — `~/.MATLAB_Add-Ons`.
• Mac — `~/Library/Application Support/MathWorks/MATLAB_Add-Ons`

MATLAB Online — `/MATLAB_Add-Ons`

To change the default installation folder:

1. On the **Home** tab, in the **Environment** section, click **Preferences > MATLAB > Add-Ons**.
2. In the **Installation Folder** field, specify a folder name to which you have write access.
If you change the default installation folder, add-ons installed in the previously selected folder are no longer accessible from within MATLAB. Changing the default installation folder or customizing installed add-ons is not supported in MATLAB Online.

**Manage Add-Ons**

To view and manage installed add-ons, go to the **Home** tab and select **Add-Ons > Manage Add-Ons**. The Add-On Manager displays all add-ons that are installed in the add-ons installation folder, as well as MATLAB products and hardware support packages.

To manage an individual add-on, click the options button † to the right of the add-on and select from the available actions:

- **Open Folder**
- **Open Documentation**
- **View in Add-on Explorer**
- **View Getting Started Guide**
- **Setup**
- **Version**
- **Enabled**
- **Uninstall**

Not all actions are available for all add-ons.

To customize your MATLAB environment, use the **Enabled** action to enable and disable add-ons. You also can enable or disable add-ons using the `matlab.addons.enableAddon` and `matlab.addons.disableAddon` functions.

If an add-on has multiple versions installed, only one version can be enabled. To view the currently enabled version, select **Version**. MATLAB displays a check mark next to the currently enabled version. To enable a different version, click it. For more information about installing multiple versions of an add-on, see `matlab.addons.install`.

**Update Add-Ons**

You can update installed add-ons as well as your current installed version of MATLAB using the Add-On Manager. On the **Home** tab, click **Help > Check for Updates**.
Add-On Manager opens with the **Updates** tab selected. View and install any available updates.

**Run Apps**

An app is a self-contained MATLAB program with a user interface. To view and interact with the user interface after installing the app, run it. Go to the **Apps** tab and expand the apps gallery by clicking the down arrow ▼ on the far right. Then, navigate to your installed app and click the icon. Custom apps that you write or receive from someone else appear in the **My Apps** section. You can run multiple custom apps concurrently, including multiple instances of the same app.

**See Also**

- `matlab.addons.enableAddon`
- `matlab.addons.install`
- `matlab.addons.installedAddons`
- `matlab.addons.isAddonEnabled`

**Related Examples**

- “Package Apps From the MATLAB Toolstrip”
- “Create and Share Toolboxes”
Internationalization

- “Locale Settings for MATLAB Process” on page 9-2
- “Limitations to International Character Support” on page 9-4
- “Set Locale on Windows Platforms” on page 9-5
- “Set Locale on macOS Platforms” on page 9-7
- “Set Locale on Linux Platforms” on page 9-9
- “Unexpected Behavior on macOS Platforms” on page 9-10
- “Characters Incorrectly Displayed on Windows Systems” on page 9-11
- “datenum Might Not Return Correct Value” on page 9-12
- “Numbers Display Period for Decimal Point” on page 9-13
- “File or Folder Names Incorrectly Displayed” on page 9-14
- “Script Compatibility” on page 9-15
- “MATLAB Desktop Language Preference“ on page 9-16
- “X Servers and International Keyboard Layouts” on page 9-17
Locale Settings for MATLAB Process

The locale setting defines the language of your user interface and the display formats for information like time, date, and currency. MATLAB uses the user-specified locale on all platforms.

If MATLAB does not correctly display characters in your language, you might have a locale setting problem. Locale is composed of individual settings which you can control. Each platform uses different parameters to specify the locale setting. The following terms are relevant to understanding locale settings.

- **locale** — Format: `language_territory.codeset`

  For example, for the U.S. English locale setting `en_US.US-ASCII`, `en` means that the display language is English. `US` indicates that time and date displays use U.S. conventions. `US-ASCII` is the coded character set (codeset) used to display text.

- **character set** — Set of characters that make up a language used by a region. The MATLAB supported character set is the character set specified by the user locale setting.

- **codeset** — Abbreviation for *coded character set*. A set of characters with a unique numerical value assigned to each character.

- **encoding** — Scheme for assigning numerical values to a character set to create a codeset.

- **7-bit ASCII** — Either the codeset or the characters contained in that codeset. There are 128 characters, which include letters, digits, symbols, control characters, and graphics characters. The term *ASCII* in MathWorks documentation is the same as *7-bit ASCII*.

- **Unicode** — Character codeset. Excerpt from the unicode.org website: “Unicode® provides a unique number for every character, no matter what the platform, no matter what the program, no matter what the language.”

- **user locale setting** — Setting on your computer that specifies the locale that you want to use when running MATLAB. If your user-specified locale is not supported, MATLAB uses the default locale `en_US_POSIX.US-ASCII`. 
• system locale setting — Setting on Microsoft Windows platforms. The user locale and system locale must be the same value. If these values are not the same, you might see garbled text or incorrectly displayed characters.
• i18n — Short for the word internationalization, where 18 stands for the number of letters between the letters i and n.

**Default Locale Setting**
MATLAB does not support every locale setting. If the user-specified locale is unsupported, MATLAB uses the default locale en_US_POSIX.US-ASCII, also known as C locale.

**Supported Character Set**
MATLAB supports the character set specified by the user locale setting.

**Platform-Specific Localized Formats for Current Folder Browser**
In the Current Folder Browser, MATLAB usually uses platform-neutral localized formats and rules. You can, however, use the operating system short date format to control the format for displaying file date and time data.

**See Also**

**Related Examples**
• “Set Locale on Windows Platforms” on page 9-5
• “Set Locale on macOS Platforms” on page 9-7
• “Set Locale on Linux Platforms” on page 9-9
Limitations to International Character Support

MATLAB does not support non-7-bit ASCII characters in the following features:

- MATLAB C/C++ and Fortran engine library functions and the \texttt{loadlibrary} function cannot find files located in folder names that contain non-7-bit ASCII characters.
- MATLAB C/C++ and Fortran engine library functions and the \texttt{calllib} function used to call C library functions cannot convert Unicode-compatible input arguments of type \texttt{char*} to MATLAB character arrays.
- The \texttt{matlab.wsdl.createWSDLClient} function cannot read non-7-bit ASCII characters in Web Services Description Language (WSDL) documents.

When you have a file containing text that has characters in a different encoding than that of your platform, when you save or publish your file, MATLAB displays those characters as garbled text.
Set Locale on Windows Platforms

MATLAB reads the user locale and system locale on Windows platforms. The user locale and system locale must be the same value. If these values are not the same, you might see garbled text or incorrectly displayed characters.

MATLAB does not support every locale setting. If your locale is not supported, MATLAB uses the default locale `en_US_POSIX.US-ASCII`, also known as C locale.

When you change the system locale, restart your system; otherwise, you might see unexpected behaviors.

Locale on Windows 10 Platforms

The following instructions are based on Version 10.0.16299 Build 16299. Refer to your version of Windows 10 documentation for information about setting region information using the Settings app.

1. From **Time & Language**, select **Region & language**.
2. Under **Related Settings**, select **Additional date, time, & regional settings**.
3. Select **Region** to change location.
4. On the **Formats** tab, select a target locale from the **Format** drop-down list, and then click **Apply**. This action sets the user locale.
5. On the **Administrative** tab, click the **Change system locale...** button.
6. Select a target locale from the **Current system locale** drop-down list. This action sets the system locale.
7. Exit each dialog box by clicking the **OK** buttons.
8. Restart the system.

Locale on Windows 8 Platforms

To open the **Control Panel**, use Microsoft Windows 8 documentation.

User Locale

1. From the **Control Panel**, select **Clock, Language, and Region > Region**.
2. Open **Formats** tab.
3 Select a target locale from the **Format** drop-down list.

**System Locale**

1 From the **Control Panel**, select **Clock, Language, and Region > Region**.
2 Open **Administrative** tab.
3 Look in the **Language for non-Unicode programs** section.
4 Click **Change system locale...** button.
5 Select a target locale from the **Current system locale** drop-down list.
6 Restart the system.

**Locale on Windows 7 Platforms**

**User Locale**

1 Select **Start > Control Panel > Clock, Language, and Region > Region and Language**.
2 Open **Formats** tab.
3 Select a target locale from the **Format** drop-down list.

**System Locale**

1 Select **Start > Control Panel > Clock, Language, and Region > Region and Language**.
2 Open **Administrative** tab.
3 Look in the **Language for non-Unicode programs** section.
4 Click **Change system locale...** button.
5 Select a target locale from the **Current system locale** drop-down list.
6 Restart the system.
Set Locale on macOS Platforms

On the Apple macOS platform, MATLAB reads the user locale setting. MATLAB automatically chooses a codeset for each combination of language and territory.

If you customize the locale setting, MATLAB ignores the customized portion. MATLAB ignores the LANG environment variable and the Terminal application locale setting.

MATLAB does not support every locale setting. If your locale is not supported, MATLAB uses the default locale en_US_POSIX.US-ASCII, also known as C locale.

To view or set the region on Mac OS X 10.10:

1. Select System Preferences > Language & Region.
2. Select a region and country from Region.

To set the Primary language:

1. In the Language & Region dialog box, either drag an existing item to the top of the Preferred languages list, or select the + button to add a language and then drag the language to the top.
2. MATLAB detects the latest setting; you do not need to restart your system.

Changing the preferred language might change the locale to a value that MATLAB does not support. When this happens, you might see garbled text or incorrect characters. To fix this problem, change the Format language value:

1. In the Language & Region dialog box, change the Preferred languages value to the original value.
2. Click the Advanced... button, and make note of the Format language value.
3. Click OK.
4. Change the Preferred languages value back to your preferred language.
5. Click the Advanced... button again. If the Format language value changed, reselect the original language value.
See Also

External Websites

- Why does MATLAB fail to load my preferred language on macOS Sierra?
Set Locale on Linux Platforms

Use the LANG environment variable to specify the locale to be used by MATLAB.

MATLAB does not support every locale setting. If your locale is not supported, MATLAB uses the default locale en_US_POSIX.US-ASCII, also known as C locale.

See Also

More About
• “Numbers Display Period for Decimal Point” on page 9-13
Unexpected Behavior on macOS Platforms

If you customize the locale setting, MATLAB ignores the customized portion.

MATLAB ignores the LANG environment variable and the Terminal application locale setting.

See Also

Related Examples

- “Set Locale on macOS Platforms” on page 9-7
Characters Incorrectly Displayed on Windows Systems

The user locale and system locale must be the same value on the Microsoft Windows platform. If these values are not the same, you might see garbled text or incorrect characters.

See Also

Related Examples
•  “Set Locale on Windows Platforms” on page 9-5
datenum Might Not Return Correct Value

The results of the `datenum` function vary depending on the locale. To ensure the correct calculation of functions using date values associated with files and folders, replace `datenum` function calls with the use of the `dir` function `datenum` field.

For example, look at the modification date of your MATLAB `license_agreement.txt` file:

```matlab
cd(matlabroot)
f = dir('license_agreement.txt')
```

MATLAB displays information similar to:

```matlab
f =
    name: 'license_agreement.txt'
    date: '10-May-2015 17:48:22'
    bytes: 5124
    isdir: 0
    datenum: 7.3317e+005
```

If your code uses the `date` field of the `dir` command, similar to:

```matlab
n = datenum(f.date);
```

replace it with the `datenum` field:

```matlab
n = f.datenum;
```

See Also

dir
Numbers Display Period for Decimal Point

MATLAB reads the user locale for all categories except for the numeric category (which is equivalent with LC_NUMERIC). This category controls numeric data formatting and parsing. MATLAB always sets LC_NUMERIC to the C locale.

MATLAB uses a period for a decimal point, regardless of the format specified by the user locale. For example, the value of pi can be displayed as \(3,1416\) or \(3.1416\), depending on the format used by a locale. MATLAB always displays \(3.1416\).

The MATLAB language reserves the use of commas to the cases described in the Symbol Reference topic.

See Also

More About

- Symbol Reference: Comma
File or Folder Names Incorrectly Displayed

On Windows and Linux platforms, characters used in file or folder names must be in the supported character set.

On macOS platforms, for files and folders used by MATLAB, characters in the file or folder name must be in the 7-bit ASCII character set.

See Also

More About

• “Locale Settings for MATLAB Process” on page 9-2
Script Compatibility

Non-7-bit ASCII characters in plain text files, such as MATLAB scripts or functions, created with one locale setting might not be compatible with a different locale setting. This can happen when a script written on a Windows platform is run on a Linux platform, because the platforms use different default locale settings.

For example, if you create a script with the ja_JP.UTF-8 locale setting on a Linux system, the script might not be compatible when executed on a Windows platform with the Japanese_Japan.932 locale setting.
MATLAB Desktop Language Preference

MathWorks provides localized versions of MATLAB for selected non-English platforms. For these products only, you can choose the language in which the MATLAB desktop appears. Desktop items (such as dialog boxes, button names, and menu items) and error and warning messages appear in the language that you select. For information about this preference, see the Desktop language (selected non-English systems only) option in the General Preferences panel. If you change the preference, the change applies only to the MATLAB desktop.

Most desktop elements and Apps use the language selected in the Desktop language preference. However, system dialog messages, such as file selectors or color pickers, use the operating system display language.

See Also

More About

• “Translated Documentation” on page 4-16
• “General Preferences” on page 2-44
**X Servers and International Keyboard Layouts**

Simulink requires the *XKEYBOARD* extension to detect the keyboard layout that is currently active. Some older X servers do not support this extension. If this extension is absent or disabled, then Simulink assumes a default layout. When the default layout does not match the keyboard layout, some keys might not produce the expected characters.

Suppose you are using a Linux based computer with a German keyboard. Without the *XKEYBOARD* extension, Simulink uses the default layout, which is English, and can therefore produce incorrect characters. MATLAB correctly recognizes the keyboard as German.

If you encounter this issue, try enabling the *XKEYBOARD* extension, or use an X server that supports this extension.
MATLAB Online
Restore Files in MATLAB Online

MATLAB Online provides access to MATLAB from a standard web browser. In MATLAB Online, each time you save a program file, MATLAB stores the contents of your program in the version history. To recover a previous version of a file, select the File Versions tab.

The file version history appears, as shown in the following figure.

Browse for the file you want by selecting from the list, or by clicking Older or Newer. When you find the file, click Restore as Latest. MATLAB adds the restored file to the top of your history with a new timestamp and version number.

See Also

More About

- “Share Folders in MATLAB” on page 6-36
- “Manage Files and Folders” on page 6-32
Post-Installation Tasks
Configure the MATLAB Startup Accelerator

When you install MathWorks products on your computer, the installation includes a utility program that can speed up MATLAB startup, called the MATLAB Startup Accelerator. By default, the installer configures this utility as a scheduled task on your computer that runs several times each day. (For information about changing this default behavior, see “Install Without Configuring the MATLAB Startup Accelerator” (Installation, Licensing, and Activation).)

While you are not required to modify this configuration, the startup accelerator works best if you coordinate when it runs with your particular MATLAB usage patterns. For example, by default, the startup accelerator runs at 8:00 a.m. and again at 1:00 p.m. every day, or whenever you log on to your computer. To take full advantage of the startup accelerator, schedule it to run at a time just before you typically start MATLAB.

To modify this configuration, use the Windows Task Scheduler. In the Windows Task Scheduler, these start times are called triggers. You can modify these triggers to customize when the startup accelerator runs. You can also add triggers, delete triggers, or delete the startup accelerator task completely. The following section shows how to change when the startup accelerator runs using the Windows Task Scheduler. For more information about the Task Scheduler, see Windows documentation.

Change When the MATLAB Startup Accelerator Runs

To change when the MATLAB Startup Accelerator runs on your computer, use the Windows Task Scheduler.

1  Start the Windows Task Scheduler.

   On the Windows Start menu, search for the phrase “task scheduler” and press Enter.

2  Click Task Scheduler Library in the Console tree to view scheduled tasks and double-click the name of the startup accelerator to change the configuration.
3 To change when the task is scheduled to start, click the Trigger tab in the task properties dialog box. In the list of triggers displayed, select the trigger you want to change, and click **Edit**.
To change the time the task is scheduled to run, enter a new time and click **OK**.

4 Select trigger that you want to edit.

Click **Edit** to modify the trigger.
Configure the MATLAB Startup Accelerator

Change the trigger schedule time.

Click OK.