Main Content

Project System

A project folder contains assets (such as 3D models and texture maps) that are shared by multiple RoadRunner scenes.

Project assets include various components that are created from files such as 3D models, texture maps, and vector graphics. They also include various files specific to RoadRunner, such as materials and road marking styles.

A current project is always active in RoadRunner. When you run RoadRunner, you must select or create a project. The current project is displayed on the Title Bar.

Most projects contain the default assets included with RoadRunner. These assets include a small assortment of materials, models, and other assets. You can also separately purchase the RoadRunner Asset Library, which comes with a large array of generic and country-specific assets.

A fire hydrant asset from the RoadRunner Asset Library selected in teh Library Browser and displayed in the 2D Editor.

The Project Folder

A project folder contains these subdirectories:

  • The Project directory contains a single file named "Project.rrproj", which defines a unique reference ID for the project. This file should not be modified or moved.

  • The Scenes directory stores individual scenes that use this project (refer to Scenes). When you first create a project, this folder contains several sample scenes. When you save a new scene, RoadRunner defaults to this directory.

  • The Exports directory is the default location to write out exported data from RoadRunner, so this directory is empty when a project is first created. You are not required to use this directory for exported data. For more information, see Exporting.

  • The Assets directory stores all asset files available for use in a scene. These assets appear in the Library Browser.

Note

It is recommended that you place the entire project folder under version control. Refer to Project and Scene Version Control.

Asset Types

RoadRunner supports a variety of asset types. For a full list, refer to Assets.

Asset Metafiles

For every asset within the "Assets" directory tree, RoadRunner automatically creates an associated metafile with the ".rrmeta" file extension.

The metafile contains additional data associated with the asset, the details of which vary for different asset types. The metafile also contains a unique ID that can be used to identify a specific asset (even if the asset is renamed or moved into a different directory within the "Assets" tree).

This file should always be kept in the same location as the asset itself. Asset operations performed with the Library Browser automatically update the corresponding metafiles.

Create a New Project from the Start Page

  1. Open the RoadRunner application.

  2. Click the New Scene button on the Start Page. Another menu will appear asking you to select a project.

  3. In this second menu, click the New Project button. A file browser will appear asking you to select a directory in which to create the project.

    Note

    If you create a project that is on a network drive, changes made to asset files might not be automatically reflected in the Library Browser. In addition, performance might be slower. For improved performance and full Library Browser functionality, create a project on a local disk.

  4. In the file browser, choose (or create) an empty directory in which to create your project.

  5. In the dialog box, select whether to install the RoadRunner Asset Library assets in your project. If you have a RoadRunner Asset Library license, click Yes to populate the Assets folder with the library assets. If you do not have a license, this option is disabled. Instead, click No to populate the Assets folder with a set of default assets included with RoadRunner.

Create a New Project from Within RoadRunner

  1. Select File > Change Project on the Main Menu. A menu will appear asking you to select your project.

  2. Jump to step 3 in the Create a New Project from the Start Page section.

Change the Current Project

  1. Select File > Change Project on the Main Menu. A menu will appear asking you to select your project.

  2. If your project is listed on the "Recent Projects" list, then select it directly. Alternatively, click the Open Project button to open a file browser and select your project.

  3. Choose the root directory of the existing project to which you want to switch. This action changes the current project and creates a new scene.

Create, Modify, and Delete Assets

Refer to the Library Browser documentation.

Save the Current Project

Modified assets are not saved until the current project is saved. To save the current project, select the File > Save Project menu option. Alternatively, save your current scenes, and the current project will save automatically.

Related Topics