MATLAB Answers

1

Trouble installing 2014a on Mavericks

Asked by Joseph Areeda on 23 Mar 2014
Latest activity Commented on by Walter Roberson
on 15 Feb 2015
I have upgraded to Mavericks.
When trying to install 2014a, I get an error.
The installer makes it through login to Mathwork, selecting the license (a TAH if that makes a difference) it verifies the license but after asking for the installation path, the products to install, when I hit the install button almost immediately it says:
The application encountered an unexpected error and needs to close. You may want to try re-installing your product(s). More information can be found at /var/folders/7_/q1v63_1s55b09v3x90rkr0ym0000gn/T/mathworks_areeda.log
The relevant information from the log file is:
Statistics Toolbox 9.0 Symbolic Math Toolbox 6.0
(Mar 22, 2014 19:14:39) java.lang.NullPointerException at com.mathworks.install.ComponentSizeAggregator.add(ComponentSizeAggregator.java:13) at com.mathworks.install.ProductInstallerImpl.downloadProducts(ProductInstallerImpl.java:96)
There is plenty of disk space, I've tried with the Mac JDK 8 and the latest Oracle (7.51). I've downloaded several times and the md5 sum matches. I downloaded and installed it on a mt. lion imac and scientic linux and every thing in fine on the other systems.
I've run out of ideas and would appreciate any suggestions.
Thanks, Joe

  5 Comments

Got something similar (with Mavericks) so I reduced the toolboxes to:
MATLAB, Curve Fitting Toolbox,Signal Processing Toolbox, Statistics Toolbox
and all is fine.
The issue may be with specific toolboxes - but I didn't investigate.
Thanks for the comments.
Walter: I did get 2014a to install on Mt. Lion with all the toolboxes. I did have a similar issue with NetBeans that I was able to resolve by specifying which JDK to use.
Malcolm: I think you're onto something. I'll go try a minimal subset of toolboxes, the University license has many that I don't use.
I suspect it's the Java version but I haven't figured out how to override the Apple installation with Oracle's.
I'll report back.
Edit: Well my problems seems to be a bit different. Just choosing Matlab still fails with the same error.
Joseph MATLAB is bundled with Java 7 on the Mac from R2013b onwards. Not sure if MATLAB_JAVA has any affect (as on Windows). I have 6, 7 and 8 on my Mac. Default at install was 8. MATLAB runs with the bundled version by default.
Check java -version at the system terminal. I guess there could be an issue if the installer is using 6.
Sounds like an issue for TMW support.

Sign in to comment.

Products

1 Answer

Answer by the cyclist
on 24 Mar 2014
Edited by the cyclist
on 24 Mar 2014
 Accepted Answer

I am guessing you had the 2014a prerelease version downloaded. You need to delete the old version from both the Applications directory and the Downloads directory (which I can infer from you message is probably /Users/areeda/Downloads).
I don't think this is related to the Java/Retina/font/rendering issues that the latest versions of MATLAB have.

  10 Comments

I moved System/Library/Java/JavaVirtualMachines/ aside and specifically installed Java 8 Runtime from Oracle, but it did not make any difference, I still get the same error.
@Walter
Then I am at a loss. I have a working installation on Mavericks as described above.
It is just possible (but unlikely) that the system default Java was v7 at the time of the install a couple of weeks ago (in which case it could have been u51 or the u60 early access as I have both on the system).
Sorry not to be more helpful.
ML
I think I just tracked this to there being a Mathworks directory in my Downloads directory, that the installer had loaded files into, including from R2014a pre-release. Once I trashed that, I was able to proceed with the download and install on Yosemite. I had, per the cyclist, removed the pre-release installer, but I did not look before for the possibility that files from that former install were in some other directory.

Sign in to comment.