MATLAB Answers

What is MathWorks’ response to the Heartbleed security vulnerability?

9 views (last 30 days)
The Heartbleed security vulnerability was disclosed on Monday, April 7, 2014. Heartbleed exposes a vulnerability in OpenSSL (a widely used cryptographic library that supports private communications across the Internet). How does the OpenSSL Heartbleed bug affect MathWorks and its products?

Accepted Answer

MathWorks Support Team
MathWorks Support Team on 15 Apr 2014
We have patched our web site to eliminate the OpenSSL bug and we have no evidence that this threat has affected MathWorks site users. But as a precaution, you may want to change your MathWorks Account password.
In addition, MathWorks products, including MATLAB, Simulink and add-ons, do not use the OpenSSL library and are not affected by the vulnerability, with the exception of MATLAB Production Server.
OpenSSL is used by the MATLAB Production Server product in releases R2013b+ and R2014a for the optional support of the HTTPS protocol for secure client-server communication. If you use or intend to use this feature, please check the bug report 1072344 for a patch.

  0 Comments

Sign in to comment.

More Answers (0)

Sign in to answer this question.