Host target Communication lost once target PC is booted into the xPC environment

6 views (last 30 days)
Hi all,
The communication between my host and target PC is lost everytime I boot the target PC into the xPC environment. I've tried 3 ways of booting - FDD, network, and CD boot - and all gave the same result. However, in the windows environment, the communication works well.
I purchased an EXPI9301CTBLK Intel Gigabit CT Desktop Adapter ) and plugged it into the PCIe slot. This card has Intel 82574L gigabit ethernet controller. I also checked 'Device Instance ID' for the device which are; vendor = 0x8086 and device ID = 0x10D3. Hence, I'm sure it's compatible. This card is properly installed and it works well in the windows environment (I used it for internet too).
I've also tried to adjust the BIOS setting for the target PC under Peripherals'>Onboard device>Onboard LAn boot Rom and disable it. I thought to disable the onboard ethernet. It still doesn't work.
I've seen this solution to a problem which is very similar to mine: but... it still doesn't work. =(
Any ideas anyone?
Here are some details of my comps.
Dell laptop - Intel core i7 CPU, Intel 82577LM gigabit network adapter, Windows 7.
Target PC:
Desktop Shuttle XPC - SG33G50 motherboard with built in Generic MArvell Yukon 88
Here are some info perhaps useful to you:
??? Error using ==> AutoConnect at 7
Message: A connection attempt failed because the connected
party did not properly respond after a period of time, or
established connection failed because connected host has failed
to respond
Source: System
Error in ==> getxpcpci>getInstalledPCI at 294
Error in ==> getxpcpci at 123
>> getxpcenv
xPC Target default environment
Version : 5.0
CCompiler : VisualC
CompilerPath : C:\Program Files\Microsoft Visual Studio 10.0
Name : TargetPC1
TargetRAMSizeMB : Auto
MaxModelSize : 1MB
SecondaryIDE : off
NonPentiumSupport : off
MulticoreSupport : off
HostTargetComm : TcpIp
RS232HostPort : COM1
RS232Baudrate : 115200
TcpIpTargetAddress :
TcpIpTargetPort : 22222
TcpIpSubNetMask :
TcpIpGateway :
TcpIpTargetDriver : I8254x
TcpIpTargetBusType : PCI
TcpIpTargetISAMemPort : 0x300
TcpIpTargetISAIRQ : 5
TargetScope : Enabled
xPC Target Embedded Option
EmbeddedOption : Enabled
TargetBoot : NetworkBoot
TargetMACAddress : 00:1b:21:ad:8e:70
BootFloppyLocation :
CDBootImageLocation : C:\Users\ang.cs\Desktop
DOSLoaderLocation :

Accepted Answer

Sangyoon Lee
Sangyoon Lee on 31 Jul 2014
I was having the same issue where the target machine will just black out after recognizing the boot image. It turns out, just unchecking the "USB support" option from the target settings was the magic key for my problem.

More Answers (2)

Arnaud Miege
Arnaud Miege on 29 Jul 2011
Are the host and target connected directly or through a network? If directly, you need to use a cross-over cable.
Also, did you check that the gateway ( is the same on both host and target computers? It seems to me that you've left the default value. It needs to match what's on your host computer.
Can you ping the target using the ping command in DOS when the target is booted with xPC Target? If not, then there's something wrong with the TCP/IP settings, and there's no point in trying to connect to the target from MATLAB.
James on 6 Aug 2011
Thanks Arnaud and Walter for the answers. Will get back to you soon if this works.
James on 22 Aug 2011
Hi Arnaud,
Sorry for the late reply. Was away for a while.
I've changed the 'xpcexplr' gateway to, similar to that on the host PC. The target PC boots into the xPC environment but when I ping from the host PC (on DOS), it's not successful.
any ideas?
Could it be the bios setup?

Sign in to comment.

Reto Rüegg
Reto Rüegg on 24 Apr 2012
Hello all,
have someone solved this problem? It seems, that I'm stucking in the same situation...

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!