MATLAB Answers

1

geotiffread and MultiLayer images

Asked by Mohammad Abouali on 14 Aug 2014
Latest activity Answered by Daan Poppema on 4 Sep 2019
Hi,
When I try to read multi layer geotiff images using geotiffread, I receive an error that the multiple image in that geotiff are not of the same size.
This is how I tried to read the image
[I,R]=geotiffread('filename.tif')
or
[I,R]=geotiffread('filename.tif',1) % to force read only the first layer.
I can read them just fine with the imread and using the imfinfo I manually create R myself. But I think this is a bug that needs to be addressed in geotiffread.
MATLAB is correct about the multiple images not having the same size. The fact is that those other images/layers are the pyramid or overview layers. However, that does not make any sense that geotiff read not be able to read the specified layer from the file and complaining about it.
Here is the error:
Error using geotiffinfo>readinfo (line 261)
Multiple images exist in the file and their sizes are different.
Error in geotiffinfo (line 241)
info = readinfo(filename);
Error in geotiffread (line 78)
info = geotiffinfo(filename);

  7 Comments

I have this problem too, please let me know the answer if anyone had solved it.Thank you!
It's because the photoscan exported images contain multiple layers with different sizes. See the link for detailed solution. https://cosmojiang.wordpress.com/2018/04/02/matlab-geotiffread-for-multiple-layers/
@ Yu Jiang Thanks for posting your workaround. Even with your changes, I still got an error, which I fixed by implementing the following code into geotiffinfo.m (search for first line and a half to find relevant section)
tagName = 'GeoKeyDirectoryTag';
if isfield(geoTiffTags, tagName) & tagName~='GeoKeyDirectoryTag' %add this second part after the & symbol
[geoTiffTags.(tagName)] = deal(translateGeoKeyDirectoryTag(geoTiffTags(1)));
end

Sign in to comment.

2 Answers

Answer by Matthew Cooper on 22 Nov 2016

I had the same problem with a DEM I generated using Agisoft Photoscan software. To solve the problem, I loaded the DEM into ArcMap and then I exported the DEM. This is an annoying work around but it solved the problem for me - I was able to read the exported DEM into Matlab. I have actually used this workaround to solve a few other incompatibility issues between various geospatial analysis software and Matlab, namely issues involving "no data" values. Arc does something when it exports the DEM that makes the exported DEM compatible with geotiffread.

  1 Comment

Ihe another band in the tif file is mask_file or external rectangle consist of 0 or 255.

Sign in to comment.


Answer by Daan Poppema on 4 Sep 2019

I had the same problem with DEM's from Agisoft Photoscan/Metashape. Unfortunately the solutions above did not work for me. In the end, my workaround is changing the settings in Agisoft during DEM export. If you deselect 'write tiled TIFF' (for the pyramid scheme) and deselect 'Generate TIFF overviews' in Agisoft, the resulting tiff only contains 1 image and you don't get an error in Matlab.

  0 Comments

Sign in to comment.