MATLAB Answers

Philip
0

Intel® Parallel Studio XE 2015 for Fortran

Asked by Philip
on 30 Sep 2014
Latest activity Answered by Xiangcheng Lee on 20 Jun 2018
I would like to use Intel Visual Fortran Composer XE 2015 for Fortran along with Microsoft Visual Studio 2013 Professional to compile Fortran code into mex files. Currently MATLAB only supports Intel Visual Fortran Composer XE 2013 for Fortran along with Microsoft Visual Studio 2012 Professional. Is there a way I can edit the mex options so MATLAB recognizes the new compilers? Thanks for the help.

  1 Comment

Not using the supported compilers might work, but is a recipe for many sleepless nights trying to figure out why things either don't work or fail in subtle ways...

Sign in to comment.

2 Answers

Answer by Amro
on 15 Nov 2014
Edited by Amro
on 15 Nov 2014
 Accepted Answer

You could create your own version of the necessary configurations from the existing ones.
First copy the latest XML file from: $MATLABROOT\bin\win64\mexopts\intel_fortran_13_vs2012.xml and place it on the desktop. Next modify it to work with your compiler version. Mostly you'll have to adjust it to look for the IFORT_COMPILER15 environment variable. You might need to modify a few other paths...
Finally when you want to compile a Fortran MEX-file, simply specify your custom config file as:
mex -f intel_fortran_15_vs2013.xml -largeArrayDims some_func.f
If you're interested, here are my versions of the XML files (C, C++, and Fortran): GitHub Gist

  2 Comments

I finally got around to trying your suggestion and it worked flawlessly. Thank you!
Hi,@Amro,I meet the similar problem, I use Matlab 2012a while the fortran compiler is vs2013 + Intel® Visual Fortran x15 in win10. Besides I don't quite understand how to adjust the xml file to my fortran compiler (it's already added to the environment path).Can you explain the procedure in details. Many thanks

Sign in to comment.


Answer by Xiangcheng Lee on 20 Jun 2018

Hi,Philip. I met the same problem. can you teach me how to create my own version of the necessary configurations. I use the Intel Visual Fortran XE 2013 and Microsoft Visual Studio 2013. but my version of MATLAB only support intel_fortran_13_vs2012.xml . I hope can get your reply, Thanks so much!

  0 Comments

Sign in to comment.