How to run multi robot warehouse simulation?

11 views (last 30 days)
I am learning to use Robotics System Toolbox from the example provided by MATLAB.
I followed all steps provided above yet failed to run the simulation in the end with the error shown below.
Error robotcontroller_msf.obj: Undefined (*ABS*). Symbol .file
gmake: *** [../../../../robotController_msf.mexw64] Error 1
### Build procedure for robotController aborted due to an error.
Simulation targets built:
Model Action Rebuild Reason
robotController Failed Code generation information file does not exist.
0 of 1 models built (0 models already up to date) Build duration: 0h 2m 53.638s
Unable to update models referenced by 'multiRobotExampleModel'.
Caused by: Error(s) encountered while building "robotController_msf"
Component:Simulink | Category:Block diagram error
I tried to check the block diagram of robotController but couldn't locate the error.
Any suggesstions for running the simulation smoothly?

Accepted Answer

Karsh Tharyani
Karsh Tharyani on 4 Jan 2022
Hi Tuck,
I am sorry you are running into this. It is a little hard to diagnose this without looking at the full build log, but there are two things which you can try to get around this:
  • Using a different directory to run the example (by copying the example's supporting files and live script); somewhere with a relatively shorter path (for instance inside, "C:/dir1/subdir1" instead of "C:/dir1/subdir1/subsubdir1")
  • Make sure that there is sufficient space in the directory where you are running the example from.
If you are still running into issues, I strongly suggest reaching out to our Technical Support team, as this will help us in quickly resolving the issue.
I hope this helps!
god luck
god luck on 18 Nov 2022
Hello,I have also encountered the same problem, and your method has not solved it. The tech support website you sent is also inaccessible.
E:/MATLAB/R2021b\sys\lcc64\lcc64\bin\lcclib64 /out:robotControllerlib.lib @robotController.rsp 'cmd' 不是内部或外部命令,也不是可运行的程序 或批处理文件。 gmake: *** [robotControllerlib.lib] Error 1 ### Build procedure for robotController aborted due to an error.
编译的仿真目标: 模型 操作 重新编译原因 ====================================================== robotController 失败 robotController_msf.mexw64 不存在。 编译了 0 个模型,共 1 个模型(0 个模型已经是最新的) 编译持续时间: 0h 0m 29.25s
Unable to update models referenced by 'multiRobotExampleModel'.
原因: Error(s) encountered while building "robotControllerlib"

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!