MATLAB Answers

0

missmatch between mcr version and packaged jar (Failed to find the library libmwmclmcrrt.so.7.13)

Asked by Ronen Narkis on 2 Nov 2011

Hey,

Im trying to run my matlab application on Redhat, im compiling the application using matlab 7.13 and iv installed the bundeled mcr (which is version 7.16 -> mcrinstall prints the version),

While im trying to run the application Im getting:

Exception: java.lang.UnsatisfiedLinkError, Message: Failed to find the library libmwmclmcrrt.so.7.13, required by MATLAB Builder JA, on java.library.path. This library is typically installed along with MATLAB or the MCR, its absence may indicate an issue with that installation or the current path configuration. The MCR version that this component is trying to use is: 7.13.

Iv installed matlab using the Java applet, how do I solve this issue?

Ronen

  0 Comments

Sign in to comment.

3 Answers

Answer by Kaustubha Govind on 2 Nov 2011

You need to add configure LD_LIBRARY_PATH and XAPPLRESDIR as the documentation suggests. See Path for Java Applications on All Platforms.

  0 Comments

Sign in to comment.


Answer by Ronen Narkis on 2 Nov 2011

Thanks, looks like I added it wrong, now Im getting:

Exception: java.lang.NoClassDefFoundError, Message: Could not initialize class com.mathworks.toolbox.javabuilder.internal.MWMCR java.lang.NoClassDefFoundError: Could not initialize class com.mathworks.toolbox.javabuilder.internal.MWMCR at com.mathworks.toolbox.javabuilder.MWUtil.CreateStructArray(MWUtil.java:182) at com.mathworks.toolbox.javabuilder.MWStructArray.(MWStructArray.java:73)

Ronen

  0 Comments

Sign in to comment.


Answer by Ronen Narkis on 2 Nov 2011

Hmm, my mistake this error keeps happening, again iv added LD_LIBRARY_PATH but the shared object version that the JVM is looking for is 13 while the mcr version is 16:

Error Detail Exception: java.lang.UnsatisfiedLinkError, Message: Failed to find the library libmwmclmcrrt.so.7.13, required by MATLAB Builder JA, on java.library.path. This library is typically installed along with MATLAB or the MCR, its absence may indicate an issue with that installation or the current path configuration. The MCR version that this component is trying to use is: 7.13.

java.lang.UnsatisfiedLinkError: Failed to find the library libmwmclmcrrt.so.7.13, required by MATLAB Builder JA, on java.library.path. This library is typically installed along with MATLAB or the MCR, its absence may indicate an issue with that installation or the current path configuration. The MCR version that this component is trying to use is: 7.13.

Ill contact support,

Ronen

  1 Comment

You need to get the version of the MCR corresponding to the compiled Java application (in your case, version 13). The versions are tightly coupled.

Sign in to comment.