MATLAB Answers

ginput does not work in 2015a on ubuntu 14.04

2 views (last 30 days)
Lian
Lian on 14 May 2015
Commented: Lian on 22 May 2015
I have a strange problem: I wrote a script using 2011b some time ago on a mac OS X and it worked perfectly, but now I try to run it on my office workstation running ubuntu 14.04 and Matlab 2015a, the ginput function does not respond to my mouse click anymore. My code looks like this:
...
figure (1), a 3D isosurface plot
...
figure(2), involves ginput
and now the problem happens.
I've tried a different script where figure(1) is a simple sin function plot, then ginput in figure(2) seems to work fine. So what might be the problem? I hope it is nothing to do with my graphics card (nvidia quadro K2000D). Many thanks!
  2 Comments
Lian
Lian on 22 May 2015
Thanks. Didn't see your comment until now. Yes, I've installed 2012b in the same machine and it works fine. So it is the version problem.

Sign in to comment.

Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!