MATLAB Answers

Can ping to LEGO EV3 wifi (Netgear) IP address, but fail to connect to it wirelessly - usb connection works. Any suggestions?

31 views (last 30 days)
Paul Bothma
Paul Bothma on 11 Mar 2016
Commented: Paul Pattenden on 5 Sep 2019
mylego = legoev3('usb')
mylego =
legoev3 with properties:
FirmwareVersion: 'V1.09E'
HardwareID: []
IPAddress: []
CommunicationType: 'USB'
BatteryLevel: 100
ConnectedSensors: {'touch' 'gyro' 'color' 'sonic'}
>> mylego = legoev3('wifi','192.168.129.62','00165348b96b')
Error using legoev3 (line 271)
Failed to connect to '192.168.129.62'. Please check your network settings.

  2 Comments

Andrew Jackson
Andrew Jackson on 20 Oct 2018
Hi there
Did you come right with this? I have the exact same problem and I downgraded to the V1.08H firmware which enabled me to successfully Ping from my PC to the ev3, however it still returns the same error message as you mention above when I try create a matlab object using legoev3('')
thanks

Sign in to comment.

Answers (4)

pravin behera
pravin behera on 15 Mar 2016
Hey hello... Try doing this way.. first connect your LEGO EV3 to wifi through NETGEAR, then go to brick settings>> Brick Info(very bottom)>> IP address (also u can get many info) >> ID
note down the "IP address" and "ID"
now try wirting this code to connect to wifi through matlab
mylego = legoev3('wifi','192.168.0.124','001653497c86')
and my ip address is "192.168.0.124" my LEGO ID is "001653497c86"
This should work, it works for me :)

  4 Comments

Show 1 older comment
Corbyn Yhap
Corbyn Yhap on 2 May 2016
I downgraded the firmware to 1.08 H, however, the IP Address does not seem to show up in my Brick Info screen. Can we only communicate with the EV3 using a Wifi dongle instead of the Ethernet Adapter suggested?
Bookwormo
Bookwormo on 20 Nov 2016
Thanks for sharing this. I have firmware 1.09E installed but I receive the following error message with the code snippet above: Error using error Unable to load a message catalog 'legoev3io:build'. Please check the file location and format.
Error in legoev3 (line 237) error(message('legoev3io:build:Legoev3WiFiFailed'));

Sign in to comment.


Jwalant Bhatt
Jwalant Bhatt on 28 Nov 2017
It connects through wifi dongle by downgrading the firmware to 1.08 H.

  2 Comments

Multiplexer
Multiplexer on 11 Jun 2018

https://www.lego.com/en-US/mindstorms/mindstormservices/firmware-download-page/?assetid=%7b38E66EC3-1C63-4305-BD8C-561A6E554116%7d

here you go

Sign in to comment.


fox tan
fox tan on 18 May 2016
Edited: fox tan on 18 May 2016
if I just install MATLAB support packge for EV3,it can conncet to EV3 via wifi. But when I intalled simulink support packge for EV3, matlab cannot conncet to EV3.

  0 Comments

Sign in to comment.


Graham Chow
Graham Chow on 18 Jan 2019
Edited: Graham Chow on 18 Jan 2019
In version 1.09H and 1.09E they have removed telnet access so you can't connect.
However in version 1.09D (special developer version lego have made), you can connect to via telnet. But they have added a password. It is possible (and I have done it) to modify the legoev3.m and evShell_IO.m files to send through the password and successfully connect. But I have not worked out how to do this in simulink - maybe matlab used compiled code to connect up to the ev3.
So the short answer is yes, you need to use 1.08H or 1.08E.
I suppose mathworks could support 1.09D if they really wanted to make a change, but I'm not seeing the benefits.

  1 Comment

Paul Pattenden
Paul Pattenden on 5 Sep 2019
I have tried to find the .bin file for previous firmware versions (eg 1.08E) to fix this... but no luck so far. The link above does not work any more.
Has anyone got an updated link for 1.08E (or indeed any MatLab wifi compatible firmware version???)
Fingers crossed.
PP

Sign in to comment.

Sign in to answer this question.