Why do I get the error message that says:" Error installing third party software MinGW 4.9.2 Core: java.util.​zip.ZipExc​eption: archive is not a ZIP archive"

1 view (last 30 days)
Whenever I try installing MinGW 4.9.2, I get the error message that says "Error installing third party software MinGW 4.9.2 Core: java.util.zip.ZipException: archive is not a ZIP archive" I want to install MinGW-w64 C/C++ compiler so that I can be able to use/run my generated code since when I type mex -setup, Matlab tells me I need the compiler. I tried doing the installation from TDM-GCC using the Addons Menu. I am using Matlab 2015b.
Note: Someone had similar problem in 2011 and Matlab support team give this answer below which the person accepted as best answer: "This error can occur when there is not enough space in the /tmp directory to contain the product archive during extraction. Increasing the space available within the /tmp directory will resolve this error." If this is the solution, how do I increase space in the /tmp directory? Please help. Thanks.

Accepted Answer

Walter Roberson
Walter Roberson on 14 Nov 2016
In MATLAB,
disp(tempdir)
cd(tempdir)
ls
and start deleting the files there, if any.
The temp directory is probably on your C drive, so you might need to free up space on your drive. I recently have begun to use the open source project WinDirStat to check where my Windows disk space is used up. I found that a lot of my space was being used up by the Windows Side-By-Side directory; cleaning information for that is at https://msdn.microsoft.com/en-us/windows/hardware/commercialize/manufacture/desktop/clean-up-the-winsxs-folder
  3 Comments

Sign in to comment.

More Answers (1)

chenxi zhao
chenxi zhao on 27 Aug 2017
when I tried to install matlab r2016b in mac, I got the same error message---- archive is not a zip archive. How to solve this problem in mac? thx!

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!