MATLAB Answers

Why mex -setup finds my compilers but xpcsetCC/slrtsetCC does not?

5 views (last 30 days)
Giannis Tz
Giannis Tz on 21 Feb 2017
Edited: Jan on 22 Feb 2017
I am using Matlab 2015a 32bits. I am trying to download a simulink model to a Target PC. Unfortunately when I run xpcsetCC -setup or slrtsetCC -setup to set a C compiler, it returns "No compilers found". At the same time, when I run mex -setup it returns all the installed compilers. I tried to set manually the path to the compiler using the command xpcsetCC(TYPE, LOCATION) with no success.
At the same computer I have installed Matlab 2015b 64bits. In that installation everything is working just perfect.
Thanks everyone in advance!

  0 Comments

Sign in to comment.

Answers (1)

Jan
Jan on 21 Feb 2017
Are the installed compilers found on this List ?

  2 Comments

Jan
Jan on 22 Feb 2017
I see the restriction:
7..sln project generation is not supported when using the
Microsoft Windows SDK.
Does this concern your work?
What does happen your you type xpcsetCC(TYPE, LOCATION)? What do you use as LOCATION?

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!