App Designer won't use discrete graphics card?

3 views (last 30 days)
Camile van der Heijden
Camile van der Heijden on 9 Jan 2018
So I've been working on an application in the new App Designer (Matlab version 2016b) and have run in to performance problems. I'm using a timer to regularly (and rapidly) update several line-plots and text areas, however, I've noticed the (discrete Nvidia) GPU in my laptop isn't loaded at all. This causes such a significant performance hit, that the app becomes unusable. To test whether the problem might have something to do with the new 'uifigure' used by the app designer (as opposed to the standard 'figure' that GUIDE uses), I've recreated the app with the timer and all plots/text areas in figure (but without the controls). The 'standard figure version' runs perfectly fine en when checking, I can see the dGPU being put to work (although it doesn't even break a sweat).
Anyone know of a way to fix this problem / force the use of the dGPU in app designer? Unless I find a way, I'm stuck recoding the thing in GUIDE, which is time I'd rather spend on further development.
Much obliged to anyone who can help!
  2 Comments
Camile van der Heijden
Camile van der Heijden on 10 Jan 2018
I think I've come across that question before. Problem is, the dGPU is already the default device, yet the app designer app still refuses to utilize it.
Thanks anyway.

Sign in to comment.

Answers (0)

Categories

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!