MATLAB Answers

0

Simulink model doesn't look configured for the Texas Instruments' F28379D processor

Hi All,
I am interfacing TMS320F28379D with MATLAB 2016a. I tried to adjust the Configuration Parameters > Code Generation > Coder Target > Code Target Hardware Resources to establish the connection between the board and Simulink but I cannot find my MCU in the provided list even though it is supported by the Embedded Coder.
Any ideas on how to troubleshoot this issue would be appreciated. Thanks!

  0 Comments

Sign in to comment.

1 Answer

Answer by Venkatesh Chilapur on 1 Mar 2018
 Accepted Answer

Make sure to select the System Target file as ert.tlc under code generation pane.

  2 Comments

Thank you for your answer.
When I chose ert.tlc instead of idelink_ert.tlc, the Coder Target pane has disappeared.
Can you please give more information about how to configure Simulink to program TMS320F28379D. Thanks!
I solved the issue by selecting ert.tlc and selecting the board in Configuration Parameters > Diagnostics > Hardware Implementation. Thank you.

Sign in to comment.